images: Don't use image-bootdirect on non-x86 archs 65/43865/2
authorMauro Carvalho Chehab <mchehab@osg.samsung.com>
Mon, 13 Jul 2015 10:41:07 +0000 (07:41 -0300)
committerMauro Carvalho Chehab <mchehab@osg.samsung.com>
Sun, 19 Jul 2015 12:27:32 +0000 (12:27 +0000)
image-bootdirect requires syslinux, with is only availabe on x86.
So, it shouldn't be used on other archs.

Change-Id: I1608d92fd7a3d54550dc79cae2ef71d1b18b9397
Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>
meta-tizen-common-base/recipes-image/images/tizen-common-core-image-minimal.bb

index 24102bf..1e21098 100644 (file)
@@ -4,7 +4,11 @@ SUMMARY = "A very basic Wayland image with a terminal"
 LICENSE = "MIT"
 DESCRIPTION = "A weston image with Tizen common."
 
-inherit core-image distro_features_check image-bootdirect
+IMAGE_CLASSES ?= "core-image distro_features_check"
+IMAGE_CLASSES_append_x86 += "image-bootdirect"
+IMAGE_CLASSES_append_x86-64 += "image-bootdirect"
+
+inherit ${IMAGE_CLASSES}
 
 IMAGE_FEATURES += "splash package-management ssh-server-dropbear hwcodecs"