fix blacklist module 18/41518/2
authorJean-Benoit MARTIN <jean-benoit.martin@open.eurogiciel.org>
Tue, 5 May 2015 15:40:25 +0000 (17:40 +0200)
committerJean-Benoit MARTIN <jean-benoit.martin@open.eurogiciel.org>
Tue, 16 Jun 2015 12:31:26 +0000 (14:31 +0200)
Change-Id: Ie491c0f9d4a527736ff04f4cf096a719952d9e45
Signed-off-by: Jean-Benoit MARTIN <jean-benoit.martin@open.eurogiciel.org>
meta-tizen-common-base/recipes-image/config-image/config-image.bb

index ed10ba2..2e7281c 100644 (file)
@@ -45,6 +45,13 @@ EOF
   
 }
 
+pkg_preinst_${PN}() {
+
+    # fix TIVI-2291
+    sed -ri "s/(^blacklist i8042.*$)/#fix from base-general.post \1/" $D/etc/modprobe.d/blacklist.conf
+
+}
+
 pkg_postinst_${PN} () {
   chsmack -t $D${sysconfdir}
   chsmack -a 'System::Shared' $D${sysconfdir}