add specific config in postinstall image 17/41517/2
authorJean-Benoit MARTIN <jean-benoit.martin@open.eurogiciel.org>
Tue, 5 May 2015 15:09:50 +0000 (17:09 +0200)
committerJean-Benoit MARTIN <jean-benoit.martin@open.eurogiciel.org>
Tue, 16 Jun 2015 12:31:26 +0000 (14:31 +0200)
Change-Id: I12d4808f55c2cbdff991850d9140d13422fee888
Signed-off-by: Jean-Benoit MARTIN <jean-benoit.martin@open.eurogiciel.org>
meta-tizen-common-base/recipes-image/config-image/config-image.bb

index 8805915..ed10ba2 100644 (file)
@@ -78,6 +78,32 @@ pkg_postinst_${PN} () {
     ln -s volatile/log  $D${localstatedir}/log
     
  fi
+  [ "x$D" != "x" ] && exit 1
+   mkdir -p $D/etc/profile.d
+   chsmack -a System $D/var/lib/buxton/*.db
+   chown -R buxton:buxton $D/var/lib/buxton
+   buxtonctl set-label base vconf User
+   vconftool set -t string db/ail/ail_info "0" -f -s User
+   vconftool set -t string db/menuscreen/desktop "0" -f -s User
+   vconftool set -t string db/menu_widget/language "en_US.utf8" -f -s User
+   chown -R alice:users $D/home/alice
+   chown -R bob:users $D/home/bob
+   chown -R carol:users $D/home/carol
+   chown -R guest:users $D/home/guest
+   source $D/etc/tizen-platform.conf
+   chsmack -a '*' $D/var/lib/buxton || true
+   chsmack -a '*' /var/lib/buxton/* || true
+   chmod 0777 $D/var/lib/buxton || true
+   chmod 0666 $D/var/lib/buxton/* || true
+   ail_initdb
+   pkg_initdb
+   chmod 0600 $D/var/lib/buxton/* || true
+   chmod 0700 $D/var/lib/buxton || true
+   chsmack -a System $D/var/lib/buxton/* || true
+   chsmack -a System $D/var/lib/buxton || true
+   chsmack -a User $D/home/*/.applications/*/*
+   chsmack -a User $D/home/*/.applications/*/.*
 }
 
 FILES_${PN} = "${sysconfdir}/tizen \