1. Remove samsung extension code, 2. Block unnecessary build and exclude doc related...
[platform/upstream/libexif.git] / packaging / libexif.spec
1 Name:           libexif
2 Version:        0.6.21
3 Release:        1
4 License:        LGPL-2.1+
5 Summary:        An EXIF Tag Parsing Library for Digital Cameras
6 Url:            http://libexif.sourceforge.net
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 Source1001:        libexif.manifest
11 Requires(post):  /sbin/ldconfig
12 Requires(postun):  /sbin/ldconfig
13
14 %define debug_package_requires %{name} = %{version}-%{release}
15
16 %description
17 This library is used to parse EXIF information from JPEGs created by
18 digital cameras.
19
20 %package devel
21 Summary:        An EXIF Tag Parsing Library for Digital Cameras (Development files)
22 Group:          Development/Libraries/C and C++
23 Requires:       %{name} = %{version}
24
25 %description devel
26 This library is used to parse EXIF information from JPEGs created by
27 digital cameras.
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33 %build
34 sh ./autogen.sh
35 %configure --with-pic \
36         --disable-static \
37         --disable-docs
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 mkdir -p %{buildroot}/usr/share/license
43 cp COPYING %{buildroot}/usr/share/license/%{name}
44 %make_install
45 #%find_lang %{name}-12
46
47 %post  -p /sbin/ldconfig
48
49 %postun  -p /sbin/ldconfig
50
51 #%files -f %{name}-12.lang
52 %files
53 %manifest %{name}.manifest
54 %defattr(-,root,root)
55 %{_libdir}/*.so.*
56 %{_datadir}/license/%{name}
57
58 %files devel
59 %defattr(-,root,root)
60 %{_includedir}/libexif
61 %{_libdir}/*.so
62 %{_libdir}/pkgconfig/libexif.pc
63