riscv64: Update config.sub and config.guess
[platform/upstream/libexif.git] / packaging / libexif.spec
1 Name:           libexif
2 Version:        0.6.22
3 Release:        0
4 License:        LGPL-2.1
5 Summary:        An EXIF Tag Parsing Library for Digital Cameras
6 Url:            https://libexif.github.io
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Requires(post):  /sbin/ldconfig
10 Requires(postun):  /sbin/ldconfig
11
12 %define debug_package_requires %{name} = %{version}-%{release}
13
14 %description
15 This library is used to parse EXIF information from JPEGs created by
16 digital cameras.
17
18 %package devel
19 Summary:        An EXIF Tag Parsing Library for Digital Cameras (Development files)
20 Group:          Development/Libraries/C and C++
21 Requires:       %{name} = %{version}
22
23 %description devel
24 This library is used to parse EXIF information from JPEGs created by
25 digital cameras.
26
27 %prep
28 %setup -q
29
30 %build
31 sh ./autogen.sh
32 %configure --with-pic \
33         --disable-static \
34         --disable-docs
35
36 make %{?jobs:-j%jobs}
37
38 %install
39 %make_install
40 #%find_lang %{name}-12
41
42 %post  -p /sbin/ldconfig
43
44 %postun  -p /sbin/ldconfig
45
46 #%files -f %{name}-12.lang
47 %files
48 %manifest %{name}.manifest
49 %license COPYING
50 %defattr(-,root,root)
51 %{_libdir}/*.so.*
52
53 %files devel
54 %defattr(-,root,root)
55 %{_includedir}/libexif
56 %{_libdir}/*.so
57 %{_libdir}/pkgconfig/libexif.pc
58