add packaging
[platform/upstream/libexif.git] / packaging / libexif.spec
1 Name:           libexif
2 Version:        0.6.21
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        An EXIF Tag Parsing Library for Digital Cameras
6 Url:            http://libexif.sourceforge.net
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 BuildRequires:  doxygen
11 BuildRequires:  pkg-config
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
13
14 %define debug_package_requires %{name} = %{version}-%{release}
15
16 %description
17 This library is used to parse EXIF information from JPEGs created by
18 digital cameras.
19
20 %package devel
21 Summary:        An EXIF Tag Parsing Library for Digital Cameras (Development files)
22 Group:          Development/Libraries/C and C++
23 Requires:       %{name} = %{version}
24 Requires:       glibc-devel
25
26 %description devel
27 This library is used to parse EXIF information from JPEGs created by
28 digital cameras.
29
30 %prep
31 %setup -q
32
33 %build
34 %configure --with-pic \
35         --disable-static \
36         --with-doc-dir=%{_docdir}/%{name}
37 make %{?_smp_mflags}
38
39 %check
40 make check
41
42 %install
43 %make_install
44 %find_lang %{name}-12
45
46 %post  -p /sbin/ldconfig
47
48 %postun  -p /sbin/ldconfig
49
50 %files -f %{name}-12.lang
51 %defattr(-,root,root)
52 %{_libdir}/*.so.*
53
54 %files devel
55 %defattr(-,root,root)
56 %doc %{_docdir}/%{name}
57 %{_libdir}/*.so
58 %{_libdir}/pkgconfig/*.pc
59 %{_includedir}/*
60
61 %changelog