qtdemux: Determine duration with reference to track header duration
[platform/upstream/gstreamer.git] / packaging / gst-plugins-good.spec
1 %bcond_with x
2 %define gst_branch 1.0
3
4 Name:           gst-plugins-good
5 Version:        1.16.2
6 Release:        31
7 License:        LGPL-2.1+
8 Summary:        GStreamer Streaming-Media Framework Plug-Ins
9 Url:            http://gstreamer.freedesktop.org/
10 Group:          Multimedia/Framework
11 Source:         http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.xz
12 Source100:      common.tar.gz
13 BuildRequires:  gcc-c++
14 BuildRequires:  gettext-tools
15 BuildRequires:  pkgconfig(glib-2.0) >= 2.32
16 BuildRequires:  pkgconfig(gstreamer-1.0)
17 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  orc >= 0.4.16
20 BuildRequires:  python
21 BuildRequires:  xsltproc
22 BuildRequires:  pkgconfig(bzip2)
23 BuildRequires:  pkgconfig(libpng) >= 1.2
24 BuildRequires:  pkgconfig(libpulse) >= 1.0
25 BuildRequires:  pkgconfig(libsoup-2.4)
26 BuildRequires:  pkgconfig(libxml-2.0) >= 2.4.9
27 # TODO find where process.h comes from, not kernel-devel and not wxWidgets so far.
28 %if %{with x}
29 BuildRequires:  pkgconfig(ice)
30 BuildRequires:  pkgconfig(sm)
31 BuildRequires:  pkgconfig(xdamage)
32 BuildRequires:  pkgconfig(xfixes)
33 # used by libgstvideo4linux2.so
34 BuildRequires:  pkgconfig(xv)
35 %endif
36
37 BuildRequires:  pkgconfig(vpx)
38 BuildRequires:  pkgconfig(zlib)
39 %if "%{tizen_profile_name}" != "tv"
40 BuildRequires:  pkgconfig(libv4l2)
41 %endif
42 BuildRequires:  pkgconfig(vconf)
43 BuildRequires:  pkgconfig(gio-2.0)
44 BuildRequires:  pkgconfig(libtbm)
45 Requires:       gst-plugins-base >= 1.0.0
46 Requires:       gstreamer >= 1.0.5
47
48 %description
49 GStreamer is a streaming media framework based on graphs of filters
50 that operate on media data. Applications using this library can do
51 anything media-related, from real-time sound processing to playing
52 videos. Its plug-in-based architecture means that new data types or
53 processing capabilities can be added simply by installing new plug-ins.
54
55 %package extra
56 Summary:        Complementary plugins for %{name}
57 Group:          Productivity/Multimedia/Other
58 Requires:       %{name} = %{version}
59 Enhances:       gst-plugins-good
60
61 %description extra
62 This package provides complementary plugins for %{name} and
63 plugins not included in official Tizen images, which may be used for development / experimental purposes.
64
65 %prep
66 %setup -q -n gst-plugins-good-%{version}
67 %setup -q -T -D -a 100
68
69 %build
70 # FIXME:
71 # warning: failed to load external entity "xml/element-v4l2src-details.xml"
72 # warning: failed to load external entity "xml/plugin-video4linux2.xml"
73 export V=1
74 NOCONFIGURE=1 ./autogen.sh
75 export CFLAGS+=" \
76         -DTIZEN_FEATURE_V4L2SRC_AUTO_SCAN_DEVICE_NODE\
77         -DTIZEN_FEATURE_V4L2SRC_SUPPORT_CAMERA_ID\
78         -DTIZEN_FEATURE_V4L2VIDEO_ADJ_RANK\
79         -DTIZEN_FEATURE_WAVPARSE_MODIFICATION\
80         -DTIZEN_FEATURE_MP3PARSE_MODIFICATION\
81         -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
82         -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
83         -DTIZEN_FEATURE_QTDEMUX_DURATION\
84         -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
85         -DTIZEN_FEATURE_GST_UPSTREAM_AVOID_BUILD_BREAK\
86         -DTIZEN_FEATURE_RTSP_MODIFICATION\
87         -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
88         -DTIZEN_FEATURE_SOUP_MODIFICATION\
89         -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
90         -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
91         -DTIZEN_FEATURE_AVIDEMUX_MODIFICATION\
92         -DTIZEN_FEATURE_USE_LIBV4L2\
93         -DTIZEN_FEATURE_V4L2_ADDITIONAL_CID_SUPPORT\
94         -DTIZEN_FEATURE_V4L2_TBM_SUPPORT\
95         -D__TIZEN__\
96         -fstack-protector-strong\
97         -Wl,-z,relro\
98         -D_FORTIFY_SOURCE=2"
99 %configure\
100 %if ! 0%{?ENABLE_AALIB}
101         --disable-aalib\
102 %endif
103 %if "%{tizen_profile_name}" != "tv"
104         --with-libv4l2 \
105 %endif
106         --enable-v4l2-probe\
107         --disable-gtk-doc\
108         --with-gtk=3.0\
109         --disable-monoscope\
110         --disable-y4m\
111         --disable-taglib\
112         --disable-wavpack\
113         --enable-experimental\
114         --disable-equalizer\
115 %if "%{tizen_profile_name}" == "tv"
116         --disable-flv\
117         --disable-videobox\
118         --disable-videomixer\
119 %endif
120         --disable-alpha\
121         --disable-auparse\
122         --disable-flx\
123         --disable-goom\
124         --disable-goom2k1\
125         --disable-level\
126         --disable-multipart\
127         --disable-spectrum\
128         --disable-cutter\
129         --disable-dtmf\
130         --disable-oss4\
131         --disable-oss\
132         --disable-shapewipe
133
134 make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
135
136 %install
137 %make_install
138 %find_lang %{name}-%{gst_branch}
139
140 %lang_package -f %{name}-%{gst_branch}
141
142 %files
143 %manifest %{name}.manifest
144 %defattr(-, root, root)
145 %license COPYING
146 %{_libdir}/gstreamer-%{gst_branch}/libgstalaw.so
147 #%{_libdir}/gstreamer-%{gst_branch}/libgstalpha.so
148 #%{_libdir}/gstreamer-%{gst_branch}/libgstalphacolor.so
149 %{_libdir}/gstreamer-%{gst_branch}/libgstapetag.so
150 %{_libdir}/gstreamer-%{gst_branch}/libgstaudiofx.so
151 %{_libdir}/gstreamer-%{gst_branch}/libgstaudioparsers.so
152 #%{_libdir}/gstreamer-%{gst_branch}/libgstauparse.so
153 %{_libdir}/gstreamer-%{gst_branch}/libgstautodetect.so
154 %{_libdir}/gstreamer-%{gst_branch}/libgstavi.so
155 # Not yet ported
156 #%{_libdir}/gstreamer-%{gst_branch}/libgstcutter.so
157 %{_libdir}/gstreamer-%{gst_branch}/libgstdebug.so
158 # Not yet ported
159 %{_libdir}/gstreamer-%{gst_branch}/libgstdeinterlace.so
160 %{_libdir}/gstreamer-%{gst_branch}/libgsteffectv.so
161
162 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
163
164 #%{_libdir}/gstreamer-%{gst_branch}/libgstflxdec.so
165 #%{_libdir}/gstreamer-%{gst_branch}/libgstgoom.so
166 #%{_libdir}/gstreamer-%{gst_branch}/libgstgoom2k1.so
167 %{_libdir}/gstreamer-%{gst_branch}/libgsticydemux.so
168 %{_libdir}/gstreamer-%{gst_branch}/libgstid3demux.so
169 %{_libdir}/gstreamer-%{gst_branch}/libgstinterleave.so
170 %{_libdir}/gstreamer-%{gst_branch}/libgstisomp4.so
171 %{_libdir}/gstreamer-%{gst_branch}/libgstjpeg.so
172 #%{_libdir}/gstreamer-%{gst_branch}/libgstlevel.so
173 %{_libdir}/gstreamer-%{gst_branch}/libgstmatroska.so
174 #%{_libdir}/gstreamer-%{gst_branch}/libgstmonoscope.so
175 %{_libdir}/gstreamer-%{gst_branch}/libgstmulaw.so
176 %{_libdir}/gstreamer-%{gst_branch}/libgstmultifile.so
177 #%{_libdir}/gstreamer-%{gst_branch}/libgstmultipart.so
178 %{_libdir}/gstreamer-%{gst_branch}/libgstnavigationtest.so
179 #%{_libdir}/gstreamer-%{gst_branch}/libgstoss4audio.so
180 #%{_libdir}/gstreamer-%{gst_branch}/libgstossaudio.so
181 %{_libdir}/gstreamer-%{gst_branch}/libgstpulseaudio.so
182 %{_libdir}/gstreamer-%{gst_branch}/libgstreplaygain.so
183 %{_libdir}/gstreamer-%{gst_branch}/libgstrtp.so
184 %{_libdir}/gstreamer-%{gst_branch}/libgstrtpmanager.so
185 %{_libdir}/gstreamer-%{gst_branch}/libgstrtsp.so
186 #%{_libdir}/gstreamer-%{gst_branch}/libgstshapewipe.so
187 %{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
188 #%{_libdir}/gstreamer-%{gst_branch}/libgstspectrum.so
189 #%{_libdir}/gstreamer-%{gst_branch}/libgstspeex.so
190 %{_libdir}/gstreamer-%{gst_branch}/libgstudp.so
191 %{_libdir}/gstreamer-%{gst_branch}/libgstvideo4linux2.so
192
193 %{_libdir}/gstreamer-%{gst_branch}/libgstvideocrop.so
194 %{_libdir}/gstreamer-%{gst_branch}/libgstvideofilter.so
195 %if "%{tizen_profile_name}" != "tv"
196 %{_libdir}/gstreamer-%{gst_branch}/libgstflv.so
197 #%{_libdir}/gstreamer-%{gst_branch}/libgstequalizer.so
198 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstIirEqualizer10Bands.prs
199 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstIirEqualizer3Bands.prs
200 %{_datadir}/gstreamer-%{gst_branch}/presets/GstQTMux.prs
201 %{_libdir}/gstreamer-%{gst_branch}/libgstvideobox.so
202 %{_libdir}/gstreamer-%{gst_branch}/libgstvideomixer.so
203 %endif
204 %{_libdir}/gstreamer-%{gst_branch}/libgstwavenc.so
205 %{_libdir}/gstreamer-%{gst_branch}/libgstwavparse.so
206 %if %{with x}
207 %{_libdir}/gstreamer-%{gst_branch}/libgstximagesrc.so
208 %endif
209 #%{_libdir}/gstreamer-%{gst_branch}/libgsty4menc.so
210 #%{_libdir}/gstreamer-%{gst_branch}/libgstcairo.so
211 %{_libdir}/gstreamer-%{gst_branch}/libgstsoup.so
212 #%{_libdir}/gstreamer-%{gst_branch}/libgstflac.so
213 %{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
214 %{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
215 #%{_libdir}/gstreamer-%{gst_branch}/libgstdtmf.so
216 %{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so
217
218
219 %files extra
220 %manifest %{name}.manifest
221 %defattr(-, root, root)
222 %if 0%{?ENABLE_AALIB}
223 %{_libdir}/gstreamer-%{gst_branch}/libgstaasink.so
224 %endif
225 %{_libdir}/gstreamer-%{gst_branch}/libgstpng.so
226 %{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so