packaging: Turn off ASan build to fix gummiboot build
[platform/upstream/gnu-efi.git] / packaging / gnu-efi.spec
1 Name:           gnu-efi
2 Version:        3.0
3 Release:        1
4 License:        BSD-3-Clause
5 Summary:        EFI development environment
6 Url:            http://sourceforge.net/projects/gnu-efi/
7 Group:          System/Boot
8 Source0:        http://download.sourceforge.net/%{name}/%{name}_%{version}.orig.tar.gz
9 Source1001:     gnu-efi.manifest
10 ExclusiveArch:  %ix86 x86_64
11
12
13 %description
14 gnu-efi is a library for building EFI applications
15
16 %prep
17 %setup -q -n %{name}-%{version}
18 cp %{SOURCE1001} .
19
20 %build
21 %{?asan:/usr/bin/gcc-unforce-options}
22 %{?ubsan:/usr/bin/gcc-unforce-options}
23 export CFLAGS+=" -fno-stack-protector "
24 export CXXFLAGS+=" -fno-stack-protector "
25 make
26
27 %install
28 make install PREFIX=%{_prefix} INSTALLROOT=%{buildroot}
29
30 %files
31 %manifest %{name}.manifest
32 %defattr(-,root,root)
33 %{_includedir}/efi/*
34 %{_prefix}/lib/*