add packaging
[platform/upstream/findutils.git] / packaging / findutils.spec
1 Name:           findutils
2 Version:        4.2.31
3 Release:        1
4 License:        GPL-2.0+
5 Summary:        The GNU versions of find utilities (find and xargs)
6 Url:            http://www.gnu.org/software/findutils/
7 Group:          Applications/File
8 Source:         %{name}-%{version}.tar.bz2
9 #Source1: ftp://ftp.gnu.org/gnu/findutils/%{name}-%{version}.tar.gz.sig
10 Patch1:         findutils-4.2.31-no-locate.patch
11 Patch2:         findutils-bmc12931-find-ls-stack-overflow.patch
12
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gzip
16 BuildRequires:  libtool
17
18 %description
19 The findutils package contains programs which will help you locate
20 files on your system.  The find utility searches through a hierarchy
21 of directories looking for files which match a certain set of criteria
22 (such as a filename pattern).  The xargs utility builds and executes
23 command lines from standard input arguments (usually lists of file
24 names generated by the find command).
25
26 You should install findutils because it includes tools that are very
27 useful for finding things on your system.
28
29 %prep
30 %setup -q
31 %patch1 -p1 -b .no-locate
32 %patch2 -p1
33
34 %build
35 export CFLAGS="%{optflags} -D_GNU_SOURCE"
36 export CXXFLAGS="%{optflags} -D_GNU_SOURCE"
37 %configure --without-selinux --disable-nls
38
39 make %{?_smp_mflags}
40 %check
41 make check
42
43 %install
44 %make_install
45
46
47 %docs_package
48
49 %files
50 %defattr(-,root,root)
51 %doc COPYING
52 %{_bindir}/find
53 %{_bindir}/xargs
54