dri2proto should not try to build into a pure wayland platform.
[platform/upstream/dri2proto.git] / packaging / dri2proto.spec
1 %bcond_with x
2
3 Name:     dri2proto
4 Summary:  X.Org X11 Protocol dri2proto
5 Version:  2.8
6 Release:  1
7 Group:    Development/System
8 License:  MIT
9 URL:      http://www.x.org
10 Source0:  %{name}-%{version}.tar.bz2
11 Source1001:     dri2proto.manifest
12
13 BuildRequires: pkgconfig
14 BuildRequires: pkgconfig(xorg-macros)
15
16 %if !%{with x}
17 ExclusiveArch:
18 %endif
19
20 %description
21 %{summary}
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28
29 %configure --disable-static \
30              --libdir=%{_datadir} \
31              --without-xmlto
32
33 make %{?jobs:-j%jobs}
34
35 %install
36 %make_install
37
38 %remove_docs
39
40 %files
41 %manifest %{name}.manifest
42 %license COPYING
43 %defattr(-,root,root,-)
44 %{_includedir}/X11/extensions/*.h
45 %{_datadir}/pkgconfig/*.pc