Change the LOG_TAG
[platform/framework/web/livebox-cpp.git] / packaging / liblivebox-cpp.spec
1 Name: liblivebox-cpp
2 Summary: C++ adaptor for a livebox 
3 Version: 0.2.3
4 Release: 1
5 Group: main/app
6 License: Flora License
7 Source0: %{name}-%{version}.tar.gz
8 BuildRequires: cmake, gettext-tools
9 BuildRequires: pkgconfig(dlog)
10 BuildRequires: pkgconfig(livebox)
11 BuildRequires: pkgconfig(livebox-service)
12
13 %description
14 Livebox development library (C++)
15
16 %package devel
17 Summary: Files for livebox development.
18 Group: Development/Libraries
19 Requires: %{name} = %{version}-%{release}
20
21 %description devel
22 Livebox development library (C++) (dev)
23
24 %prep
25 %setup -q
26
27 %build
28 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
29 make %{?jobs:-j%jobs}
30
31 %install
32 rm -rf %{buildroot}
33 %make_install
34 mkdir -p %{buildroot}/usr/share/license
35
36 %post
37
38 %files -n liblivebox-cpp
39 %manifest liblivebox-cpp.manifest
40 %defattr(-,root,root,-)
41 /usr/lib/*.so*
42 /usr/share/license/*
43
44 %files devel
45 %defattr(-,root,root,-)
46 /usr/include/livebox-cpp/livebox-cpp.h
47 /usr/share/doc/livebox-cpp/livebox-cpp_PG.h
48 /usr/lib/pkgconfig/*.pc