[osp-compat] Change package version into 1.2.2.0
[platform/framework/native/compat.git] / packaging / osp-compat.spec
1 %define debug_package %{nil}
2 %define __strip /bin/true
3
4 Name:       osp-compat
5 Summary:    osp-compat library 
6 Version:    1.2.2.0
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Apache License, Version 2.0
10 Source0:    %{name}-%{version}.tar.gz
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(osp-appfw)
13 BuildRequires:  pkgconfig(osp-net)
14 BuildRequires:  pkgconfig(osp-nfc)
15 BuildRequires:  pkgconfig(osp-social)
16 BuildRequires:  pkgconfig(osp-uifw)
17
18 Provides:       libosp-compat.so.1
19
20 %description
21 osp-compat library
22
23 %package debug
24 Summary:    osp-compat (Development)
25 Group:      TO_BE/FILLED_IN
26 Requires:   %{name} = %{version}-%{release}
27
28 %description debug
29 osp-compat library (DEV)
30
31 %prep
32 %setup -q
33
34 %build
35 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
36 %ifarch %{ix86}
37 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_X86_ -D_OSP_EMUL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DEMUL=1
38 %else
39 CXXFLAGS="$CXXFLAGS -D_OSP_DEBUG_ -D_OSP_ARMEL_" cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DFULLVER=%{version} -DMAJORVER=${MAJORVER} -DTARGET=1
40 %endif
41
42 # Call make instruction with smp support
43 make %{?jobs:-j%jobs}
44
45 %install
46 rm -rf %{buildroot}
47 mkdir -p %{buildroot}/usr/share/license
48 cp %{_builddir}/%{name}-%{version}/LICENSE.APLv2  %{buildroot}/usr/share/license/%{name}
49
50 %make_install
51
52 %post -p /sbin/ldconfig
53
54 %postun -p /sbin/ldconfig
55
56 %files
57 %manifest osp-compat.manifest
58 %defattr(-,root,root,-)
59 /usr/share/license/%{name}
60 %{_libdir}/osp/libosp-compat.so*
61
62 %files debug
63 %{_libdir}/osp/debug/*.so*