CMake support
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.41
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali-devel
47 BuildRequires:  dali-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  fribidi-devel
65
66 BuildRequires:  pkgconfig(capi-system-info)
67 BuildRequires:  pkgconfig(capi-system-sensor)
68
69 BuildRequires:  pkgconfig(cairo)
70
71 BuildRequires:  pkgconfig(wayland-egl)
72 BuildRequires:  pkgconfig(wayland-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # dali-adaptor uses ecore mainloop
77 %if 0%{?tizen_version_major} >= 5
78 BuildRequires:  pkgconfig(ecore-wl2)
79 BuildRequires:  pkgconfig(wayland-egl-tizen)
80 %else
81 BuildRequires:  pkgconfig(ecore-wayland)
82 %endif
83
84 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
85 BuildRequires:  pkgconfig(libtbm)
86
87 BuildRequires:  pkgconfig(tpkp-curl)
88
89 # for dali-adaptor
90 BuildRequires:  pkgconfig(appcore-ui)
91 BuildRequires:  pkgconfig(appcore-widget-base)
92 BuildRequires:  pkgconfig(bundle)
93 BuildRequires:  pkgconfig(capi-appfw-app-common)
94 BuildRequires:  pkgconfig(capi-appfw-app-control)
95 BuildRequires:  pkgconfig(ecore-imf)
96
97 BuildRequires:  pkgconfig(capi-system-system-settings)
98
99 # for feedback plugin
100 BuildRequires:  pkgconfig(mm-sound)
101 BuildRequires:  pkgconfig(feedback)
102
103 # for multiprofile
104 Requires:   %{name}-compat = %{version}-%{release}
105 Recommends: %{name}-profile_common = %{version}-%{release}
106
107 %description
108 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
109 platform abstraction and application shell
110
111 ###########################################
112 # Dali adapter for profiles
113 ###########################################
114
115 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
116 # if mobile || "undefined"
117 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
118 %package profile_mobile
119 Summary:        The DALi Tizen Adaptor for mobile
120 Provides:       %{name}-compat = %{version}-%{release}
121 Conflicts:      %{name}-profile_tv
122 Conflicts:      %{name}-profile_wearable
123 Conflicts:      %{name}-profile_ivi
124 Conflicts:      %{name}-profile_common
125 %description profile_mobile
126 The DALi Tizen Adaptor for mobile.
127 %endif
128
129 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
130 # if tv ||"undefined"
131 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
132 %package profile_tv
133 Summary:        The DALi Tizen Adaptor for tv
134 Provides:       %{name}-compat = %{version}-%{release}
135 Conflicts:      %{name}-profile_mobile
136 Conflicts:      %{name}-profile_wearable
137 Conflicts:      %{name}-profile_ivi
138 Conflicts:      %{name}-profile_common
139 %description profile_tv
140 The DALi Tizen Adaptor for tv.
141 %endif
142
143 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
144 # if wearable || "undefined"
145 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
146 %package profile_wearable
147 Summary:        The DALi Tizen Adaptor for wearable
148 Provides:       %{name}-compat = %{version}-%{release}
149 Conflicts:      %{name}-profile_mobile
150 Conflicts:      %{name}-profile_tv
151 Conflicts:      %{name}-profile_ivi
152 Conflicts:      %{name}-profile_common
153 %description profile_wearable
154 The DALi Tizen Adaptor for wearable.
155 %endif
156
157 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
158 # if ivi ||"undefined"
159 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
160 %package profile_ivi
161 Summary:        The DALi Tizen Adaptor for ivi
162 Provides:       %{name}-compat = %{version}-%{release}
163 Conflicts:      %{name}-profile_mobile
164 Conflicts:      %{name}-profile_wearable
165 Conflicts:      %{name}-profile_tv
166 Conflicts:      %{name}-profile_common
167 %description profile_ivi
168 The DALi Tizen Adaptor for ivi.
169 %endif
170
171 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
172 # if common ||"undefined"
173 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
174 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
175 %package profile_common
176 Summary:        The DALi Tizen Adaptor for common
177 Provides:       %{name}-compat = %{version}-%{release}
178 Conflicts:      %{name}-profile_mobile
179 Conflicts:      %{name}-profile_wearable
180 Conflicts:      %{name}-profile_tv
181 Conflicts:      %{name}-profile_ivi
182 %description profile_common
183 The DALi Tizen Adaptor for common.
184 %endif
185
186 ##############################
187 # devel
188 ##############################
189 %package devel
190 Summary:    Development components for the DALi Tizen Adaptor
191 Group:      Development/Building
192 Requires:   %{name} = %{version}-%{release}
193 Requires:   %{name}-integration-devel = %{version}-%{release}
194
195 %description devel
196 Development components for the DALi Tizen Adaptor - public headers and package configs
197
198 ##############################
199 # integration-devel
200 ##############################
201 %package integration-devel
202 Summary:    Integration development package for the Adaptor
203 Group:      Development/Building
204 Requires:   %{name} = %{version}-%{release}
205
206 %description integration-devel
207 Integration development package for the Adaptor - headers for integrating with an adaptor library.
208
209 ##############################
210 # Dali Feedback Plugin
211 ##############################
212 %package dali-feedback-plugin
213 Summary:    Plugin to play haptic and audio feedback for Dali
214 Group:      System/Libraries
215 Requires:   %{name} = %{version}-%{release}
216 %description dali-feedback-plugin
217 Feedback plugin to play haptic and audio feedback for Dali
218
219 ##############################
220 # Preparation
221 ##############################
222 %prep
223 %setup -q
224
225 #Use TZ_PATH when tizen version is 3.x or greater
226
227 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
228 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
229 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
230 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
231 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
232 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
233
234 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
235 %define dali_plugin_sound_files  /plugins/sounds/
236 %define dev_include_path %{_includedir}
237
238 ##############################
239 # Build
240 ##############################
241 %build
242 PREFIX+="/usr"
243 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
244 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
245
246 %ifarch %{arm}
247 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
248 %endif
249
250 CFLAGS+=" -DWAYLAND"
251 CXXFLAGS+=" -DWAYLAND"
252 configure_flags=" -DENABLE_WAYLAND=ON"
253
254 # Use this conditional when Tizen version is 5.x or greater
255 %if 0%{?tizen_version_major} >= 5
256 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
257
258 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
259 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
260 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
261 configure_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
262 %endif
263
264 libtoolize --force
265 cd %{_builddir}/%{name}-%{version}/build/tizen
266
267 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
268 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
269 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
270 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
271 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
272 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
273 %if 0%{?tizen_platform_config_supported}
274 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
275 %endif
276
277 # Set up the build via Cmake
278 #######################################################################
279 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
280 # if mobile || "undefined"
281 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
282
283 mkdir mobile
284 pushd mobile
285
286 cmake \
287 %if 0%{?enable_debug}
288       -DCMAKE_BUILD_TYPE=Debug \
289 %endif
290 %if 0%{?enable_trace}
291       -DENABLE_TRACE=ON \
292 %endif
293       -DCMAKE_INSTALL_PREFIX=$PREFIX \
294       -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
295       -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
296       -DENABLE_PROFILE=MOBILE \
297       -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major} \
298       -DENABLE_FEEDBACK=YES \
299       -DENABLE_APPFW=YES \
300       $configure_flags \
301       ..
302
303 # Build.
304 make %{?jobs:-j%jobs}
305 popd
306
307 %endif
308
309 #######################################################################
310 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
311 # if tv ||"undefined"
312 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
313
314 mkdir tv
315 pushd tv
316
317 cmake \
318 %if 0%{?enable_debug}
319       -DCMAKE_BUILD_TYPE=Debug \
320 %endif
321 %if 0%{?enable_trace}
322       -DENABLE_TRACE=ON \
323 %endif
324       -DCMAKE_INSTALL_PREFIX=$PREFIX \
325       -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
326       -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
327       -DENABLE_PROFILE=TV \
328       -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major} \
329       -DENABLE_FEEDBACK=YES \
330       -DENABLE_APPFW=YES \
331       $configure_flags \
332       ..
333
334 # Build.
335 make %{?jobs:-j%jobs}
336 popd
337
338 %endif
339
340 #######################################################################
341 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
342 # if wearable || "undefined"
343 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
344
345 mkdir wearable
346 pushd wearable
347
348 cmake \
349 %if 0%{?enable_debug}
350       -DCMAKE_BUILD_TYPE=Debug \
351 %endif
352 %if 0%{?enable_trace}
353       -DENABLE_TRACE=ON \
354 %endif
355       -DCMAKE_INSTALL_PREFIX=$PREFIX \
356       -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
357       -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
358       -DENABLE_PROFILE=WEARABLE \
359       -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major} \
360       -DENABLE_FEEDBACK=YES \
361       -DENABLE_APPFW=YES \
362       $configure_flags \
363       ..
364
365 # Build.
366 make %{?jobs:-j%jobs}
367 popd
368
369 %endif
370
371 #######################################################################
372 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
373 # if ivi ||"undefined"
374 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
375
376 mkdir ivi
377 pushd ivi
378
379 cmake \
380 %if 0%{?enable_debug}
381       -DCMAKE_BUILD_TYPE=Debug \
382 %endif
383 %if 0%{?enable_trace}
384       -DENABLE_TRACE=ON \
385 %endif
386       -DCMAKE_INSTALL_PREFIX=$PREFIX \
387       -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
388       -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
389       -DENABLE_PROFILE=IVI \
390       -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major} \
391       -DENABLE_FEEDBACK=YES \
392       -DENABLE_APPFW=YES \
393       $configure_flags \
394       ..
395
396 # Build.
397 make %{?jobs:-j%jobs}
398 popd
399
400 %endif
401
402 #######################################################################
403 # common
404 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
405 # if common ||"undefined"
406 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
407
408 mkdir common
409 pushd common
410
411 cmake \
412 %if 0%{?enable_debug}
413       -DCMAKE_BUILD_TYPE=Debug \
414 %endif
415 %if 0%{?enable_trace}
416       -DENABLE_TRACE=ON \
417 %endif
418       -DCMAKE_INSTALL_PREFIX=$PREFIX \
419       -DCMAKE_INSTALL_LIBDIR=%{_libdir} \
420       -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir} \
421       -DENABLE_PROFILE=COMMON \
422       -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major} \
423       -DENABLE_FEEDBACK=YES \
424       -DENABLE_APPFW=YES \
425       $configure_flags \
426       ..
427
428 # Build.
429 make %{?jobs:-j%jobs}
430 popd
431
432 %endif
433
434 ##############################
435 # Installation
436 ##############################
437 %install
438 rm -rf %{buildroot}
439
440 pushd %{_builddir}/%{name}-%{version}/build/tizen
441
442 # if mobile || "undefined"
443 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
444 pushd mobile
445 %make_install
446 pushd  %{buildroot}%{_libdir}
447 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile
448 popd
449 make clean # So that we can gather symbol/size information for only one profile
450 popd
451 %endif
452
453 # if tv ||"undefined"
454 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
455 pushd tv
456 %make_install
457 pushd  %{buildroot}%{_libdir}
458 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv
459 popd
460 make clean # So that we can gather symbol/size information for only one profile
461 popd
462 %endif
463
464 # if wearable || "undefined"
465 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
466 pushd wearable
467 %make_install
468 pushd  %{buildroot}%{_libdir}
469 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable
470 popd
471 make clean # So that we can gather symbol/size information for only one profile
472 popd
473 %endif
474
475 # if ivi ||"undefined"
476 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
477 pushd ivi
478 %make_install
479 pushd  %{buildroot}%{_libdir}
480 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi
481 popd
482 make clean # So that we can gather symbol/size information for only one profile
483 popd
484 %endif
485
486 # if common ||"undefined"
487 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
488 pushd common
489 %make_install
490 # No clean so we can gather symbol/size information for the common profile
491 popd
492 %endif
493
494 # Create links to ensure linking with cxx11 library is preserved
495 pushd  %{buildroot}%{_libdir}
496 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
497 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
498 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
499 popd
500
501 ##############################
502 # Upgrade order:
503 # 1 - Pre Install new package
504 # 2 - Install new package
505 # 3 - Post install new package
506 # 4 - Pre uninstall old package
507 # 5 - Remove files not overwritten by new package
508 # 6 - Post uninstall old package
509 ##############################
510
511 ##############################
512 # Adaptor package Commands
513 %pre
514 exit 0
515
516 %post
517 /sbin/ldconfig
518 exit 0
519
520 %preun
521 exit 0
522
523 %postun
524 /sbin/ldconfig
525 exit 0
526
527 ##############################
528 # Mobile Profile Commands
529 # if mobile || "undefined"
530 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
531 %post profile_mobile
532 pushd %{_libdir}
533 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
534 popd
535 /sbin/ldconfig
536 exit 0
537
538 %postun profile_mobile
539 /sbin/ldconfig
540 exit 0
541 %endif
542
543 ##############################
544 # TV Profile Commands
545 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
546 %post profile_tv
547 pushd %{_libdir}
548 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
549 popd
550 /sbin/ldconfig
551 exit 0
552
553 %postun profile_tv
554 /sbin/ldconfig
555 exit 0
556 %endif
557
558 ##############################
559 # Wearable Profile Commands
560 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
561 %post profile_wearable
562 pushd %{_libdir}
563 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
564 popd
565 /sbin/ldconfig
566 exit 0
567
568 %postun profile_wearable
569 /sbin/ldconfig
570 exit 0
571 %endif
572
573 ##############################
574 # IVI Profile Commands
575 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
576 %post profile_ivi
577 pushd %{_libdir}
578 ln -sf libdali-adaptor.ivi libdali-adaptor.so.0.0.0
579 popd
580 /sbin/ldconfig
581 exit 0
582
583 %postun profile_ivi
584 /sbin/ldconfig
585 exit 0
586 %endif
587
588 ##############################
589 # Common Profile Commands
590 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
591 %post profile_common
592 /sbin/ldconfig
593 exit 0
594
595 %postun profile_common
596 /sbin/ldconfig
597 exit 0
598 %endif
599
600 ##############################
601 # Files in Binary Packages
602 ##############################
603
604 %files
605 %manifest dali-adaptor.manifest
606 %defattr(-,root,root,-)
607 %dir %{user_shader_cache_dir}
608 %{_bindir}/*
609 %license LICENSE
610 %defattr(-,root,root,-)
611 %{_libdir}/libdali-adaptor-cxx11.so
612 %{_libdir}/libdali-adaptor-cxx11.so.0
613 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
614 %{_libdir}/libdali-adaptor.so
615 %{_libdir}/libdali-adaptor.so.0
616 %{_libdir}/libdali-adaptor.so.0.0.0
617
618 #################################################
619
620 %files dali-feedback-plugin
621 %manifest dali-adaptor.manifest
622 %defattr(-,root,root,-)
623 %{_libdir}/libdali-feedback-plugin-cxx11.so*
624 %{dali_plugin_sound_files}/*
625
626 #################################################
627
628 # if common ||"undefined"
629 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
630 %files profile_common
631 %manifest dali-adaptor.manifest
632 # default .so files are housed in the main pkg.
633 %endif
634
635 # if mobile || "undefined"
636 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
637 %files profile_mobile
638 %manifest dali-adaptor.manifest
639 %defattr(-,root,root,-)
640 %{_libdir}/libdali-adaptor.so.mobile
641 %endif
642
643 # if tv ||"undefined"
644 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
645 %files profile_tv
646 %manifest dali-adaptor.manifest
647 %defattr(-,root,root,-)
648 %{_libdir}/libdali-adaptor.so.tv
649 %endif
650
651 # if wearable || "undefined"
652 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
653 %files profile_wearable
654 %manifest dali-adaptor.manifest
655 %defattr(-,root,root,-)
656 %{_libdir}/libdali-adaptor.so.wearable
657 %endif
658
659 # if ivi ||"undefined"
660 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
661 %files profile_ivi
662 %manifest dali-adaptor.manifest
663 %defattr(-,root,root,-)
664 %{_libdir}/libdali-adaptor.so.ivi
665 %endif
666
667 %files devel
668 %defattr(-,root,root,-)
669 %{dev_include_path}/dali/dali.h
670 %{dev_include_path}/dali/public-api/*
671 %{dev_include_path}/dali/devel-api/*
672 %{dev_include_path}/dali/doc/*
673 %{_libdir}/pkgconfig/dali-adaptor.pc
674
675 %files integration-devel
676 %defattr(-,root,root,-)
677 %{dev_include_path}/dali/integration-api/adaptors/*
678 %{_libdir}/pkgconfig/dali-adaptor-integration.pc