[dali_2.3.22] Merge branch 'devel/master'
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.3.22
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 %endif
40
41 BuildRequires:  pkgconfig(screen_connector_provider)
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(wayland-egl)
71 BuildRequires:  pkgconfig(wayland-client)
72 BuildRequires:  pkgconfig(input-method-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # WebP support only from Tizen 6 onwards
77 %if 0%{?tizen_version_major} >= 6
78 BuildRequires:  pkgconfig(libwebp)
79 BuildRequires:  pkgconfig(libwebpdecoder)
80 BuildRequires:  pkgconfig(libwebpdemux)
81 BuildRequires:  pkgconfig(libwebpmux)
82 %endif
83
84 # We use ecore mainloop
85 %if 0%{?tizen_version_major} >= 5
86 BuildRequires:  pkgconfig(ecore-wl2)
87 BuildRequires:  pkgconfig(wayland-egl-tizen)
88 %else
89 BuildRequires:  pkgconfig(ecore-wayland)
90 %endif
91
92 # We need tbm_surface in tizen 3.0 wayland
93 BuildRequires:  pkgconfig(libtbm)
94
95 # for the adaptor
96 BuildRequires:  pkgconfig(app-core-ui-cpp)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for ATSPI (Accessibility) support
106 BuildRequires:  pkgconfig(eldbus)
107
108 # for feedback plugin
109 BuildRequires:  pkgconfig(mm-sound)
110 BuildRequires:  pkgconfig(feedback)
111 BuildRequires:  pkgconfig(component-based-core-base)
112
113
114 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
115 BuildRequires:  pkgconfig(thorvg)
116 %endif
117
118 # for multiprofile
119 Requires:   %{name}-compat = %{version}-%{release}
120 Recommends: %{name}-profile_common = %{version}-%{release}
121
122 %description
123 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
124 platform abstraction and application shell
125
126 ###########################################
127 # Dali adapter for profiles
128 ###########################################
129
130 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
131 # if mobile || "undefined"
132 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
133 %package profile_mobile
134 Summary:        The DALi Tizen Adaptor for mobile
135 Provides:       %{name}-compat = %{version}-%{release}
136 Conflicts:      %{name}-profile_tv
137 Conflicts:      %{name}-profile_wearable
138 Conflicts:      %{name}-profile_ivi
139 Conflicts:      %{name}-profile_common
140 Requires:       %{name}
141 %description profile_mobile
142 The DALi Tizen Adaptor for mobile.
143 %endif
144
145 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
146 # if tv ||"undefined"
147 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
148 %package profile_tv
149 Summary:        The DALi Tizen Adaptor for tv
150 Provides:       %{name}-compat = %{version}-%{release}
151 Conflicts:      %{name}-profile_mobile
152 Conflicts:      %{name}-profile_wearable
153 Conflicts:      %{name}-profile_ivi
154 Conflicts:      %{name}-profile_common
155 Requires:       %{name}
156 %description profile_tv
157 The DALi Tizen Adaptor for tv.
158 %endif
159
160 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
161 # if wearable || "undefined"
162 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
163 %package profile_wearable
164 Summary:        The DALi Tizen Adaptor for wearable
165 Provides:       %{name}-compat = %{version}-%{release}
166 Conflicts:      %{name}-profile_mobile
167 Conflicts:      %{name}-profile_tv
168 Conflicts:      %{name}-profile_ivi
169 Conflicts:      %{name}-profile_common
170 Requires:       %{name}
171 %description profile_wearable
172 The DALi Tizen Adaptor for wearable.
173 %endif
174
175 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
176 # if ivi ||"undefined"
177 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
178 %package profile_ivi
179 Summary:        The DALi Tizen Adaptor for ivi
180 Provides:       %{name}-compat = %{version}-%{release}
181 Conflicts:      %{name}-profile_mobile
182 Conflicts:      %{name}-profile_wearable
183 Conflicts:      %{name}-profile_tv
184 Conflicts:      %{name}-profile_common
185 Requires:       %{name}
186 %description profile_ivi
187 The DALi Tizen Adaptor for ivi.
188 %endif
189
190 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
191 # if common ||"undefined"
192 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
193 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
194 %package profile_common
195 Summary:        The DALi Tizen Adaptor for common
196 Provides:       %{name}-compat = %{version}-%{release}
197 Conflicts:      %{name}-profile_mobile
198 Conflicts:      %{name}-profile_wearable
199 Conflicts:      %{name}-profile_tv
200 Conflicts:      %{name}-profile_ivi
201 Requires:       %{name}
202 %description profile_common
203 The DALi Tizen Adaptor for common.
204 %endif
205
206 ##############################
207 # devel
208 ##############################
209 %package devel
210 Summary:    Development components for the DALi Tizen Adaptor
211 Group:      Development/Building
212 Requires:   %{name} = %{version}-%{release}
213 Requires:   %{name}-integration-devel = %{version}-%{release}
214
215 %description devel
216 Development components for the DALi Tizen Adaptor - public headers and package configs
217
218 ##############################
219 # integration-devel
220 ##############################
221 %package integration-devel
222 Summary:    Integration development package for the Adaptor
223 Group:      Development/Building
224 Requires:   %{name} = %{version}-%{release}
225
226 %description integration-devel
227 Integration development package for the Adaptor - headers for integrating with an adaptor library.
228
229 ##############################
230 # Dali Feedback Plugin
231 ##############################
232 %package dali2-feedback-plugin
233 Summary:    Plugin to play haptic and audio feedback for Dali
234 Group:      System/Libraries
235 Requires:   %{name} = %{version}-%{release}
236 %description dali2-feedback-plugin
237 Feedback plugin to play haptic and audio feedback for Dali
238
239 #Use TZ_PATH when tizen version is 3.x or greater
240 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
241 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
242 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
243 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
244 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
245 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
246
247 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
248 %define dali_plugin_sound_files  /plugins/sounds/
249
250 ##############################
251 # Preparation
252 ##############################
253 %prep
254 %setup -q
255
256
257 ##############################
258 # Build
259 ##############################
260 %build
261 PREFIX+="/usr"
262 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
263 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
264
265 %ifarch %{arm}
266 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
267 %endif
268
269 CFLAGS+=" -DWAYLAND"
270 CXXFLAGS+=" -DWAYLAND"
271 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON"
272
273 %if 0%{?enable_streamline}
274 cmake_flags+=" -DENABLE_TRACE_STREAMLINE=ON"
275 %else
276 cmake_flags+=" -DENABLE_TRACE=ON"
277 %endif
278
279 # Use this conditional when Tizen version is 5.x or greater
280 %if 0%{?tizen_version_major} >= 5
281 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
282
283 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
284 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
285 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
286 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
287 %endif
288
289 # Use this conditional when Tizen version is 7.x or greater
290 %if 0%{?tizen_version_major} >= 7
291 CXXFLAGS+=" -DOVER_TIZEN_VERSION_7"
292 %endif
293
294 # Use this conditional when Tizen version is 8.x or greater
295 %if 0%{?tizen_version_major} >= 8
296 CXXFLAGS+=" -DOVER_TIZEN_VERSION_8"
297 %endif
298
299 %if 0%{?enable_debug}
300 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
301 %endif
302
303 %if 0%{?enable_logging}
304 cmake_flags+=" -DENABLE_NETWORK_LOGGING=ON"
305 %endif
306
307 libtoolize --force
308 cd %{_builddir}/%{name}-%{version}/build/tizen
309
310 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
311 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
312 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
313 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
314 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
315 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
316 %if 0%{?tizen_platform_config_supported}
317 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
318 %endif
319
320 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
321 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
322 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
323 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
324 cmake_flags+=" -DENABLE_FEEDBACK=YES"
325 cmake_flags+=" -DENABLE_APPFW=YES"
326 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
327
328 # Set up the build via Cmake
329 #######################################################################
330 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
331 # if mobile || "undefined"
332 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
333
334 mkdir -p mobile
335 pushd mobile
336
337 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
338
339 # Build.
340 make %{?jobs:-j%jobs}
341 popd
342
343 %endif
344
345 #######################################################################
346 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
347 # if tv ||"undefined"
348 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
349
350 mkdir -p tv
351 pushd tv
352
353 cmake -DENABLE_PROFILE=TV $cmake_flags ..
354
355 # Build.
356 make %{?jobs:-j%jobs}
357 popd
358
359 %endif
360
361 #######################################################################
362 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
363 # if wearable || "undefined"
364 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
365
366 mkdir -p wearable
367 pushd wearable
368
369 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
370
371 # Build.
372 make %{?jobs:-j%jobs}
373 popd
374
375 %endif
376
377 #######################################################################
378 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
379 # if ivi ||"undefined"
380 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
381
382 mkdir -p ivi
383 pushd ivi
384
385 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
386
387 # Build.
388 make %{?jobs:-j%jobs}
389 popd
390
391 %endif
392
393 #######################################################################
394 # common
395 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
396 # if common ||"undefined"
397 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
398
399 mkdir -p common
400 pushd common
401
402 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
403
404 # Build.
405 make %{?jobs:-j%jobs}
406 popd
407
408 %endif
409
410 ##############################
411 # Installation
412 ##############################
413 %install
414 rm -rf %{buildroot}
415
416 pushd %{_builddir}/%{name}-%{version}/build/tizen
417
418 # if mobile || "undefined"
419 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
420 pushd mobile
421 %make_install
422 %if "%{?profile}" != "mobile"
423 pushd  %{buildroot}%{_libdir}
424 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
425 popd
426 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
427 %endif
428 popd
429 %endif
430
431 # if tv ||"undefined"
432 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
433 pushd tv
434 %make_install
435 %if "%{?profile}" != "tv"
436 pushd  %{buildroot}%{_libdir}
437 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
438 popd
439 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
440 %endif
441 popd
442 %endif
443
444 # if wearable || "undefined"
445 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
446 pushd wearable
447 %make_install
448 %if "%{?profile}" != "wearable"
449 pushd  %{buildroot}%{_libdir}
450 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
451 popd
452 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
453 %endif
454 popd
455 %endif
456
457 # if ivi ||"undefined"
458 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
459 pushd ivi
460 %make_install
461 %if "%{?profile}" != "ivi"
462 pushd  %{buildroot}%{_libdir}
463 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
464 popd
465 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
466 %endif
467 popd
468 %endif
469
470 # if common ||"undefined"
471 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
472 pushd common
473 %make_install
474 # No clean so we can gather symbol/size information for the common profile
475 popd
476 %endif
477
478 # Create a symbolic link in integration-api to preserve legacy repo build
479 pushd %{buildroot}%{_includedir}/dali/integration-api
480 ln -sf adaptor-framework adaptors
481 popd
482
483 ##############################
484 # Upgrade order:
485 # 1 - Pre Install new package
486 # 2 - Install new package
487 # 3 - Post install new package
488 # 4 - Pre uninstall old package
489 # 5 - Remove files not overwritten by new package
490 # 6 - Post uninstall old package
491 ##############################
492
493 ##############################
494 # Adaptor package Commands
495 %pre
496 exit 0
497
498 %post
499 pushd %{_libdir}
500 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
501 popd
502 /sbin/ldconfig
503 exit 0
504
505 %preun
506 exit 0
507
508 %postun
509 /sbin/ldconfig
510 exit 0
511
512 ##############################
513 # Mobile Profile Commands
514 # if mobile || "undefined"
515 # No need to create a symbolic link on install required if only building this profile
516 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
517 %post profile_mobile
518 %if "%{?profile}" != "mobile"
519 pushd %{_libdir}
520 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
521 popd
522 %endif
523 /sbin/ldconfig
524 exit 0
525
526 %postun profile_mobile
527 /sbin/ldconfig
528 exit 0
529 %endif
530
531 ##############################
532 # TV Profile Commands
533 # No need to create a symbolic link on install required if only building this profile
534 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
535 %post profile_tv
536 %if "%{?profile}" != "tv"
537 pushd %{_libdir}
538 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
539 popd
540 %endif
541 /sbin/ldconfig
542 exit 0
543
544 %postun profile_tv
545 /sbin/ldconfig
546 exit 0
547 %endif
548
549 ##############################
550 # Wearable Profile Commands
551 # No need to create a symbolic link on install required if only building this profile
552 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
553 %post profile_wearable
554 %if "%{?profile}" != "wearable"
555 pushd %{_libdir}
556 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
557 popd
558 %endif
559 /sbin/ldconfig
560 exit 0
561
562 %postun profile_wearable
563 /sbin/ldconfig
564 exit 0
565 %endif
566
567 ##############################
568 # IVI Profile Commands
569 # No need to create a symbolic link on install required if only building this profile
570 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
571 %post profile_ivi
572 %if "%{?profile}" != "ivi"
573 pushd %{_libdir}
574 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
575 popd
576 %endif
577 /sbin/ldconfig
578 exit 0
579
580 %postun profile_ivi
581 /sbin/ldconfig
582 exit 0
583 %endif
584
585 ##############################
586 # Common Profile Commands
587 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
588 %post profile_common
589 /sbin/ldconfig
590 exit 0
591
592 %postun profile_common
593 /sbin/ldconfig
594 exit 0
595 %endif
596
597 ##############################
598 # Files in Binary Packages
599 ##############################
600
601 %files
602 %manifest dali-adaptor.manifest
603 %defattr(-,root,root,-)
604 %dir %{user_shader_cache_dir}
605 %{_bindir}/*
606 %license LICENSE
607 %defattr(-,root,root,-)
608 %{_libdir}/libdali2-adaptor.so
609 %{_libdir}/libdali2-adaptor.so.2
610 %{_libdir}/libdali2-adaptor.so.2.0.0
611
612 #################################################
613
614 %files dali2-feedback-plugin
615 %manifest dali-adaptor.manifest
616 %defattr(-,root,root,-)
617 %{_libdir}/libdali2-feedback-plugin.so*
618 %{dali_plugin_sound_files}/*
619
620 #################################################
621
622 # if common ||"undefined"
623 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
624 %files profile_common
625 %manifest dali-adaptor.manifest
626 # default .so files are housed in the main pkg.
627 %endif
628
629 # if mobile || "undefined"
630 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
631 %files profile_mobile
632 %manifest dali-adaptor.manifest
633 %defattr(-,root,root,-)
634 %if "%{?profile}" != "mobile"
635 %{_libdir}/libdali2-adaptor.so.mobile
636 %endif
637 %endif
638
639 # if tv ||"undefined"
640 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
641 %files profile_tv
642 %manifest dali-adaptor.manifest
643 %defattr(-,root,root,-)
644 %if "%{?profile}" != "tv"
645 %{_libdir}/libdali2-adaptor.so.tv
646 %endif
647 %endif
648
649 # if wearable || "undefined"
650 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
651 %files profile_wearable
652 %manifest dali-adaptor.manifest
653 %defattr(-,root,root,-)
654 %if "%{?profile}" != "wearable"
655 %{_libdir}/libdali2-adaptor.so.wearable
656 %endif
657 %endif
658
659 # if ivi ||"undefined"
660 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
661 %files profile_ivi
662 %manifest dali-adaptor.manifest
663 %defattr(-,root,root,-)
664 %if "%{?profile}" != "ivi"
665 %{_libdir}/libdali2-adaptor.so.ivi
666 %endif
667 %endif
668
669 %files devel
670 %defattr(-,root,root,-)
671 %{_includedir}/dali/dali.h
672 %{_includedir}/dali/public-api/*
673 %{_includedir}/dali/devel-api/*
674 %{_includedir}/dali/doc/*
675 %{_libdir}/pkgconfig/dali2-adaptor.pc
676
677 %files integration-devel
678 %defattr(-,root,root,-)
679 %{_includedir}/dali/integration-api/adaptor-framework/*
680 %{_includedir}/dali/integration-api/adaptors
681 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc