Merge "Remove DALI_ADAPTOR_COMPILATION define" into devel/master
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.43
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30 Provides: libdali-adaptor-cxx11.so
31 Provides: libdali-adaptor-cxx11.so.0
32 Provides: libdali-adaptor-cxx11.so.0.0.0
33
34 %define tizen_platform_config_supported 1
35 BuildRequires:  pkgconfig(libtzplatform-config)
36
37 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
38 # if wearable || "undefined"
39 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
40 BuildRequires:  pkgconfig(capi-appfw-watch-application)
41 BuildRequires:  pkgconfig(appcore-watch)
42 BuildRequires:  pkgconfig(screen_connector_provider)
43 %endif
44
45 BuildRequires:  pkgconfig(gles20)
46 BuildRequires:  pkgconfig(glesv2)
47 BuildRequires:  pkgconfig(ttrace)
48
49 BuildRequires:  dali-devel
50 BuildRequires:  dali-integration-devel
51
52 BuildRequires:  pkgconfig
53 BuildRequires:  gawk
54 BuildRequires:  cmake
55 BuildRequires:  giflib-devel
56 BuildRequires:  pkgconfig(fontconfig)
57 BuildRequires:  libjpeg-turbo-devel
58 BuildRequires:  pkgconfig(vconf)
59 BuildRequires:  tts-devel
60 BuildRequires:  pkgconfig(dlog)
61 BuildRequires:  libdrm-devel
62 BuildRequires:  pkgconfig(libexif)
63 BuildRequires:  pkgconfig(libpng)
64 BuildRequires:  pkgconfig(egl)
65 BuildRequires:  libcurl-devel
66 BuildRequires:  pkgconfig(harfbuzz)
67 BuildRequires:  fribidi-devel
68
69 BuildRequires:  pkgconfig(capi-system-info)
70 BuildRequires:  pkgconfig(capi-system-sensor)
71
72 BuildRequires:  pkgconfig(cairo)
73
74 BuildRequires:  pkgconfig(wayland-egl)
75 BuildRequires:  pkgconfig(wayland-client)
76 BuildRequires:  wayland-devel
77 BuildRequires:  wayland-extension-client-devel
78
79 # dali-adaptor uses ecore mainloop
80 %if 0%{?tizen_version_major} >= 5
81 BuildRequires:  pkgconfig(ecore-wl2)
82 BuildRequires:  pkgconfig(wayland-egl-tizen)
83 %else
84 BuildRequires:  pkgconfig(ecore-wayland)
85 %endif
86
87 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
88 BuildRequires:  pkgconfig(libtbm)
89
90 BuildRequires:  pkgconfig(tpkp-curl)
91
92 # for dali-adaptor
93 BuildRequires:  pkgconfig(appcore-ui)
94 BuildRequires:  pkgconfig(appcore-widget-base)
95 BuildRequires:  pkgconfig(bundle)
96 BuildRequires:  pkgconfig(capi-appfw-app-common)
97 BuildRequires:  pkgconfig(capi-appfw-app-control)
98 BuildRequires:  pkgconfig(ecore-imf)
99
100 BuildRequires:  pkgconfig(capi-system-system-settings)
101
102 # for feedback plugin
103 BuildRequires:  pkgconfig(mm-sound)
104 BuildRequires:  pkgconfig(feedback)
105
106 # for multiprofile
107 Requires:   %{name}-compat = %{version}-%{release}
108 Recommends: %{name}-profile_common = %{version}-%{release}
109
110 %description
111 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
112 platform abstraction and application shell
113
114 ###########################################
115 # Dali adapter for profiles
116 ###########################################
117
118 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
119 # if mobile || "undefined"
120 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
121 %package profile_mobile
122 Summary:        The DALi Tizen Adaptor for mobile
123 Provides:       %{name}-compat = %{version}-%{release}
124 Conflicts:      %{name}-profile_tv
125 Conflicts:      %{name}-profile_wearable
126 Conflicts:      %{name}-profile_ivi
127 Conflicts:      %{name}-profile_common
128 %description profile_mobile
129 The DALi Tizen Adaptor for mobile.
130 %endif
131
132 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
133 # if tv ||"undefined"
134 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
135 %package profile_tv
136 Summary:        The DALi Tizen Adaptor for tv
137 Provides:       %{name}-compat = %{version}-%{release}
138 Conflicts:      %{name}-profile_mobile
139 Conflicts:      %{name}-profile_wearable
140 Conflicts:      %{name}-profile_ivi
141 Conflicts:      %{name}-profile_common
142 %description profile_tv
143 The DALi Tizen Adaptor for tv.
144 %endif
145
146 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
147 # if wearable || "undefined"
148 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
149 %package profile_wearable
150 Summary:        The DALi Tizen Adaptor for wearable
151 Provides:       %{name}-compat = %{version}-%{release}
152 Conflicts:      %{name}-profile_mobile
153 Conflicts:      %{name}-profile_tv
154 Conflicts:      %{name}-profile_ivi
155 Conflicts:      %{name}-profile_common
156 %description profile_wearable
157 The DALi Tizen Adaptor for wearable.
158 %endif
159
160 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
161 # if ivi ||"undefined"
162 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
163 %package profile_ivi
164 Summary:        The DALi Tizen Adaptor for ivi
165 Provides:       %{name}-compat = %{version}-%{release}
166 Conflicts:      %{name}-profile_mobile
167 Conflicts:      %{name}-profile_wearable
168 Conflicts:      %{name}-profile_tv
169 Conflicts:      %{name}-profile_common
170 %description profile_ivi
171 The DALi Tizen Adaptor for ivi.
172 %endif
173
174 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
175 # if common ||"undefined"
176 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
177 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
178 %package profile_common
179 Summary:        The DALi Tizen Adaptor for common
180 Provides:       %{name}-compat = %{version}-%{release}
181 Conflicts:      %{name}-profile_mobile
182 Conflicts:      %{name}-profile_wearable
183 Conflicts:      %{name}-profile_tv
184 Conflicts:      %{name}-profile_ivi
185 %description profile_common
186 The DALi Tizen Adaptor for common.
187 %endif
188
189 ##############################
190 # devel
191 ##############################
192 %package devel
193 Summary:    Development components for the DALi Tizen Adaptor
194 Group:      Development/Building
195 Requires:   %{name} = %{version}-%{release}
196 Requires:   %{name}-integration-devel = %{version}-%{release}
197
198 %description devel
199 Development components for the DALi Tizen Adaptor - public headers and package configs
200
201 ##############################
202 # integration-devel
203 ##############################
204 %package integration-devel
205 Summary:    Integration development package for the Adaptor
206 Group:      Development/Building
207 Requires:   %{name} = %{version}-%{release}
208
209 %description integration-devel
210 Integration development package for the Adaptor - headers for integrating with an adaptor library.
211
212 ##############################
213 # Dali Feedback Plugin
214 ##############################
215 %package dali-feedback-plugin
216 Summary:    Plugin to play haptic and audio feedback for Dali
217 Group:      System/Libraries
218 Requires:   %{name} = %{version}-%{release}
219 %description dali-feedback-plugin
220 Feedback plugin to play haptic and audio feedback for Dali
221
222 ##############################
223 # Preparation
224 ##############################
225 %prep
226 %setup -q
227
228 #Use TZ_PATH when tizen version is 3.x or greater
229
230 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
231 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
232 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
233 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
234 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
235 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
236
237 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
238 %define dali_plugin_sound_files  /plugins/sounds/
239 %define dev_include_path %{_includedir}
240
241 ##############################
242 # Build
243 ##############################
244 %build
245 PREFIX+="/usr"
246 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
247 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
248
249 %ifarch %{arm}
250 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
251 %endif
252
253 CFLAGS+=" -DWAYLAND"
254 CXXFLAGS+=" -DWAYLAND"
255 cmake_flags=" -DENABLE_WAYLAND=ON"
256
257 # Use this conditional when Tizen version is 5.x or greater
258 %if 0%{?tizen_version_major} >= 5
259 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
260
261 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
262 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
263 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
264 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
265 %endif
266
267 %if 0%{?enable_debug}
268 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
269 %endif
270
271 %if 0%{?enable_trace}
272 cmake_flags+=" -DENABLE_TRACE=ON"
273 %endif
274
275 libtoolize --force
276 cd %{_builddir}/%{name}-%{version}/build/tizen
277
278 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
279 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
280 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
281 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
282 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
283 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
284 %if 0%{?tizen_platform_config_supported}
285 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
286 %endif
287
288 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
289 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
290 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
291 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
292 cmake_flags+=" -DENABLE_FEEDBACK=YES"
293 cmake_flags+=" -DENABLE_APPFW=YES"
294
295 # Set up the build via Cmake
296 #######################################################################
297 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
298 # if mobile || "undefined"
299 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
300
301 mkdir mobile
302 pushd mobile
303
304 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
305
306 # Build.
307 make %{?jobs:-j%jobs}
308 popd
309
310 %endif
311
312 #######################################################################
313 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
314 # if tv ||"undefined"
315 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
316
317 mkdir tv
318 pushd tv
319
320 cmake -DENABLE_PROFILE=TV $cmake_flags ..
321
322 # Build.
323 make %{?jobs:-j%jobs}
324 popd
325
326 %endif
327
328 #######################################################################
329 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
330 # if wearable || "undefined"
331 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
332
333 mkdir wearable
334 pushd wearable
335
336 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
337
338 # Build.
339 make %{?jobs:-j%jobs}
340 popd
341
342 %endif
343
344 #######################################################################
345 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
346 # if ivi ||"undefined"
347 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
348
349 mkdir ivi
350 pushd ivi
351
352 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
353
354 # Build.
355 make %{?jobs:-j%jobs}
356 popd
357
358 %endif
359
360 #######################################################################
361 # common
362 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
363 # if common ||"undefined"
364 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
365
366 mkdir common
367 pushd common
368
369 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
370
371 # Build.
372 make %{?jobs:-j%jobs}
373 popd
374
375 %endif
376
377 ##############################
378 # Installation
379 ##############################
380 %install
381 rm -rf %{buildroot}
382
383 pushd %{_builddir}/%{name}-%{version}/build/tizen
384
385 # if mobile || "undefined"
386 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
387 pushd mobile
388 %make_install
389 pushd  %{buildroot}%{_libdir}
390 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile
391 popd
392 %if "%{?profile}" != "mobile"
393 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
394 %endif
395 popd
396 %endif
397
398 # if tv ||"undefined"
399 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
400 pushd tv
401 %make_install
402 pushd  %{buildroot}%{_libdir}
403 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv
404 popd
405 %if "%{?profile}" != "tv"
406 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
407 %endif
408 popd
409 %endif
410
411 # if wearable || "undefined"
412 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
413 pushd wearable
414 %make_install
415 pushd  %{buildroot}%{_libdir}
416 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable
417 popd
418 %if "%{?profile}" != "wearable"
419 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
420 %endif
421 popd
422 %endif
423
424 # if ivi ||"undefined"
425 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
426 pushd ivi
427 %make_install
428 pushd  %{buildroot}%{_libdir}
429 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi
430 popd
431 %if "%{?profile}" != "ivi"
432 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
433 %endif
434 popd
435 %endif
436
437 # if common ||"undefined"
438 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
439 pushd common
440 %make_install
441 # No clean so we can gather symbol/size information for the common profile
442 popd
443 %endif
444
445 # Create links to ensure linking with cxx11 library is preserved
446 pushd  %{buildroot}%{_libdir}
447 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
448 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
449 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
450 popd
451
452 ##############################
453 # Upgrade order:
454 # 1 - Pre Install new package
455 # 2 - Install new package
456 # 3 - Post install new package
457 # 4 - Pre uninstall old package
458 # 5 - Remove files not overwritten by new package
459 # 6 - Post uninstall old package
460 ##############################
461
462 ##############################
463 # Adaptor package Commands
464 %pre
465 exit 0
466
467 %post
468 /sbin/ldconfig
469 exit 0
470
471 %preun
472 exit 0
473
474 %postun
475 /sbin/ldconfig
476 exit 0
477
478 ##############################
479 # Mobile Profile Commands
480 # if mobile || "undefined"
481 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
482 %post profile_mobile
483 pushd %{_libdir}
484 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
485 popd
486 /sbin/ldconfig
487 exit 0
488
489 %postun profile_mobile
490 /sbin/ldconfig
491 exit 0
492 %endif
493
494 ##############################
495 # TV Profile Commands
496 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
497 %post profile_tv
498 pushd %{_libdir}
499 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
500 popd
501 /sbin/ldconfig
502 exit 0
503
504 %postun profile_tv
505 /sbin/ldconfig
506 exit 0
507 %endif
508
509 ##############################
510 # Wearable Profile Commands
511 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
512 %post profile_wearable
513 pushd %{_libdir}
514 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
515 popd
516 /sbin/ldconfig
517 exit 0
518
519 %postun profile_wearable
520 /sbin/ldconfig
521 exit 0
522 %endif
523
524 ##############################
525 # IVI Profile Commands
526 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
527 %post profile_ivi
528 pushd %{_libdir}
529 ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
530 popd
531 /sbin/ldconfig
532 exit 0
533
534 %postun profile_ivi
535 /sbin/ldconfig
536 exit 0
537 %endif
538
539 ##############################
540 # Common Profile Commands
541 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
542 %post profile_common
543 /sbin/ldconfig
544 exit 0
545
546 %postun profile_common
547 /sbin/ldconfig
548 exit 0
549 %endif
550
551 ##############################
552 # Files in Binary Packages
553 ##############################
554
555 %files
556 %manifest dali-adaptor.manifest
557 %defattr(-,root,root,-)
558 %dir %{user_shader_cache_dir}
559 %{_bindir}/*
560 %license LICENSE
561 %defattr(-,root,root,-)
562 %{_libdir}/libdali-adaptor-cxx11.so
563 %{_libdir}/libdali-adaptor-cxx11.so.0
564 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
565 %{_libdir}/libdali-adaptor.so
566 %{_libdir}/libdali-adaptor.so.0
567 %{_libdir}/libdali-adaptor.so.0.0.0
568
569 #################################################
570
571 %files dali-feedback-plugin
572 %manifest dali-adaptor.manifest
573 %defattr(-,root,root,-)
574 %{_libdir}/libdali-feedback-plugin-cxx11.so*
575 %{dali_plugin_sound_files}/*
576
577 #################################################
578
579 # if common ||"undefined"
580 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
581 %files profile_common
582 %manifest dali-adaptor.manifest
583 # default .so files are housed in the main pkg.
584 %endif
585
586 # if mobile || "undefined"
587 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
588 %files profile_mobile
589 %manifest dali-adaptor.manifest
590 %defattr(-,root,root,-)
591 %{_libdir}/libdali-adaptor.so.mobile
592 %endif
593
594 # if tv ||"undefined"
595 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
596 %files profile_tv
597 %manifest dali-adaptor.manifest
598 %defattr(-,root,root,-)
599 %{_libdir}/libdali-adaptor.so.tv
600 %endif
601
602 # if wearable || "undefined"
603 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
604 %files profile_wearable
605 %manifest dali-adaptor.manifest
606 %defattr(-,root,root,-)
607 %{_libdir}/libdali-adaptor.so.wearable
608 %endif
609
610 # if ivi ||"undefined"
611 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
612 %files profile_ivi
613 %manifest dali-adaptor.manifest
614 %defattr(-,root,root,-)
615 %{_libdir}/libdali-adaptor.so.ivi
616 %endif
617
618 %files devel
619 %defattr(-,root,root,-)
620 %{dev_include_path}/dali/dali.h
621 %{dev_include_path}/dali/public-api/*
622 %{dev_include_path}/dali/devel-api/*
623 %{dev_include_path}/dali/doc/*
624 %{_libdir}/pkgconfig/dali-adaptor.pc
625
626 %files integration-devel
627 %defattr(-,root,root,-)
628 %{dev_include_path}/dali/integration-api/adaptors/*
629 %{_libdir}/pkgconfig/dali-adaptor-integration.pc