DALi Version 1.4.54
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.54
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30 Provides: libdali-adaptor-cxx11.so
31 Provides: libdali-adaptor-cxx11.so.0
32 Provides: libdali-adaptor-cxx11.so.0.0.0
33 Provides: libdali-adaptor.so
34 Provides: libdali-adaptor.so.0
35 Provides: libdali-adaptor.so.0.0.0
36
37 %define tizen_platform_config_supported 1
38 BuildRequires:  pkgconfig(libtzplatform-config)
39
40 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
41 # if wearable || "undefined"
42 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
43 BuildRequires:  pkgconfig(capi-appfw-watch-application)
44 BuildRequires:  pkgconfig(appcore-watch)
45 BuildRequires:  pkgconfig(screen_connector_provider)
46 %endif
47
48 BuildRequires:  pkgconfig(gles20)
49 BuildRequires:  pkgconfig(glesv2)
50 BuildRequires:  pkgconfig(ttrace)
51
52 BuildRequires:  dali-devel
53 BuildRequires:  dali-integration-devel
54
55 BuildRequires:  pkgconfig
56 BuildRequires:  gawk
57 BuildRequires:  cmake
58 BuildRequires:  giflib-devel
59 BuildRequires:  pkgconfig(fontconfig)
60 BuildRequires:  libjpeg-turbo-devel
61 BuildRequires:  pkgconfig(vconf)
62 BuildRequires:  tts-devel
63 BuildRequires:  pkgconfig(dlog)
64 BuildRequires:  libdrm-devel
65 BuildRequires:  pkgconfig(libexif)
66 BuildRequires:  pkgconfig(libpng)
67 BuildRequires:  pkgconfig(egl)
68 BuildRequires:  libcurl-devel
69 BuildRequires:  pkgconfig(harfbuzz)
70 BuildRequires:  fribidi-devel
71
72 BuildRequires:  pkgconfig(capi-system-info)
73 BuildRequires:  pkgconfig(capi-system-sensor)
74
75 BuildRequires:  pkgconfig(cairo)
76
77 BuildRequires:  pkgconfig(wayland-egl)
78 BuildRequires:  pkgconfig(wayland-client)
79 BuildRequires:  wayland-devel
80 BuildRequires:  wayland-extension-client-devel
81
82 # dali-adaptor uses ecore mainloop
83 %if 0%{?tizen_version_major} >= 5
84 BuildRequires:  pkgconfig(ecore-wl2)
85 BuildRequires:  pkgconfig(wayland-egl-tizen)
86 %else
87 BuildRequires:  pkgconfig(ecore-wayland)
88 %endif
89
90 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
91 BuildRequires:  pkgconfig(libtbm)
92
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 # for dali-adaptor
96 BuildRequires:  pkgconfig(appcore-ui)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for feedback plugin
106 BuildRequires:  pkgconfig(mm-sound)
107 BuildRequires:  pkgconfig(feedback)
108
109 # for multiprofile
110 Requires:   %{name}-compat = %{version}-%{release}
111 Recommends: %{name}-profile_common = %{version}-%{release}
112
113 %description
114 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
115 platform abstraction and application shell
116
117 ###########################################
118 # Dali adapter for profiles
119 ###########################################
120
121 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
122 # if mobile || "undefined"
123 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
124 %package profile_mobile
125 Summary:        The DALi Tizen Adaptor for mobile
126 Provides:       %{name}-compat = %{version}-%{release}
127 Conflicts:      %{name}-profile_tv
128 Conflicts:      %{name}-profile_wearable
129 Conflicts:      %{name}-profile_ivi
130 Conflicts:      %{name}-profile_common
131 Requires:       %{name}
132 %description profile_mobile
133 The DALi Tizen Adaptor for mobile.
134 %endif
135
136 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
137 # if tv ||"undefined"
138 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
139 %package profile_tv
140 Summary:        The DALi Tizen Adaptor for tv
141 Provides:       %{name}-compat = %{version}-%{release}
142 Conflicts:      %{name}-profile_mobile
143 Conflicts:      %{name}-profile_wearable
144 Conflicts:      %{name}-profile_ivi
145 Conflicts:      %{name}-profile_common
146 Requires:       %{name}
147 %description profile_tv
148 The DALi Tizen Adaptor for tv.
149 %endif
150
151 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
152 # if wearable || "undefined"
153 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
154 %package profile_wearable
155 Summary:        The DALi Tizen Adaptor for wearable
156 Provides:       %{name}-compat = %{version}-%{release}
157 Conflicts:      %{name}-profile_mobile
158 Conflicts:      %{name}-profile_tv
159 Conflicts:      %{name}-profile_ivi
160 Conflicts:      %{name}-profile_common
161 Requires:       %{name}
162 %description profile_wearable
163 The DALi Tizen Adaptor for wearable.
164 %endif
165
166 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
167 # if ivi ||"undefined"
168 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
169 %package profile_ivi
170 Summary:        The DALi Tizen Adaptor for ivi
171 Provides:       %{name}-compat = %{version}-%{release}
172 Conflicts:      %{name}-profile_mobile
173 Conflicts:      %{name}-profile_wearable
174 Conflicts:      %{name}-profile_tv
175 Conflicts:      %{name}-profile_common
176 Requires:       %{name}
177 %description profile_ivi
178 The DALi Tizen Adaptor for ivi.
179 %endif
180
181 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
182 # if common ||"undefined"
183 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
184 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
185 %package profile_common
186 Summary:        The DALi Tizen Adaptor for common
187 Provides:       %{name}-compat = %{version}-%{release}
188 Conflicts:      %{name}-profile_mobile
189 Conflicts:      %{name}-profile_wearable
190 Conflicts:      %{name}-profile_tv
191 Conflicts:      %{name}-profile_ivi
192 Requires:       %{name}
193 %description profile_common
194 The DALi Tizen Adaptor for common.
195 %endif
196
197 ##############################
198 # devel
199 ##############################
200 %package devel
201 Summary:    Development components for the DALi Tizen Adaptor
202 Group:      Development/Building
203 Requires:   %{name} = %{version}-%{release}
204 Requires:   %{name}-integration-devel = %{version}-%{release}
205
206 %description devel
207 Development components for the DALi Tizen Adaptor - public headers and package configs
208
209 ##############################
210 # integration-devel
211 ##############################
212 %package integration-devel
213 Summary:    Integration development package for the Adaptor
214 Group:      Development/Building
215 Requires:   %{name} = %{version}-%{release}
216
217 %description integration-devel
218 Integration development package for the Adaptor - headers for integrating with an adaptor library.
219
220 ##############################
221 # Dali Feedback Plugin
222 ##############################
223 %package dali-feedback-plugin
224 Summary:    Plugin to play haptic and audio feedback for Dali
225 Group:      System/Libraries
226 Requires:   %{name} = %{version}-%{release}
227 %description dali-feedback-plugin
228 Feedback plugin to play haptic and audio feedback for Dali
229
230 ##############################
231 # Preparation
232 ##############################
233 %prep
234 %setup -q
235
236 #Use TZ_PATH when tizen version is 3.x or greater
237
238 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
239 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
240 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
241 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
242 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
243 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
244
245 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
246 %define dali_plugin_sound_files  /plugins/sounds/
247
248 ##############################
249 # Build
250 ##############################
251 %build
252 PREFIX+="/usr"
253 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
254 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
255
256 %ifarch %{arm}
257 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
258 %endif
259
260 CFLAGS+=" -DWAYLAND"
261 CXXFLAGS+=" -DWAYLAND"
262 cmake_flags=" -DENABLE_WAYLAND=ON"
263
264 # Use this conditional when Tizen version is 5.x or greater
265 %if 0%{?tizen_version_major} >= 5
266 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
267
268 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
269 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
270 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
271 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
272 %endif
273
274 %if 0%{?enable_debug}
275 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
276 %endif
277
278 %if 0%{?enable_trace}
279 cmake_flags+=" -DENABLE_TRACE=ON"
280 %endif
281
282 libtoolize --force
283 cd %{_builddir}/%{name}-%{version}/build/tizen
284
285 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
286 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
287 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
288 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
289 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
290 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
291 %if 0%{?tizen_platform_config_supported}
292 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
293 %endif
294
295 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
296 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
297 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
298 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
299 cmake_flags+=" -DENABLE_FEEDBACK=YES"
300 cmake_flags+=" -DENABLE_APPFW=YES"
301
302 # Set up the build via Cmake
303 #######################################################################
304 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
305 # if mobile || "undefined"
306 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
307
308 mkdir mobile
309 pushd mobile
310
311 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
312
313 # Build.
314 make %{?jobs:-j%jobs}
315 popd
316
317 %endif
318
319 #######################################################################
320 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
321 # if tv ||"undefined"
322 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
323
324 mkdir tv
325 pushd tv
326
327 cmake -DENABLE_PROFILE=TV $cmake_flags ..
328
329 # Build.
330 make %{?jobs:-j%jobs}
331 popd
332
333 %endif
334
335 #######################################################################
336 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
337 # if wearable || "undefined"
338 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
339
340 mkdir wearable
341 pushd wearable
342
343 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
344
345 # Build.
346 make %{?jobs:-j%jobs}
347 popd
348
349 %endif
350
351 #######################################################################
352 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
353 # if ivi ||"undefined"
354 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
355
356 mkdir ivi
357 pushd ivi
358
359 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
360
361 # Build.
362 make %{?jobs:-j%jobs}
363 popd
364
365 %endif
366
367 #######################################################################
368 # common
369 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
370 # if common ||"undefined"
371 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
372
373 mkdir common
374 pushd common
375
376 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
377
378 # Build.
379 make %{?jobs:-j%jobs}
380 popd
381
382 %endif
383
384 ##############################
385 # Installation
386 ##############################
387 %install
388 rm -rf %{buildroot}
389
390 pushd %{_builddir}/%{name}-%{version}/build/tizen
391
392 # if mobile || "undefined"
393 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
394 pushd mobile
395 %make_install
396 %if "%{?profile}" != "mobile"
397 pushd  %{buildroot}%{_libdir}
398 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
399 popd
400 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
401 %endif
402 popd
403 %endif
404
405 # if tv ||"undefined"
406 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
407 pushd tv
408 %make_install
409 %if "%{?profile}" != "tv"
410 pushd  %{buildroot}%{_libdir}
411 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
412 popd
413 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
414 %endif
415 popd
416 %endif
417
418 # if wearable || "undefined"
419 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
420 pushd wearable
421 %make_install
422 %if "%{?profile}" != "wearable"
423 pushd  %{buildroot}%{_libdir}
424 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
425 popd
426 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
427 %endif
428 popd
429 %endif
430
431 # if ivi ||"undefined"
432 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
433 pushd ivi
434 %make_install
435 %if "%{?profile}" != "ivi"
436 pushd  %{buildroot}%{_libdir}
437 cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
438 popd
439 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
440 %endif
441 popd
442 %endif
443
444 # if common ||"undefined"
445 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
446 pushd common
447 %make_install
448 # No clean so we can gather symbol/size information for the common profile
449 popd
450 %endif
451
452 # Create links to ensure linking with cxx11 library is preserved
453 pushd  %{buildroot}%{_libdir}
454 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
455 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
456 ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
457 popd
458
459 # Create a symbolic link in integration-api to preserve legacy repo build
460 pushd %{buildroot}%{_includedir}/dali/integration-api
461 ln -sf adaptor-framework adaptors
462 popd
463
464 ##############################
465 # Upgrade order:
466 # 1 - Pre Install new package
467 # 2 - Install new package
468 # 3 - Post install new package
469 # 4 - Pre uninstall old package
470 # 5 - Remove files not overwritten by new package
471 # 6 - Post uninstall old package
472 ##############################
473
474 ##############################
475 # Adaptor package Commands
476 %pre
477 exit 0
478
479 %post
480 pushd %{_libdir}
481 for i in mobile tv wearable ivi; do [[ -f libdali-adaptor.so.$i ]] && ln -sf libdali-adaptor.so.$i libdali-adaptor.so.0.0.0; done
482 popd
483 /sbin/ldconfig
484 exit 0
485
486 %preun
487 exit 0
488
489 %postun
490 /sbin/ldconfig
491 exit 0
492
493 ##############################
494 # Mobile Profile Commands
495 # if mobile || "undefined"
496 # No need to create a symbolic link on install required if only building this profile
497 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
498 %post profile_mobile
499 %if "%{?profile}" != "mobile"
500 pushd %{_libdir}
501 ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
502 popd
503 %endif
504 /sbin/ldconfig
505 exit 0
506
507 %postun profile_mobile
508 /sbin/ldconfig
509 exit 0
510 %endif
511
512 ##############################
513 # TV Profile Commands
514 # No need to create a symbolic link on install required if only building this profile
515 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
516 %post profile_tv
517 %if "%{?profile}" != "tv"
518 pushd %{_libdir}
519 ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
520 popd
521 %endif
522 /sbin/ldconfig
523 exit 0
524
525 %postun profile_tv
526 /sbin/ldconfig
527 exit 0
528 %endif
529
530 ##############################
531 # Wearable Profile Commands
532 # No need to create a symbolic link on install required if only building this profile
533 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
534 %post profile_wearable
535 %if "%{?profile}" != "wearable"
536 pushd %{_libdir}
537 ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
538 popd
539 %endif
540 /sbin/ldconfig
541 exit 0
542
543 %postun profile_wearable
544 /sbin/ldconfig
545 exit 0
546 %endif
547
548 ##############################
549 # IVI Profile Commands
550 # No need to create a symbolic link on install required if only building this profile
551 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
552 %post profile_ivi
553 %if "%{?profile}" != "ivi"
554 pushd %{_libdir}
555 ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
556 popd
557 %endif
558 /sbin/ldconfig
559 exit 0
560
561 %postun profile_ivi
562 /sbin/ldconfig
563 exit 0
564 %endif
565
566 ##############################
567 # Common Profile Commands
568 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
569 %post profile_common
570 /sbin/ldconfig
571 exit 0
572
573 %postun profile_common
574 /sbin/ldconfig
575 exit 0
576 %endif
577
578 ##############################
579 # Files in Binary Packages
580 ##############################
581
582 %files
583 %manifest dali-adaptor.manifest
584 %defattr(-,root,root,-)
585 %dir %{user_shader_cache_dir}
586 %{_bindir}/*
587 %license LICENSE
588 %defattr(-,root,root,-)
589 %{_libdir}/libdali-adaptor-cxx11.so
590 %{_libdir}/libdali-adaptor-cxx11.so.0
591 %{_libdir}/libdali-adaptor-cxx11.so.0.0.0
592 %{_libdir}/libdali-adaptor.so
593 %{_libdir}/libdali-adaptor.so.0
594 %{_libdir}/libdali-adaptor.so.0.0.0
595
596 #################################################
597
598 %files dali-feedback-plugin
599 %manifest dali-adaptor.manifest
600 %defattr(-,root,root,-)
601 %{_libdir}/libdali-feedback-plugin-cxx11.so*
602 %{dali_plugin_sound_files}/*
603
604 #################################################
605
606 # if common ||"undefined"
607 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
608 %files profile_common
609 %manifest dali-adaptor.manifest
610 # default .so files are housed in the main pkg.
611 %endif
612
613 # if mobile || "undefined"
614 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
615 %files profile_mobile
616 %manifest dali-adaptor.manifest
617 %defattr(-,root,root,-)
618 %if "%{?profile}" != "mobile"
619 %{_libdir}/libdali-adaptor.so.mobile
620 %endif
621 %endif
622
623 # if tv ||"undefined"
624 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
625 %files profile_tv
626 %manifest dali-adaptor.manifest
627 %defattr(-,root,root,-)
628 %if "%{?profile}" != "tv"
629 %{_libdir}/libdali-adaptor.so.tv
630 %endif
631 %endif
632
633 # if wearable || "undefined"
634 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
635 %files profile_wearable
636 %manifest dali-adaptor.manifest
637 %defattr(-,root,root,-)
638 %if "%{?profile}" != "wearable"
639 %{_libdir}/libdali-adaptor.so.wearable
640 %endif
641 %endif
642
643 # if ivi ||"undefined"
644 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
645 %files profile_ivi
646 %manifest dali-adaptor.manifest
647 %defattr(-,root,root,-)
648 %if "%{?profile}" != "ivi"
649 %{_libdir}/libdali-adaptor.so.ivi
650 %endif
651 %endif
652
653 %files devel
654 %defattr(-,root,root,-)
655 %{_includedir}/dali/dali.h
656 %{_includedir}/dali/public-api/*
657 %{_includedir}/dali/devel-api/*
658 %{_includedir}/dali/doc/*
659 %{_libdir}/pkgconfig/dali-adaptor.pc
660
661 %files integration-devel
662 %defattr(-,root,root,-)
663 %{_includedir}/dali/integration-api/adaptor-framework/*
664 %{_includedir}/dali/integration-api/adaptors
665 %{_libdir}/pkgconfig/dali-adaptor-integration.pc