Merge branch 'devel/master' into devel/graphics
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.0.25
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(cairo)
71
72 BuildRequires:  pkgconfig(wayland-egl)
73 BuildRequires:  pkgconfig(wayland-client)
74 BuildRequires:  wayland-devel
75 BuildRequires:  wayland-extension-client-devel
76
77 # WebP support only from Tizen 6 onwards
78 %if 0%{?tizen_version_major} >= 6
79 BuildRequires:  pkgconfig(libwebp)
80 BuildRequires:  pkgconfig(libwebpdecoder)
81 BuildRequires:  pkgconfig(libwebpdemux)
82 BuildRequires:  pkgconfig(libwebpmux)
83 %endif
84
85 # We use ecore mainloop
86 %if 0%{?tizen_version_major} >= 5
87 BuildRequires:  pkgconfig(ecore-wl2)
88 BuildRequires:  pkgconfig(wayland-egl-tizen)
89 %else
90 BuildRequires:  pkgconfig(ecore-wayland)
91 %endif
92
93 # We need tbm_surface in tizen 3.0 wayland
94 BuildRequires:  pkgconfig(libtbm)
95
96 # for the adaptor
97 BuildRequires:  pkgconfig(appcore-ui)
98 BuildRequires:  pkgconfig(appcore-widget-base)
99 BuildRequires:  pkgconfig(bundle)
100 BuildRequires:  pkgconfig(capi-appfw-app-common)
101 BuildRequires:  pkgconfig(capi-appfw-app-control)
102 BuildRequires:  pkgconfig(ecore-imf)
103
104 BuildRequires:  pkgconfig(capi-system-system-settings)
105
106 # for ATSPI (Accessibility) support
107 BuildRequires:  pkgconfig(eldbus)
108
109 # for feedback plugin
110 BuildRequires:  pkgconfig(mm-sound)
111 BuildRequires:  pkgconfig(feedback)
112 BuildRequires:  pkgconfig(component-based-core-base)
113
114
115 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
116 BuildRequires:  pkgconfig(thorvg)
117 %endif
118
119 # for multiprofile
120 Requires:   %{name}-compat = %{version}-%{release}
121 Recommends: %{name}-profile_common = %{version}-%{release}
122
123 %description
124 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
125 platform abstraction and application shell
126
127 ###########################################
128 # Dali adapter for profiles
129 ###########################################
130
131 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
132 # if mobile || "undefined"
133 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
134 %package profile_mobile
135 Summary:        The DALi Tizen Adaptor for mobile
136 Provides:       %{name}-compat = %{version}-%{release}
137 Conflicts:      %{name}-profile_tv
138 Conflicts:      %{name}-profile_wearable
139 Conflicts:      %{name}-profile_ivi
140 Conflicts:      %{name}-profile_common
141 Requires:       %{name}
142 %description profile_mobile
143 The DALi Tizen Adaptor for mobile.
144 %endif
145
146 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
147 # if tv ||"undefined"
148 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
149 %package profile_tv
150 Summary:        The DALi Tizen Adaptor for tv
151 Provides:       %{name}-compat = %{version}-%{release}
152 Conflicts:      %{name}-profile_mobile
153 Conflicts:      %{name}-profile_wearable
154 Conflicts:      %{name}-profile_ivi
155 Conflicts:      %{name}-profile_common
156 Requires:       %{name}
157 %description profile_tv
158 The DALi Tizen Adaptor for tv.
159 %endif
160
161 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
162 # if wearable || "undefined"
163 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
164 %package profile_wearable
165 Summary:        The DALi Tizen Adaptor for wearable
166 Provides:       %{name}-compat = %{version}-%{release}
167 Conflicts:      %{name}-profile_mobile
168 Conflicts:      %{name}-profile_tv
169 Conflicts:      %{name}-profile_ivi
170 Conflicts:      %{name}-profile_common
171 Requires:       %{name}
172 %description profile_wearable
173 The DALi Tizen Adaptor for wearable.
174 %endif
175
176 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
177 # if ivi ||"undefined"
178 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
179 %package profile_ivi
180 Summary:        The DALi Tizen Adaptor for ivi
181 Provides:       %{name}-compat = %{version}-%{release}
182 Conflicts:      %{name}-profile_mobile
183 Conflicts:      %{name}-profile_wearable
184 Conflicts:      %{name}-profile_tv
185 Conflicts:      %{name}-profile_common
186 Requires:       %{name}
187 %description profile_ivi
188 The DALi Tizen Adaptor for ivi.
189 %endif
190
191 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
192 # if common ||"undefined"
193 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
194 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
195 %package profile_common
196 Summary:        The DALi Tizen Adaptor for common
197 Provides:       %{name}-compat = %{version}-%{release}
198 Conflicts:      %{name}-profile_mobile
199 Conflicts:      %{name}-profile_wearable
200 Conflicts:      %{name}-profile_tv
201 Conflicts:      %{name}-profile_ivi
202 Requires:       %{name}
203 %description profile_common
204 The DALi Tizen Adaptor for common.
205 %endif
206
207 ##############################
208 # devel
209 ##############################
210 %package devel
211 Summary:    Development components for the DALi Tizen Adaptor
212 Group:      Development/Building
213 Requires:   %{name} = %{version}-%{release}
214 Requires:   %{name}-integration-devel = %{version}-%{release}
215
216 %description devel
217 Development components for the DALi Tizen Adaptor - public headers and package configs
218
219 ##############################
220 # integration-devel
221 ##############################
222 %package integration-devel
223 Summary:    Integration development package for the Adaptor
224 Group:      Development/Building
225 Requires:   %{name} = %{version}-%{release}
226
227 %description integration-devel
228 Integration development package for the Adaptor - headers for integrating with an adaptor library.
229
230 ##############################
231 # Dali Feedback Plugin
232 ##############################
233 %package dali2-feedback-plugin
234 Summary:    Plugin to play haptic and audio feedback for Dali
235 Group:      System/Libraries
236 Requires:   %{name} = %{version}-%{release}
237 %description dali2-feedback-plugin
238 Feedback plugin to play haptic and audio feedback for Dali
239
240 ##############################
241 # Preparation
242 ##############################
243 %prep
244 %setup -q
245
246 #Use TZ_PATH when tizen version is 3.x or greater
247
248 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
249 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
250 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
251 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
252 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
253 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
254
255 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
256 %define dali_plugin_sound_files  /plugins/sounds/
257
258 ##############################
259 # Build
260 ##############################
261 %build
262 PREFIX+="/usr"
263 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
264 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
265
266 %ifarch %{arm}
267 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
268 %endif
269
270 CFLAGS+=" -DWAYLAND"
271 CXXFLAGS+=" -DWAYLAND"
272 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON"
273
274 # Use this conditional when Tizen version is 5.x or greater
275 %if 0%{?tizen_version_major} >= 5
276 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
277
278 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
279 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
280 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
281 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
282 %endif
283
284 %if 0%{?enable_debug}
285 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
286 %endif
287
288 %if 0%{?enable_trace}
289 cmake_flags+=" -DENABLE_TRACE=ON"
290 %endif
291
292 libtoolize --force
293 cd %{_builddir}/%{name}-%{version}/build/tizen
294
295 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
296 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
297 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
298 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
299 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
300 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
301 %if 0%{?tizen_platform_config_supported}
302 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
303 %endif
304
305 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
306 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
307 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
308 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
309 cmake_flags+=" -DENABLE_FEEDBACK=YES"
310 cmake_flags+=" -DENABLE_APPFW=YES"
311 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
312
313 # Set up the build via Cmake
314 #######################################################################
315 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
316 # if mobile || "undefined"
317 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
318
319 mkdir mobile
320 pushd mobile
321
322 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
323
324 # Build.
325 make %{?jobs:-j%jobs}
326 popd
327
328 %endif
329
330 #######################################################################
331 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
332 # if tv ||"undefined"
333 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
334
335 mkdir tv
336 pushd tv
337
338 cmake -DENABLE_PROFILE=TV $cmake_flags ..
339
340 # Build.
341 make %{?jobs:-j%jobs}
342 popd
343
344 %endif
345
346 #######################################################################
347 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
348 # if wearable || "undefined"
349 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
350
351 mkdir wearable
352 pushd wearable
353
354 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
355
356 # Build.
357 make %{?jobs:-j%jobs}
358 popd
359
360 %endif
361
362 #######################################################################
363 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
364 # if ivi ||"undefined"
365 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
366
367 mkdir ivi
368 pushd ivi
369
370 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
371
372 # Build.
373 make %{?jobs:-j%jobs}
374 popd
375
376 %endif
377
378 #######################################################################
379 # common
380 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
381 # if common ||"undefined"
382 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
383
384 mkdir common
385 pushd common
386
387 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
388
389 # Build.
390 make %{?jobs:-j%jobs}
391 popd
392
393 %endif
394
395 ##############################
396 # Installation
397 ##############################
398 %install
399 rm -rf %{buildroot}
400
401 pushd %{_builddir}/%{name}-%{version}/build/tizen
402
403 # if mobile || "undefined"
404 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
405 pushd mobile
406 %make_install
407 %if "%{?profile}" != "mobile"
408 pushd  %{buildroot}%{_libdir}
409 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
410 popd
411 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
412 %endif
413 popd
414 %endif
415
416 # if tv ||"undefined"
417 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
418 pushd tv
419 %make_install
420 %if "%{?profile}" != "tv"
421 pushd  %{buildroot}%{_libdir}
422 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
423 popd
424 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
425 %endif
426 popd
427 %endif
428
429 # if wearable || "undefined"
430 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
431 pushd wearable
432 %make_install
433 %if "%{?profile}" != "wearable"
434 pushd  %{buildroot}%{_libdir}
435 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
436 popd
437 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
438 %endif
439 popd
440 %endif
441
442 # if ivi ||"undefined"
443 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
444 pushd ivi
445 %make_install
446 %if "%{?profile}" != "ivi"
447 pushd  %{buildroot}%{_libdir}
448 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
449 popd
450 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
451 %endif
452 popd
453 %endif
454
455 # if common ||"undefined"
456 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
457 pushd common
458 %make_install
459 # No clean so we can gather symbol/size information for the common profile
460 popd
461 %endif
462
463 # Create a symbolic link in integration-api to preserve legacy repo build
464 pushd %{buildroot}%{_includedir}/dali/integration-api
465 ln -sf adaptor-framework adaptors
466 popd
467
468 ##############################
469 # Upgrade order:
470 # 1 - Pre Install new package
471 # 2 - Install new package
472 # 3 - Post install new package
473 # 4 - Pre uninstall old package
474 # 5 - Remove files not overwritten by new package
475 # 6 - Post uninstall old package
476 ##############################
477
478 ##############################
479 # Adaptor package Commands
480 %pre
481 exit 0
482
483 %post
484 pushd %{_libdir}
485 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
486 popd
487 /sbin/ldconfig
488 exit 0
489
490 %preun
491 exit 0
492
493 %postun
494 /sbin/ldconfig
495 exit 0
496
497 ##############################
498 # Mobile Profile Commands
499 # if mobile || "undefined"
500 # No need to create a symbolic link on install required if only building this profile
501 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
502 %post profile_mobile
503 %if "%{?profile}" != "mobile"
504 pushd %{_libdir}
505 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
506 popd
507 %endif
508 /sbin/ldconfig
509 exit 0
510
511 %postun profile_mobile
512 /sbin/ldconfig
513 exit 0
514 %endif
515
516 ##############################
517 # TV Profile Commands
518 # No need to create a symbolic link on install required if only building this profile
519 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
520 %post profile_tv
521 %if "%{?profile}" != "tv"
522 pushd %{_libdir}
523 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
524 popd
525 %endif
526 /sbin/ldconfig
527 exit 0
528
529 %postun profile_tv
530 /sbin/ldconfig
531 exit 0
532 %endif
533
534 ##############################
535 # Wearable Profile Commands
536 # No need to create a symbolic link on install required if only building this profile
537 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
538 %post profile_wearable
539 %if "%{?profile}" != "wearable"
540 pushd %{_libdir}
541 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
542 popd
543 %endif
544 /sbin/ldconfig
545 exit 0
546
547 %postun profile_wearable
548 /sbin/ldconfig
549 exit 0
550 %endif
551
552 ##############################
553 # IVI Profile Commands
554 # No need to create a symbolic link on install required if only building this profile
555 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
556 %post profile_ivi
557 %if "%{?profile}" != "ivi"
558 pushd %{_libdir}
559 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
560 popd
561 %endif
562 /sbin/ldconfig
563 exit 0
564
565 %postun profile_ivi
566 /sbin/ldconfig
567 exit 0
568 %endif
569
570 ##############################
571 # Common Profile Commands
572 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
573 %post profile_common
574 /sbin/ldconfig
575 exit 0
576
577 %postun profile_common
578 /sbin/ldconfig
579 exit 0
580 %endif
581
582 ##############################
583 # Files in Binary Packages
584 ##############################
585
586 %files
587 %manifest dali-adaptor.manifest
588 %defattr(-,root,root,-)
589 %dir %{user_shader_cache_dir}
590 %{_bindir}/*
591 %license LICENSE
592 %defattr(-,root,root,-)
593 %{_libdir}/libdali2-adaptor.so
594 %{_libdir}/libdali2-adaptor.so.2
595 %{_libdir}/libdali2-adaptor.so.2.0.0
596
597 #################################################
598
599 %files dali2-feedback-plugin
600 %manifest dali-adaptor.manifest
601 %defattr(-,root,root,-)
602 %{_libdir}/libdali2-feedback-plugin.so*
603 %{dali_plugin_sound_files}/*
604
605 #################################################
606
607 # if common ||"undefined"
608 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
609 %files profile_common
610 %manifest dali-adaptor.manifest
611 # default .so files are housed in the main pkg.
612 %endif
613
614 # if mobile || "undefined"
615 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
616 %files profile_mobile
617 %manifest dali-adaptor.manifest
618 %defattr(-,root,root,-)
619 %if "%{?profile}" != "mobile"
620 %{_libdir}/libdali2-adaptor.so.mobile
621 %endif
622 %endif
623
624 # if tv ||"undefined"
625 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
626 %files profile_tv
627 %manifest dali-adaptor.manifest
628 %defattr(-,root,root,-)
629 %if "%{?profile}" != "tv"
630 %{_libdir}/libdali2-adaptor.so.tv
631 %endif
632 %endif
633
634 # if wearable || "undefined"
635 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
636 %files profile_wearable
637 %manifest dali-adaptor.manifest
638 %defattr(-,root,root,-)
639 %if "%{?profile}" != "wearable"
640 %{_libdir}/libdali2-adaptor.so.wearable
641 %endif
642 %endif
643
644 # if ivi ||"undefined"
645 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
646 %files profile_ivi
647 %manifest dali-adaptor.manifest
648 %defattr(-,root,root,-)
649 %if "%{?profile}" != "ivi"
650 %{_libdir}/libdali2-adaptor.so.ivi
651 %endif
652 %endif
653
654 %files devel
655 %defattr(-,root,root,-)
656 %{_includedir}/dali/dali.h
657 %{_includedir}/dali/public-api/*
658 %{_includedir}/dali/devel-api/*
659 %{_includedir}/dali/doc/*
660 %{_libdir}/pkgconfig/dali2-adaptor.pc
661
662 %files integration-devel
663 %defattr(-,root,root,-)
664 %{_includedir}/dali/integration-api/adaptor-framework/*
665 %{_includedir}/dali/integration-api/adaptors
666 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc