DALi Version 1.9.18
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.9.18
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(libwebp)
54 BuildRequires:  pkgconfig(libwebpdecoder)
55 BuildRequires:  pkgconfig(libwebpdemux)
56 BuildRequires:  pkgconfig(libwebpmux)
57 BuildRequires:  pkgconfig(fontconfig)
58 BuildRequires:  libjpeg-turbo-devel
59 BuildRequires:  pkgconfig(vconf)
60 BuildRequires:  tts-devel
61 BuildRequires:  pkgconfig(dlog)
62 BuildRequires:  libdrm-devel
63 BuildRequires:  pkgconfig(libexif)
64 BuildRequires:  pkgconfig(libpng)
65 BuildRequires:  pkgconfig(egl)
66 BuildRequires:  libcurl-devel
67 BuildRequires:  pkgconfig(harfbuzz)
68 BuildRequires:  fribidi-devel
69
70 BuildRequires:  pkgconfig(capi-system-info)
71 BuildRequires:  pkgconfig(capi-system-sensor)
72
73 BuildRequires:  pkgconfig(cairo)
74
75 BuildRequires:  pkgconfig(wayland-egl)
76 BuildRequires:  pkgconfig(wayland-client)
77 BuildRequires:  wayland-devel
78 BuildRequires:  wayland-extension-client-devel
79
80 # We use ecore mainloop
81 %if 0%{?tizen_version_major} >= 5
82 BuildRequires:  pkgconfig(ecore-wl2)
83 BuildRequires:  pkgconfig(wayland-egl-tizen)
84 %else
85 BuildRequires:  pkgconfig(ecore-wayland)
86 %endif
87
88 # We need tbm_surface in tizen 3.0 wayland
89 BuildRequires:  pkgconfig(libtbm)
90
91 # for the adaptor
92 BuildRequires:  pkgconfig(appcore-ui)
93 BuildRequires:  pkgconfig(appcore-widget-base)
94 BuildRequires:  pkgconfig(bundle)
95 BuildRequires:  pkgconfig(capi-appfw-app-common)
96 BuildRequires:  pkgconfig(capi-appfw-app-control)
97 BuildRequires:  pkgconfig(ecore-imf)
98
99 BuildRequires:  pkgconfig(capi-system-system-settings)
100
101 # for feedback plugin
102 BuildRequires:  pkgconfig(mm-sound)
103 BuildRequires:  pkgconfig(feedback)
104 BuildRequires:  pkgconfig(component-based-core-base)
105
106 # for multiprofile
107 Requires:   %{name}-compat = %{version}-%{release}
108 Recommends: %{name}-profile_common = %{version}-%{release}
109
110 %description
111 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
112 platform abstraction and application shell
113
114 ###########################################
115 # Dali adapter for profiles
116 ###########################################
117
118 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
119 # if mobile || "undefined"
120 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
121 %package profile_mobile
122 Summary:        The DALi Tizen Adaptor for mobile
123 Provides:       %{name}-compat = %{version}-%{release}
124 Conflicts:      %{name}-profile_tv
125 Conflicts:      %{name}-profile_wearable
126 Conflicts:      %{name}-profile_ivi
127 Conflicts:      %{name}-profile_common
128 Requires:       %{name}
129 %description profile_mobile
130 The DALi Tizen Adaptor for mobile.
131 %endif
132
133 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
134 # if tv ||"undefined"
135 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
136 %package profile_tv
137 Summary:        The DALi Tizen Adaptor for tv
138 Provides:       %{name}-compat = %{version}-%{release}
139 Conflicts:      %{name}-profile_mobile
140 Conflicts:      %{name}-profile_wearable
141 Conflicts:      %{name}-profile_ivi
142 Conflicts:      %{name}-profile_common
143 Requires:       %{name}
144 %description profile_tv
145 The DALi Tizen Adaptor for tv.
146 %endif
147
148 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
149 # if wearable || "undefined"
150 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
151 %package profile_wearable
152 Summary:        The DALi Tizen Adaptor for wearable
153 Provides:       %{name}-compat = %{version}-%{release}
154 Conflicts:      %{name}-profile_mobile
155 Conflicts:      %{name}-profile_tv
156 Conflicts:      %{name}-profile_ivi
157 Conflicts:      %{name}-profile_common
158 Requires:       %{name}
159 %description profile_wearable
160 The DALi Tizen Adaptor for wearable.
161 %endif
162
163 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
164 # if ivi ||"undefined"
165 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
166 %package profile_ivi
167 Summary:        The DALi Tizen Adaptor for ivi
168 Provides:       %{name}-compat = %{version}-%{release}
169 Conflicts:      %{name}-profile_mobile
170 Conflicts:      %{name}-profile_wearable
171 Conflicts:      %{name}-profile_tv
172 Conflicts:      %{name}-profile_common
173 Requires:       %{name}
174 %description profile_ivi
175 The DALi Tizen Adaptor for ivi.
176 %endif
177
178 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
179 # if common ||"undefined"
180 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
181 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
182 %package profile_common
183 Summary:        The DALi Tizen Adaptor for common
184 Provides:       %{name}-compat = %{version}-%{release}
185 Conflicts:      %{name}-profile_mobile
186 Conflicts:      %{name}-profile_wearable
187 Conflicts:      %{name}-profile_tv
188 Conflicts:      %{name}-profile_ivi
189 Requires:       %{name}
190 %description profile_common
191 The DALi Tizen Adaptor for common.
192 %endif
193
194 ##############################
195 # devel
196 ##############################
197 %package devel
198 Summary:    Development components for the DALi Tizen Adaptor
199 Group:      Development/Building
200 Requires:   %{name} = %{version}-%{release}
201 Requires:   %{name}-integration-devel = %{version}-%{release}
202
203 %description devel
204 Development components for the DALi Tizen Adaptor - public headers and package configs
205
206 ##############################
207 # integration-devel
208 ##############################
209 %package integration-devel
210 Summary:    Integration development package for the Adaptor
211 Group:      Development/Building
212 Requires:   %{name} = %{version}-%{release}
213
214 %description integration-devel
215 Integration development package for the Adaptor - headers for integrating with an adaptor library.
216
217 ##############################
218 # Dali Feedback Plugin
219 ##############################
220 %package dali2-feedback-plugin
221 Summary:    Plugin to play haptic and audio feedback for Dali
222 Group:      System/Libraries
223 Requires:   %{name} = %{version}-%{release}
224 %description dali2-feedback-plugin
225 Feedback plugin to play haptic and audio feedback for Dali
226
227 ##############################
228 # Preparation
229 ##############################
230 %prep
231 %setup -q
232
233 #Use TZ_PATH when tizen version is 3.x or greater
234
235 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
236 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
237 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
238 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
239 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
240 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
241
242 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
243 %define dali_plugin_sound_files  /plugins/sounds/
244
245 ##############################
246 # Build
247 ##############################
248 %build
249 PREFIX+="/usr"
250 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
251 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
252
253 %ifarch %{arm}
254 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
255 %endif
256
257 CFLAGS+=" -DWAYLAND"
258 CXXFLAGS+=" -DWAYLAND"
259 cmake_flags=" -DENABLE_WAYLAND=ON"
260
261 # Use this conditional when Tizen version is 5.x or greater
262 %if 0%{?tizen_version_major} >= 5
263 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
264
265 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
266 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
267 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
268 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
269 %endif
270
271 %if 0%{?enable_debug}
272 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
273 %endif
274
275 %if 0%{?enable_trace}
276 cmake_flags+=" -DENABLE_TRACE=ON"
277 %endif
278
279 libtoolize --force
280 cd %{_builddir}/%{name}-%{version}/build/tizen
281
282 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
283 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
284 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
285 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
286 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
287 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
288 %if 0%{?tizen_platform_config_supported}
289 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
290 %endif
291
292 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
293 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
294 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
295 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
296 cmake_flags+=" -DENABLE_FEEDBACK=YES"
297 cmake_flags+=" -DENABLE_APPFW=YES"
298 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
299
300 # Set up the build via Cmake
301 #######################################################################
302 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
303 # if mobile || "undefined"
304 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
305
306 mkdir mobile
307 pushd mobile
308
309 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
310
311 # Build.
312 make %{?jobs:-j%jobs}
313 popd
314
315 %endif
316
317 #######################################################################
318 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
319 # if tv ||"undefined"
320 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
321
322 mkdir tv
323 pushd tv
324
325 cmake -DENABLE_PROFILE=TV $cmake_flags ..
326
327 # Build.
328 make %{?jobs:-j%jobs}
329 popd
330
331 %endif
332
333 #######################################################################
334 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
335 # if wearable || "undefined"
336 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
337
338 mkdir wearable
339 pushd wearable
340
341 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
342
343 # Build.
344 make %{?jobs:-j%jobs}
345 popd
346
347 %endif
348
349 #######################################################################
350 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
351 # if ivi ||"undefined"
352 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
353
354 mkdir ivi
355 pushd ivi
356
357 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
358
359 # Build.
360 make %{?jobs:-j%jobs}
361 popd
362
363 %endif
364
365 #######################################################################
366 # common
367 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
368 # if common ||"undefined"
369 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
370
371 mkdir common
372 pushd common
373
374 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
375
376 # Build.
377 make %{?jobs:-j%jobs}
378 popd
379
380 %endif
381
382 ##############################
383 # Installation
384 ##############################
385 %install
386 rm -rf %{buildroot}
387
388 pushd %{_builddir}/%{name}-%{version}/build/tizen
389
390 # if mobile || "undefined"
391 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
392 pushd mobile
393 %make_install
394 %if "%{?profile}" != "mobile"
395 pushd  %{buildroot}%{_libdir}
396 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
397 popd
398 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
399 %endif
400 popd
401 %endif
402
403 # if tv ||"undefined"
404 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
405 pushd tv
406 %make_install
407 %if "%{?profile}" != "tv"
408 pushd  %{buildroot}%{_libdir}
409 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
410 popd
411 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
412 %endif
413 popd
414 %endif
415
416 # if wearable || "undefined"
417 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
418 pushd wearable
419 %make_install
420 %if "%{?profile}" != "wearable"
421 pushd  %{buildroot}%{_libdir}
422 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
423 popd
424 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
425 %endif
426 popd
427 %endif
428
429 # if ivi ||"undefined"
430 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
431 pushd ivi
432 %make_install
433 %if "%{?profile}" != "ivi"
434 pushd  %{buildroot}%{_libdir}
435 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
436 popd
437 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
438 %endif
439 popd
440 %endif
441
442 # if common ||"undefined"
443 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
444 pushd common
445 %make_install
446 # No clean so we can gather symbol/size information for the common profile
447 popd
448 %endif
449
450 # Create a symbolic link in integration-api to preserve legacy repo build
451 pushd %{buildroot}%{_includedir}/dali/integration-api
452 ln -sf adaptor-framework adaptors
453 popd
454
455 ##############################
456 # Upgrade order:
457 # 1 - Pre Install new package
458 # 2 - Install new package
459 # 3 - Post install new package
460 # 4 - Pre uninstall old package
461 # 5 - Remove files not overwritten by new package
462 # 6 - Post uninstall old package
463 ##############################
464
465 ##############################
466 # Adaptor package Commands
467 %pre
468 exit 0
469
470 %post
471 pushd %{_libdir}
472 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
473 popd
474 /sbin/ldconfig
475 exit 0
476
477 %preun
478 exit 0
479
480 %postun
481 /sbin/ldconfig
482 exit 0
483
484 ##############################
485 # Mobile Profile Commands
486 # if mobile || "undefined"
487 # No need to create a symbolic link on install required if only building this profile
488 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
489 %post profile_mobile
490 %if "%{?profile}" != "mobile"
491 pushd %{_libdir}
492 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
493 popd
494 %endif
495 /sbin/ldconfig
496 exit 0
497
498 %postun profile_mobile
499 /sbin/ldconfig
500 exit 0
501 %endif
502
503 ##############################
504 # TV Profile Commands
505 # No need to create a symbolic link on install required if only building this profile
506 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
507 %post profile_tv
508 %if "%{?profile}" != "tv"
509 pushd %{_libdir}
510 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
511 popd
512 %endif
513 /sbin/ldconfig
514 exit 0
515
516 %postun profile_tv
517 /sbin/ldconfig
518 exit 0
519 %endif
520
521 ##############################
522 # Wearable Profile Commands
523 # No need to create a symbolic link on install required if only building this profile
524 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
525 %post profile_wearable
526 %if "%{?profile}" != "wearable"
527 pushd %{_libdir}
528 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
529 popd
530 %endif
531 /sbin/ldconfig
532 exit 0
533
534 %postun profile_wearable
535 /sbin/ldconfig
536 exit 0
537 %endif
538
539 ##############################
540 # IVI Profile Commands
541 # No need to create a symbolic link on install required if only building this profile
542 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
543 %post profile_ivi
544 %if "%{?profile}" != "ivi"
545 pushd %{_libdir}
546 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.0.0.0
547 popd
548 %endif
549 /sbin/ldconfig
550 exit 0
551
552 %postun profile_ivi
553 /sbin/ldconfig
554 exit 0
555 %endif
556
557 ##############################
558 # Common Profile Commands
559 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
560 %post profile_common
561 /sbin/ldconfig
562 exit 0
563
564 %postun profile_common
565 /sbin/ldconfig
566 exit 0
567 %endif
568
569 ##############################
570 # Files in Binary Packages
571 ##############################
572
573 %files
574 %manifest dali-adaptor.manifest
575 %defattr(-,root,root,-)
576 %dir %{user_shader_cache_dir}
577 %{_bindir}/*
578 %license LICENSE
579 %defattr(-,root,root,-)
580 %{_libdir}/libdali2-adaptor.so
581 %{_libdir}/libdali2-adaptor.so.2
582 %{_libdir}/libdali2-adaptor.so.2.0.0
583
584 #################################################
585
586 %files dali2-feedback-plugin
587 %manifest dali-adaptor.manifest
588 %defattr(-,root,root,-)
589 %{_libdir}/libdali2-feedback-plugin.so*
590 %{dali_plugin_sound_files}/*
591
592 #################################################
593
594 # if common ||"undefined"
595 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
596 %files profile_common
597 %manifest dali-adaptor.manifest
598 # default .so files are housed in the main pkg.
599 %endif
600
601 # if mobile || "undefined"
602 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
603 %files profile_mobile
604 %manifest dali-adaptor.manifest
605 %defattr(-,root,root,-)
606 %if "%{?profile}" != "mobile"
607 %{_libdir}/libdali2-adaptor.so.mobile
608 %endif
609 %endif
610
611 # if tv ||"undefined"
612 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
613 %files profile_tv
614 %manifest dali-adaptor.manifest
615 %defattr(-,root,root,-)
616 %if "%{?profile}" != "tv"
617 %{_libdir}/libdali2-adaptor.so.tv
618 %endif
619 %endif
620
621 # if wearable || "undefined"
622 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
623 %files profile_wearable
624 %manifest dali-adaptor.manifest
625 %defattr(-,root,root,-)
626 %if "%{?profile}" != "wearable"
627 %{_libdir}/libdali2-adaptor.so.wearable
628 %endif
629 %endif
630
631 # if ivi ||"undefined"
632 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
633 %files profile_ivi
634 %manifest dali-adaptor.manifest
635 %defattr(-,root,root,-)
636 %if "%{?profile}" != "ivi"
637 %{_libdir}/libdali2-adaptor.so.ivi
638 %endif
639 %endif
640
641 %files devel
642 %defattr(-,root,root,-)
643 %{_includedir}/dali/dali.h
644 %{_includedir}/dali/public-api/*
645 %{_includedir}/dali/devel-api/*
646 %{_includedir}/dali/doc/*
647 %{_libdir}/pkgconfig/dali2-adaptor.pc
648
649 %files integration-devel
650 %defattr(-,root,root,-)
651 %{_includedir}/dali/integration-api/adaptor-framework/*
652 %{_includedir}/dali/integration-api/adaptors
653 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc