[Tizen] Add DALi Autofill implementation
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.36
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali-devel
47 BuildRequires:  dali-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  giflib-devel
52 BuildRequires:  pkgconfig(fontconfig)
53 BuildRequires:  libjpeg-turbo-devel
54 BuildRequires:  pkgconfig(vconf)
55 BuildRequires:  tts-devel
56 BuildRequires:  pkgconfig(dlog)
57 BuildRequires:  libdrm-devel
58 BuildRequires:  pkgconfig(libexif)
59 BuildRequires:  pkgconfig(libpng)
60 BuildRequires:  pkgconfig(egl)
61 BuildRequires:  libcurl-devel
62 BuildRequires:  pkgconfig(harfbuzz)
63 BuildRequires:  fribidi-devel
64
65 BuildRequires:  pkgconfig(capi-system-info)
66 BuildRequires:  pkgconfig(capi-system-sensor)
67
68 BuildRequires:  pkgconfig(cairo)
69
70 BuildRequires:  pkgconfig(wayland-egl)
71 BuildRequires:  pkgconfig(wayland-client)
72 BuildRequires:  wayland-devel
73 BuildRequires:  wayland-extension-client-devel
74
75 # dali-adaptor uses ecore mainloop
76 %if 0%{?tizen_version_major} >= 5
77 BuildRequires:  pkgconfig(ecore-wl2)
78 BuildRequires:  pkgconfig(wayland-egl-tizen)
79 %else
80 BuildRequires:  pkgconfig(ecore-wayland)
81 %endif
82
83 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
84 BuildRequires:  pkgconfig(libtbm)
85
86 BuildRequires:  pkgconfig(tpkp-curl)
87
88 # for dali-adaptor
89 BuildRequires:  pkgconfig(appcore-ui)
90 BuildRequires:  pkgconfig(appcore-widget-base)
91 BuildRequires:  pkgconfig(bundle)
92 BuildRequires:  pkgconfig(capi-appfw-app-common)
93 BuildRequires:  pkgconfig(capi-appfw-app-control)
94 BuildRequires:  pkgconfig(ecore-imf)
95
96 BuildRequires:  pkgconfig(capi-system-system-settings)
97
98 # for autofill
99 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
100 BuildRequires:  pkgconfig(capi-ui-autofill)
101 %endif
102
103 # for feedback plugin
104 BuildRequires:  pkgconfig(mm-sound)
105 BuildRequires:  pkgconfig(feedback)
106
107 # for multiprofile
108 Requires:   %{name}-compat = %{version}-%{release}
109 Recommends: %{name}-profile_common = %{version}-%{release}
110
111 %description
112 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
113 platform abstraction and application shell
114
115 ###########################################
116 # Dali adapter for profiles
117 ###########################################
118
119 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
120 # if mobile || "undefined"
121 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
122 %package profile_mobile
123 Summary:        The DALi Tizen Adaptor for mobile
124 Provides:       %{name}-compat = %{version}-%{release}
125 Conflicts:      %{name}-profile_tv
126 Conflicts:      %{name}-profile_wearable
127 Conflicts:      %{name}-profile_ivi
128 Conflicts:      %{name}-profile_common
129 %description profile_mobile
130 The DALi Tizen Adaptor for mobile.
131 %endif
132
133 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
134 # if tv ||"undefined"
135 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
136 %package profile_tv
137 Summary:        The DALi Tizen Adaptor for tv
138 Provides:       %{name}-compat = %{version}-%{release}
139 Conflicts:      %{name}-profile_mobile
140 Conflicts:      %{name}-profile_wearable
141 Conflicts:      %{name}-profile_ivi
142 Conflicts:      %{name}-profile_common
143 %description profile_tv
144 The DALi Tizen Adaptor for tv.
145 %endif
146
147 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
148 # if wearable || "undefined"
149 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
150 %package profile_wearable
151 Summary:        The DALi Tizen Adaptor for wearable
152 Provides:       %{name}-compat = %{version}-%{release}
153 Conflicts:      %{name}-profile_mobile
154 Conflicts:      %{name}-profile_tv
155 Conflicts:      %{name}-profile_ivi
156 Conflicts:      %{name}-profile_common
157 %description profile_wearable
158 The DALi Tizen Adaptor for wearable.
159 %endif
160
161 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
162 # if ivi ||"undefined"
163 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
164 %package profile_ivi
165 Summary:        The DALi Tizen Adaptor for ivi
166 Provides:       %{name}-compat = %{version}-%{release}
167 Conflicts:      %{name}-profile_mobile
168 Conflicts:      %{name}-profile_wearable
169 Conflicts:      %{name}-profile_tv
170 Conflicts:      %{name}-profile_common
171 %description profile_ivi
172 The DALi Tizen Adaptor for ivi.
173 %endif
174
175 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
176 # if common ||"undefined"
177 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
178 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
179 %package profile_common
180 Summary:        The DALi Tizen Adaptor for common
181 Provides:       %{name}-compat = %{version}-%{release}
182 Conflicts:      %{name}-profile_mobile
183 Conflicts:      %{name}-profile_wearable
184 Conflicts:      %{name}-profile_tv
185 Conflicts:      %{name}-profile_ivi
186 %description profile_common
187 The DALi Tizen Adaptor for common.
188 %endif
189
190 ##############################
191 # devel
192 ##############################
193 %package devel
194 Summary:    Development components for the DALi Tizen Adaptor
195 Group:      Development/Building
196 Requires:   %{name} = %{version}-%{release}
197 Requires:   %{name}-integration-devel = %{version}-%{release}
198
199 %description devel
200 Development components for the DALi Tizen Adaptor - public headers and package configs
201
202 ##############################
203 # integration-devel
204 ##############################
205 %package integration-devel
206 Summary:    Integration development package for the Adaptor
207 Group:      Development/Building
208 Requires:   %{name} = %{version}-%{release}
209
210 %description integration-devel
211 Integration development package for the Adaptor - headers for integrating with an adaptor library.
212
213 ##############################
214 # Dali Feedback Plugin
215 ##############################
216 %package dali-feedback-plugin
217 Summary:    Plugin to play haptic and audio feedback for Dali
218 Group:      System/Libraries
219 Requires:   %{name} = %{version}-%{release}
220 %description dali-feedback-plugin
221 Feedback plugin to play haptic and audio feedback for Dali
222
223 ##############################
224 # Preparation
225 ##############################
226 %prep
227 %setup -q
228
229 #Use TZ_PATH when tizen version is 3.x or greater
230
231 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
232 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
233 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
234 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
235 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
236 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
237
238 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
239 %define dali_plugin_sound_files  /plugins/sounds/
240 %define dev_include_path %{_includedir}
241
242 ##############################
243 # Build
244 ##############################
245 %build
246 PREFIX+="/usr"
247 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
248 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
249
250 %ifarch %{arm}
251 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
252 %endif
253
254 CFLAGS+=" -DWAYLAND"
255 CXXFLAGS+=" -DWAYLAND"
256 configure_flags="--enable-wayland"
257
258 # Use this conditional when Tizen version is 5.x or greater
259 %if 0%{?tizen_version_major} >= 5
260 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
261
262 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
263 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
264 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
265 configure_flags+=" --enable-ecore-wayland2"
266 %endif
267
268 libtoolize --force
269 cd %{_builddir}/%{name}-%{version}/build/tizen
270 autoreconf --install
271
272 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
273 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
274 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
275 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
276 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
277 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
278 %if 0%{?tizen_platform_config_supported}
279 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
280 %endif
281
282 # Set up the build via configure.
283 #######################################################################
284 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
285 # if mobile || "undefined"
286 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
287 %configure --prefix=$PREFIX --with-jpeg-turbo \
288            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
289            --enable-tizen-major-version=%{tizen_version_major} \
290            --enable-tizen-minor-version=%{tizen_version_minor} \
291            --enable-feedback \
292            --enable-efl=no \
293 %if 0%{?enable_debug}
294            --enable-debug \
295 %endif
296 %if 0%{?enable_trace}
297            --enable-trace \
298 %endif
299            --enable-appfw=yes \
300            $configure_flags --libdir=%{_libdir} \
301            --enable-rename-so=no
302
303 # Build.
304 make %{?jobs:-j%jobs}
305
306 pushd %{_builddir}/%{name}-%{version}/build/tizen
307 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
308 popd
309
310 pushd %{buildroot}%{_libdir}
311 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
312 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
313 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
314 popd
315
316 make clean
317
318 %endif
319
320 #######################################################################
321 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
322 # if tv ||"undefined"
323 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
324 %configure --prefix=$PREFIX --with-jpeg-turbo \
325            --enable-shaderbincache=DISABLE --enable-profile=TV \
326            --enable-tizen-major-version=%{tizen_version_major} \
327            --enable-tizen-minor-version=%{tizen_version_minor} \
328            --enable-feedback \
329            --enable-efl=no \
330 %if 0%{?enable_debug}
331            --enable-debug \
332 %endif
333 %if 0%{?enable_trace}
334            --enable-trace \
335 %endif
336            --enable-appfw=yes \
337            $configure_flags --libdir=%{_libdir} \
338            --enable-rename-so=no
339
340 # Build.
341 make %{?jobs:-j%jobs}
342
343 pushd %{_builddir}/%{name}-%{version}/build/tizen
344 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
345 popd
346
347 pushd %{buildroot}%{_libdir}
348 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
349 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
350 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
351 popd
352
353 make clean
354 %endif
355
356 #######################################################################
357 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
358 # if wearable || "undefined"
359 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
360 %configure --prefix=$PREFIX --with-jpeg-turbo \
361            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
362            --enable-tizen-major-version=%{tizen_version_major} \
363            --enable-tizen-minor-version=%{tizen_version_minor} \
364            --enable-feedback \
365            --enable-efl=no \
366 %if 0%{?enable_debug}
367            --enable-debug \
368 %endif
369 %if 0%{?enable_trace}
370            --enable-trace \
371 %endif
372            --enable-appfw=yes \
373            $configure_flags --libdir=%{_libdir} \
374            --enable-rename-so=no
375
376 # Build.
377 make %{?jobs:-j%jobs}
378
379 pushd %{_builddir}/%{name}-%{version}/build/tizen
380 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
381 popd
382
383 pushd %{buildroot}%{_libdir}
384 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
385 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
386 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
387 popd
388
389 make clean
390 %endif
391
392 #######################################################################
393 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
394 # if ivi ||"undefined"
395 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
396 %configure --prefix=$PREFIX --with-jpeg-turbo \
397            --enable-shaderbincache=DISABLE --enable-profile=IVI \
398            --enable-tizen-major-version=%{tizen_version_major} \
399            --enable-tizen-minor-version=%{tizen_version_minor} \
400            --enable-feedback \
401            --enable-efl=no \
402 %if 0%{?enable_debug}
403            --enable-debug \
404 %endif
405 %if 0%{?enable_trace}
406            --enable-trace \
407 %endif
408            --enable-appfw=yes \
409            $configure_flags --libdir=%{_libdir} \
410            --enable-rename-so=no
411
412 # Build.
413 make %{?jobs:-j%jobs}
414
415 pushd %{_builddir}/%{name}-%{version}/build/tizen
416 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
417 popd
418
419 pushd %{buildroot}%{_libdir}
420 for FILE in libdali-adaptor*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
421 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
422
423 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
424 popd
425
426 make clean
427 %endif
428
429 #######################################################################
430 # common
431 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
432 # if common ||"undefined"
433 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
434 %configure --prefix=$PREFIX --with-jpeg-turbo \
435            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
436            --enable-tizen-major-version=%{tizen_version_major} \
437            --enable-tizen-minor-version=%{tizen_version_minor} \
438            --enable-feedback \
439            --enable-efl=no \
440 %if 0%{?enable_debug}
441            --enable-debug \
442 %endif
443 %if 0%{?enable_trace}
444            --enable-trace \
445 %endif
446            --enable-appfw=yes \
447            $configure_flags --libdir=%{_libdir} \
448            --enable-rename-so=no
449
450 # Build.
451 make %{?jobs:-j%jobs}
452
453 pushd %{_builddir}/%{name}-%{version}/build/tizen
454 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
455 popd
456
457 pushd %{buildroot}%{_libdir}
458 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
459 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
460
461 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
462 popd
463
464 make clean
465
466 %endif
467
468 ##############################
469 # Installation
470 ##############################
471 %install
472 rm -rf %{buildroot}
473
474 pushd %{_builddir}/%{name}-%{version}/build/tizen
475 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
476
477
478 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
479 # !unified && (wearable || tv || ivi || mobile)
480 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
481 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
482 %endif
483
484 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
485 # wearable || tv || ivi || mobile || unified
486 %if "%{?profile}" != "common"
487 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
488 mv dali-adaptor*.pc %{buildroot}%{_libdir}/pkgconfig/
489 %endif
490 popd
491
492 ################################################
493 #rename
494 ###############################################
495 pushd %{buildroot}%{_libdir}
496
497 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
498 # if common ||"undefined"
499 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
500 rm -rf libdali-adaptor*.so
501 ln -s libdali-adaptor-cxx11.so.0.0.0 libdali-adaptor.so
502 #%endif
503
504 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
505 # if wearable || "undefined"
506 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
507 rm -rf libdali-adaptor*.so.wearable
508 ln -s libdali-adaptor-cxx11.so.0.0.*.wearable libdali-adaptor.so.wearable
509 %endif
510
511 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
512 # if tv ||"undefined"
513 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
514 rm -rf libdali-adaptor*.so.tv
515 ln -s libdali-adaptor-cxx11.so.0.0.*.tv libdali-adaptor.so.tv
516 %endif
517
518 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
519 # if ivi ||"undefined"
520 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
521 rm -rf libdali-adaptor*.so.ivi
522 ln -s libdali-adaptor-cxx11.so.0.0.*.ivi libdali-adaptor.so.ivi
523 %endif
524
525 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
526 # if mobile || "undefined"
527 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
528 rm -rf libdali-adaptor*.so.mobile
529 ln -s libdali-adaptor-cxx11.so.0.0.*.mobile libdali-adaptor.so.mobile
530 %endif
531 popd
532
533 ##############################
534 # Upgrade order:
535 # 1 - Pre Install new package
536 # 2 - Install new package
537 # 3 - Post install new package
538 # 4 - Pre uninstall old package
539 # 5 - Remove files not overwritten by new package
540 # 6 - Post uninstall old package
541 ##############################
542
543 %pre
544 exit 0
545
546 ##############################
547 #  Post Install new package
548 ##############################
549 %post
550 /sbin/ldconfig
551 exit 0
552
553 ##############################
554 #  Pre Uninstall old package
555 ##############################
556 %preun
557 exit 0
558
559 ##############################
560 #  Post Uninstall old package
561 ##############################
562 %postun
563 /sbin/ldconfig
564 exit 0
565
566 ##############################
567
568 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
569 # if mobile || "undefined"
570 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
571 %post profile_mobile
572 pushd %{_libdir}
573 for FILE in libdali-adaptor-cxx11.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
574 popd
575 /sbin/ldconfig
576 exit 0
577
578 %postun profile_mobile
579 /sbin/ldconfig
580 exit 0
581 %endif
582
583 ##############################
584
585 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
586 # if tv ||"undefined"
587 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
588 %post profile_tv
589 pushd %{_libdir}
590 for FILE in libdali-adaptor-cxx11.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
591 popd
592 /sbin/ldconfig
593 exit 0
594
595 %postun profile_tv
596 /sbin/ldconfig
597 exit 0
598 %endif
599
600 ##############################
601
602 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
603 # if wearable || "undefined"
604 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
605 %post profile_wearable
606 pushd %{_libdir}
607 for FILE in libdali-adaptor-cxx11.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
608 popd
609 /sbin/ldconfig
610 exit 0
611
612 %postun profile_wearable
613 /sbin/ldconfig
614 exit 0
615 %endif
616
617 ##############################
618
619 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
620 # if ivi ||"undefined"
621 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
622 %post profile_ivi
623 pushd %{_libdir}
624 for FILE in libdali-adaptor-cxx11.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
625 popd
626 /sbin/ldconfig
627 exit 0
628
629 %postun profile_ivi
630 /sbin/ldconfig
631 exit 0
632 %endif
633
634 ##############################
635 # Files in Binary Packages
636 ##############################
637
638 %files
639 %manifest dali-adaptor.manifest
640 %defattr(-,root,root,-)
641 %dir %{user_shader_cache_dir}
642 %{_bindir}/*
643 %license LICENSE
644
645 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
646 # if common ||"undefined"
647 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
648 %defattr(-,root,root,-)
649 %{_libdir}/libdali-adaptor-cxx11.so.0*
650 %{_libdir}/libdali-adaptor.so
651 %exclude %{_libdir}/libdali-adap*.so*.mobile
652 %exclude %{_libdir}/libdali-adap*.so*.wearable
653 %exclude %{_libdir}/libdali-adap*.so*.tv
654 %exclude %{_libdir}/libdali-adap*.so*.ivi
655 #%endif
656
657 #################################################
658
659 %files dali-feedback-plugin
660 %manifest dali-adaptor.manifest
661 %defattr(-,root,root,-)
662 %{_libdir}/libdali-feedback-plugin-cxx11.so*
663 %{dali_plugin_sound_files}/*
664
665 #################################################
666
667 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
668 # if common ||"undefined"
669 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
670 %files profile_common
671 # default .so files are housed in the main pkg.
672 %endif
673
674 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
675 # if mobile || "undefined"
676 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
677 %files profile_mobile
678 %manifest dali-adaptor.manifest
679 %defattr(-,root,root,-)
680 %{_libdir}/libdali-adaptor.so.mobile
681 %{_libdir}/libdali-adaptor-cxx11.so.0*.mobile
682 %endif
683
684 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
685 # if tv ||"undefined"
686 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
687 %files profile_tv
688 %manifest dali-adaptor.manifest
689 %defattr(-,root,root,-)
690 %{_libdir}/libdali-adaptor.so.tv
691 %{_libdir}/libdali-adaptor-cxx11.so.0*.tv
692 %endif
693
694 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
695 # if wearable || "undefined"
696 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
697 %files profile_wearable
698 %manifest dali-adaptor.manifest
699 %defattr(-,root,root,-)
700 %{_libdir}/libdali-adaptor.so.wearable
701 %{_libdir}/libdali-adaptor-cxx11.so.0*.wearable
702 %endif
703
704 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
705 # if ivi ||"undefined"
706 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
707 %files profile_ivi
708 %manifest dali-adaptor.manifest
709 %defattr(-,root,root,-)
710 %{_libdir}/libdali-adaptor.so.ivi
711 %{_libdir}/libdali-adaptor-cxx11.so.0*.ivi
712 %endif
713
714
715 %files devel
716 %defattr(-,root,root,-)
717 %{dev_include_path}/dali/dali.h
718 %{dev_include_path}/dali/public-api/*
719 %{dev_include_path}/dali/devel-api/*
720 %{dev_include_path}/dali/doc/*
721 %{_libdir}/pkgconfig/dali-adaptor.pc
722
723 %files integration-devel
724 %defattr(-,root,root,-)
725 %{dev_include_path}/dali/integration-api/adaptors/*
726 %{_libdir}/pkgconfig/dali-adaptor-integration.pc
727