Revert "[Tizen] Added 'make clean' on each profile build."
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.52
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107 BuildRequires:  pkgconfig(elementary)
108
109 %if 0%{?tizen_version_major} == 3
110 BuildRequires:  pkgconfig(capi-appfw-application)
111 %else
112 BuildRequires:  pkgconfig(appcore-ui)
113 BuildRequires:  pkgconfig(capi-appfw-app-common)
114 BuildRequires:  pkgconfig(capi-appfw-app-control)
115 %endif
116 BuildRequires:  pkgconfig(capi-system-system-settings)
117
118 # for feedback plugin
119 BuildRequires:  pkgconfig(mm-sound)
120 %if 0%{?tizen_version_major} >= 3
121 BuildRequires:  pkgconfig(feedback)
122 %endif
123
124 # for videoplayer Plugin
125 BuildRequires:  pkgconfig(capi-media-player)
126
127
128 # for multiprofile
129 Requires:   %{name}-compat = %{version}-%{release}
130 Recommends: %{name}-profile_common = %{version}-%{release}
131
132 %description
133 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
134 platform abstraction and application shell
135
136 ###########################################
137 # Dali adapter for profiles
138 ###########################################
139
140 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
141 # if mobile || "undefined"
142 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
143 %package profile_mobile
144 Summary:        The DALi Tizen Adaptor for mobile
145 Provides:       %{name}-compat = %{version}-%{release}
146 Conflicts:      %{name}-profile_tv
147 Conflicts:      %{name}-profile_wearable
148 Conflicts:      %{name}-profile_ivi
149 Conflicts:      %{name}-profile_common
150 %description profile_mobile
151 The DALi Tizen Adaptor for mobile.
152 %endif
153
154 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
155 # if tv ||"undefined"
156 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
157 %package profile_tv
158 Summary:        The DALi Tizen Adaptor for tv
159 Provides:       %{name}-compat = %{version}-%{release}
160 Conflicts:      %{name}-profile_mobile
161 Conflicts:      %{name}-profile_wearable
162 Conflicts:      %{name}-profile_ivi
163 Conflicts:      %{name}-profile_common
164 %description profile_tv
165 The DALi Tizen Adaptor for tv.
166 %endif
167
168 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
169 # if wearable || "undefined"
170 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
171 %package profile_wearable
172 Summary:        The DALi Tizen Adaptor for wearable
173 Provides:       %{name}-compat = %{version}-%{release}
174 Conflicts:      %{name}-profile_mobile
175 Conflicts:      %{name}-profile_tv
176 Conflicts:      %{name}-profile_ivi
177 Conflicts:      %{name}-profile_common
178 %description profile_wearable
179 The DALi Tizen Adaptor for wearable.
180 %endif
181
182 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
183 # if ivi ||"undefined"
184 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
185 %package profile_ivi
186 Summary:        The DALi Tizen Adaptor for ivi
187 Provides:       %{name}-compat = %{version}-%{release}
188 Conflicts:      %{name}-profile_mobile
189 Conflicts:      %{name}-profile_wearable
190 Conflicts:      %{name}-profile_tv
191 Conflicts:      %{name}-profile_common
192 %description profile_ivi
193 The DALi Tizen Adaptor for ivi.
194 %endif
195
196 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
197 # if common ||"undefined"
198 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
199 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
200 %package profile_common
201 %define tizen_2_2_compatibility 0
202 Summary:        The DALi Tizen Adaptor for common
203 Provides:       %{name}-compat = %{version}-%{release}
204 Conflicts:      %{name}-profile_mobile
205 Conflicts:      %{name}-profile_wearable
206 Conflicts:      %{name}-profile_tv
207 Conflicts:      %{name}-profile_ivi
208 %description profile_common
209 The DALi Tizen Adaptor for common.
210 %endif
211
212 ##############################
213 # devel
214 ##############################
215 %package devel
216 Summary:    Development components for the DALi Tizen Adaptor
217 Group:      Development/Building
218 Requires:   %{name} = %{version}-%{release}
219 Requires:   %{name}-integration-devel = %{version}-%{release}
220
221 %description devel
222 Development components for the DALi Tizen Adaptor - public headers and package configs
223
224 ##############################
225 # integration-devel
226 ##############################
227 %package integration-devel
228 Summary:    Integration development package for the Adaptor
229 Group:      Development/Building
230 Requires:   %{name} = %{version}-%{release}
231
232 %description integration-devel
233 Integration development package for the Adaptor - headers for integrating with an adaptor library.
234
235 ##############################
236 # Dali Feedback Plugin
237 ##############################
238 %package dali-feedback-plugin
239 Summary:    Plugin to play haptic and audio feedback for Dali
240 Group:      System/Libraries
241 Requires:   %{name} = %{version}-%{release}
242 %description dali-feedback-plugin
243 Feedback plugin to play haptic and audio feedback for Dali
244
245 ##############################
246 # Dali VideoPlayer Plugin
247 ##############################
248 %if %{with wayland}
249
250 %package dali-video-player-plugin
251 Summary:    Plugin to play a video file for Dali
252 Group:      System/Libraries
253 %description dali-video-player-plugin
254 VideoPlayer plugin to play a video file for Dali
255 %endif
256
257 ##############################
258 # Preparation
259 ##############################
260 %prep
261 %setup -q
262
263 #Use TZ_PATH when tizen version is 3.x or greater
264
265 %if 0%{?tizen_version_major} >= 3
266 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
267 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
268 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
269 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
270 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
271 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
272 %else
273 %define dali_data_rw_dir         /usr/share/dali/
274 %define dali_data_ro_dir         /usr/share/dali/
275 %define font_preloaded_path      /usr/share/fonts/
276 %define font_downloaded_path     /opt/share/fonts/
277 %define font_application_path    /usr/share/app_fonts/
278 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
279 %endif
280
281 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
282 %define dali_plugin_sound_files  /plugins/sounds/
283 %define dev_include_path %{_includedir}
284
285 ##############################
286 # Build
287 ##############################
288 %build
289 PREFIX+="/usr"
290 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
291 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
292
293 %ifarch %{arm}
294 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
295 %endif
296
297 %if %{with wayland}
298 CFLAGS+=" -DWAYLAND"
299 CXXFLAGS+=" -DWAYLAND"
300 configure_flags="--enable-wayland"
301 %endif
302
303 # Use this conditional when Tizen version is 4.x or greater
304 %if 0%{?tizen_version_major} >= 4
305 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
306 %endif
307
308 %if 0%{?tizen_2_2_compatibility}
309 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
310 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
311 %endif
312
313 libtoolize --force
314 cd %{_builddir}/%{name}-%{version}/build/tizen
315 autoreconf --install
316
317 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
318 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
319 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
320 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
321 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
322 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
323 %if 0%{?tizen_platform_config_supported}
324 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
325 %endif
326
327 # Default to GLES 2.0 if not specified.
328 %{!?target_gles_version: %define target_gles_version 20}
329
330 # Set up the build via configure.
331 #######################################################################
332 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
333 # if mobile || "undefined"
334 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
335 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
336            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
337            --enable-tizen-major-version=%{tizen_version_major} \
338 %if 0%{?tizen_version_major} >= 3
339            --enable-feedback \
340 %endif
341            --enable-videoplayer \
342 %if 0%{?tizen_2_2_compatibility}
343            --with-tizen-2-2-compatibility \
344 %endif
345 %if %{with wayland}
346            --enable-efl=no \
347 %else
348            --enable-efl=yes \
349 %endif
350 %if 0%{?enable_debug}
351            --enable-debug \
352 %endif
353            --enable-appfw=yes \
354            $configure_flags --libdir=%{_libdir}
355
356 # Build.
357 make %{?jobs:-j%jobs}
358
359 pushd %{_builddir}/%{name}-%{version}/build/tizen
360 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
361 popd
362
363 pushd %{buildroot}%{_libdir}
364 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
365 popd
366
367 %endif
368
369 #######################################################################
370 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
371 # if tv ||"undefined"
372 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
373 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
374            --enable-shaderbincache=DISABLE --enable-profile=TV \
375            --enable-tizen-major-version=%{tizen_version_major} \
376 %if 0%{?tizen_version_major} >= 3
377            --enable-feedback \
378 %endif
379            --enable-videoplayer \
380 %if 0%{?tizen_2_2_compatibility}
381            --with-tizen-2-2-compatibility \
382 %endif
383 %if %{with wayland}
384            --enable-efl=no \
385 %else
386            --enable-efl=yes \
387 %endif
388 %if 0%{?enable_debug}
389            --enable-debug \
390 %endif
391            --enable-appfw=yes \
392            $configure_flags --libdir=%{_libdir}
393
394 # Build.
395 make %{?jobs:-j%jobs}
396
397 pushd %{_builddir}/%{name}-%{version}/build/tizen
398 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
399 popd
400
401 pushd %{buildroot}%{_libdir}
402 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
403 popd
404
405 %endif
406
407 #######################################################################
408 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
409 # if wearable || "undefined"
410 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
411 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
412            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
413            --enable-tizen-major-version=%{tizen_version_major} \
414 %if 0%{?tizen_version_major} >= 3
415            --enable-feedback \
416 %endif
417            --enable-videoplayer \
418 %if 0%{?tizen_2_2_compatibility}
419            --with-tizen-2-2-compatibility \
420 %endif
421 %if %{with wayland}
422            --enable-efl=no \
423 %else
424            --enable-efl=yes \
425 %endif
426 %if 0%{?enable_debug}
427            --enable-debug \
428 %endif
429            --enable-appfw=yes \
430            $configure_flags --libdir=%{_libdir}
431
432 # Build.
433 make %{?jobs:-j%jobs}
434
435 pushd %{_builddir}/%{name}-%{version}/build/tizen
436 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
437 popd
438
439 pushd %{buildroot}%{_libdir}
440 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
441 popd
442
443 %endif
444
445 #######################################################################
446 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
447 # if ivi ||"undefined"
448 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
449 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
450            --enable-shaderbincache=DISABLE --enable-profile=IVI \
451            --enable-tizen-major-version=%{tizen_version_major} \
452 %if 0%{?tizen_version_major} >= 3
453            --enable-feedback \
454 %endif
455            --enable-videoplayer \
456 %if 0%{?tizen_2_2_compatibility}
457            --with-tizen-2-2-compatibility \
458 %endif
459 %if %{with wayland}
460            --enable-efl=no \
461 %else
462            --enable-efl=yes \
463 %endif
464 %if 0%{?enable_debug}
465            --enable-debug \
466 %endif
467            --enable-appfw=yes \
468            $configure_flags --libdir=%{_libdir}
469
470 # Build.
471 make %{?jobs:-j%jobs}
472
473 pushd %{_builddir}/%{name}-%{version}/build/tizen
474 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
475 popd
476
477 pushd %{buildroot}%{_libdir}
478 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
479 popd
480
481 %endif
482
483 #######################################################################
484 # common ( build dali_videoplayer_plugin for common uses )
485 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
486 # if common ||"undefined"
487 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
488 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
489            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
490            --enable-tizen-major-version=%{tizen_version_major} \
491 %if 0%{?tizen_version_major} >= 3
492            --enable-feedback \
493 %endif
494            --enable-videoplayer \
495 %if 0%{?tizen_2_2_compatibility}
496            --with-tizen-2-2-compatibility \
497 %endif
498 %if %{with wayland}
499            --enable-efl=no \
500 %else
501            --enable-efl=yes \
502 %endif
503 %if 0%{?enable_debug}
504            --enable-debug \
505 %endif
506            --enable-appfw=yes \
507            $configure_flags --libdir=%{_libdir}
508
509 # Build.
510 make %{?jobs:-j%jobs}
511 %endif
512
513
514 ##############################
515 # Installation
516 ##############################
517 %install
518 rm -rf %{buildroot}
519
520 pushd %{_builddir}/%{name}-%{version}/build/tizen
521 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
522
523
524 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
525 # !unified && (wearable || tv || ivi || mobile)
526 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
527 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
528 %endif
529
530 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
531 # wearable || tv || ivi || mobile || unified
532 %if "%{?profile}" != "common"
533 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
534 %endif
535 popd
536
537 ##############################
538 # Upgrade order:
539 # 1 - Pre Install new package
540 # 2 - Install new package
541 # 3 - Post install new package
542 # 4 - Pre uninstall old package
543 # 5 - Remove files not overwritten by new package
544 # 6 - Post uninstall old package
545 ##############################
546
547 %pre
548 exit 0
549
550 ##############################
551 #  Post Install new package
552 ##############################
553 %post
554 /sbin/ldconfig
555 exit 0
556
557 ##############################
558 #  Pre Uninstall old package
559 ##############################
560 %preun
561 exit 0
562
563 ##############################
564 #  Post Uninstall old package
565 ##############################
566 %postun
567 /sbin/ldconfig
568 exit 0
569
570 %if %{with wayland}
571 %post dali-video-player-plugin
572 /sbin/ldconfig
573 exit 0
574 %endif
575
576 %if %{with wayland}
577 %postun dali-video-player-plugin
578 /sbin/ldconfig
579 exit 0
580 %endif
581
582
583 ##############################
584
585 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
586 # if mobile || "undefined"
587 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
588 %post profile_mobile
589 pushd %{_libdir}
590 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
591 popd
592 /sbin/ldconfig
593 exit 0
594
595 %postun profile_mobile
596 /sbin/ldconfig
597 exit 0
598 %endif
599
600 ##############################
601
602 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
603 # if tv ||"undefined"
604 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
605 %post profile_tv
606 pushd %{_libdir}
607 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
608 popd
609 /sbin/ldconfig
610 exit 0
611
612 %postun profile_tv
613 /sbin/ldconfig
614 exit 0
615 %endif
616
617 ##############################
618
619 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
620 # if wearable || "undefined"
621 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
622 %post profile_wearable
623 pushd %{_libdir}
624 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
625 popd
626 /sbin/ldconfig
627 exit 0
628
629 %postun profile_wearable
630 /sbin/ldconfig
631 exit 0
632 %endif
633
634 ##############################
635
636 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
637 # if ivi ||"undefined"
638 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
639 %post profile_ivi
640 pushd %{_libdir}
641 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
642 popd
643 /sbin/ldconfig
644 exit 0
645
646 %postun profile_ivi
647 /sbin/ldconfig
648 exit 0
649 %endif
650
651
652 ##############################
653 # Files in Binary Packages
654 ##############################
655
656 %files
657 %manifest dali-adaptor.manifest
658 %defattr(-,root,root,-)
659 %defattr(-,app,app,-)
660 %dir %{user_shader_cache_dir}
661 %{_bindir}/*
662 %license LICENSE
663
664 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
665 # if common ||"undefined"
666 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
667 %defattr(-,root,root,-)
668 %{_libdir}/libdali-adap*.so*
669 %exclude %{_libdir}/libdali-adap*.so*.mobile
670 %exclude %{_libdir}/libdali-adap*.so*.wearable
671 %exclude %{_libdir}/libdali-adap*.so*.tv
672 %exclude %{_libdir}/libdali-adap*.so*.ivi
673 %endif
674
675 %if %{with wayland}
676 %files dali-video-player-plugin
677 %manifest dali-adaptor.manifest
678 %defattr(-,root,root,-)
679 %{_libdir}/libdali-video-player-plugin.so*
680 %license LICENSE
681 %endif
682
683 %if 0%{?tizen_version_major} >= 3
684 %files dali-feedback-plugin
685 %manifest dali-adaptor.manifest
686 %defattr(-,root,root,-)
687 %{_libdir}/libdali-feedback-plugin.so*
688 %{dali_plugin_sound_files}/*
689 %endif
690
691 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
692 # if common ||"undefined"
693 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
694 %files profile_common
695 # default .so files are housed in the main pkg.
696 %endif
697
698 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
699 # if mobile || "undefined"
700 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
701 %files profile_mobile
702 %manifest dali-adaptor.manifest
703 %defattr(-,root,root,-)
704 %{_libdir}/libdali-adap*.so*.mobile
705 %endif
706
707 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
708 # if tv ||"undefined"
709 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
710 %files profile_tv
711 %manifest dali-adaptor.manifest
712 %defattr(-,root,root,-)
713 %{_libdir}/libdali-adap*.so*.tv
714 %endif
715
716 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
717 # if wearable || "undefined"
718 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
719 %files profile_wearable
720 %manifest dali-adaptor.manifest
721 %defattr(-,root,root,-)
722 %{_libdir}/libdali-adap*.so*.wearable
723 %endif
724
725 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
726 # if ivi ||"undefined"
727 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
728 %files profile_ivi
729 %manifest dali-adaptor.manifest
730 %defattr(-,root,root,-)
731 %{_libdir}/libdali-adap*.so*.ivi
732 %endif
733
734
735 %files devel
736 %defattr(-,root,root,-)
737 %{dev_include_path}/dali/dali.h
738 %{dev_include_path}/dali/public-api/*
739 %{dev_include_path}/dali/devel-api/*
740 %{dev_include_path}/dali/doc/*
741 %{_libdir}/pkgconfig/dali-adaptor.pc
742
743 %files integration-devel
744 %defattr(-,root,root,-)
745 %{dev_include_path}/dali/integration-api/adaptors/*
746 %{_libdir}/pkgconfig/dali-adaptor-integration.pc