[3.0] Fix build error
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12
13 %bcond_with wayland
14
15 Name:       dali-adaptor
16 Summary:    The DALi Tizen Adaptor
17 Version:    1.1.49
18 Release:    1
19 Group:      System/Libraries
20 License:    Apache-2.0 and BSD-2-Clause and MIT
21 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
22 Source0:    %{name}-%{version}.tar.gz
23
24 Requires(post): /sbin/ldconfig
25 Requires(postun): /sbin/ldconfig
26 Requires:       giflib
27
28 #need libtzplatform-config for directory if tizen version is 3.x
29
30 %if "%{tizen_version_major}" == "3"
31 BuildRequires:  pkgconfig(libtzplatform-config)
32 %endif
33
34
35 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
36
37 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
38 %define profile %{tizen_profile_name}
39 %endif
40
41 %if "%{profile}" == "mobile"
42 %define dali_profile MOBILE
43 %define dali_feedback_plugin 1
44 %define dali_videoplayer_plugin 1
45 %define shaderbincache_flag DISABLE
46 BuildRequires:  pkgconfig(gles20)
47 %define gles_requirement_setup 1
48 %endif
49
50 %if "%{profile}" == "tv"
51 %define dali_profile TV
52 %define dali_feedback_plugin 0
53 %define dali_videoplayer_plugin 1
54 %define shaderbincache_flag ENABLE
55 BuildRequires:  pkgconfig(glesv2)
56 %define gles_requirement_setup 1
57 %endif
58
59 %if "%{profile}" == "wearable"
60 %define dali_profile WEARABLE
61 %define dali_feedback_plugin 0
62 %define dali_videoplayer_plugin 1
63 %define shaderbincache_flag DISABLE
64 BuildRequires:  pkgconfig(gles20)
65 BuildRequires:  pkgconfig(capi-appfw-watch-application)
66 BuildRequires:  pkgconfig(appcore-watch)
67 BuildRequires:  pkgconfig(screen_connector_provider)
68 %define gles_requirement_setup 1
69 %endif
70
71 %if "%{profile}" == "ivi"
72 %define dali_profile IVI
73 %define dali_feedback_plugin 0
74 %define dali_videoplayer_plugin 1
75 %define shaderbincache_flag DISABLE
76 BuildRequires:  pkgconfig(glesv2)
77 %define gles_requirement_setup 1
78 %endif
79
80 %if "%{profile}" == "common"
81 %define dali_profile COMMON
82 %define dali_feedback_plugin 0
83 %define dali_videoplayer_plugin 1
84 %define tizen_2_2_compatibility 0
85 %define shaderbincache_flag DISABLE
86 BuildRequires:  pkgconfig(glesv2)
87 %define gles_requirement_setup 1
88 %endif
89
90 # If we have not set a BuildRequires for the gles version, default it here.
91 %{!?gles_requirement_setup: BuildRequires:  pkgconfig(glesv2)}
92
93 BuildRequires:  pkgconfig
94 BuildRequires:  gawk
95 BuildRequires:  giflib-devel
96 BuildRequires:  pkgconfig(fontconfig)
97 BuildRequires:  libjpeg-turbo-devel
98 BuildRequires:  dali-devel
99 BuildRequires:  dali-integration-devel
100 BuildRequires:  pkgconfig(vconf)
101 BuildRequires:  tts-devel
102 BuildRequires:  pkgconfig(dlog)
103 BuildRequires:  libdrm-devel
104 BuildRequires:  pkgconfig(libexif)
105 BuildRequires:  pkgconfig(libpng)
106 BuildRequires:  pkgconfig(egl)
107 BuildRequires:  libcurl-devel
108 BuildRequires:  pkgconfig(harfbuzz)
109 BuildRequires:  fribidi-devel
110
111 %if 0%{?tizen_2_2_compatibility} != 1
112 BuildRequires:  pkgconfig(capi-system-info)
113 BuildRequires:  pkgconfig(capi-system-sensor)
114 %endif
115
116 # Tizen currently does not have libuv as a separate libuv package
117 # So we have to look into the uv headers bundled inside node-js
118 BuildRequires:  nodejs-devel
119
120
121 %if %{with wayland}
122
123 ####### BUILDING FOR WAYLAND #######
124 BuildRequires:  pkgconfig(wayland-egl)
125 BuildRequires:  pkgconfig(wayland-client)
126 BuildRequires:  wayland-devel
127 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
128 %if "%{profile}" != "common"
129 BuildRequires:  wayland-extension-client-devel
130 %endif
131
132 # dali-adaptor-uv uses libuv mainloop and has its own wayland client (it needs wayland-client headers).
133 BuildRequires:  libxkbcommon-devel
134
135 # dali-adaptor uses ecore mainloop
136 BuildRequires:  pkgconfig(ecore-wayland)
137 BuildRequires:  pkgconfig(wayland-tbm-client)
138 BuildRequires:  pkgconfig(tizen-extension-client)
139
140 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
141 BuildRequires:  pkgconfig(libtbm)
142
143 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
144 BuildRequires:  pkgconfig(tpkp-curl)
145
146 ####### BUILDING FOR X11#######
147 %else
148 BuildRequires:  pkgconfig(egl)
149 BuildRequires:  pkgconfig(xext)
150 BuildRequires:  pkgconfig(xi)
151 BuildRequires:  pkgconfig(xfixes)
152 BuildRequires:  pkgconfig(xdamage)
153 BuildRequires:  pkgconfig(utilX)
154 %endif
155
156 # for dali-adaptor
157 BuildRequires:  pkgconfig(evas)
158 BuildRequires:  pkgconfig(elementary)
159 BuildRequires:  pkgconfig(capi-appfw-application)
160 BuildRequires:  pkgconfig(capi-system-system-settings)
161
162 %if 0%{?over_tizen_2_2}
163 BuildRequires:  pkgconfig(capi-system-info)
164 %endif
165
166
167
168 %description
169 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
170 platform abstraction and application shell
171
172 ##############################
173 # devel
174 ##############################
175 %package devel
176 Summary:    Development components for the DALi Tizen Adaptor
177 Group:      Development/Building
178 Requires:   %{name} = %{version}-%{release}
179 Requires:   %{name}-integration-devel = %{version}-%{release}
180
181 %description devel
182 Development components for the DALi Tizen Adaptor - public headers and package configs
183
184 ##############################
185 # integration-devel
186 ##############################
187 %package integration-devel
188 Summary:    Integration development package for the Adaptor
189 Group:      Development/Building
190 Requires:   %{name} = %{version}-%{release}
191
192 %description integration-devel
193 Integration development package for the Adaptor - headers for integrating with an adaptor library.
194
195 ##############################
196 # Dali Feedback Plugin
197 ##############################
198 %package dali-feedback-plugin
199 Summary:    Plugin to play haptic and audio feedback for Dali
200 Group:      System/Libraries
201 %if 0%{?dali_feedback_plugin}
202 BuildRequires:  pkgconfig(mm-sound)
203 BuildRequires:  pkgconfig(feedback)
204 %endif
205
206 %description dali-feedback-plugin
207 Feedback plugin to play haptic and audio feedback for Dali
208
209 ##############################
210 # Dali VideoPlayer Plugin
211 ##############################
212 %if %{with wayland}
213
214 %package dali-video-player-plugin
215 Summary:    Plugin to play a video file for Dali
216 Group:      System/Libraries
217 %if 0%{?dali_videoplayer_plugin}
218 BuildRequires:  pkgconfig(capi-media-player)
219 %endif
220
221 %description dali-video-player-plugin
222 VideoPlayer plugin to play a video file for Dali
223 %endif
224
225 ##############################
226 # Preparation
227 ##############################
228 %prep
229 %setup -q
230
231 #Use TZ_PATH when tizen version is 3.x
232
233 %if "%{tizen_version_major}" == "2"
234 %define dali_data_rw_dir         /usr/share/dali/
235 %define dali_data_ro_dir         /usr/share/dali/
236 %define font_preloaded_path      /usr/share/fonts/
237 %define font_downloaded_path     /opt/share/fonts/
238 %define font_application_path    /usr/share/app_fonts/
239 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
240 %else
241 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
242 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
243 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
244 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
245 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
246 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
247 %endif
248
249 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
250 %define dali_plugin_sound_files  /plugins/sounds/
251 %define dev_include_path %{_includedir}
252
253 ##############################
254 # Build
255 ##############################
256 %build
257 PREFIX+="/usr"
258 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
259 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
260
261 %ifarch %{arm}
262 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc -DSCREEN_ROTATION_ENABLED"
263 %endif
264
265 %if "%{?_with_emulator}" == "1"
266 CXXFLAGS+=" -DSCREEN_ROTATION_ENABLED"
267 %endif
268
269 %if %{with wayland}
270 CFLAGS+=" -DWAYLAND"
271 CXXFLAGS+=" -DWAYLAND"
272 configure_flags="--enable-wayland"
273 %endif
274
275 %if 0%{?tizen_2_2_compatibility}
276 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
277 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
278 %endif
279
280 libtoolize --force
281 cd %{_builddir}/%{name}-%{version}/build/tizen
282 autoreconf --install
283
284 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
285 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
286 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
287 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
288 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
289 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
290
291 # Default to GLES 2.0 if not specified.
292 %{!?target_gles_version: %define target_gles_version 20}
293
294 #--enable-efl=no \ # only affects dali-adaptor-uv
295 #--enable-appfw=yes \ # affects both dali-adaptor & dali-adaptor-uv
296 #--with-libuv=/usr/include/node/ \ # only affects dali-adaptor-uv
297
298 # Set up the build via configure.
299 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} --enable-shaderbincache=%{shaderbincache_flag} --enable-profile=%{dali_profile} \
300 %if 0%{?dali_feedback_plugin}
301            --enable-feedback \
302 %endif
303 %if 0%{?dali_videoplayer_plugin}
304            --enable-videoplayer \
305 %endif
306 %if 0%{?tizen_2_2_compatibility}
307            --with-tizen-2-2-compatibility \
308 %endif
309 %if %{with wayland}
310            --enable-efl=no \
311 %else
312            --enable-efl=yes \
313 %endif
314 %if 0%{?enable_debug}
315            --enable-debug \
316 %endif
317            --enable-appfw=yes \
318            --with-libuv=/usr/include/node/ \
319            $configure_flags --libdir=%{_libdir}
320
321 # Build.
322 make %{?jobs:-j%jobs}
323
324 ##############################
325 # Installation
326 ##############################
327 %install
328 rm -rf %{buildroot}
329 cd build/tizen
330 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
331
332
333 ##############################
334 # Upgrade order:
335 # 1 - Pre Install new package
336 # 2 - Install new package
337 # 3 - Post install new package
338 # 4 - Pre uninstall old package
339 # 5 - Remove files not overwritten by new package
340 # 6 - Post uninstall old package
341 ##############################
342
343 %pre
344 exit 0
345
346 ##############################
347 #  Post Install new package
348 ##############################
349 %post
350 /sbin/ldconfig
351 exit 0
352
353 %if 0%{?dali_feedback_plugin}
354 %post dali-feedback-plugin
355 /sbin/ldconfig
356 exit 0
357 %endif
358
359 %if %{with wayland}
360 %if 0%{?dali_videoplayer_plugin}
361 %post dali-video-player-plugin
362 /sbin/ldconfig
363 exit 0
364 %endif
365 %endif
366
367 ##############################
368 #   Pre Uninstall old package
369 ##############################
370 %preun
371 exit 0
372
373 ##############################
374 #   Post Uninstall old package
375 ##############################
376 %postun
377 /sbin/ldconfig
378 exit 0
379
380 %if 0%{?dali_feedback_plugin}
381 %postun dali-feedback-plugin
382 /sbin/ldconfig
383 exit 0
384 %endif
385
386 %if %{with wayland}
387 %if 0%{?dali_videoplayer_plugin}
388 %postun dali-video-player-plugin
389 /sbin/ldconfig
390 exit 0
391 %endif
392 %endif
393
394 ##############################
395 # Files in Binary Packages
396 ##############################
397
398 %files
399 %manifest dali-adaptor.manifest
400 %defattr(-,root,root,-)
401 %{_libdir}/libdali-adap*.so*
402 %defattr(-,app,app,-)
403 %dir %{user_shader_cache_dir}
404 %{_bindir}/*
405 %license LICENSE
406 #%{_datadir}/license/%{name}
407
408 %files devel
409 %defattr(-,root,root,-)
410 %{dev_include_path}/dali/dali.h
411 %{dev_include_path}/dali/public-api/*
412 %{dev_include_path}/dali/devel-api/*
413 %{dev_include_path}/dali/doc/*
414 %{_libdir}/pkgconfig/dali-adaptor.pc
415 %{_libdir}/pkgconfig/dali-adaptor-uv.pc
416
417 %files integration-devel
418 %defattr(-,root,root,-)
419 %{dev_include_path}/dali/integration-api/adaptors/*
420 %{_libdir}/pkgconfig/dali-adaptor-integration.pc
421
422 %if 0%{?dali_feedback_plugin}
423 %files dali-feedback-plugin
424 %defattr(-,root,root,-)
425 %{_libdir}/libdali-feedback-plugin.so*
426 %{dali_plugin_sound_files}/*
427 %endif
428
429 %if %{with wayland}
430 %if 0%{?dali_videoplayer_plugin}
431 %files dali-video-player-plugin
432 %manifest dali-adaptor.manifest
433 %defattr(-,root,root,-)
434 %{_libdir}/libdali-video-player-plugin.so*
435 %license LICENSE
436 %endif
437 %endif