[Tizen] Add DALi Autofill implementation
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.9.36
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  fribidi-devel
65
66 BuildRequires:  pkgconfig(capi-system-info)
67 BuildRequires:  pkgconfig(capi-system-sensor)
68
69 BuildRequires:  pkgconfig(cairo)
70
71 BuildRequires:  pkgconfig(wayland-egl)
72 BuildRequires:  pkgconfig(wayland-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # WebP support only from Tizen 6 onwards
77 %if 0%{?tizen_version_major} >= 6
78 BuildRequires:  pkgconfig(libwebp)
79 BuildRequires:  pkgconfig(libwebpdecoder)
80 BuildRequires:  pkgconfig(libwebpdemux)
81 BuildRequires:  pkgconfig(libwebpmux)
82 %endif
83
84 # We use ecore mainloop
85 %if 0%{?tizen_version_major} >= 5
86 BuildRequires:  pkgconfig(ecore-wl2)
87 BuildRequires:  pkgconfig(wayland-egl-tizen)
88 %else
89 BuildRequires:  pkgconfig(ecore-wayland)
90 %endif
91
92 # We need tbm_surface in tizen 3.0 wayland
93 BuildRequires:  pkgconfig(libtbm)
94
95 # for the adaptor
96 BuildRequires:  pkgconfig(appcore-ui)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for autofill
106 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
107 BuildRequires:  pkgconfig(capi-ui-autofill)
108 %endif
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113 BuildRequires:  pkgconfig(component-based-core-base)
114
115 # for multiprofile
116 Requires:   %{name}-compat = %{version}-%{release}
117 Recommends: %{name}-profile_common = %{version}-%{release}
118
119 %description
120 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
121 platform abstraction and application shell
122
123 ###########################################
124 # Dali adapter for profiles
125 ###########################################
126
127 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
128 # if mobile || "undefined"
129 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
130 %package profile_mobile
131 Summary:        The DALi Tizen Adaptor for mobile
132 Provides:       %{name}-compat = %{version}-%{release}
133 Conflicts:      %{name}-profile_tv
134 Conflicts:      %{name}-profile_wearable
135 Conflicts:      %{name}-profile_ivi
136 Conflicts:      %{name}-profile_common
137 Requires:       %{name}
138 %description profile_mobile
139 The DALi Tizen Adaptor for mobile.
140 %endif
141
142 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
143 # if tv ||"undefined"
144 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
145 %package profile_tv
146 Summary:        The DALi Tizen Adaptor for tv
147 Provides:       %{name}-compat = %{version}-%{release}
148 Conflicts:      %{name}-profile_mobile
149 Conflicts:      %{name}-profile_wearable
150 Conflicts:      %{name}-profile_ivi
151 Conflicts:      %{name}-profile_common
152 Requires:       %{name}
153 %description profile_tv
154 The DALi Tizen Adaptor for tv.
155 %endif
156
157 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
158 # if wearable || "undefined"
159 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
160 %package profile_wearable
161 Summary:        The DALi Tizen Adaptor for wearable
162 Provides:       %{name}-compat = %{version}-%{release}
163 Conflicts:      %{name}-profile_mobile
164 Conflicts:      %{name}-profile_tv
165 Conflicts:      %{name}-profile_ivi
166 Conflicts:      %{name}-profile_common
167 Requires:       %{name}
168 %description profile_wearable
169 The DALi Tizen Adaptor for wearable.
170 %endif
171
172 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
173 # if ivi ||"undefined"
174 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
175 %package profile_ivi
176 Summary:        The DALi Tizen Adaptor for ivi
177 Provides:       %{name}-compat = %{version}-%{release}
178 Conflicts:      %{name}-profile_mobile
179 Conflicts:      %{name}-profile_wearable
180 Conflicts:      %{name}-profile_tv
181 Conflicts:      %{name}-profile_common
182 Requires:       %{name}
183 %description profile_ivi
184 The DALi Tizen Adaptor for ivi.
185 %endif
186
187 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
188 # if common ||"undefined"
189 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
190 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
191 %package profile_common
192 Summary:        The DALi Tizen Adaptor for common
193 Provides:       %{name}-compat = %{version}-%{release}
194 Conflicts:      %{name}-profile_mobile
195 Conflicts:      %{name}-profile_wearable
196 Conflicts:      %{name}-profile_tv
197 Conflicts:      %{name}-profile_ivi
198 Requires:       %{name}
199 %description profile_common
200 The DALi Tizen Adaptor for common.
201 %endif
202
203 ##############################
204 # devel
205 ##############################
206 %package devel
207 Summary:    Development components for the DALi Tizen Adaptor
208 Group:      Development/Building
209 Requires:   %{name} = %{version}-%{release}
210 Requires:   %{name}-integration-devel = %{version}-%{release}
211
212 %description devel
213 Development components for the DALi Tizen Adaptor - public headers and package configs
214
215 ##############################
216 # integration-devel
217 ##############################
218 %package integration-devel
219 Summary:    Integration development package for the Adaptor
220 Group:      Development/Building
221 Requires:   %{name} = %{version}-%{release}
222
223 %description integration-devel
224 Integration development package for the Adaptor - headers for integrating with an adaptor library.
225
226 ##############################
227 # Dali Feedback Plugin
228 ##############################
229 %package dali2-feedback-plugin
230 Summary:    Plugin to play haptic and audio feedback for Dali
231 Group:      System/Libraries
232 Requires:   %{name} = %{version}-%{release}
233 %description dali2-feedback-plugin
234 Feedback plugin to play haptic and audio feedback for Dali
235
236 ##############################
237 # Preparation
238 ##############################
239 %prep
240 %setup -q
241
242 #Use TZ_PATH when tizen version is 3.x or greater
243
244 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
245 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
246 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
247 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
248 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
249 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
250
251 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
252 %define dali_plugin_sound_files  /plugins/sounds/
253
254 ##############################
255 # Build
256 ##############################
257 %build
258 PREFIX+="/usr"
259 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
260 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
261
262 %ifarch %{arm}
263 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
264 %endif
265
266 CFLAGS+=" -DWAYLAND"
267 CXXFLAGS+=" -DWAYLAND"
268 cmake_flags=" -DENABLE_WAYLAND=ON"
269
270 # Use this conditional when Tizen version is 5.x or greater
271 %if 0%{?tizen_version_major} >= 5
272 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
273
274 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
275 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
276 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
277 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
278 %endif
279
280 %if 0%{?enable_debug}
281 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
282 %endif
283
284 %if 0%{?enable_trace}
285 cmake_flags+=" -DENABLE_TRACE=ON"
286 %endif
287
288 libtoolize --force
289 cd %{_builddir}/%{name}-%{version}/build/tizen
290
291 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
292 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
293 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
294 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
295 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
296 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
297 %if 0%{?tizen_platform_config_supported}
298 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
299 %endif
300
301 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
302 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
303 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
304 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
305 cmake_flags+=" -DENABLE_TIZEN_MINOR_VERSION=%{tizen_version_minor}"
306 cmake_flags+=" -DENABLE_FEEDBACK=YES"
307 cmake_flags+=" -DENABLE_APPFW=YES"
308 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
309
310 # Set up the build via Cmake
311 #######################################################################
312 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
313 # if mobile || "undefined"
314 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
315
316 mkdir mobile
317 pushd mobile
318
319 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
320
321 # Build.
322 make %{?jobs:-j%jobs}
323 popd
324
325 %endif
326
327 #######################################################################
328 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
329 # if tv ||"undefined"
330 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
331
332 mkdir tv
333 pushd tv
334
335 cmake -DENABLE_PROFILE=TV $cmake_flags ..
336
337 # Build.
338 make %{?jobs:-j%jobs}
339 popd
340
341 %endif
342
343 #######################################################################
344 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
345 # if wearable || "undefined"
346 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
347
348 mkdir wearable
349 pushd wearable
350
351 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
352
353 # Build.
354 make %{?jobs:-j%jobs}
355 popd
356
357 %endif
358
359 #######################################################################
360 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
361 # if ivi ||"undefined"
362 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
363
364 mkdir ivi
365 pushd ivi
366
367 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
368
369 # Build.
370 make %{?jobs:-j%jobs}
371 popd
372
373 %endif
374
375 #######################################################################
376 # common
377 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
378 # if common ||"undefined"
379 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
380
381 mkdir common
382 pushd common
383
384 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
385
386 # Build.
387 make %{?jobs:-j%jobs}
388 popd
389
390 %endif
391
392 ##############################
393 # Installation
394 ##############################
395 %install
396 rm -rf %{buildroot}
397
398 pushd %{_builddir}/%{name}-%{version}/build/tizen
399
400 # if mobile || "undefined"
401 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
402 pushd mobile
403 %make_install
404 %if "%{?profile}" != "mobile"
405 pushd  %{buildroot}%{_libdir}
406 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
407 popd
408 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
409 %endif
410 popd
411 %endif
412
413 # if tv ||"undefined"
414 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
415 pushd tv
416 %make_install
417 %if "%{?profile}" != "tv"
418 pushd  %{buildroot}%{_libdir}
419 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
420 popd
421 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
422 %endif
423 popd
424 %endif
425
426 # if wearable || "undefined"
427 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
428 pushd wearable
429 %make_install
430 %if "%{?profile}" != "wearable"
431 pushd  %{buildroot}%{_libdir}
432 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
433 popd
434 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
435 %endif
436 popd
437 %endif
438
439 # if ivi ||"undefined"
440 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
441 pushd ivi
442 %make_install
443 %if "%{?profile}" != "ivi"
444 pushd  %{buildroot}%{_libdir}
445 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
446 popd
447 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
448 %endif
449 popd
450 %endif
451
452 # if common ||"undefined"
453 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
454 pushd common
455 %make_install
456 # No clean so we can gather symbol/size information for the common profile
457 popd
458 %endif
459
460 # Create a symbolic link in integration-api to preserve legacy repo build
461 pushd %{buildroot}%{_includedir}/dali/integration-api
462 ln -sf adaptor-framework adaptors
463 popd
464
465 ##############################
466 # Upgrade order:
467 # 1 - Pre Install new package
468 # 2 - Install new package
469 # 3 - Post install new package
470 # 4 - Pre uninstall old package
471 # 5 - Remove files not overwritten by new package
472 # 6 - Post uninstall old package
473 ##############################
474
475 ##############################
476 # Adaptor package Commands
477 %pre
478 exit 0
479
480 %post
481 pushd %{_libdir}
482 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
483 popd
484 /sbin/ldconfig
485 exit 0
486
487 %preun
488 exit 0
489
490 %postun
491 /sbin/ldconfig
492 exit 0
493
494 ##############################
495 # Mobile Profile Commands
496 # if mobile || "undefined"
497 # No need to create a symbolic link on install required if only building this profile
498 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
499 %post profile_mobile
500 %if "%{?profile}" != "mobile"
501 pushd %{_libdir}
502 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
503 popd
504 %endif
505 /sbin/ldconfig
506 exit 0
507
508 %postun profile_mobile
509 /sbin/ldconfig
510 exit 0
511 %endif
512
513 ##############################
514 # TV Profile Commands
515 # No need to create a symbolic link on install required if only building this profile
516 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
517 %post profile_tv
518 %if "%{?profile}" != "tv"
519 pushd %{_libdir}
520 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
521 popd
522 %endif
523 /sbin/ldconfig
524 exit 0
525
526 %postun profile_tv
527 /sbin/ldconfig
528 exit 0
529 %endif
530
531 ##############################
532 # Wearable Profile Commands
533 # No need to create a symbolic link on install required if only building this profile
534 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
535 %post profile_wearable
536 %if "%{?profile}" != "wearable"
537 pushd %{_libdir}
538 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
539 popd
540 %endif
541 /sbin/ldconfig
542 exit 0
543
544 %postun profile_wearable
545 /sbin/ldconfig
546 exit 0
547 %endif
548
549 ##############################
550 # IVI Profile Commands
551 # No need to create a symbolic link on install required if only building this profile
552 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
553 %post profile_ivi
554 %if "%{?profile}" != "ivi"
555 pushd %{_libdir}
556 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
557 popd
558 %endif
559 /sbin/ldconfig
560 exit 0
561
562 %postun profile_ivi
563 /sbin/ldconfig
564 exit 0
565 %endif
566
567 ##############################
568 # Common Profile Commands
569 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
570 %post profile_common
571 /sbin/ldconfig
572 exit 0
573
574 %postun profile_common
575 /sbin/ldconfig
576 exit 0
577 %endif
578
579 ##############################
580 # Files in Binary Packages
581 ##############################
582
583 %files
584 %manifest dali-adaptor.manifest
585 %defattr(-,root,root,-)
586 %dir %{user_shader_cache_dir}
587 %{_bindir}/*
588 %license LICENSE
589 %defattr(-,root,root,-)
590 %{_libdir}/libdali2-adaptor.so
591 %{_libdir}/libdali2-adaptor.so.2
592 %{_libdir}/libdali2-adaptor.so.2.0.0
593
594 #################################################
595
596 %files dali2-feedback-plugin
597 %manifest dali-adaptor.manifest
598 %defattr(-,root,root,-)
599 %{_libdir}/libdali2-feedback-plugin.so*
600 %{dali_plugin_sound_files}/*
601
602 #################################################
603
604 # if common ||"undefined"
605 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
606 %files profile_common
607 %manifest dali-adaptor.manifest
608 # default .so files are housed in the main pkg.
609 %endif
610
611 # if mobile || "undefined"
612 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
613 %files profile_mobile
614 %manifest dali-adaptor.manifest
615 %defattr(-,root,root,-)
616 %if "%{?profile}" != "mobile"
617 %{_libdir}/libdali2-adaptor.so.mobile
618 %endif
619 %endif
620
621 # if tv ||"undefined"
622 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
623 %files profile_tv
624 %manifest dali-adaptor.manifest
625 %defattr(-,root,root,-)
626 %if "%{?profile}" != "tv"
627 %{_libdir}/libdali2-adaptor.so.tv
628 %endif
629 %endif
630
631 # if wearable || "undefined"
632 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
633 %files profile_wearable
634 %manifest dali-adaptor.manifest
635 %defattr(-,root,root,-)
636 %if "%{?profile}" != "wearable"
637 %{_libdir}/libdali2-adaptor.so.wearable
638 %endif
639 %endif
640
641 # if ivi ||"undefined"
642 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
643 %files profile_ivi
644 %manifest dali-adaptor.manifest
645 %defattr(-,root,root,-)
646 %if "%{?profile}" != "ivi"
647 %{_libdir}/libdali2-adaptor.so.ivi
648 %endif
649 %endif
650
651 %files devel
652 %defattr(-,root,root,-)
653 %{_includedir}/dali/dali.h
654 %{_includedir}/dali/public-api/*
655 %{_includedir}/dali/devel-api/*
656 %{_includedir}/dali/doc/*
657 %{_libdir}/pkgconfig/dali2-adaptor.pc
658
659 %files integration-devel
660 %defattr(-,root,root,-)
661 %{_includedir}/dali/integration-api/adaptor-framework/*
662 %{_includedir}/dali/integration-api/adaptors
663 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc