[AT-SPI] simplify dbus
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.0.30
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(cairo)
71
72 BuildRequires:  pkgconfig(wayland-egl)
73 BuildRequires:  pkgconfig(wayland-client)
74 BuildRequires:  wayland-devel
75 BuildRequires:  wayland-extension-client-devel
76
77 # WebP support only from Tizen 6 onwards
78 %if 0%{?tizen_version_major} >= 6
79 BuildRequires:  pkgconfig(libwebp)
80 BuildRequires:  pkgconfig(libwebpdecoder)
81 BuildRequires:  pkgconfig(libwebpdemux)
82 BuildRequires:  pkgconfig(libwebpmux)
83 %endif
84
85 # We use ecore mainloop
86 %if 0%{?tizen_version_major} >= 5
87 BuildRequires:  pkgconfig(ecore-wl2)
88 BuildRequires:  pkgconfig(wayland-egl-tizen)
89 %else
90 BuildRequires:  pkgconfig(ecore-wayland)
91 %endif
92
93 # We need tbm_surface in tizen 3.0 wayland
94 BuildRequires:  pkgconfig(libtbm)
95
96 # for the adaptor
97 BuildRequires:  pkgconfig(appcore-ui)
98 BuildRequires:  pkgconfig(appcore-widget-base)
99 BuildRequires:  pkgconfig(bundle)
100 BuildRequires:  pkgconfig(capi-appfw-app-common)
101 BuildRequires:  pkgconfig(capi-appfw-app-control)
102 BuildRequires:  pkgconfig(ecore-imf)
103
104 BuildRequires:  pkgconfig(capi-system-system-settings)
105
106 # for ATSPI (Accessibility) support
107 BuildRequires:  pkgconfig(eldbus)
108
109 # for autofill
110 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
111 BuildRequires:  pkgconfig(capi-ui-autofill)
112 %endif
113
114 # for feedback plugin
115 BuildRequires:  pkgconfig(mm-sound)
116 BuildRequires:  pkgconfig(feedback)
117 BuildRequires:  pkgconfig(component-based-core-base)
118
119
120 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
121 BuildRequires:  pkgconfig(thorvg)
122 %endif
123
124 # for multiprofile
125 Requires:   %{name}-compat = %{version}-%{release}
126 Recommends: %{name}-profile_common = %{version}-%{release}
127
128 %description
129 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
130 platform abstraction and application shell
131
132 ###########################################
133 # Dali adapter for profiles
134 ###########################################
135
136 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
137 # if mobile || "undefined"
138 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
139 %package profile_mobile
140 Summary:        The DALi Tizen Adaptor for mobile
141 Provides:       %{name}-compat = %{version}-%{release}
142 Conflicts:      %{name}-profile_tv
143 Conflicts:      %{name}-profile_wearable
144 Conflicts:      %{name}-profile_ivi
145 Conflicts:      %{name}-profile_common
146 Requires:       %{name}
147 %description profile_mobile
148 The DALi Tizen Adaptor for mobile.
149 %endif
150
151 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
152 # if tv ||"undefined"
153 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
154 %package profile_tv
155 Summary:        The DALi Tizen Adaptor for tv
156 Provides:       %{name}-compat = %{version}-%{release}
157 Conflicts:      %{name}-profile_mobile
158 Conflicts:      %{name}-profile_wearable
159 Conflicts:      %{name}-profile_ivi
160 Conflicts:      %{name}-profile_common
161 Requires:       %{name}
162 %description profile_tv
163 The DALi Tizen Adaptor for tv.
164 %endif
165
166 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
167 # if wearable || "undefined"
168 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
169 %package profile_wearable
170 Summary:        The DALi Tizen Adaptor for wearable
171 Provides:       %{name}-compat = %{version}-%{release}
172 Conflicts:      %{name}-profile_mobile
173 Conflicts:      %{name}-profile_tv
174 Conflicts:      %{name}-profile_ivi
175 Conflicts:      %{name}-profile_common
176 Requires:       %{name}
177 %description profile_wearable
178 The DALi Tizen Adaptor for wearable.
179 %endif
180
181 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
182 # if ivi ||"undefined"
183 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
184 %package profile_ivi
185 Summary:        The DALi Tizen Adaptor for ivi
186 Provides:       %{name}-compat = %{version}-%{release}
187 Conflicts:      %{name}-profile_mobile
188 Conflicts:      %{name}-profile_wearable
189 Conflicts:      %{name}-profile_tv
190 Conflicts:      %{name}-profile_common
191 Requires:       %{name}
192 %description profile_ivi
193 The DALi Tizen Adaptor for ivi.
194 %endif
195
196 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
197 # if common ||"undefined"
198 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
199 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
200 %package profile_common
201 Summary:        The DALi Tizen Adaptor for common
202 Provides:       %{name}-compat = %{version}-%{release}
203 Conflicts:      %{name}-profile_mobile
204 Conflicts:      %{name}-profile_wearable
205 Conflicts:      %{name}-profile_tv
206 Conflicts:      %{name}-profile_ivi
207 Requires:       %{name}
208 %description profile_common
209 The DALi Tizen Adaptor for common.
210 %endif
211
212 ##############################
213 # devel
214 ##############################
215 %package devel
216 Summary:    Development components for the DALi Tizen Adaptor
217 Group:      Development/Building
218 Requires:   %{name} = %{version}-%{release}
219 Requires:   %{name}-integration-devel = %{version}-%{release}
220
221 %description devel
222 Development components for the DALi Tizen Adaptor - public headers and package configs
223
224 ##############################
225 # integration-devel
226 ##############################
227 %package integration-devel
228 Summary:    Integration development package for the Adaptor
229 Group:      Development/Building
230 Requires:   %{name} = %{version}-%{release}
231
232 %description integration-devel
233 Integration development package for the Adaptor - headers for integrating with an adaptor library.
234
235 ##############################
236 # Dali Feedback Plugin
237 ##############################
238 %package dali2-feedback-plugin
239 Summary:    Plugin to play haptic and audio feedback for Dali
240 Group:      System/Libraries
241 Requires:   %{name} = %{version}-%{release}
242 %description dali2-feedback-plugin
243 Feedback plugin to play haptic and audio feedback for Dali
244
245 ##############################
246 # Preparation
247 ##############################
248 %prep
249 %setup -q
250
251 #Use TZ_PATH when tizen version is 3.x or greater
252
253 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
254 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
255 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
256 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
257 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
258 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
259
260 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
261 %define dali_plugin_sound_files  /plugins/sounds/
262
263 ##############################
264 # Build
265 ##############################
266 %build
267 PREFIX+="/usr"
268 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
269 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
270
271 %ifarch %{arm}
272 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
273 %endif
274
275 CFLAGS+=" -DWAYLAND"
276 CXXFLAGS+=" -DWAYLAND"
277 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON"
278
279 # Use this conditional when Tizen version is 5.x or greater
280 %if 0%{?tizen_version_major} >= 5
281 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
282
283 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
284 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
285 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
286 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
287 %endif
288
289 %if 0%{?enable_debug}
290 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
291 %endif
292
293 %if 0%{?enable_trace}
294 cmake_flags+=" -DENABLE_TRACE=ON"
295 %endif
296
297 libtoolize --force
298 cd %{_builddir}/%{name}-%{version}/build/tizen
299
300 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
301 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
302 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
303 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
304 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
305 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
306 %if 0%{?tizen_platform_config_supported}
307 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
308 %endif
309
310 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
311 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
312 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
313 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
314 cmake_flags+=" -DENABLE_TIZEN_MINOR_VERSION=%{tizen_version_minor}"
315 cmake_flags+=" -DENABLE_FEEDBACK=YES"
316 cmake_flags+=" -DENABLE_APPFW=YES"
317 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
318
319 # Set up the build via Cmake
320 #######################################################################
321 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
322 # if mobile || "undefined"
323 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
324
325 mkdir mobile
326 pushd mobile
327
328 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
329
330 # Build.
331 make %{?jobs:-j%jobs}
332 popd
333
334 %endif
335
336 #######################################################################
337 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
338 # if tv ||"undefined"
339 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
340
341 mkdir tv
342 pushd tv
343
344 cmake -DENABLE_PROFILE=TV $cmake_flags ..
345
346 # Build.
347 make %{?jobs:-j%jobs}
348 popd
349
350 %endif
351
352 #######################################################################
353 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
354 # if wearable || "undefined"
355 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
356
357 mkdir wearable
358 pushd wearable
359
360 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
361
362 # Build.
363 make %{?jobs:-j%jobs}
364 popd
365
366 %endif
367
368 #######################################################################
369 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
370 # if ivi ||"undefined"
371 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
372
373 mkdir ivi
374 pushd ivi
375
376 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
377
378 # Build.
379 make %{?jobs:-j%jobs}
380 popd
381
382 %endif
383
384 #######################################################################
385 # common
386 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
387 # if common ||"undefined"
388 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
389
390 mkdir common
391 pushd common
392
393 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
394
395 # Build.
396 make %{?jobs:-j%jobs}
397 popd
398
399 %endif
400
401 ##############################
402 # Installation
403 ##############################
404 %install
405 rm -rf %{buildroot}
406
407 pushd %{_builddir}/%{name}-%{version}/build/tizen
408
409 # if mobile || "undefined"
410 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
411 pushd mobile
412 %make_install
413 %if "%{?profile}" != "mobile"
414 pushd  %{buildroot}%{_libdir}
415 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
416 popd
417 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
418 %endif
419 popd
420 %endif
421
422 # if tv ||"undefined"
423 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
424 pushd tv
425 %make_install
426 %if "%{?profile}" != "tv"
427 pushd  %{buildroot}%{_libdir}
428 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
429 popd
430 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
431 %endif
432 popd
433 %endif
434
435 # if wearable || "undefined"
436 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
437 pushd wearable
438 %make_install
439 %if "%{?profile}" != "wearable"
440 pushd  %{buildroot}%{_libdir}
441 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
442 popd
443 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
444 %endif
445 popd
446 %endif
447
448 # if ivi ||"undefined"
449 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
450 pushd ivi
451 %make_install
452 %if "%{?profile}" != "ivi"
453 pushd  %{buildroot}%{_libdir}
454 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
455 popd
456 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
457 %endif
458 popd
459 %endif
460
461 # if common ||"undefined"
462 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
463 pushd common
464 %make_install
465 # No clean so we can gather symbol/size information for the common profile
466 popd
467 %endif
468
469 # Create a symbolic link in integration-api to preserve legacy repo build
470 pushd %{buildroot}%{_includedir}/dali/integration-api
471 ln -sf adaptor-framework adaptors
472 popd
473
474 ##############################
475 # Upgrade order:
476 # 1 - Pre Install new package
477 # 2 - Install new package
478 # 3 - Post install new package
479 # 4 - Pre uninstall old package
480 # 5 - Remove files not overwritten by new package
481 # 6 - Post uninstall old package
482 ##############################
483
484 ##############################
485 # Adaptor package Commands
486 %pre
487 exit 0
488
489 %post
490 pushd %{_libdir}
491 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
492 popd
493 /sbin/ldconfig
494 exit 0
495
496 %preun
497 exit 0
498
499 %postun
500 /sbin/ldconfig
501 exit 0
502
503 ##############################
504 # Mobile Profile Commands
505 # if mobile || "undefined"
506 # No need to create a symbolic link on install required if only building this profile
507 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
508 %post profile_mobile
509 %if "%{?profile}" != "mobile"
510 pushd %{_libdir}
511 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
512 popd
513 %endif
514 /sbin/ldconfig
515 exit 0
516
517 %postun profile_mobile
518 /sbin/ldconfig
519 exit 0
520 %endif
521
522 ##############################
523 # TV Profile Commands
524 # No need to create a symbolic link on install required if only building this profile
525 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
526 %post profile_tv
527 %if "%{?profile}" != "tv"
528 pushd %{_libdir}
529 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
530 popd
531 %endif
532 /sbin/ldconfig
533 exit 0
534
535 %postun profile_tv
536 /sbin/ldconfig
537 exit 0
538 %endif
539
540 ##############################
541 # Wearable Profile Commands
542 # No need to create a symbolic link on install required if only building this profile
543 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
544 %post profile_wearable
545 %if "%{?profile}" != "wearable"
546 pushd %{_libdir}
547 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
548 popd
549 %endif
550 /sbin/ldconfig
551 exit 0
552
553 %postun profile_wearable
554 /sbin/ldconfig
555 exit 0
556 %endif
557
558 ##############################
559 # IVI Profile Commands
560 # No need to create a symbolic link on install required if only building this profile
561 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
562 %post profile_ivi
563 %if "%{?profile}" != "ivi"
564 pushd %{_libdir}
565 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
566 popd
567 %endif
568 /sbin/ldconfig
569 exit 0
570
571 %postun profile_ivi
572 /sbin/ldconfig
573 exit 0
574 %endif
575
576 ##############################
577 # Common Profile Commands
578 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
579 %post profile_common
580 /sbin/ldconfig
581 exit 0
582
583 %postun profile_common
584 /sbin/ldconfig
585 exit 0
586 %endif
587
588 ##############################
589 # Files in Binary Packages
590 ##############################
591
592 %files
593 %manifest dali-adaptor.manifest
594 %defattr(-,root,root,-)
595 %dir %{user_shader_cache_dir}
596 %{_bindir}/*
597 %license LICENSE
598 %defattr(-,root,root,-)
599 %{_libdir}/libdali2-adaptor.so
600 %{_libdir}/libdali2-adaptor.so.2
601 %{_libdir}/libdali2-adaptor.so.2.0.0
602
603 #################################################
604
605 %files dali2-feedback-plugin
606 %manifest dali-adaptor.manifest
607 %defattr(-,root,root,-)
608 %{_libdir}/libdali2-feedback-plugin.so*
609 %{dali_plugin_sound_files}/*
610
611 #################################################
612
613 # if common ||"undefined"
614 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
615 %files profile_common
616 %manifest dali-adaptor.manifest
617 # default .so files are housed in the main pkg.
618 %endif
619
620 # if mobile || "undefined"
621 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
622 %files profile_mobile
623 %manifest dali-adaptor.manifest
624 %defattr(-,root,root,-)
625 %if "%{?profile}" != "mobile"
626 %{_libdir}/libdali2-adaptor.so.mobile
627 %endif
628 %endif
629
630 # if tv ||"undefined"
631 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
632 %files profile_tv
633 %manifest dali-adaptor.manifest
634 %defattr(-,root,root,-)
635 %if "%{?profile}" != "tv"
636 %{_libdir}/libdali2-adaptor.so.tv
637 %endif
638 %endif
639
640 # if wearable || "undefined"
641 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
642 %files profile_wearable
643 %manifest dali-adaptor.manifest
644 %defattr(-,root,root,-)
645 %if "%{?profile}" != "wearable"
646 %{_libdir}/libdali2-adaptor.so.wearable
647 %endif
648 %endif
649
650 # if ivi ||"undefined"
651 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
652 %files profile_ivi
653 %manifest dali-adaptor.manifest
654 %defattr(-,root,root,-)
655 %if "%{?profile}" != "ivi"
656 %{_libdir}/libdali2-adaptor.so.ivi
657 %endif
658 %endif
659
660 %files devel
661 %defattr(-,root,root,-)
662 %{_includedir}/dali/dali.h
663 %{_includedir}/dali/public-api/*
664 %{_includedir}/dali/devel-api/*
665 %{_includedir}/dali/doc/*
666 %{_libdir}/pkgconfig/dali2-adaptor.pc
667
668 %files integration-devel
669 %defattr(-,root,root,-)
670 %{_includedir}/dali/integration-api/adaptor-framework/*
671 %{_includedir}/dali/integration-api/adaptors
672 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc