DALi Version 1.2.55
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.55
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107
108 %if 0%{?tizen_version_major} == 3
109 BuildRequires:  pkgconfig(capi-appfw-application)
110 BuildRequires:  pkgconfig(elementary)
111 %else
112 BuildRequires:  pkgconfig(appcore-ui)
113 BuildRequires:  pkgconfig(capi-appfw-app-common)
114 BuildRequires:  pkgconfig(capi-appfw-app-control)
115 BuildRequires:  pkgconfig(ecore-imf)
116 %endif
117 BuildRequires:  pkgconfig(capi-system-system-settings)
118
119 # for feedback plugin
120 BuildRequires:  pkgconfig(mm-sound)
121 %if 0%{?tizen_version_major} >= 3
122 BuildRequires:  pkgconfig(feedback)
123 %endif
124
125 # for videoplayer Plugin
126 BuildRequires:  pkgconfig(capi-media-player)
127
128
129 # for multiprofile
130 Requires:   %{name}-compat = %{version}-%{release}
131 Recommends: %{name}-profile_common = %{version}-%{release}
132
133 %description
134 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
135 platform abstraction and application shell
136
137 ###########################################
138 # Dali adapter for profiles
139 ###########################################
140
141 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
142 # if mobile || "undefined"
143 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
144 %package profile_mobile
145 Summary:        The DALi Tizen Adaptor for mobile
146 Provides:       %{name}-compat = %{version}-%{release}
147 Conflicts:      %{name}-profile_tv
148 Conflicts:      %{name}-profile_wearable
149 Conflicts:      %{name}-profile_ivi
150 Conflicts:      %{name}-profile_common
151 %description profile_mobile
152 The DALi Tizen Adaptor for mobile.
153 %endif
154
155 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
156 # if tv ||"undefined"
157 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
158 %package profile_tv
159 Summary:        The DALi Tizen Adaptor for tv
160 Provides:       %{name}-compat = %{version}-%{release}
161 Conflicts:      %{name}-profile_mobile
162 Conflicts:      %{name}-profile_wearable
163 Conflicts:      %{name}-profile_ivi
164 Conflicts:      %{name}-profile_common
165 %description profile_tv
166 The DALi Tizen Adaptor for tv.
167 %endif
168
169 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
170 # if wearable || "undefined"
171 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
172 %package profile_wearable
173 Summary:        The DALi Tizen Adaptor for wearable
174 Provides:       %{name}-compat = %{version}-%{release}
175 Conflicts:      %{name}-profile_mobile
176 Conflicts:      %{name}-profile_tv
177 Conflicts:      %{name}-profile_ivi
178 Conflicts:      %{name}-profile_common
179 %description profile_wearable
180 The DALi Tizen Adaptor for wearable.
181 %endif
182
183 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
184 # if ivi ||"undefined"
185 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
186 %package profile_ivi
187 Summary:        The DALi Tizen Adaptor for ivi
188 Provides:       %{name}-compat = %{version}-%{release}
189 Conflicts:      %{name}-profile_mobile
190 Conflicts:      %{name}-profile_wearable
191 Conflicts:      %{name}-profile_tv
192 Conflicts:      %{name}-profile_common
193 %description profile_ivi
194 The DALi Tizen Adaptor for ivi.
195 %endif
196
197 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
198 # if common ||"undefined"
199 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
200 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
201 %package profile_common
202 %define tizen_2_2_compatibility 0
203 Summary:        The DALi Tizen Adaptor for common
204 Provides:       %{name}-compat = %{version}-%{release}
205 Conflicts:      %{name}-profile_mobile
206 Conflicts:      %{name}-profile_wearable
207 Conflicts:      %{name}-profile_tv
208 Conflicts:      %{name}-profile_ivi
209 %description profile_common
210 The DALi Tizen Adaptor for common.
211 %endif
212
213 ##############################
214 # devel
215 ##############################
216 %package devel
217 Summary:    Development components for the DALi Tizen Adaptor
218 Group:      Development/Building
219 Requires:   %{name} = %{version}-%{release}
220 Requires:   %{name}-integration-devel = %{version}-%{release}
221
222 %description devel
223 Development components for the DALi Tizen Adaptor - public headers and package configs
224
225 ##############################
226 # integration-devel
227 ##############################
228 %package integration-devel
229 Summary:    Integration development package for the Adaptor
230 Group:      Development/Building
231 Requires:   %{name} = %{version}-%{release}
232
233 %description integration-devel
234 Integration development package for the Adaptor - headers for integrating with an adaptor library.
235
236 ##############################
237 # Dali Feedback Plugin
238 ##############################
239 %package dali-feedback-plugin
240 Summary:    Plugin to play haptic and audio feedback for Dali
241 Group:      System/Libraries
242 Requires:   %{name} = %{version}-%{release}
243 %description dali-feedback-plugin
244 Feedback plugin to play haptic and audio feedback for Dali
245
246 ##############################
247 # Dali VideoPlayer Plugin
248 ##############################
249 %if %{with wayland}
250
251 %package dali-video-player-plugin
252 Summary:    Plugin to play a video file for Dali
253 Group:      System/Libraries
254 %description dali-video-player-plugin
255 VideoPlayer plugin to play a video file for Dali
256 %endif
257
258 ##############################
259 # Preparation
260 ##############################
261 %prep
262 %setup -q
263
264 #Use TZ_PATH when tizen version is 3.x or greater
265
266 %if 0%{?tizen_version_major} >= 3
267 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
268 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
269 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
270 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
271 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
272 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
273 %else
274 %define dali_data_rw_dir         /usr/share/dali/
275 %define dali_data_ro_dir         /usr/share/dali/
276 %define font_preloaded_path      /usr/share/fonts/
277 %define font_downloaded_path     /opt/share/fonts/
278 %define font_application_path    /usr/share/app_fonts/
279 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
280 %endif
281
282 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
283 %define dali_plugin_sound_files  /plugins/sounds/
284 %define dev_include_path %{_includedir}
285
286 ##############################
287 # Build
288 ##############################
289 %build
290 PREFIX+="/usr"
291 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
292 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
293
294 %ifarch %{arm}
295 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
296 %endif
297
298 %if %{with wayland}
299 CFLAGS+=" -DWAYLAND"
300 CXXFLAGS+=" -DWAYLAND"
301 configure_flags="--enable-wayland"
302 %endif
303
304 # Use this conditional when Tizen version is 4.x or greater
305 %if 0%{?tizen_version_major} >= 4
306 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
307 %endif
308
309 %if 0%{?tizen_2_2_compatibility}
310 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
311 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
312 %endif
313
314 libtoolize --force
315 cd %{_builddir}/%{name}-%{version}/build/tizen
316 autoreconf --install
317
318 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
319 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
320 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
321 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
322 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
323 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
324 %if 0%{?tizen_platform_config_supported}
325 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
326 %endif
327
328 # Default to GLES 2.0 if not specified.
329 %{!?target_gles_version: %define target_gles_version 20}
330
331 # Set up the build via configure.
332 #######################################################################
333 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
334 # if mobile || "undefined"
335 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
336 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
337            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
338            --enable-tizen-major-version=%{tizen_version_major} \
339 %if 0%{?tizen_version_major} >= 3
340            --enable-feedback \
341 %endif
342            --enable-videoplayer \
343 %if 0%{?tizen_2_2_compatibility}
344            --with-tizen-2-2-compatibility \
345 %endif
346 %if %{with wayland}
347            --enable-efl=no \
348 %else
349            --enable-efl=yes \
350 %endif
351 %if 0%{?enable_debug}
352            --enable-debug \
353 %endif
354            --enable-appfw=yes \
355            $configure_flags --libdir=%{_libdir}
356
357 # Build.
358 make %{?jobs:-j%jobs}
359
360 pushd %{_builddir}/%{name}-%{version}/build/tizen
361 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
362 popd
363
364 pushd %{buildroot}%{_libdir}
365 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
366 popd
367
368 %endif
369
370 #######################################################################
371 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
372 # if tv ||"undefined"
373 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
374 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
375            --enable-shaderbincache=DISABLE --enable-profile=TV \
376            --enable-tizen-major-version=%{tizen_version_major} \
377 %if 0%{?tizen_version_major} >= 3
378            --enable-feedback \
379 %endif
380            --enable-videoplayer \
381 %if 0%{?tizen_2_2_compatibility}
382            --with-tizen-2-2-compatibility \
383 %endif
384 %if %{with wayland}
385            --enable-efl=no \
386 %else
387            --enable-efl=yes \
388 %endif
389 %if 0%{?enable_debug}
390            --enable-debug \
391 %endif
392            --enable-appfw=yes \
393            $configure_flags --libdir=%{_libdir}
394
395 # Build.
396 make %{?jobs:-j%jobs}
397
398 pushd %{_builddir}/%{name}-%{version}/build/tizen
399 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
400 popd
401
402 pushd %{buildroot}%{_libdir}
403 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
404 popd
405
406 %endif
407
408 #######################################################################
409 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
410 # if wearable || "undefined"
411 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
412 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
413            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
414            --enable-tizen-major-version=%{tizen_version_major} \
415 %if 0%{?tizen_version_major} >= 3
416            --enable-feedback \
417 %endif
418            --enable-videoplayer \
419 %if 0%{?tizen_2_2_compatibility}
420            --with-tizen-2-2-compatibility \
421 %endif
422 %if %{with wayland}
423            --enable-efl=no \
424 %else
425            --enable-efl=yes \
426 %endif
427 %if 0%{?enable_debug}
428            --enable-debug \
429 %endif
430            --enable-appfw=yes \
431            $configure_flags --libdir=%{_libdir}
432
433 # Build.
434 make %{?jobs:-j%jobs}
435
436 pushd %{_builddir}/%{name}-%{version}/build/tizen
437 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
438 popd
439
440 pushd %{buildroot}%{_libdir}
441 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
442 popd
443
444 %endif
445
446 #######################################################################
447 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
448 # if ivi ||"undefined"
449 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
450 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
451            --enable-shaderbincache=DISABLE --enable-profile=IVI \
452            --enable-tizen-major-version=%{tizen_version_major} \
453 %if 0%{?tizen_version_major} >= 3
454            --enable-feedback \
455 %endif
456            --enable-videoplayer \
457 %if 0%{?tizen_2_2_compatibility}
458            --with-tizen-2-2-compatibility \
459 %endif
460 %if %{with wayland}
461            --enable-efl=no \
462 %else
463            --enable-efl=yes \
464 %endif
465 %if 0%{?enable_debug}
466            --enable-debug \
467 %endif
468            --enable-appfw=yes \
469            $configure_flags --libdir=%{_libdir}
470
471 # Build.
472 make %{?jobs:-j%jobs}
473
474 pushd %{_builddir}/%{name}-%{version}/build/tizen
475 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
476 popd
477
478 pushd %{buildroot}%{_libdir}
479 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
480 popd
481
482 %endif
483
484 #######################################################################
485 # common ( build dali_videoplayer_plugin for common uses )
486 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
487 # if common ||"undefined"
488 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
489 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
490            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
491            --enable-tizen-major-version=%{tizen_version_major} \
492 %if 0%{?tizen_version_major} >= 3
493            --enable-feedback \
494 %endif
495            --enable-videoplayer \
496 %if 0%{?tizen_2_2_compatibility}
497            --with-tizen-2-2-compatibility \
498 %endif
499 %if %{with wayland}
500            --enable-efl=no \
501 %else
502            --enable-efl=yes \
503 %endif
504 %if 0%{?enable_debug}
505            --enable-debug \
506 %endif
507            --enable-appfw=yes \
508            $configure_flags --libdir=%{_libdir}
509
510 # Build.
511 make %{?jobs:-j%jobs}
512 %endif
513
514
515 ##############################
516 # Installation
517 ##############################
518 %install
519 rm -rf %{buildroot}
520
521 pushd %{_builddir}/%{name}-%{version}/build/tizen
522 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
523
524
525 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
526 # !unified && (wearable || tv || ivi || mobile)
527 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
528 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
529 %endif
530
531 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
532 # wearable || tv || ivi || mobile || unified
533 %if "%{?profile}" != "common"
534 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
535 %endif
536 popd
537
538 ##############################
539 # Upgrade order:
540 # 1 - Pre Install new package
541 # 2 - Install new package
542 # 3 - Post install new package
543 # 4 - Pre uninstall old package
544 # 5 - Remove files not overwritten by new package
545 # 6 - Post uninstall old package
546 ##############################
547
548 %pre
549 exit 0
550
551 ##############################
552 #  Post Install new package
553 ##############################
554 %post
555 /sbin/ldconfig
556 exit 0
557
558 ##############################
559 #  Pre Uninstall old package
560 ##############################
561 %preun
562 exit 0
563
564 ##############################
565 #  Post Uninstall old package
566 ##############################
567 %postun
568 /sbin/ldconfig
569 exit 0
570
571 %if %{with wayland}
572 %post dali-video-player-plugin
573 /sbin/ldconfig
574 exit 0
575 %endif
576
577 %if %{with wayland}
578 %postun dali-video-player-plugin
579 /sbin/ldconfig
580 exit 0
581 %endif
582
583
584 ##############################
585
586 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
587 # if mobile || "undefined"
588 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
589 %post profile_mobile
590 pushd %{_libdir}
591 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
592 popd
593 /sbin/ldconfig
594 exit 0
595
596 %postun profile_mobile
597 /sbin/ldconfig
598 exit 0
599 %endif
600
601 ##############################
602
603 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
604 # if tv ||"undefined"
605 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
606 %post profile_tv
607 pushd %{_libdir}
608 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
609 popd
610 /sbin/ldconfig
611 exit 0
612
613 %postun profile_tv
614 /sbin/ldconfig
615 exit 0
616 %endif
617
618 ##############################
619
620 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
621 # if wearable || "undefined"
622 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
623 %post profile_wearable
624 pushd %{_libdir}
625 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
626 popd
627 /sbin/ldconfig
628 exit 0
629
630 %postun profile_wearable
631 /sbin/ldconfig
632 exit 0
633 %endif
634
635 ##############################
636
637 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
638 # if ivi ||"undefined"
639 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
640 %post profile_ivi
641 pushd %{_libdir}
642 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
643 popd
644 /sbin/ldconfig
645 exit 0
646
647 %postun profile_ivi
648 /sbin/ldconfig
649 exit 0
650 %endif
651
652
653 ##############################
654 # Files in Binary Packages
655 ##############################
656
657 %files
658 %manifest dali-adaptor.manifest
659 %defattr(-,root,root,-)
660 %defattr(-,app,app,-)
661 %dir %{user_shader_cache_dir}
662 %{_bindir}/*
663 %license LICENSE
664
665 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
666 # if common ||"undefined"
667 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
668 %defattr(-,root,root,-)
669 %{_libdir}/libdali-adap*.so*
670 %exclude %{_libdir}/libdali-adap*.so*.mobile
671 %exclude %{_libdir}/libdali-adap*.so*.wearable
672 %exclude %{_libdir}/libdali-adap*.so*.tv
673 %exclude %{_libdir}/libdali-adap*.so*.ivi
674 %endif
675
676 %if %{with wayland}
677 %files dali-video-player-plugin
678 %manifest dali-adaptor.manifest
679 %defattr(-,root,root,-)
680 %{_libdir}/libdali-video-player-plugin.so*
681 %license LICENSE
682 %endif
683
684 %if 0%{?tizen_version_major} >= 3
685 %files dali-feedback-plugin
686 %manifest dali-adaptor.manifest
687 %defattr(-,root,root,-)
688 %{_libdir}/libdali-feedback-plugin.so*
689 %{dali_plugin_sound_files}/*
690 %endif
691
692 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
693 # if common ||"undefined"
694 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
695 %files profile_common
696 # default .so files are housed in the main pkg.
697 %endif
698
699 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
700 # if mobile || "undefined"
701 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
702 %files profile_mobile
703 %manifest dali-adaptor.manifest
704 %defattr(-,root,root,-)
705 %{_libdir}/libdali-adap*.so*.mobile
706 %endif
707
708 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
709 # if tv ||"undefined"
710 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
711 %files profile_tv
712 %manifest dali-adaptor.manifest
713 %defattr(-,root,root,-)
714 %{_libdir}/libdali-adap*.so*.tv
715 %endif
716
717 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
718 # if wearable || "undefined"
719 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
720 %files profile_wearable
721 %manifest dali-adaptor.manifest
722 %defattr(-,root,root,-)
723 %{_libdir}/libdali-adap*.so*.wearable
724 %endif
725
726 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
727 # if ivi ||"undefined"
728 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
729 %files profile_ivi
730 %manifest dali-adaptor.manifest
731 %defattr(-,root,root,-)
732 %{_libdir}/libdali-adap*.so*.ivi
733 %endif
734
735
736 %files devel
737 %defattr(-,root,root,-)
738 %{dev_include_path}/dali/dali.h
739 %{dev_include_path}/dali/public-api/*
740 %{dev_include_path}/dali/devel-api/*
741 %{dev_include_path}/dali/doc/*
742 %{_libdir}/pkgconfig/dali-adaptor.pc
743
744 %files integration-devel
745 %defattr(-,root,root,-)
746 %{dev_include_path}/dali/integration-api/adaptors/*
747 %{_libdir}/pkgconfig/dali-adaptor-integration.pc