Revert "[Tizen] add bundle package for widget"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.50
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107 BuildRequires:  pkgconfig(elementary)
108
109 %if 0%{?tizen_version_major} == 3
110 BuildRequires:  pkgconfig(capi-appfw-application)
111 %else
112 BuildRequires:  pkgconfig(appcore-ui)
113 BuildRequires:  pkgconfig(appcore-multiwindow)
114 BuildRequires:  pkgconfig(capi-appfw-app-common)
115 BuildRequires:  pkgconfig(capi-appfw-app-control)
116 BuildRequires:  pkgconfig(screen_connector_provider)
117 %endif
118 BuildRequires:  pkgconfig(capi-system-system-settings)
119
120 # for feedback plugin
121 BuildRequires:  pkgconfig(mm-sound)
122 %if 0%{?tizen_version_major} >= 3
123 BuildRequires:  pkgconfig(feedback)
124 %endif
125
126 # for videoplayer Plugin
127 BuildRequires:  pkgconfig(capi-media-player)
128
129
130 # for multiprofile
131 Requires:   %{name}-compat = %{version}-%{release}
132 Recommends: %{name}-profile_common = %{version}-%{release}
133
134 %description
135 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
136 platform abstraction and application shell
137
138 ###########################################
139 # Dali adapter for profiles
140 ###########################################
141
142 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
143 # if mobile || "undefined"
144 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
145 %package profile_mobile
146 Summary:        The DALi Tizen Adaptor for mobile
147 Provides:       %{name}-compat = %{version}-%{release}
148 Conflicts:      %{name}-profile_tv
149 Conflicts:      %{name}-profile_wearable
150 Conflicts:      %{name}-profile_ivi
151 Conflicts:      %{name}-profile_common
152 %description profile_mobile
153 The DALi Tizen Adaptor for mobile.
154 %endif
155
156 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
157 # if tv ||"undefined"
158 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
159 %package profile_tv
160 Summary:        The DALi Tizen Adaptor for tv
161 Provides:       %{name}-compat = %{version}-%{release}
162 Conflicts:      %{name}-profile_mobile
163 Conflicts:      %{name}-profile_wearable
164 Conflicts:      %{name}-profile_ivi
165 Conflicts:      %{name}-profile_common
166 %description profile_tv
167 The DALi Tizen Adaptor for tv.
168 %endif
169
170 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
171 # if wearable || "undefined"
172 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
173 %package profile_wearable
174 Summary:        The DALi Tizen Adaptor for wearable
175 Provides:       %{name}-compat = %{version}-%{release}
176 Conflicts:      %{name}-profile_mobile
177 Conflicts:      %{name}-profile_tv
178 Conflicts:      %{name}-profile_ivi
179 Conflicts:      %{name}-profile_common
180 %description profile_wearable
181 The DALi Tizen Adaptor for wearable.
182 %endif
183
184 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
185 # if ivi ||"undefined"
186 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
187 %package profile_ivi
188 Summary:        The DALi Tizen Adaptor for ivi
189 Provides:       %{name}-compat = %{version}-%{release}
190 Conflicts:      %{name}-profile_mobile
191 Conflicts:      %{name}-profile_wearable
192 Conflicts:      %{name}-profile_tv
193 Conflicts:      %{name}-profile_common
194 %description profile_ivi
195 The DALi Tizen Adaptor for ivi.
196 %endif
197
198 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
199 # if common ||"undefined"
200 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
201 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
202 %package profile_common
203 %define tizen_2_2_compatibility 0
204 Summary:        The DALi Tizen Adaptor for common
205 Provides:       %{name}-compat = %{version}-%{release}
206 Conflicts:      %{name}-profile_mobile
207 Conflicts:      %{name}-profile_wearable
208 Conflicts:      %{name}-profile_tv
209 Conflicts:      %{name}-profile_ivi
210 %description profile_common
211 The DALi Tizen Adaptor for common.
212 %endif
213
214 ##############################
215 # devel
216 ##############################
217 %package devel
218 Summary:    Development components for the DALi Tizen Adaptor
219 Group:      Development/Building
220 Requires:   %{name} = %{version}-%{release}
221 Requires:   %{name}-integration-devel = %{version}-%{release}
222
223 %description devel
224 Development components for the DALi Tizen Adaptor - public headers and package configs
225
226 ##############################
227 # integration-devel
228 ##############################
229 %package integration-devel
230 Summary:    Integration development package for the Adaptor
231 Group:      Development/Building
232 Requires:   %{name} = %{version}-%{release}
233
234 %description integration-devel
235 Integration development package for the Adaptor - headers for integrating with an adaptor library.
236
237 ##############################
238 # Dali Feedback Plugin
239 ##############################
240 %package dali-feedback-plugin
241 Summary:    Plugin to play haptic and audio feedback for Dali
242 Group:      System/Libraries
243 Requires:   %{name} = %{version}-%{release}
244 %description dali-feedback-plugin
245 Feedback plugin to play haptic and audio feedback for Dali
246
247 ##############################
248 # Dali VideoPlayer Plugin
249 ##############################
250 %if %{with wayland}
251
252 %package dali-video-player-plugin
253 Summary:    Plugin to play a video file for Dali
254 Group:      System/Libraries
255 %description dali-video-player-plugin
256 VideoPlayer plugin to play a video file for Dali
257 %endif
258
259 ##############################
260 # Preparation
261 ##############################
262 %prep
263 %setup -q
264
265 #Use TZ_PATH when tizen version is 3.x or greater
266
267 %if 0%{?tizen_version_major} >= 3
268 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
269 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
270 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
271 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
272 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
273 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
274 %else
275 %define dali_data_rw_dir         /usr/share/dali/
276 %define dali_data_ro_dir         /usr/share/dali/
277 %define font_preloaded_path      /usr/share/fonts/
278 %define font_downloaded_path     /opt/share/fonts/
279 %define font_application_path    /usr/share/app_fonts/
280 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
281 %endif
282
283 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
284 %define dali_plugin_sound_files  /plugins/sounds/
285 %define dev_include_path %{_includedir}
286
287 ##############################
288 # Build
289 ##############################
290 %build
291 PREFIX+="/usr"
292 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
293 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
294
295 %ifarch %{arm}
296 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
297 %endif
298
299 %if %{with wayland}
300 CFLAGS+=" -DWAYLAND"
301 CXXFLAGS+=" -DWAYLAND"
302 configure_flags="--enable-wayland"
303 %endif
304
305 # Use this conditional when Tizen version is 4.x or greater
306 %if 0%{?tizen_version_major} >= 4
307 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
308 %endif
309
310 %if 0%{?tizen_2_2_compatibility}
311 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
312 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
313 %endif
314
315 libtoolize --force
316 cd %{_builddir}/%{name}-%{version}/build/tizen
317 autoreconf --install
318
319 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
320 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
321 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
322 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
323 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
324 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
325 %if 0%{?tizen_platform_config_supported}
326 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
327 %endif
328
329 # Default to GLES 2.0 if not specified.
330 %define target_gles_version 20
331
332 # Set up the build via configure.
333 #######################################################################
334 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
335 # if mobile || "undefined"
336 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
337
338 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
339            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
340            --enable-tizen-major-version=%{tizen_version_major} \
341 %if 0%{?tizen_version_major} >= 3
342            --enable-feedback \
343 %endif
344            --enable-videoplayer \
345 %if 0%{?tizen_2_2_compatibility}
346            --with-tizen-2-2-compatibility \
347 %endif
348 %if %{with wayland}
349            --enable-efl=no \
350 %else
351            --enable-efl=yes \
352 %endif
353 %if 0%{?enable_debug}
354            --enable-debug \
355 %endif
356            --enable-appfw=yes \
357            $configure_flags --libdir=%{_libdir}
358
359 # Build.
360 make %{?jobs:-j%jobs}
361
362 pushd %{_builddir}/%{name}-%{version}/build/tizen
363 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
364 popd
365
366 pushd %{buildroot}%{_libdir}
367 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
368 popd
369
370 make clean
371
372 %endif
373
374 #######################################################################
375 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
376 # if tv ||"undefined"
377 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
378
379 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
380            --enable-shaderbincache=DISABLE --enable-profile=TV \
381            --enable-tizen-major-version=%{tizen_version_major} \
382 %if 0%{?tizen_version_major} >= 3
383            --enable-feedback \
384 %endif
385            --enable-videoplayer \
386 %if 0%{?tizen_2_2_compatibility}
387            --with-tizen-2-2-compatibility \
388 %endif
389 %if %{with wayland}
390            --enable-efl=no \
391 %else
392            --enable-efl=yes \
393 %endif
394 %if 0%{?enable_debug}
395            --enable-debug \
396 %endif
397            --enable-appfw=yes \
398            $configure_flags --libdir=%{_libdir}
399
400 # Build.
401 make %{?jobs:-j%jobs}
402
403 pushd %{_builddir}/%{name}-%{version}/build/tizen
404 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
405 popd
406
407 pushd %{buildroot}%{_libdir}
408 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
409 popd
410
411 make clean
412 %endif
413
414 #######################################################################
415 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
416 # if wearable || "undefined"
417 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
418
419 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
420            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
421            --enable-tizen-major-version=%{tizen_version_major} \
422 %if 0%{?tizen_version_major} >= 3
423            --enable-feedback \
424 %endif
425            --enable-videoplayer \
426 %if 0%{?tizen_2_2_compatibility}
427            --with-tizen-2-2-compatibility \
428 %endif
429 %if %{with wayland}
430            --enable-efl=no \
431 %else
432            --enable-efl=yes \
433 %endif
434 %if 0%{?enable_debug}
435            --enable-debug \
436 %endif
437            --enable-appfw=yes \
438            $configure_flags --libdir=%{_libdir}
439
440 # Build.
441 make %{?jobs:-j%jobs}
442
443 pushd %{_builddir}/%{name}-%{version}/build/tizen
444 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
445 popd
446
447 pushd %{buildroot}%{_libdir}
448 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
449 popd
450
451 make clean
452 %endif
453
454 #######################################################################
455 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
456 # if ivi ||"undefined"
457 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
458
459 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
460            --enable-shaderbincache=DISABLE --enable-profile=IVI \
461            --enable-tizen-major-version=%{tizen_version_major} \
462 %if 0%{?tizen_version_major} >= 3
463            --enable-feedback \
464 %endif
465            --enable-videoplayer \
466 %if 0%{?tizen_2_2_compatibility}
467            --with-tizen-2-2-compatibility \
468 %endif
469 %if %{with wayland}
470            --enable-efl=no \
471 %else
472            --enable-efl=yes \
473 %endif
474 %if 0%{?enable_debug}
475            --enable-debug \
476 %endif
477            --enable-appfw=yes \
478            $configure_flags --libdir=%{_libdir}
479
480 # Build.
481 make %{?jobs:-j%jobs}
482
483 pushd %{_builddir}/%{name}-%{version}/build/tizen
484 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
485 popd
486
487 pushd %{buildroot}%{_libdir}
488 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
489 popd
490
491 make clean
492 %endif
493
494 #######################################################################
495 # common ( build dali_videoplayer_plugin for common uses )
496 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
497 # if common ||"undefined"
498 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
499
500 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
501            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
502            --enable-tizen-major-version=%{tizen_version_major} \
503 %if 0%{?tizen_version_major} >= 3
504            --enable-feedback \
505 %endif
506            --enable-videoplayer \
507 %if 0%{?tizen_2_2_compatibility}
508            --with-tizen-2-2-compatibility \
509 %endif
510 %if %{with wayland}
511            --enable-efl=no \
512 %else
513            --enable-efl=yes \
514 %endif
515 %if 0%{?enable_debug}
516            --enable-debug \
517 %endif
518            --enable-appfw=yes \
519            $configure_flags --libdir=%{_libdir}
520
521 # Build.
522 make %{?jobs:-j%jobs}
523
524 %endif
525
526
527 ##############################
528 # Installation
529 ##############################
530 %install
531 rm -rf %{buildroot}
532
533 pushd %{_builddir}/%{name}-%{version}/build/tizen
534 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
535
536
537 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
538 # !unified && (wearable || tv || ivi || mobile)
539 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
540 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
541 %endif
542
543 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
544 # wearable || tv || ivi || mobile || unified
545 %if "%{?profile}" != "common"
546 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
547 %endif
548 popd
549
550 ##############################
551 # Upgrade order:
552 # 1 - Pre Install new package
553 # 2 - Install new package
554 # 3 - Post install new package
555 # 4 - Pre uninstall old package
556 # 5 - Remove files not overwritten by new package
557 # 6 - Post uninstall old package
558 ##############################
559
560 %pre
561 exit 0
562
563 ##############################
564 #  Post Install new package
565 ##############################
566 %post
567 /sbin/ldconfig
568 exit 0
569
570 ##############################
571 #  Pre Uninstall old package
572 ##############################
573 %preun
574 exit 0
575
576 ##############################
577 #  Post Uninstall old package
578 ##############################
579 %postun
580 /sbin/ldconfig
581 exit 0
582
583 %if %{with wayland}
584 %post dali-video-player-plugin
585 /sbin/ldconfig
586 exit 0
587 %endif
588
589 %if %{with wayland}
590 %postun dali-video-player-plugin
591 /sbin/ldconfig
592 exit 0
593 %endif
594
595
596 ##############################
597
598 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
599 # if mobile || "undefined"
600 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
601 %post profile_mobile
602 pushd %{_libdir}
603 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
604 popd
605 /sbin/ldconfig
606 exit 0
607
608 %postun profile_mobile
609 /sbin/ldconfig
610 exit 0
611 %endif
612
613 ##############################
614
615 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
616 # if tv ||"undefined"
617 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
618 %post profile_tv
619 pushd %{_libdir}
620 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
621 popd
622 /sbin/ldconfig
623 exit 0
624
625 %postun profile_tv
626 /sbin/ldconfig
627 exit 0
628 %endif
629
630 ##############################
631
632 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
633 # if wearable || "undefined"
634 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
635 %post profile_wearable
636 pushd %{_libdir}
637 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
638 popd
639 /sbin/ldconfig
640 exit 0
641
642 %postun profile_wearable
643 /sbin/ldconfig
644 exit 0
645 %endif
646
647 ##############################
648
649 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
650 # if ivi ||"undefined"
651 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
652 %post profile_ivi
653 pushd %{_libdir}
654 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
655 popd
656 /sbin/ldconfig
657 exit 0
658
659 %postun profile_ivi
660 /sbin/ldconfig
661 exit 0
662 %endif
663
664
665 ##############################
666 # Files in Binary Packages
667 ##############################
668
669 %files
670 %manifest dali-adaptor.manifest
671 %defattr(-,root,root,-)
672 %defattr(-,app,app,-)
673 %dir %{user_shader_cache_dir}
674 %{_bindir}/*
675 %license LICENSE
676
677 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
678 # if common ||"undefined"
679 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
680 %defattr(-,root,root,-)
681 %{_libdir}/libdali-adap*.so*
682 %exclude %{_libdir}/libdali-adap*.so*.mobile
683 %exclude %{_libdir}/libdali-adap*.so*.wearable
684 %exclude %{_libdir}/libdali-adap*.so*.tv
685 %exclude %{_libdir}/libdali-adap*.so*.ivi
686 %endif
687
688 %if %{with wayland}
689 %files dali-video-player-plugin
690 %manifest dali-adaptor.manifest
691 %defattr(-,root,root,-)
692 %{_libdir}/libdali-video-player-plugin.so*
693 %license LICENSE
694 %endif
695
696 %if 0%{?tizen_version_major} >= 3
697 %files dali-feedback-plugin
698 %manifest dali-adaptor.manifest
699 %defattr(-,root,root,-)
700 %{_libdir}/libdali-feedback-plugin.so*
701 %{dali_plugin_sound_files}/*
702 %endif
703
704 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
705 # if common ||"undefined"
706 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
707 %files profile_common
708 # default .so files are housed in the main pkg.
709 %endif
710
711 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
712 # if mobile || "undefined"
713 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
714 %files profile_mobile
715 %manifest dali-adaptor.manifest
716 %defattr(-,root,root,-)
717 %{_libdir}/libdali-adap*.so*.mobile
718 %endif
719
720 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
721 # if tv ||"undefined"
722 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
723 %files profile_tv
724 %manifest dali-adaptor.manifest
725 %defattr(-,root,root,-)
726 %{_libdir}/libdali-adap*.so*.tv
727 %endif
728
729 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
730 # if wearable || "undefined"
731 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
732 %files profile_wearable
733 %manifest dali-adaptor.manifest
734 %defattr(-,root,root,-)
735 %{_libdir}/libdali-adap*.so*.wearable
736 %endif
737
738 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
739 # if ivi ||"undefined"
740 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
741 %files profile_ivi
742 %manifest dali-adaptor.manifest
743 %defattr(-,root,root,-)
744 %{_libdir}/libdali-adap*.so*.ivi
745 %endif
746
747
748 %files devel
749 %defattr(-,root,root,-)
750 %{dev_include_path}/dali/dali.h
751 %{dev_include_path}/dali/public-api/*
752 %{dev_include_path}/dali/devel-api/*
753 %{dev_include_path}/dali/doc/*
754 %{_libdir}/pkgconfig/dali-adaptor.pc
755
756 %files integration-devel
757 %defattr(-,root,root,-)
758 %{dev_include_path}/dali/integration-api/adaptors/*
759 %{_libdir}/pkgconfig/dali-adaptor-integration.pc