revise installing a license file
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.52
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107 BuildRequires:  pkgconfig(elementary)
108
109 %if 0%{?tizen_version_major} == 3
110 BuildRequires:  pkgconfig(capi-appfw-application)
111 %else
112 BuildRequires:  pkgconfig(bundle)
113 BuildRequires:  pkgconfig(appcore-ui)
114 BuildRequires:  pkgconfig(appcore-multiwindow)
115 BuildRequires:  pkgconfig(capi-appfw-app-common)
116 BuildRequires:  pkgconfig(capi-appfw-app-control)
117 BuildRequires:  pkgconfig(screen_connector_provider)
118 %endif
119 BuildRequires:  pkgconfig(capi-system-system-settings)
120
121 # for feedback plugin
122 BuildRequires:  pkgconfig(mm-sound)
123 %if 0%{?tizen_version_major} >= 3
124 BuildRequires:  pkgconfig(feedback)
125 %endif
126
127 # for videoplayer Plugin
128 BuildRequires:  pkgconfig(capi-media-player)
129
130
131 # for multiprofile
132 Requires:   %{name}-compat = %{version}-%{release}
133 Recommends: %{name}-profile_common = %{version}-%{release}
134
135 %description
136 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
137 platform abstraction and application shell
138
139 ###########################################
140 # Dali adapter for profiles
141 ###########################################
142
143 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
144 # if mobile || "undefined"
145 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
146 %package profile_mobile
147 Summary:        The DALi Tizen Adaptor for mobile
148 Provides:       %{name}-compat = %{version}-%{release}
149 Conflicts:      %{name}-profile_tv
150 Conflicts:      %{name}-profile_wearable
151 Conflicts:      %{name}-profile_ivi
152 Conflicts:      %{name}-profile_common
153 %description profile_mobile
154 The DALi Tizen Adaptor for mobile.
155 %endif
156
157 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
158 # if tv ||"undefined"
159 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
160 %package profile_tv
161 Summary:        The DALi Tizen Adaptor for tv
162 Provides:       %{name}-compat = %{version}-%{release}
163 Conflicts:      %{name}-profile_mobile
164 Conflicts:      %{name}-profile_wearable
165 Conflicts:      %{name}-profile_ivi
166 Conflicts:      %{name}-profile_common
167 %description profile_tv
168 The DALi Tizen Adaptor for tv.
169 %endif
170
171 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
172 # if wearable || "undefined"
173 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
174 %package profile_wearable
175 Summary:        The DALi Tizen Adaptor for wearable
176 Provides:       %{name}-compat = %{version}-%{release}
177 Conflicts:      %{name}-profile_mobile
178 Conflicts:      %{name}-profile_tv
179 Conflicts:      %{name}-profile_ivi
180 Conflicts:      %{name}-profile_common
181 %description profile_wearable
182 The DALi Tizen Adaptor for wearable.
183 %endif
184
185 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
186 # if ivi ||"undefined"
187 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
188 %package profile_ivi
189 Summary:        The DALi Tizen Adaptor for ivi
190 Provides:       %{name}-compat = %{version}-%{release}
191 Conflicts:      %{name}-profile_mobile
192 Conflicts:      %{name}-profile_wearable
193 Conflicts:      %{name}-profile_tv
194 Conflicts:      %{name}-profile_common
195 %description profile_ivi
196 The DALi Tizen Adaptor for ivi.
197 %endif
198
199 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
200 # if common ||"undefined"
201 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
202 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
203 %package profile_common
204 %define tizen_2_2_compatibility 0
205 Summary:        The DALi Tizen Adaptor for common
206 Provides:       %{name}-compat = %{version}-%{release}
207 Conflicts:      %{name}-profile_mobile
208 Conflicts:      %{name}-profile_wearable
209 Conflicts:      %{name}-profile_tv
210 Conflicts:      %{name}-profile_ivi
211 %description profile_common
212 The DALi Tizen Adaptor for common.
213 %endif
214
215 ##############################
216 # devel
217 ##############################
218 %package devel
219 Summary:    Development components for the DALi Tizen Adaptor
220 Group:      Development/Building
221 Requires:   %{name} = %{version}-%{release}
222 Requires:   %{name}-integration-devel = %{version}-%{release}
223
224 %description devel
225 Development components for the DALi Tizen Adaptor - public headers and package configs
226
227 ##############################
228 # integration-devel
229 ##############################
230 %package integration-devel
231 Summary:    Integration development package for the Adaptor
232 Group:      Development/Building
233 Requires:   %{name} = %{version}-%{release}
234
235 %description integration-devel
236 Integration development package for the Adaptor - headers for integrating with an adaptor library.
237
238 ##############################
239 # Dali Feedback Plugin
240 ##############################
241 %package dali-feedback-plugin
242 Summary:    Plugin to play haptic and audio feedback for Dali
243 Group:      System/Libraries
244 Requires:   %{name} = %{version}-%{release}
245 %description dali-feedback-plugin
246 Feedback plugin to play haptic and audio feedback for Dali
247
248 ##############################
249 # Dali VideoPlayer Plugin
250 ##############################
251 %if %{with wayland}
252
253 %package dali-video-player-plugin
254 Summary:    Plugin to play a video file for Dali
255 Group:      System/Libraries
256 %description dali-video-player-plugin
257 VideoPlayer plugin to play a video file for Dali
258 %endif
259
260 ##############################
261 # Preparation
262 ##############################
263 %prep
264 %setup -q
265
266 #Use TZ_PATH when tizen version is 3.x or greater
267
268 %if 0%{?tizen_version_major} >= 3
269 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
270 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
271 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
272 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
273 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
274 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
275 %else
276 %define dali_data_rw_dir         /usr/share/dali/
277 %define dali_data_ro_dir         /usr/share/dali/
278 %define font_preloaded_path      /usr/share/fonts/
279 %define font_downloaded_path     /opt/share/fonts/
280 %define font_application_path    /usr/share/app_fonts/
281 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
282 %endif
283
284 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
285 %define dali_plugin_sound_files  /plugins/sounds/
286 %define dev_include_path %{_includedir}
287
288 ##############################
289 # Build
290 ##############################
291 %build
292 PREFIX+="/usr"
293 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
294 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
295
296 %ifarch %{arm}
297 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
298 %endif
299
300 %if %{with wayland}
301 CFLAGS+=" -DWAYLAND"
302 CXXFLAGS+=" -DWAYLAND"
303 configure_flags="--enable-wayland"
304 %endif
305
306 # Use this conditional when Tizen version is 4.x or greater
307 %if 0%{?tizen_version_major} >= 4
308 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
309 %endif
310
311 %if 0%{?tizen_2_2_compatibility}
312 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
313 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
314 %endif
315
316 libtoolize --force
317 cd %{_builddir}/%{name}-%{version}/build/tizen
318 autoreconf --install
319
320 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
321 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
322 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
323 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
324 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
325 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
326 %if 0%{?tizen_platform_config_supported}
327 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
328 %endif
329
330 # Default to GLES 2.0 if not specified.
331 %define target_gles_version 20
332
333 # Set up the build via configure.
334 #######################################################################
335 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
336 # if mobile || "undefined"
337 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
338
339 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
340            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
341            --enable-tizen-major-version=%{tizen_version_major} \
342 %if 0%{?tizen_version_major} >= 3
343            --enable-feedback \
344 %endif
345            --enable-videoplayer \
346 %if 0%{?tizen_2_2_compatibility}
347            --with-tizen-2-2-compatibility \
348 %endif
349 %if %{with wayland}
350            --enable-efl=no \
351 %else
352            --enable-efl=yes \
353 %endif
354            --enable-debug \
355            --enable-appfw=yes \
356            $configure_flags --libdir=%{_libdir}
357
358 # Build.
359 make %{?jobs:-j%jobs}
360
361 pushd %{_builddir}/%{name}-%{version}/build/tizen
362 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
363 popd
364
365 pushd %{buildroot}%{_libdir}
366 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
367 popd
368
369 make clean
370
371 %endif
372
373 #######################################################################
374 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
375 # if tv ||"undefined"
376 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
377
378 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
379            --enable-shaderbincache=DISABLE --enable-profile=TV \
380            --enable-tizen-major-version=%{tizen_version_major} \
381 %if 0%{?tizen_version_major} >= 3
382            --enable-feedback \
383 %endif
384            --enable-videoplayer \
385 %if 0%{?tizen_2_2_compatibility}
386            --with-tizen-2-2-compatibility \
387 %endif
388 %if %{with wayland}
389            --enable-efl=no \
390 %else
391            --enable-efl=yes \
392 %endif
393            --enable-debug \
394            --enable-appfw=yes \
395            $configure_flags --libdir=%{_libdir}
396
397 # Build.
398 make %{?jobs:-j%jobs}
399
400 pushd %{_builddir}/%{name}-%{version}/build/tizen
401 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
402 popd
403
404 pushd %{buildroot}%{_libdir}
405 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
406 popd
407
408 make clean
409 %endif
410
411 #######################################################################
412 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
413 # if wearable || "undefined"
414 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
415
416 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
417            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
418            --enable-tizen-major-version=%{tizen_version_major} \
419 %if 0%{?tizen_version_major} >= 3
420            --enable-feedback \
421 %endif
422            --enable-videoplayer \
423 %if 0%{?tizen_2_2_compatibility}
424            --with-tizen-2-2-compatibility \
425 %endif
426 %if %{with wayland}
427            --enable-efl=no \
428 %else
429            --enable-efl=yes \
430 %endif
431            --enable-debug \
432            --enable-appfw=yes \
433            $configure_flags --libdir=%{_libdir}
434
435 # Build.
436 make %{?jobs:-j%jobs}
437
438 pushd %{_builddir}/%{name}-%{version}/build/tizen
439 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
440 popd
441
442 pushd %{buildroot}%{_libdir}
443 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
444 popd
445
446 make clean
447 %endif
448
449 #######################################################################
450 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
451 # if ivi ||"undefined"
452 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
453
454 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
455            --enable-shaderbincache=DISABLE --enable-profile=IVI \
456            --enable-tizen-major-version=%{tizen_version_major} \
457 %if 0%{?tizen_version_major} >= 3
458            --enable-feedback \
459 %endif
460            --enable-videoplayer \
461 %if 0%{?tizen_2_2_compatibility}
462            --with-tizen-2-2-compatibility \
463 %endif
464 %if %{with wayland}
465            --enable-efl=no \
466 %else
467            --enable-efl=yes \
468 %endif
469            --enable-debug \
470            --enable-appfw=yes \
471            $configure_flags --libdir=%{_libdir}
472
473 # Build.
474 make %{?jobs:-j%jobs}
475
476 pushd %{_builddir}/%{name}-%{version}/build/tizen
477 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
478 popd
479
480 pushd %{buildroot}%{_libdir}
481 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
482 popd
483
484 make clean
485 %endif
486
487 #######################################################################
488 # common ( build dali_videoplayer_plugin for common uses )
489 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
490 # if common ||"undefined"
491 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
492
493 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
494            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
495            --enable-tizen-major-version=%{tizen_version_major} \
496 %if 0%{?tizen_version_major} >= 3
497            --enable-feedback \
498 %endif
499            --enable-videoplayer \
500 %if 0%{?tizen_2_2_compatibility}
501            --with-tizen-2-2-compatibility \
502 %endif
503 %if %{with wayland}
504            --enable-efl=no \
505 %else
506            --enable-efl=yes \
507 %endif
508            --enable-debug \
509            --enable-appfw=yes \
510            $configure_flags --libdir=%{_libdir}
511
512 # Build.
513 make %{?jobs:-j%jobs}
514
515 %endif
516
517
518 ##############################
519 # Installation
520 ##############################
521 %install
522 rm -rf %{buildroot}
523
524 pushd %{_builddir}/%{name}-%{version}/build/tizen
525 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
526
527
528 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
529 # !unified && (wearable || tv || ivi || mobile)
530 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
531 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
532 %endif
533
534 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
535 # wearable || tv || ivi || mobile || unified
536 %if "%{?profile}" != "common"
537 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
538 %endif
539 popd
540
541 ##############################
542 # Upgrade order:
543 # 1 - Pre Install new package
544 # 2 - Install new package
545 # 3 - Post install new package
546 # 4 - Pre uninstall old package
547 # 5 - Remove files not overwritten by new package
548 # 6 - Post uninstall old package
549 ##############################
550
551 %pre
552 exit 0
553
554 ##############################
555 #  Post Install new package
556 ##############################
557 %post
558 /sbin/ldconfig
559 exit 0
560
561 ##############################
562 #  Pre Uninstall old package
563 ##############################
564 %preun
565 exit 0
566
567 ##############################
568 #  Post Uninstall old package
569 ##############################
570 %postun
571 /sbin/ldconfig
572 exit 0
573
574 %if %{with wayland}
575 %post dali-video-player-plugin
576 /sbin/ldconfig
577 exit 0
578 %endif
579
580 %if %{with wayland}
581 %postun dali-video-player-plugin
582 /sbin/ldconfig
583 exit 0
584 %endif
585
586
587 ##############################
588
589 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
590 # if mobile || "undefined"
591 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
592 %post profile_mobile
593 pushd %{_libdir}
594 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
595 popd
596 /sbin/ldconfig
597 exit 0
598
599 %postun profile_mobile
600 /sbin/ldconfig
601 exit 0
602 %endif
603
604 ##############################
605
606 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
607 # if tv ||"undefined"
608 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
609 %post profile_tv
610 pushd %{_libdir}
611 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
612 popd
613 /sbin/ldconfig
614 exit 0
615
616 %postun profile_tv
617 /sbin/ldconfig
618 exit 0
619 %endif
620
621 ##############################
622
623 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
624 # if wearable || "undefined"
625 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
626 %post profile_wearable
627 pushd %{_libdir}
628 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
629 popd
630 /sbin/ldconfig
631 exit 0
632
633 %postun profile_wearable
634 /sbin/ldconfig
635 exit 0
636 %endif
637
638 ##############################
639
640 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
641 # if ivi ||"undefined"
642 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
643 %post profile_ivi
644 pushd %{_libdir}
645 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
646 popd
647 /sbin/ldconfig
648 exit 0
649
650 %postun profile_ivi
651 /sbin/ldconfig
652 exit 0
653 %endif
654
655
656 ##############################
657 # Files in Binary Packages
658 ##############################
659
660 %files
661 %manifest dali-adaptor.manifest
662 %defattr(-,root,root,-)
663 %defattr(-,app,app,-)
664 %dir %{user_shader_cache_dir}
665 %{_bindir}/*
666 %license LICENSE
667
668 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
669 # if common ||"undefined"
670 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
671 %defattr(-,root,root,-)
672 %{_libdir}/libdali-adap*.so*
673 %exclude %{_libdir}/libdali-adap*.so*.mobile
674 %exclude %{_libdir}/libdali-adap*.so*.wearable
675 %exclude %{_libdir}/libdali-adap*.so*.tv
676 %exclude %{_libdir}/libdali-adap*.so*.ivi
677 %endif
678
679 %if %{with wayland}
680 %files dali-video-player-plugin
681 %manifest dali-adaptor.manifest
682 %defattr(-,root,root,-)
683 %{_libdir}/libdali-video-player-plugin.so*
684 %license LICENSE
685 %endif
686
687 %if 0%{?tizen_version_major} >= 3
688 %files dali-feedback-plugin
689 %manifest dali-adaptor.manifest
690 %defattr(-,root,root,-)
691 %{_libdir}/libdali-feedback-plugin.so*
692 %{dali_plugin_sound_files}/*
693 %endif
694
695 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
696 # if common ||"undefined"
697 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
698 %files profile_common
699 # default .so files are housed in the main pkg.
700 %endif
701
702 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
703 # if mobile || "undefined"
704 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
705 %files profile_mobile
706 %manifest dali-adaptor.manifest
707 %defattr(-,root,root,-)
708 %{_libdir}/libdali-adap*.so*.mobile
709 %endif
710
711 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
712 # if tv ||"undefined"
713 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
714 %files profile_tv
715 %manifest dali-adaptor.manifest
716 %defattr(-,root,root,-)
717 %{_libdir}/libdali-adap*.so*.tv
718 %endif
719
720 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
721 # if wearable || "undefined"
722 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
723 %files profile_wearable
724 %manifest dali-adaptor.manifest
725 %defattr(-,root,root,-)
726 %{_libdir}/libdali-adap*.so*.wearable
727 %endif
728
729 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
730 # if ivi ||"undefined"
731 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
732 %files profile_ivi
733 %manifest dali-adaptor.manifest
734 %defattr(-,root,root,-)
735 %{_libdir}/libdali-adap*.so*.ivi
736 %endif
737
738
739 %files devel
740 %defattr(-,root,root,-)
741 %{dev_include_path}/dali/dali.h
742 %{dev_include_path}/dali/public-api/*
743 %{dev_include_path}/dali/devel-api/*
744 %{dev_include_path}/dali/doc/*
745 %{_libdir}/pkgconfig/dali-adaptor.pc
746
747 %files integration-devel
748 %defattr(-,root,root,-)
749 %{dev_include_path}/dali/integration-api/adaptors/*
750 %{_libdir}/pkgconfig/dali-adaptor-integration.pc