[Tizen] Fix Set and Get InputPanelUserData()
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.52
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107 BuildRequires:  pkgconfig(elementary)
108
109 %if 0%{?tizen_version_major} == 3
110 BuildRequires:  pkgconfig(capi-appfw-application)
111 %else
112 BuildRequires:  pkgconfig(bundle)
113 BuildRequires:  pkgconfig(appcore-ui)
114 BuildRequires:  pkgconfig(appcore-multiwindow)
115 BuildRequires:  pkgconfig(capi-appfw-app-common)
116 BuildRequires:  pkgconfig(capi-appfw-app-control)
117 BuildRequires:  pkgconfig(screen_connector_provider)
118 %endif
119 BuildRequires:  pkgconfig(capi-system-system-settings)
120
121 # for feedback plugin
122 BuildRequires:  pkgconfig(mm-sound)
123 %if 0%{?tizen_version_major} >= 3
124 BuildRequires:  pkgconfig(feedback)
125 %endif
126
127 # for videoplayer Plugin
128 BuildRequires:  pkgconfig(capi-media-player)
129
130
131 # for multiprofile
132 Requires:   %{name}-compat = %{version}-%{release}
133 Recommends: %{name}-profile_common = %{version}-%{release}
134
135 %description
136 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
137 platform abstraction and application shell
138
139 ###########################################
140 # Dali adapter for profiles
141 ###########################################
142
143 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
144 # if mobile || "undefined"
145 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
146 %package profile_mobile
147 Summary:        The DALi Tizen Adaptor for mobile
148 Provides:       %{name}-compat = %{version}-%{release}
149 Conflicts:      %{name}-profile_tv
150 Conflicts:      %{name}-profile_wearable
151 Conflicts:      %{name}-profile_ivi
152 Conflicts:      %{name}-profile_common
153 %description profile_mobile
154 The DALi Tizen Adaptor for mobile.
155 %endif
156
157 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
158 # if tv ||"undefined"
159 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
160 %package profile_tv
161 Summary:        The DALi Tizen Adaptor for tv
162 Provides:       %{name}-compat = %{version}-%{release}
163 Conflicts:      %{name}-profile_mobile
164 Conflicts:      %{name}-profile_wearable
165 Conflicts:      %{name}-profile_ivi
166 Conflicts:      %{name}-profile_common
167 %description profile_tv
168 The DALi Tizen Adaptor for tv.
169 %endif
170
171 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
172 # if wearable || "undefined"
173 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
174 %package profile_wearable
175 Summary:        The DALi Tizen Adaptor for wearable
176 Provides:       %{name}-compat = %{version}-%{release}
177 Conflicts:      %{name}-profile_mobile
178 Conflicts:      %{name}-profile_tv
179 Conflicts:      %{name}-profile_ivi
180 Conflicts:      %{name}-profile_common
181 %description profile_wearable
182 The DALi Tizen Adaptor for wearable.
183 %endif
184
185 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
186 # if ivi ||"undefined"
187 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
188 %package profile_ivi
189 Summary:        The DALi Tizen Adaptor for ivi
190 Provides:       %{name}-compat = %{version}-%{release}
191 Conflicts:      %{name}-profile_mobile
192 Conflicts:      %{name}-profile_wearable
193 Conflicts:      %{name}-profile_tv
194 Conflicts:      %{name}-profile_common
195 %description profile_ivi
196 The DALi Tizen Adaptor for ivi.
197 %endif
198
199 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
200 # if common ||"undefined"
201 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
202 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
203 %package profile_common
204 %define tizen_2_2_compatibility 0
205 Summary:        The DALi Tizen Adaptor for common
206 Provides:       %{name}-compat = %{version}-%{release}
207 Conflicts:      %{name}-profile_mobile
208 Conflicts:      %{name}-profile_wearable
209 Conflicts:      %{name}-profile_tv
210 Conflicts:      %{name}-profile_ivi
211 %description profile_common
212 The DALi Tizen Adaptor for common.
213 %endif
214
215 ##############################
216 # devel
217 ##############################
218 %package devel
219 Summary:    Development components for the DALi Tizen Adaptor
220 Group:      Development/Building
221 Requires:   %{name} = %{version}-%{release}
222 Requires:   %{name}-integration-devel = %{version}-%{release}
223
224 %description devel
225 Development components for the DALi Tizen Adaptor - public headers and package configs
226
227 ##############################
228 # integration-devel
229 ##############################
230 %package integration-devel
231 Summary:    Integration development package for the Adaptor
232 Group:      Development/Building
233 Requires:   %{name} = %{version}-%{release}
234
235 %description integration-devel
236 Integration development package for the Adaptor - headers for integrating with an adaptor library.
237
238 ##############################
239 # Dali Feedback Plugin
240 ##############################
241 %package dali-feedback-plugin
242 Summary:    Plugin to play haptic and audio feedback for Dali
243 Group:      System/Libraries
244 Requires:   %{name} = %{version}-%{release}
245 %description dali-feedback-plugin
246 Feedback plugin to play haptic and audio feedback for Dali
247
248 ##############################
249 # Dali VideoPlayer Plugin
250 ##############################
251 %if %{with wayland}
252
253 %package dali-video-player-plugin
254 Summary:    Plugin to play a video file for Dali
255 Group:      System/Libraries
256 %description dali-video-player-plugin
257 VideoPlayer plugin to play a video file for Dali
258 %endif
259
260 ##############################
261 # Preparation
262 ##############################
263 %prep
264 %setup -q
265
266 #Use TZ_PATH when tizen version is 3.x or greater
267
268 %if 0%{?tizen_version_major} >= 3
269 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
270 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
271 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
272 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
273 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
274 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
275 %else
276 %define dali_data_rw_dir         /usr/share/dali/
277 %define dali_data_ro_dir         /usr/share/dali/
278 %define font_preloaded_path      /usr/share/fonts/
279 %define font_downloaded_path     /opt/share/fonts/
280 %define font_application_path    /usr/share/app_fonts/
281 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
282 %endif
283
284 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
285 %define dali_plugin_sound_files  /plugins/sounds/
286 %define dev_include_path %{_includedir}
287
288 ##############################
289 # Build
290 ##############################
291 %build
292 PREFIX+="/usr"
293 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
294 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
295
296 %ifarch %{arm}
297 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
298 %endif
299
300 %if %{with wayland}
301 CFLAGS+=" -DWAYLAND"
302 CXXFLAGS+=" -DWAYLAND"
303 configure_flags="--enable-wayland"
304 %endif
305
306 # Use this conditional when Tizen version is 4.x or greater
307 %if 0%{?tizen_version_major} >= 4
308 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
309 %endif
310
311 %if 0%{?tizen_2_2_compatibility}
312 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
313 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
314 %endif
315
316 libtoolize --force
317 cd %{_builddir}/%{name}-%{version}/build/tizen
318 autoreconf --install
319
320 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
321 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
322 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
323 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
324 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
325 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
326 %if 0%{?tizen_platform_config_supported}
327 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
328 %endif
329
330 # Default to GLES 2.0 if not specified.
331 %define target_gles_version 20
332
333 # Set up the build via configure.
334 #######################################################################
335 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
336 # if mobile || "undefined"
337 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
338
339 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
340            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
341            --enable-tizen-major-version=%{tizen_version_major} \
342 %if 0%{?tizen_version_major} >= 3
343            --enable-feedback \
344 %endif
345            --enable-videoplayer \
346 %if 0%{?tizen_2_2_compatibility}
347            --with-tizen-2-2-compatibility \
348 %endif
349 %if %{with wayland}
350            --enable-efl=no \
351 %else
352            --enable-efl=yes \
353 %endif
354 %if 0%{?enable_debug}
355            --enable-debug \
356 %endif
357            --enable-appfw=yes \
358            $configure_flags --libdir=%{_libdir}
359
360 # Build.
361 make %{?jobs:-j%jobs}
362
363 pushd %{_builddir}/%{name}-%{version}/build/tizen
364 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
365 popd
366
367 pushd %{buildroot}%{_libdir}
368 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
369 popd
370
371 make clean
372
373 %endif
374
375 #######################################################################
376 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
377 # if tv ||"undefined"
378 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
379
380 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
381            --enable-shaderbincache=DISABLE --enable-profile=TV \
382            --enable-tizen-major-version=%{tizen_version_major} \
383 %if 0%{?tizen_version_major} >= 3
384            --enable-feedback \
385 %endif
386            --enable-videoplayer \
387 %if 0%{?tizen_2_2_compatibility}
388            --with-tizen-2-2-compatibility \
389 %endif
390 %if %{with wayland}
391            --enable-efl=no \
392 %else
393            --enable-efl=yes \
394 %endif
395 %if 0%{?enable_debug}
396            --enable-debug \
397 %endif
398            --enable-appfw=yes \
399            $configure_flags --libdir=%{_libdir}
400
401 # Build.
402 make %{?jobs:-j%jobs}
403
404 pushd %{_builddir}/%{name}-%{version}/build/tizen
405 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
406 popd
407
408 pushd %{buildroot}%{_libdir}
409 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
410 popd
411
412 make clean
413 %endif
414
415 #######################################################################
416 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
417 # if wearable || "undefined"
418 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
419
420 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
421            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
422            --enable-tizen-major-version=%{tizen_version_major} \
423 %if 0%{?tizen_version_major} >= 3
424            --enable-feedback \
425 %endif
426            --enable-videoplayer \
427 %if 0%{?tizen_2_2_compatibility}
428            --with-tizen-2-2-compatibility \
429 %endif
430 %if %{with wayland}
431            --enable-efl=no \
432 %else
433            --enable-efl=yes \
434 %endif
435 %if 0%{?enable_debug}
436            --enable-debug \
437 %endif
438            --enable-appfw=yes \
439            $configure_flags --libdir=%{_libdir}
440
441 # Build.
442 make %{?jobs:-j%jobs}
443
444 pushd %{_builddir}/%{name}-%{version}/build/tizen
445 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
446 popd
447
448 pushd %{buildroot}%{_libdir}
449 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
450 popd
451
452 make clean
453 %endif
454
455 #######################################################################
456 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
457 # if ivi ||"undefined"
458 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
459
460 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
461            --enable-shaderbincache=DISABLE --enable-profile=IVI \
462            --enable-tizen-major-version=%{tizen_version_major} \
463 %if 0%{?tizen_version_major} >= 3
464            --enable-feedback \
465 %endif
466            --enable-videoplayer \
467 %if 0%{?tizen_2_2_compatibility}
468            --with-tizen-2-2-compatibility \
469 %endif
470 %if %{with wayland}
471            --enable-efl=no \
472 %else
473            --enable-efl=yes \
474 %endif
475 %if 0%{?enable_debug}
476            --enable-debug \
477 %endif
478            --enable-appfw=yes \
479            $configure_flags --libdir=%{_libdir}
480
481 # Build.
482 make %{?jobs:-j%jobs}
483
484 pushd %{_builddir}/%{name}-%{version}/build/tizen
485 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
486 popd
487
488 pushd %{buildroot}%{_libdir}
489 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
490 popd
491
492 make clean
493 %endif
494
495 #######################################################################
496 # common ( build dali_videoplayer_plugin for common uses )
497 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
498 # if common ||"undefined"
499 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
500
501 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
502            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
503            --enable-tizen-major-version=%{tizen_version_major} \
504 %if 0%{?tizen_version_major} >= 3
505            --enable-feedback \
506 %endif
507            --enable-videoplayer \
508 %if 0%{?tizen_2_2_compatibility}
509            --with-tizen-2-2-compatibility \
510 %endif
511 %if %{with wayland}
512            --enable-efl=no \
513 %else
514            --enable-efl=yes \
515 %endif
516 %if 0%{?enable_debug}
517            --enable-debug \
518 %endif
519            --enable-appfw=yes \
520            $configure_flags --libdir=%{_libdir}
521
522 # Build.
523 make %{?jobs:-j%jobs}
524
525 %endif
526
527
528 ##############################
529 # Installation
530 ##############################
531 %install
532 rm -rf %{buildroot}
533
534 pushd %{_builddir}/%{name}-%{version}/build/tizen
535 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
536
537
538 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
539 # !unified && (wearable || tv || ivi || mobile)
540 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
541 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
542 %endif
543
544 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
545 # wearable || tv || ivi || mobile || unified
546 %if "%{?profile}" != "common"
547 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
548 %endif
549 popd
550
551 ##############################
552 # Upgrade order:
553 # 1 - Pre Install new package
554 # 2 - Install new package
555 # 3 - Post install new package
556 # 4 - Pre uninstall old package
557 # 5 - Remove files not overwritten by new package
558 # 6 - Post uninstall old package
559 ##############################
560
561 %pre
562 exit 0
563
564 ##############################
565 #  Post Install new package
566 ##############################
567 %post
568 /sbin/ldconfig
569 exit 0
570
571 ##############################
572 #  Pre Uninstall old package
573 ##############################
574 %preun
575 exit 0
576
577 ##############################
578 #  Post Uninstall old package
579 ##############################
580 %postun
581 /sbin/ldconfig
582 exit 0
583
584 %if %{with wayland}
585 %post dali-video-player-plugin
586 /sbin/ldconfig
587 exit 0
588 %endif
589
590 %if %{with wayland}
591 %postun dali-video-player-plugin
592 /sbin/ldconfig
593 exit 0
594 %endif
595
596
597 ##############################
598
599 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
600 # if mobile || "undefined"
601 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
602 %post profile_mobile
603 pushd %{_libdir}
604 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
605 popd
606 /sbin/ldconfig
607 exit 0
608
609 %postun profile_mobile
610 /sbin/ldconfig
611 exit 0
612 %endif
613
614 ##############################
615
616 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
617 # if tv ||"undefined"
618 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
619 %post profile_tv
620 pushd %{_libdir}
621 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
622 popd
623 /sbin/ldconfig
624 exit 0
625
626 %postun profile_tv
627 /sbin/ldconfig
628 exit 0
629 %endif
630
631 ##############################
632
633 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
634 # if wearable || "undefined"
635 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
636 %post profile_wearable
637 pushd %{_libdir}
638 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
639 popd
640 /sbin/ldconfig
641 exit 0
642
643 %postun profile_wearable
644 /sbin/ldconfig
645 exit 0
646 %endif
647
648 ##############################
649
650 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
651 # if ivi ||"undefined"
652 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
653 %post profile_ivi
654 pushd %{_libdir}
655 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
656 popd
657 /sbin/ldconfig
658 exit 0
659
660 %postun profile_ivi
661 /sbin/ldconfig
662 exit 0
663 %endif
664
665
666 ##############################
667 # Files in Binary Packages
668 ##############################
669
670 %files
671 %manifest dali-adaptor.manifest
672 %defattr(-,root,root,-)
673 %defattr(-,app,app,-)
674 %dir %{user_shader_cache_dir}
675 %{_bindir}/*
676 %license LICENSE
677
678 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
679 # if common ||"undefined"
680 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
681 %defattr(-,root,root,-)
682 %{_libdir}/libdali-adap*.so*
683 %exclude %{_libdir}/libdali-adap*.so*.mobile
684 %exclude %{_libdir}/libdali-adap*.so*.wearable
685 %exclude %{_libdir}/libdali-adap*.so*.tv
686 %exclude %{_libdir}/libdali-adap*.so*.ivi
687 %endif
688
689 %if %{with wayland}
690 %files dali-video-player-plugin
691 %manifest dali-adaptor.manifest
692 %defattr(-,root,root,-)
693 %{_libdir}/libdali-video-player-plugin.so*
694 %license LICENSE
695 %endif
696
697 %if 0%{?tizen_version_major} >= 3
698 %files dali-feedback-plugin
699 %manifest dali-adaptor.manifest
700 %defattr(-,root,root,-)
701 %{_libdir}/libdali-feedback-plugin.so*
702 %{dali_plugin_sound_files}/*
703 %endif
704
705 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
706 # if common ||"undefined"
707 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
708 %files profile_common
709 # default .so files are housed in the main pkg.
710 %endif
711
712 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
713 # if mobile || "undefined"
714 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
715 %files profile_mobile
716 %manifest dali-adaptor.manifest
717 %defattr(-,root,root,-)
718 %{_libdir}/libdali-adap*.so*.mobile
719 %endif
720
721 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
722 # if tv ||"undefined"
723 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
724 %files profile_tv
725 %manifest dali-adaptor.manifest
726 %defattr(-,root,root,-)
727 %{_libdir}/libdali-adap*.so*.tv
728 %endif
729
730 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
731 # if wearable || "undefined"
732 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
733 %files profile_wearable
734 %manifest dali-adaptor.manifest
735 %defattr(-,root,root,-)
736 %{_libdir}/libdali-adap*.so*.wearable
737 %endif
738
739 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
740 # if ivi ||"undefined"
741 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
742 %files profile_ivi
743 %manifest dali-adaptor.manifest
744 %defattr(-,root,root,-)
745 %{_libdir}/libdali-adap*.so*.ivi
746 %endif
747
748
749 %files devel
750 %defattr(-,root,root,-)
751 %{dev_include_path}/dali/dali.h
752 %{dev_include_path}/dali/public-api/*
753 %{dev_include_path}/dali/devel-api/*
754 %{dev_include_path}/dali/doc/*
755 %{_libdir}/pkgconfig/dali-adaptor.pc
756
757 %files integration-devel
758 %defattr(-,root,root,-)
759 %{dev_include_path}/dali/integration-api/adaptors/*
760 %{_libdir}/pkgconfig/dali-adaptor-integration.pc