Revert "[Tizen](ATSPI) squashed implementation"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.37
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali-devel
47 BuildRequires:  dali-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  giflib-devel
52 BuildRequires:  pkgconfig(fontconfig)
53 BuildRequires:  libjpeg-turbo-devel
54 BuildRequires:  pkgconfig(vconf)
55 BuildRequires:  tts-devel
56 BuildRequires:  pkgconfig(dlog)
57 BuildRequires:  libdrm-devel
58 BuildRequires:  pkgconfig(libexif)
59 BuildRequires:  pkgconfig(libpng)
60 BuildRequires:  pkgconfig(egl)
61 BuildRequires:  libcurl-devel
62 BuildRequires:  pkgconfig(harfbuzz)
63 BuildRequires:  fribidi-devel
64
65 BuildRequires:  pkgconfig(capi-system-info)
66 BuildRequires:  pkgconfig(capi-system-sensor)
67
68 BuildRequires:  pkgconfig(libcrypto)
69 BuildRequires:  pkgconfig(cairo)
70
71 BuildRequires:  pkgconfig(wayland-egl)
72 BuildRequires:  pkgconfig(wayland-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # dali-adaptor uses ecore mainloop
77 %if 0%{?tizen_version_major} >= 5
78 BuildRequires:  pkgconfig(ecore-wl2)
79 BuildRequires:  pkgconfig(wayland-egl-tizen)
80 %else
81 BuildRequires:  pkgconfig(ecore-wayland)
82 %endif
83
84 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
85 BuildRequires:  pkgconfig(libtbm)
86
87 BuildRequires:  pkgconfig(tpkp-curl)
88
89 # for dali-adaptor
90 BuildRequires:  pkgconfig(appcore-ui)
91 BuildRequires:  pkgconfig(appcore-widget-base)
92 BuildRequires:  pkgconfig(bundle)
93 BuildRequires:  pkgconfig(capi-appfw-app-common)
94 BuildRequires:  pkgconfig(capi-appfw-app-control)
95 BuildRequires:  pkgconfig(ecore-imf)
96
97 BuildRequires:  pkgconfig(capi-system-system-settings)
98
99 # for autofill
100 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
101 BuildRequires:  pkgconfig(capi-ui-autofill)
102 %endif
103
104 # for feedback plugin
105 BuildRequires:  pkgconfig(mm-sound)
106 BuildRequires:  pkgconfig(feedback)
107
108 # for multiprofile
109 Requires:   %{name}-compat = %{version}-%{release}
110 Recommends: %{name}-profile_common = %{version}-%{release}
111
112 %description
113 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
114 platform abstraction and application shell
115
116 ###########################################
117 # Dali adapter for profiles
118 ###########################################
119
120 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
121 # if mobile || "undefined"
122 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
123 %package profile_mobile
124 Summary:        The DALi Tizen Adaptor for mobile
125 Provides:       %{name}-compat = %{version}-%{release}
126 Conflicts:      %{name}-profile_tv
127 Conflicts:      %{name}-profile_wearable
128 Conflicts:      %{name}-profile_ivi
129 Conflicts:      %{name}-profile_common
130 %description profile_mobile
131 The DALi Tizen Adaptor for mobile.
132 %endif
133
134 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
135 # if tv ||"undefined"
136 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
137 %package profile_tv
138 Summary:        The DALi Tizen Adaptor for tv
139 Provides:       %{name}-compat = %{version}-%{release}
140 Conflicts:      %{name}-profile_mobile
141 Conflicts:      %{name}-profile_wearable
142 Conflicts:      %{name}-profile_ivi
143 Conflicts:      %{name}-profile_common
144 %description profile_tv
145 The DALi Tizen Adaptor for tv.
146 %endif
147
148 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
149 # if wearable || "undefined"
150 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
151 %package profile_wearable
152 Summary:        The DALi Tizen Adaptor for wearable
153 Provides:       %{name}-compat = %{version}-%{release}
154 Conflicts:      %{name}-profile_mobile
155 Conflicts:      %{name}-profile_tv
156 Conflicts:      %{name}-profile_ivi
157 Conflicts:      %{name}-profile_common
158 %description profile_wearable
159 The DALi Tizen Adaptor for wearable.
160 %endif
161
162 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
163 # if ivi ||"undefined"
164 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
165 %package profile_ivi
166 Summary:        The DALi Tizen Adaptor for ivi
167 Provides:       %{name}-compat = %{version}-%{release}
168 Conflicts:      %{name}-profile_mobile
169 Conflicts:      %{name}-profile_wearable
170 Conflicts:      %{name}-profile_tv
171 Conflicts:      %{name}-profile_common
172 %description profile_ivi
173 The DALi Tizen Adaptor for ivi.
174 %endif
175
176 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
177 # if common ||"undefined"
178 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
179 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
180 %package profile_common
181 Summary:        The DALi Tizen Adaptor for common
182 Provides:       %{name}-compat = %{version}-%{release}
183 Conflicts:      %{name}-profile_mobile
184 Conflicts:      %{name}-profile_wearable
185 Conflicts:      %{name}-profile_tv
186 Conflicts:      %{name}-profile_ivi
187 %description profile_common
188 The DALi Tizen Adaptor for common.
189 %endif
190
191 ##############################
192 # devel
193 ##############################
194 %package devel
195 Summary:    Development components for the DALi Tizen Adaptor
196 Group:      Development/Building
197 Requires:   %{name} = %{version}-%{release}
198 Requires:   %{name}-integration-devel = %{version}-%{release}
199
200 %description devel
201 Development components for the DALi Tizen Adaptor - public headers and package configs
202
203 ##############################
204 # integration-devel
205 ##############################
206 %package integration-devel
207 Summary:    Integration development package for the Adaptor
208 Group:      Development/Building
209 Requires:   %{name} = %{version}-%{release}
210
211 %description integration-devel
212 Integration development package for the Adaptor - headers for integrating with an adaptor library.
213
214 ##############################
215 # Dali Feedback Plugin
216 ##############################
217 %package dali-feedback-plugin
218 Summary:    Plugin to play haptic and audio feedback for Dali
219 Group:      System/Libraries
220 Requires:   %{name} = %{version}-%{release}
221 %description dali-feedback-plugin
222 Feedback plugin to play haptic and audio feedback for Dali
223
224 ##############################
225 # Preparation
226 ##############################
227 %prep
228 %setup -q
229
230 #Use TZ_PATH when tizen version is 3.x or greater
231
232 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
233 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
234 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
235 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
236 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
237 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
238
239 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
240 %define dali_plugin_sound_files  /plugins/sounds/
241 %define dev_include_path %{_includedir}
242
243 ##############################
244 # Build
245 ##############################
246 %build
247 PREFIX+="/usr"
248 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
249 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
250
251 %ifarch %{arm}
252 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
253 %endif
254
255 CFLAGS+=" -DWAYLAND"
256 CXXFLAGS+=" -DWAYLAND"
257 configure_flags="--enable-wayland"
258
259 # Use this conditional when Tizen version is 5.x or greater
260 %if 0%{?tizen_version_major} >= 5
261 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
262
263 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
264 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
265 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
266 configure_flags+=" --enable-ecore-wayland2"
267 %endif
268
269 libtoolize --force
270 cd %{_builddir}/%{name}-%{version}/build/tizen
271 autoreconf --install
272
273 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
274 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
275 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
276 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
277 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
278 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
279 %if 0%{?tizen_platform_config_supported}
280 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
281 %endif
282
283 # Set up the build via configure.
284 #######################################################################
285 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
286 # if mobile || "undefined"
287 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
288 %configure --prefix=$PREFIX --with-jpeg-turbo \
289            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
290            --enable-tizen-major-version=%{tizen_version_major} \
291            --enable-tizen-minor-version=%{tizen_version_minor} \
292            --enable-feedback \
293            --enable-efl=no \
294 %if 0%{?enable_debug}
295            --enable-debug \
296 %endif
297 %if 0%{?enable_trace}
298            --enable-trace \
299 %endif
300            --enable-appfw=yes \
301            $configure_flags --libdir=%{_libdir} \
302            --enable-rename-so=no
303
304 # Build.
305 make %{?jobs:-j%jobs}
306
307 pushd %{_builddir}/%{name}-%{version}/build/tizen
308 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
309 popd
310
311 pushd %{buildroot}%{_libdir}
312 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
313 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
314 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
315 popd
316
317 make clean
318
319 %endif
320
321 #######################################################################
322 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
323 # if tv ||"undefined"
324 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
325 %configure --prefix=$PREFIX --with-jpeg-turbo \
326            --enable-shaderbincache=DISABLE --enable-profile=TV \
327            --enable-tizen-major-version=%{tizen_version_major} \
328            --enable-tizen-minor-version=%{tizen_version_minor} \
329            --enable-feedback \
330            --enable-efl=no \
331 %if 0%{?enable_debug}
332            --enable-debug \
333 %endif
334 %if 0%{?enable_trace}
335            --enable-trace \
336 %endif
337            --enable-appfw=yes \
338            $configure_flags --libdir=%{_libdir} \
339            --enable-rename-so=no
340
341 # Build.
342 make %{?jobs:-j%jobs}
343
344 pushd %{_builddir}/%{name}-%{version}/build/tizen
345 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
346 popd
347
348 pushd %{buildroot}%{_libdir}
349 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
350 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
351 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
352 popd
353
354 make clean
355 %endif
356
357 #######################################################################
358 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
359 # if wearable || "undefined"
360 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
361 %configure --prefix=$PREFIX --with-jpeg-turbo \
362            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
363            --enable-tizen-major-version=%{tizen_version_major} \
364            --enable-tizen-minor-version=%{tizen_version_minor} \
365            --enable-feedback \
366            --enable-efl=no \
367 %if 0%{?enable_debug}
368            --enable-debug \
369 %endif
370 %if 0%{?enable_trace}
371            --enable-trace \
372 %endif
373            --enable-appfw=yes \
374            $configure_flags --libdir=%{_libdir} \
375            --enable-rename-so=no
376
377 # Build.
378 make %{?jobs:-j%jobs}
379
380 pushd %{_builddir}/%{name}-%{version}/build/tizen
381 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
382 popd
383
384 pushd %{buildroot}%{_libdir}
385 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
386 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
387 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
388 popd
389
390 make clean
391 %endif
392
393 #######################################################################
394 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
395 # if ivi ||"undefined"
396 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
397 %configure --prefix=$PREFIX --with-jpeg-turbo \
398            --enable-shaderbincache=DISABLE --enable-profile=IVI \
399            --enable-tizen-major-version=%{tizen_version_major} \
400            --enable-tizen-minor-version=%{tizen_version_minor} \
401            --enable-feedback \
402            --enable-efl=no \
403 %if 0%{?enable_debug}
404            --enable-debug \
405 %endif
406 %if 0%{?enable_trace}
407            --enable-trace \
408 %endif
409            --enable-appfw=yes \
410            $configure_flags --libdir=%{_libdir} \
411            --enable-rename-so=no
412
413 # Build.
414 make %{?jobs:-j%jobs}
415
416 pushd %{_builddir}/%{name}-%{version}/build/tizen
417 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
418 popd
419
420 pushd %{buildroot}%{_libdir}
421 for FILE in libdali-adaptor*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
422 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
423
424 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
425 popd
426
427 make clean
428 %endif
429
430 #######################################################################
431 # common
432 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
433 # if common ||"undefined"
434 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
435 %configure --prefix=$PREFIX --with-jpeg-turbo \
436            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
437            --enable-tizen-major-version=%{tizen_version_major} \
438            --enable-tizen-minor-version=%{tizen_version_minor} \
439            --enable-feedback \
440            --enable-efl=no \
441 %if 0%{?enable_debug}
442            --enable-debug \
443 %endif
444 %if 0%{?enable_trace}
445            --enable-trace \
446 %endif
447            --enable-appfw=yes \
448            $configure_flags --libdir=%{_libdir} \
449            --enable-rename-so=no
450
451 # Build.
452 make %{?jobs:-j%jobs}
453
454 pushd %{_builddir}/%{name}-%{version}/build/tizen
455 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
456 popd
457
458 pushd %{buildroot}%{_libdir}
459 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
460 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
461
462 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
463 popd
464
465 make clean
466
467 %endif
468
469 ##############################
470 # Installation
471 ##############################
472 %install
473 rm -rf %{buildroot}
474
475 pushd %{_builddir}/%{name}-%{version}/build/tizen
476 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
477
478
479 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
480 # !unified && (wearable || tv || ivi || mobile)
481 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
482 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
483 %endif
484
485 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
486 # wearable || tv || ivi || mobile || unified
487 %if "%{?profile}" != "common"
488 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
489 mv dali-adaptor*.pc %{buildroot}%{_libdir}/pkgconfig/
490 %endif
491 popd
492
493 ################################################
494 #rename
495 ###############################################
496 pushd %{buildroot}%{_libdir}
497
498 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
499 # if common ||"undefined"
500 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
501 rm -rf libdali-adaptor*.so
502 ln -s libdali-adaptor-cxx11.so.0.0.0 libdali-adaptor.so
503 #%endif
504
505 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
506 # if wearable || "undefined"
507 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
508 rm -rf libdali-adaptor*.so.wearable
509 ln -s libdali-adaptor-cxx11.so.0.0.*.wearable libdali-adaptor.so.wearable
510 %endif
511
512 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
513 # if tv ||"undefined"
514 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
515 rm -rf libdali-adaptor*.so.tv
516 ln -s libdali-adaptor-cxx11.so.0.0.*.tv libdali-adaptor.so.tv
517 %endif
518
519 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
520 # if ivi ||"undefined"
521 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
522 rm -rf libdali-adaptor*.so.ivi
523 ln -s libdali-adaptor-cxx11.so.0.0.*.ivi libdali-adaptor.so.ivi
524 %endif
525
526 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
527 # if mobile || "undefined"
528 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
529 rm -rf libdali-adaptor*.so.mobile
530 ln -s libdali-adaptor-cxx11.so.0.0.*.mobile libdali-adaptor.so.mobile
531 %endif
532 popd
533
534 ##############################
535 # Upgrade order:
536 # 1 - Pre Install new package
537 # 2 - Install new package
538 # 3 - Post install new package
539 # 4 - Pre uninstall old package
540 # 5 - Remove files not overwritten by new package
541 # 6 - Post uninstall old package
542 ##############################
543
544 %pre
545 exit 0
546
547 ##############################
548 #  Post Install new package
549 ##############################
550 %post
551 /sbin/ldconfig
552 exit 0
553
554 ##############################
555 #  Pre Uninstall old package
556 ##############################
557 %preun
558 exit 0
559
560 ##############################
561 #  Post Uninstall old package
562 ##############################
563 %postun
564 /sbin/ldconfig
565 exit 0
566
567 ##############################
568
569 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
570 # if mobile || "undefined"
571 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
572 %post profile_mobile
573 pushd %{_libdir}
574 for FILE in libdali-adaptor-cxx11.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
575 popd
576 /sbin/ldconfig
577 exit 0
578
579 %postun profile_mobile
580 /sbin/ldconfig
581 exit 0
582 %endif
583
584 ##############################
585
586 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
587 # if tv ||"undefined"
588 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
589 %post profile_tv
590 pushd %{_libdir}
591 for FILE in libdali-adaptor-cxx11.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
592 popd
593 /sbin/ldconfig
594 exit 0
595
596 %postun profile_tv
597 /sbin/ldconfig
598 exit 0
599 %endif
600
601 ##############################
602
603 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
604 # if wearable || "undefined"
605 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
606 %post profile_wearable
607 pushd %{_libdir}
608 for FILE in libdali-adaptor-cxx11.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
609 popd
610 /sbin/ldconfig
611 exit 0
612
613 %postun profile_wearable
614 /sbin/ldconfig
615 exit 0
616 %endif
617
618 ##############################
619
620 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
621 # if ivi ||"undefined"
622 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
623 %post profile_ivi
624 pushd %{_libdir}
625 for FILE in libdali-adaptor-cxx11.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
626 popd
627 /sbin/ldconfig
628 exit 0
629
630 %postun profile_ivi
631 /sbin/ldconfig
632 exit 0
633 %endif
634
635 ##############################
636 # Files in Binary Packages
637 ##############################
638
639 %files
640 %manifest dali-adaptor.manifest
641 %defattr(-,root,root,-)
642 %dir %{user_shader_cache_dir}
643 %{_bindir}/*
644 %license LICENSE
645
646 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
647 # if common ||"undefined"
648 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
649 %defattr(-,root,root,-)
650 %{_libdir}/libdali-adaptor-cxx11.so.0*
651 %{_libdir}/libdali-adaptor.so
652 %exclude %{_libdir}/libdali-adap*.so*.mobile
653 %exclude %{_libdir}/libdali-adap*.so*.wearable
654 %exclude %{_libdir}/libdali-adap*.so*.tv
655 %exclude %{_libdir}/libdali-adap*.so*.ivi
656 #%endif
657
658 #################################################
659
660 %files dali-feedback-plugin
661 %manifest dali-adaptor.manifest
662 %defattr(-,root,root,-)
663 %{_libdir}/libdali-feedback-plugin-cxx11.so*
664 %{dali_plugin_sound_files}/*
665
666 #################################################
667
668 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
669 # if common ||"undefined"
670 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
671 %files profile_common
672 # default .so files are housed in the main pkg.
673 %endif
674
675 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
676 # if mobile || "undefined"
677 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
678 %files profile_mobile
679 %manifest dali-adaptor.manifest
680 %defattr(-,root,root,-)
681 %{_libdir}/libdali-adaptor.so.mobile
682 %{_libdir}/libdali-adaptor-cxx11.so.0*.mobile
683 %endif
684
685 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
686 # if tv ||"undefined"
687 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
688 %files profile_tv
689 %manifest dali-adaptor.manifest
690 %defattr(-,root,root,-)
691 %{_libdir}/libdali-adaptor.so.tv
692 %{_libdir}/libdali-adaptor-cxx11.so.0*.tv
693 %endif
694
695 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
696 # if wearable || "undefined"
697 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
698 %files profile_wearable
699 %manifest dali-adaptor.manifest
700 %defattr(-,root,root,-)
701 %{_libdir}/libdali-adaptor.so.wearable
702 %{_libdir}/libdali-adaptor-cxx11.so.0*.wearable
703 %endif
704
705 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
706 # if ivi ||"undefined"
707 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
708 %files profile_ivi
709 %manifest dali-adaptor.manifest
710 %defattr(-,root,root,-)
711 %{_libdir}/libdali-adaptor.so.ivi
712 %{_libdir}/libdali-adaptor-cxx11.so.0*.ivi
713 %endif
714
715
716 %files devel
717 %defattr(-,root,root,-)
718 %{dev_include_path}/dali/dali.h
719 %{dev_include_path}/dali/public-api/*
720 %{dev_include_path}/dali/devel-api/*
721 %{dev_include_path}/dali/doc/*
722 %{_libdir}/pkgconfig/dali-adaptor.pc
723
724 %files integration-devel
725 %defattr(-,root,root,-)
726 %{dev_include_path}/dali/integration-api/adaptors/*
727 %{_libdir}/pkgconfig/dali-adaptor-integration.pc
728