DALi Version 1.4.25
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.4.25
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali-devel
47 BuildRequires:  dali-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  giflib-devel
52 BuildRequires:  pkgconfig(fontconfig)
53 BuildRequires:  libjpeg-turbo-devel
54 BuildRequires:  pkgconfig(vconf)
55 BuildRequires:  tts-devel
56 BuildRequires:  pkgconfig(dlog)
57 BuildRequires:  libdrm-devel
58 BuildRequires:  pkgconfig(libexif)
59 BuildRequires:  pkgconfig(libpng)
60 BuildRequires:  pkgconfig(egl)
61 BuildRequires:  libcurl-devel
62 BuildRequires:  pkgconfig(harfbuzz)
63 BuildRequires:  fribidi-devel
64
65 BuildRequires:  pkgconfig(capi-system-info)
66 BuildRequires:  pkgconfig(capi-system-sensor)
67
68 BuildRequires:  pkgconfig(libcrypto)
69 BuildRequires:  pkgconfig(cairo)
70
71 BuildRequires:  pkgconfig(wayland-egl)
72 BuildRequires:  pkgconfig(wayland-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # dali-adaptor uses ecore mainloop
77 %if 0%{?tizen_version_major} >= 5
78 BuildRequires:  pkgconfig(ecore-wl2)
79 BuildRequires:  pkgconfig(wayland-egl-tizen)
80 %else
81 BuildRequires:  pkgconfig(ecore-wayland)
82 %endif
83
84 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
85 BuildRequires:  pkgconfig(libtbm)
86
87 BuildRequires:  pkgconfig(tpkp-curl)
88
89 # for dali-adaptor
90 BuildRequires:  pkgconfig(appcore-ui)
91 BuildRequires:  pkgconfig(appcore-widget-base)
92 BuildRequires:  pkgconfig(bundle)
93 BuildRequires:  pkgconfig(capi-appfw-app-common)
94 BuildRequires:  pkgconfig(capi-appfw-app-control)
95 BuildRequires:  pkgconfig(ecore-imf)
96
97 BuildRequires:  pkgconfig(capi-system-system-settings)
98
99 # for feedback plugin
100 BuildRequires:  pkgconfig(mm-sound)
101 BuildRequires:  pkgconfig(feedback)
102
103 # for multiprofile
104 Requires:   %{name}-compat = %{version}-%{release}
105 Recommends: %{name}-profile_common = %{version}-%{release}
106
107 %description
108 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
109 platform abstraction and application shell
110
111 ###########################################
112 # Dali adapter for profiles
113 ###########################################
114
115 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
116 # if mobile || "undefined"
117 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
118 %package profile_mobile
119 Summary:        The DALi Tizen Adaptor for mobile
120 Provides:       %{name}-compat = %{version}-%{release}
121 Conflicts:      %{name}-profile_tv
122 Conflicts:      %{name}-profile_wearable
123 Conflicts:      %{name}-profile_ivi
124 Conflicts:      %{name}-profile_common
125 %description profile_mobile
126 The DALi Tizen Adaptor for mobile.
127 %endif
128
129 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
130 # if tv ||"undefined"
131 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
132 %package profile_tv
133 Summary:        The DALi Tizen Adaptor for tv
134 Provides:       %{name}-compat = %{version}-%{release}
135 Conflicts:      %{name}-profile_mobile
136 Conflicts:      %{name}-profile_wearable
137 Conflicts:      %{name}-profile_ivi
138 Conflicts:      %{name}-profile_common
139 %description profile_tv
140 The DALi Tizen Adaptor for tv.
141 %endif
142
143 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
144 # if wearable || "undefined"
145 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
146 %package profile_wearable
147 Summary:        The DALi Tizen Adaptor for wearable
148 Provides:       %{name}-compat = %{version}-%{release}
149 Conflicts:      %{name}-profile_mobile
150 Conflicts:      %{name}-profile_tv
151 Conflicts:      %{name}-profile_ivi
152 Conflicts:      %{name}-profile_common
153 %description profile_wearable
154 The DALi Tizen Adaptor for wearable.
155 %endif
156
157 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
158 # if ivi ||"undefined"
159 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
160 %package profile_ivi
161 Summary:        The DALi Tizen Adaptor for ivi
162 Provides:       %{name}-compat = %{version}-%{release}
163 Conflicts:      %{name}-profile_mobile
164 Conflicts:      %{name}-profile_wearable
165 Conflicts:      %{name}-profile_tv
166 Conflicts:      %{name}-profile_common
167 %description profile_ivi
168 The DALi Tizen Adaptor for ivi.
169 %endif
170
171 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
172 # if common ||"undefined"
173 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
174 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
175 %package profile_common
176 Summary:        The DALi Tizen Adaptor for common
177 Provides:       %{name}-compat = %{version}-%{release}
178 Conflicts:      %{name}-profile_mobile
179 Conflicts:      %{name}-profile_wearable
180 Conflicts:      %{name}-profile_tv
181 Conflicts:      %{name}-profile_ivi
182 %description profile_common
183 The DALi Tizen Adaptor for common.
184 %endif
185
186 ##############################
187 # devel
188 ##############################
189 %package devel
190 Summary:    Development components for the DALi Tizen Adaptor
191 Group:      Development/Building
192 Requires:   %{name} = %{version}-%{release}
193 Requires:   %{name}-integration-devel = %{version}-%{release}
194
195 %description devel
196 Development components for the DALi Tizen Adaptor - public headers and package configs
197
198 ##############################
199 # integration-devel
200 ##############################
201 %package integration-devel
202 Summary:    Integration development package for the Adaptor
203 Group:      Development/Building
204 Requires:   %{name} = %{version}-%{release}
205
206 %description integration-devel
207 Integration development package for the Adaptor - headers for integrating with an adaptor library.
208
209 ##############################
210 # Dali Feedback Plugin
211 ##############################
212 %package dali-feedback-plugin
213 Summary:    Plugin to play haptic and audio feedback for Dali
214 Group:      System/Libraries
215 Requires:   %{name} = %{version}-%{release}
216 %description dali-feedback-plugin
217 Feedback plugin to play haptic and audio feedback for Dali
218
219 ##############################
220 # Preparation
221 ##############################
222 %prep
223 %setup -q
224
225 #Use TZ_PATH when tizen version is 3.x or greater
226
227 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
228 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
229 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
230 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
231 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
232 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
233
234 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
235 %define dali_plugin_sound_files  /plugins/sounds/
236 %define dev_include_path %{_includedir}
237
238 ##############################
239 # Build
240 ##############################
241 %build
242 PREFIX+="/usr"
243 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
244 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
245
246 %ifarch %{arm}
247 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
248 %endif
249
250 CFLAGS+=" -DWAYLAND"
251 CXXFLAGS+=" -DWAYLAND"
252 configure_flags="--enable-wayland"
253
254 # Use this conditional when Tizen version is 5.x or greater
255 %if 0%{?tizen_version_major} >= 5
256 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
257
258 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
259 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
260 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
261 configure_flags+=" --enable-ecore-wayland2"
262 %endif
263
264 libtoolize --force
265 cd %{_builddir}/%{name}-%{version}/build/tizen
266 autoreconf --install
267
268 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
269 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
270 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
271 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
272 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
273 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
274 %if 0%{?tizen_platform_config_supported}
275 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
276 %endif
277
278 # Set up the build via configure.
279 #######################################################################
280 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
281 # if mobile || "undefined"
282 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
283 %configure --prefix=$PREFIX --with-jpeg-turbo \
284            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
285            --enable-tizen-major-version=%{tizen_version_major} \
286            --enable-feedback \
287            --enable-efl=no \
288 %if 0%{?enable_debug}
289            --enable-debug \
290 %endif
291 %if 0%{?enable_trace}
292            --enable-trace \
293 %endif
294            --enable-appfw=yes \
295            $configure_flags --libdir=%{_libdir} \
296            --enable-rename-so=no
297
298 # Build.
299 make %{?jobs:-j%jobs}
300
301 pushd %{_builddir}/%{name}-%{version}/build/tizen
302 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
303 popd
304
305 pushd %{buildroot}%{_libdir}
306 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
307 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
308 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
309 popd
310
311 make clean
312
313 %endif
314
315 #######################################################################
316 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
317 # if tv ||"undefined"
318 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
319 %configure --prefix=$PREFIX --with-jpeg-turbo \
320            --enable-shaderbincache=DISABLE --enable-profile=TV \
321            --enable-tizen-major-version=%{tizen_version_major} \
322            --enable-feedback \
323            --enable-efl=no \
324 %if 0%{?enable_debug}
325            --enable-debug \
326 %endif
327 %if 0%{?enable_trace}
328            --enable-trace \
329 %endif
330            --enable-appfw=yes \
331            $configure_flags --libdir=%{_libdir} \
332            --enable-rename-so=no
333
334 # Build.
335 make %{?jobs:-j%jobs}
336
337 pushd %{_builddir}/%{name}-%{version}/build/tizen
338 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
339 popd
340
341 pushd %{buildroot}%{_libdir}
342 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
343 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
344 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
345 popd
346
347 make clean
348 %endif
349
350 #######################################################################
351 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
352 # if wearable || "undefined"
353 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
354 %configure --prefix=$PREFIX --with-jpeg-turbo \
355            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
356            --enable-tizen-major-version=%{tizen_version_major} \
357            --enable-feedback \
358            --enable-efl=no \
359 %if 0%{?enable_debug}
360            --enable-debug \
361 %endif
362 %if 0%{?enable_trace}
363            --enable-trace \
364 %endif
365            --enable-appfw=yes \
366            $configure_flags --libdir=%{_libdir} \
367            --enable-rename-so=no
368
369 # Build.
370 make %{?jobs:-j%jobs}
371
372 pushd %{_builddir}/%{name}-%{version}/build/tizen
373 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
374 popd
375
376 pushd %{buildroot}%{_libdir}
377 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
378 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
379 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
380 popd
381
382 make clean
383 %endif
384
385 #######################################################################
386 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
387 # if ivi ||"undefined"
388 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
389 %configure --prefix=$PREFIX --with-jpeg-turbo \
390            --enable-shaderbincache=DISABLE --enable-profile=IVI \
391            --enable-tizen-major-version=%{tizen_version_major} \
392            --enable-feedback \
393            --enable-efl=no \
394 %if 0%{?enable_debug}
395            --enable-debug \
396 %endif
397 %if 0%{?enable_trace}
398            --enable-trace \
399 %endif
400            --enable-appfw=yes \
401            $configure_flags --libdir=%{_libdir} \
402            --enable-rename-so=no
403
404 # Build.
405 make %{?jobs:-j%jobs}
406
407 pushd %{_builddir}/%{name}-%{version}/build/tizen
408 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
409 popd
410
411 pushd %{buildroot}%{_libdir}
412 for FILE in libdali-adaptor*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
413 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
414
415 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
416 popd
417
418 make clean
419 %endif
420
421 #######################################################################
422 # common
423 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
424 # if common ||"undefined"
425 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
426 %configure --prefix=$PREFIX --with-jpeg-turbo \
427            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
428            --enable-tizen-major-version=%{tizen_version_major} \
429            --enable-feedback \
430            --enable-efl=no \
431 %if 0%{?enable_debug}
432            --enable-debug \
433 %endif
434 %if 0%{?enable_trace}
435            --enable-trace \
436 %endif
437            --enable-appfw=yes \
438            $configure_flags --libdir=%{_libdir} \
439            --enable-rename-so=no
440
441 # Build.
442 make %{?jobs:-j%jobs}
443
444 pushd %{_builddir}/%{name}-%{version}/build/tizen
445 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
446 popd
447
448 pushd %{buildroot}%{_libdir}
449 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
450 for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
451
452 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
453 popd
454
455 make clean
456
457 %endif
458
459 ##############################
460 # Installation
461 ##############################
462 %install
463 rm -rf %{buildroot}
464
465 pushd %{_builddir}/%{name}-%{version}/build/tizen
466 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
467
468
469 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
470 # !unified && (wearable || tv || ivi || mobile)
471 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
472 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
473 %endif
474
475 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
476 # wearable || tv || ivi || mobile || unified
477 %if "%{?profile}" != "common"
478 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
479 mv dali-adaptor*.pc %{buildroot}%{_libdir}/pkgconfig/
480 %endif
481 popd
482
483 ################################################
484 #rename
485 ###############################################
486 pushd %{buildroot}%{_libdir}
487
488 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
489 # if common ||"undefined"
490 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
491 rm -rf libdali-adaptor*.so
492 ln -s libdali-adaptor-cxx11.so.0.0.0 libdali-adaptor.so
493 #%endif
494
495 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
496 # if wearable || "undefined"
497 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
498 rm -rf libdali-adaptor*.so.wearable
499 ln -s libdali-adaptor-cxx11.so.0.0.*.wearable libdali-adaptor.so.wearable
500 %endif
501
502 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
503 # if tv ||"undefined"
504 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
505 rm -rf libdali-adaptor*.so.tv
506 ln -s libdali-adaptor-cxx11.so.0.0.*.tv libdali-adaptor.so.tv
507 %endif
508
509 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
510 # if ivi ||"undefined"
511 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
512 rm -rf libdali-adaptor*.so.ivi
513 ln -s libdali-adaptor-cxx11.so.0.0.*.ivi libdali-adaptor.so.ivi
514 %endif
515
516 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
517 # if mobile || "undefined"
518 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
519 rm -rf libdali-adaptor*.so.mobile
520 ln -s libdali-adaptor-cxx11.so.0.0.*.mobile libdali-adaptor.so.mobile
521 %endif
522 popd
523
524 ##############################
525 # Upgrade order:
526 # 1 - Pre Install new package
527 # 2 - Install new package
528 # 3 - Post install new package
529 # 4 - Pre uninstall old package
530 # 5 - Remove files not overwritten by new package
531 # 6 - Post uninstall old package
532 ##############################
533
534 %pre
535 exit 0
536
537 ##############################
538 #  Post Install new package
539 ##############################
540 %post
541 /sbin/ldconfig
542 exit 0
543
544 ##############################
545 #  Pre Uninstall old package
546 ##############################
547 %preun
548 exit 0
549
550 ##############################
551 #  Post Uninstall old package
552 ##############################
553 %postun
554 /sbin/ldconfig
555 exit 0
556
557 ##############################
558
559 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
560 # if mobile || "undefined"
561 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
562 %post profile_mobile
563 pushd %{_libdir}
564 for FILE in libdali-adaptor-cxx11.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
565 popd
566 /sbin/ldconfig
567 exit 0
568
569 %postun profile_mobile
570 /sbin/ldconfig
571 exit 0
572 %endif
573
574 ##############################
575
576 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
577 # if tv ||"undefined"
578 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
579 %post profile_tv
580 pushd %{_libdir}
581 for FILE in libdali-adaptor-cxx11.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
582 popd
583 /sbin/ldconfig
584 exit 0
585
586 %postun profile_tv
587 /sbin/ldconfig
588 exit 0
589 %endif
590
591 ##############################
592
593 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
594 # if wearable || "undefined"
595 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
596 %post profile_wearable
597 pushd %{_libdir}
598 for FILE in libdali-adaptor-cxx11.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
599 popd
600 /sbin/ldconfig
601 exit 0
602
603 %postun profile_wearable
604 /sbin/ldconfig
605 exit 0
606 %endif
607
608 ##############################
609
610 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
611 # if ivi ||"undefined"
612 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
613 %post profile_ivi
614 pushd %{_libdir}
615 for FILE in libdali-adaptor-cxx11.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
616 popd
617 /sbin/ldconfig
618 exit 0
619
620 %postun profile_ivi
621 /sbin/ldconfig
622 exit 0
623 %endif
624
625 ##############################
626 # Files in Binary Packages
627 ##############################
628
629 %files
630 %manifest dali-adaptor.manifest
631 %defattr(-,root,root,-)
632 %dir %{user_shader_cache_dir}
633 %{_bindir}/*
634 %license LICENSE
635
636 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
637 # if common ||"undefined"
638 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
639 %defattr(-,root,root,-)
640 %{_libdir}/libdali-adaptor-cxx11.so.0*
641 %{_libdir}/libdali-adaptor.so
642 %exclude %{_libdir}/libdali-adap*.so*.mobile
643 %exclude %{_libdir}/libdali-adap*.so*.wearable
644 %exclude %{_libdir}/libdali-adap*.so*.tv
645 %exclude %{_libdir}/libdali-adap*.so*.ivi
646 #%endif
647
648 #################################################
649
650 %files dali-feedback-plugin
651 %manifest dali-adaptor.manifest
652 %defattr(-,root,root,-)
653 %{_libdir}/libdali-feedback-plugin-cxx11.so*
654 %{dali_plugin_sound_files}/*
655
656 #################################################
657
658 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
659 # if common ||"undefined"
660 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
661 %files profile_common
662 # default .so files are housed in the main pkg.
663 %endif
664
665 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
666 # if mobile || "undefined"
667 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
668 %files profile_mobile
669 %manifest dali-adaptor.manifest
670 %defattr(-,root,root,-)
671 %{_libdir}/libdali-adaptor.so.mobile
672 %{_libdir}/libdali-adaptor-cxx11.so.0*.mobile
673 %endif
674
675 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
676 # if tv ||"undefined"
677 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
678 %files profile_tv
679 %manifest dali-adaptor.manifest
680 %defattr(-,root,root,-)
681 %{_libdir}/libdali-adaptor.so.tv
682 %{_libdir}/libdali-adaptor-cxx11.so.0*.tv
683 %endif
684
685 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
686 # if wearable || "undefined"
687 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
688 %files profile_wearable
689 %manifest dali-adaptor.manifest
690 %defattr(-,root,root,-)
691 %{_libdir}/libdali-adaptor.so.wearable
692 %{_libdir}/libdali-adaptor-cxx11.so.0*.wearable
693 %endif
694
695 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
696 # if ivi ||"undefined"
697 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
698 %files profile_ivi
699 %manifest dali-adaptor.manifest
700 %defattr(-,root,root,-)
701 %{_libdir}/libdali-adaptor.so.ivi
702 %{_libdir}/libdali-adaptor-cxx11.so.0*.ivi
703 %endif
704
705
706 %files devel
707 %defattr(-,root,root,-)
708 %{dev_include_path}/dali/dali.h
709 %{dev_include_path}/dali/public-api/*
710 %{dev_include_path}/dali/devel-api/*
711 %{dev_include_path}/dali/doc/*
712 %{_libdir}/pkgconfig/dali-adaptor.pc
713
714 %files integration-devel
715 %defattr(-,root,root,-)
716 %{dev_include_path}/dali/integration-api/adaptors/*
717 %{_libdir}/pkgconfig/dali-adaptor-integration.pc
718