Revert "[Tizen] Added layout direction change by system language"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 %bcond_with wayland
19
20 Name:       dali-adaptor
21 Summary:    The DALi Tizen Adaptor
22 Version:    1.2.54
23 Release:    1
24 Group:      System/Libraries
25 License:    Apache-2.0 and BSD-3-Clause and MIT
26 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
27 Source0:    %{name}-%{version}.tar.gz
28
29 Requires(post): /sbin/ldconfig
30 Requires(postun): /sbin/ldconfig
31 Requires:       giflib
32
33 #need libtzplatform-config for directory if tizen version is 3.x
34
35 %if 0%{?tizen_version_major} >= 3
36 %define tizen_platform_config_supported 1
37 BuildRequires:  pkgconfig(libtzplatform-config)
38 %endif
39
40 # Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
41
42 %if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
43 %define profile %{tizen_profile_name}
44 %endif
45
46 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
47 # if wearable || "undefined"
48 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
49 BuildRequires:  pkgconfig(capi-appfw-watch-application)
50 BuildRequires:  pkgconfig(appcore-watch)
51 BuildRequires:  pkgconfig(screen_connector_provider)
52 %endif
53
54 BuildRequires:  pkgconfig(gles20)
55 BuildRequires:  pkgconfig(glesv2)
56
57 BuildRequires:  pkgconfig
58 BuildRequires:  gawk
59 BuildRequires:  giflib-devel
60 BuildRequires:  pkgconfig(fontconfig)
61 BuildRequires:  libjpeg-turbo-devel
62 BuildRequires:  dali-devel
63 BuildRequires:  dali-integration-devel
64 BuildRequires:  pkgconfig(vconf)
65 BuildRequires:  tts-devel
66 BuildRequires:  pkgconfig(dlog)
67 BuildRequires:  libdrm-devel
68 BuildRequires:  pkgconfig(libexif)
69 BuildRequires:  pkgconfig(libpng)
70 BuildRequires:  pkgconfig(egl)
71 BuildRequires:  libcurl-devel
72 BuildRequires:  pkgconfig(harfbuzz)
73 BuildRequires:  fribidi-devel
74
75 BuildRequires:  pkgconfig(capi-system-info)
76 BuildRequires:  pkgconfig(capi-system-sensor)
77
78 %if %{with wayland}
79
80 ####### BUILDING FOR WAYLAND #######
81 BuildRequires:  pkgconfig(wayland-egl)
82 BuildRequires:  pkgconfig(wayland-client)
83 BuildRequires:  wayland-devel
84 BuildRequires:  wayland-extension-client-devel
85
86 # dali-adaptor uses ecore mainloop
87 BuildRequires:  pkgconfig(ecore-wayland)
88
89 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
90 BuildRequires:  pkgconfig(libtbm)
91
92 # tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
93 BuildRequires:  pkgconfig(tpkp-curl)
94
95 ####### BUILDING FOR X11#######
96 %else
97 BuildRequires:  pkgconfig(egl)
98 BuildRequires:  pkgconfig(xext)
99 BuildRequires:  pkgconfig(xi)
100 BuildRequires:  pkgconfig(xfixes)
101 BuildRequires:  pkgconfig(xdamage)
102 BuildRequires:  pkgconfig(utilX)
103 %endif
104
105 # for dali-adaptor
106 BuildRequires:  pkgconfig(evas)
107
108 %if 0%{?tizen_version_major} == 3
109 BuildRequires:  pkgconfig(capi-appfw-application)
110 BuildRequires:  pkgconfig(elementary)
111 %else
112 BuildRequires:  pkgconfig(bundle)
113 BuildRequires:  pkgconfig(appcore-ui)
114 BuildRequires:  pkgconfig(appcore-multiwindow)
115 BuildRequires:  pkgconfig(capi-appfw-app-common)
116 BuildRequires:  pkgconfig(capi-appfw-app-control)
117 BuildRequires:  pkgconfig(screen_connector_provider)
118 BuildRequires:  pkgconfig(ecore-imf)
119 %endif
120 BuildRequires:  pkgconfig(capi-system-system-settings)
121
122 # for feedback plugin
123 BuildRequires:  pkgconfig(mm-sound)
124 %if 0%{?tizen_version_major} >= 3
125 BuildRequires:  pkgconfig(feedback)
126 %endif
127
128 # for videoplayer Plugin
129 BuildRequires:  pkgconfig(capi-media-player)
130
131
132 # for multiprofile
133 Requires:   %{name}-compat = %{version}-%{release}
134 Recommends: %{name}-profile_common = %{version}-%{release}
135
136 %description
137 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
138 platform abstraction and application shell
139
140 ###########################################
141 # Dali adapter for profiles
142 ###########################################
143
144 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
145 # if mobile || "undefined"
146 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
147 %package profile_mobile
148 Summary:        The DALi Tizen Adaptor for mobile
149 Provides:       %{name}-compat = %{version}-%{release}
150 Conflicts:      %{name}-profile_tv
151 Conflicts:      %{name}-profile_wearable
152 Conflicts:      %{name}-profile_ivi
153 Conflicts:      %{name}-profile_common
154 %description profile_mobile
155 The DALi Tizen Adaptor for mobile.
156 %endif
157
158 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
159 # if tv ||"undefined"
160 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
161 %package profile_tv
162 Summary:        The DALi Tizen Adaptor for tv
163 Provides:       %{name}-compat = %{version}-%{release}
164 Conflicts:      %{name}-profile_mobile
165 Conflicts:      %{name}-profile_wearable
166 Conflicts:      %{name}-profile_ivi
167 Conflicts:      %{name}-profile_common
168 %description profile_tv
169 The DALi Tizen Adaptor for tv.
170 %endif
171
172 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
173 # if wearable || "undefined"
174 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
175 %package profile_wearable
176 Summary:        The DALi Tizen Adaptor for wearable
177 Provides:       %{name}-compat = %{version}-%{release}
178 Conflicts:      %{name}-profile_mobile
179 Conflicts:      %{name}-profile_tv
180 Conflicts:      %{name}-profile_ivi
181 Conflicts:      %{name}-profile_common
182 %description profile_wearable
183 The DALi Tizen Adaptor for wearable.
184 %endif
185
186 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
187 # if ivi ||"undefined"
188 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
189 %package profile_ivi
190 Summary:        The DALi Tizen Adaptor for ivi
191 Provides:       %{name}-compat = %{version}-%{release}
192 Conflicts:      %{name}-profile_mobile
193 Conflicts:      %{name}-profile_wearable
194 Conflicts:      %{name}-profile_tv
195 Conflicts:      %{name}-profile_common
196 %description profile_ivi
197 The DALi Tizen Adaptor for ivi.
198 %endif
199
200 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
201 # if common ||"undefined"
202 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
203 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
204 %package profile_common
205 %define tizen_2_2_compatibility 0
206 Summary:        The DALi Tizen Adaptor for common
207 Provides:       %{name}-compat = %{version}-%{release}
208 Conflicts:      %{name}-profile_mobile
209 Conflicts:      %{name}-profile_wearable
210 Conflicts:      %{name}-profile_tv
211 Conflicts:      %{name}-profile_ivi
212 %description profile_common
213 The DALi Tizen Adaptor for common.
214 %endif
215
216 ##############################
217 # devel
218 ##############################
219 %package devel
220 Summary:    Development components for the DALi Tizen Adaptor
221 Group:      Development/Building
222 Requires:   %{name} = %{version}-%{release}
223 Requires:   %{name}-integration-devel = %{version}-%{release}
224
225 %description devel
226 Development components for the DALi Tizen Adaptor - public headers and package configs
227
228 ##############################
229 # integration-devel
230 ##############################
231 %package integration-devel
232 Summary:    Integration development package for the Adaptor
233 Group:      Development/Building
234 Requires:   %{name} = %{version}-%{release}
235
236 %description integration-devel
237 Integration development package for the Adaptor - headers for integrating with an adaptor library.
238
239 ##############################
240 # Dali Feedback Plugin
241 ##############################
242 %package dali-feedback-plugin
243 Summary:    Plugin to play haptic and audio feedback for Dali
244 Group:      System/Libraries
245 Requires:   %{name} = %{version}-%{release}
246 %description dali-feedback-plugin
247 Feedback plugin to play haptic and audio feedback for Dali
248
249 ##############################
250 # Dali VideoPlayer Plugin
251 ##############################
252 %if %{with wayland}
253
254 %package dali-video-player-plugin
255 Summary:    Plugin to play a video file for Dali
256 Group:      System/Libraries
257 %description dali-video-player-plugin
258 VideoPlayer plugin to play a video file for Dali
259 %endif
260
261 ##############################
262 # Preparation
263 ##############################
264 %prep
265 %setup -q
266
267 #Use TZ_PATH when tizen version is 3.x or greater
268
269 %if 0%{?tizen_version_major} >= 3
270 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
271 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
272 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
273 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
274 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
275 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
276 %else
277 %define dali_data_rw_dir         /usr/share/dali/
278 %define dali_data_ro_dir         /usr/share/dali/
279 %define font_preloaded_path      /usr/share/fonts/
280 %define font_downloaded_path     /opt/share/fonts/
281 %define font_application_path    /usr/share/app_fonts/
282 %define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
283 %endif
284
285 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
286 %define dali_plugin_sound_files  /plugins/sounds/
287 %define dev_include_path %{_includedir}
288
289 ##############################
290 # Build
291 ##############################
292 %build
293 PREFIX+="/usr"
294 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
295 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
296
297 %ifarch %{arm}
298 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
299 %endif
300
301 %if %{with wayland}
302 CFLAGS+=" -DWAYLAND"
303 CXXFLAGS+=" -DWAYLAND"
304 configure_flags="--enable-wayland"
305 %endif
306
307 # Use this conditional when Tizen version is 4.x or greater
308 %if 0%{?tizen_version_major} >= 4
309 CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
310 %endif
311
312 %if 0%{?tizen_2_2_compatibility}
313 CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
314 CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
315 %endif
316
317 libtoolize --force
318 cd %{_builddir}/%{name}-%{version}/build/tizen
319 autoreconf --install
320
321 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
322 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
323 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
324 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
325 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
326 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
327 %if 0%{?tizen_platform_config_supported}
328 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
329 %endif
330
331 # Default to GLES 2.0 if not specified.
332 %define target_gles_version 20
333
334 # Set up the build via configure.
335 #######################################################################
336 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
337 # if mobile || "undefined"
338 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
339
340 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
341            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
342            --enable-tizen-major-version=%{tizen_version_major} \
343 %if 0%{?tizen_version_major} >= 3
344            --enable-feedback \
345 %endif
346            --enable-videoplayer \
347 %if 0%{?tizen_2_2_compatibility}
348            --with-tizen-2-2-compatibility \
349 %endif
350 %if %{with wayland}
351            --enable-efl=no \
352 %else
353            --enable-efl=yes \
354 %endif
355 %if 0%{?enable_debug}
356            --enable-debug \
357 %endif
358            --enable-appfw=yes \
359            $configure_flags --libdir=%{_libdir}
360
361 # Build.
362 make %{?jobs:-j%jobs}
363
364 pushd %{_builddir}/%{name}-%{version}/build/tizen
365 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
366 popd
367
368 pushd %{buildroot}%{_libdir}
369 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
370 popd
371
372 make clean
373
374 %endif
375
376 #######################################################################
377 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
378 # if tv ||"undefined"
379 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
380
381 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
382            --enable-shaderbincache=DISABLE --enable-profile=TV \
383            --enable-tizen-major-version=%{tizen_version_major} \
384 %if 0%{?tizen_version_major} >= 3
385            --enable-feedback \
386 %endif
387            --enable-videoplayer \
388 %if 0%{?tizen_2_2_compatibility}
389            --with-tizen-2-2-compatibility \
390 %endif
391 %if %{with wayland}
392            --enable-efl=no \
393 %else
394            --enable-efl=yes \
395 %endif
396 %if 0%{?enable_debug}
397            --enable-debug \
398 %endif
399            --enable-appfw=yes \
400            $configure_flags --libdir=%{_libdir}
401
402 # Build.
403 make %{?jobs:-j%jobs}
404
405 pushd %{_builddir}/%{name}-%{version}/build/tizen
406 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
407 popd
408
409 pushd %{buildroot}%{_libdir}
410 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
411 popd
412
413 make clean
414 %endif
415
416 #######################################################################
417 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
418 # if wearable || "undefined"
419 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
420
421 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
422            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
423            --enable-tizen-major-version=%{tizen_version_major} \
424 %if 0%{?tizen_version_major} >= 3
425            --enable-feedback \
426 %endif
427            --enable-videoplayer \
428 %if 0%{?tizen_2_2_compatibility}
429            --with-tizen-2-2-compatibility \
430 %endif
431 %if %{with wayland}
432            --enable-efl=no \
433 %else
434            --enable-efl=yes \
435 %endif
436 %if 0%{?enable_debug}
437            --enable-debug \
438 %endif
439            --enable-appfw=yes \
440            $configure_flags --libdir=%{_libdir}
441
442 # Build.
443 make %{?jobs:-j%jobs}
444
445 pushd %{_builddir}/%{name}-%{version}/build/tizen
446 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
447 popd
448
449 pushd %{buildroot}%{_libdir}
450 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
451 popd
452
453 make clean
454 %endif
455
456 #######################################################################
457 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
458 # if ivi ||"undefined"
459 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
460
461 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
462            --enable-shaderbincache=DISABLE --enable-profile=IVI \
463            --enable-tizen-major-version=%{tizen_version_major} \
464 %if 0%{?tizen_version_major} >= 3
465            --enable-feedback \
466 %endif
467            --enable-videoplayer \
468 %if 0%{?tizen_2_2_compatibility}
469            --with-tizen-2-2-compatibility \
470 %endif
471 %if %{with wayland}
472            --enable-efl=no \
473 %else
474            --enable-efl=yes \
475 %endif
476 %if 0%{?enable_debug}
477            --enable-debug \
478 %endif
479            --enable-appfw=yes \
480            $configure_flags --libdir=%{_libdir}
481
482 # Build.
483 make %{?jobs:-j%jobs}
484
485 pushd %{_builddir}/%{name}-%{version}/build/tizen
486 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
487 popd
488
489 pushd %{buildroot}%{_libdir}
490 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
491 popd
492
493 make clean
494 %endif
495
496 #######################################################################
497 # common ( build dali_videoplayer_plugin for common uses )
498 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
499 # if common ||"undefined"
500 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
501
502 %configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
503            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
504            --enable-tizen-major-version=%{tizen_version_major} \
505 %if 0%{?tizen_version_major} >= 3
506            --enable-feedback \
507 %endif
508            --enable-videoplayer \
509 %if 0%{?tizen_2_2_compatibility}
510            --with-tizen-2-2-compatibility \
511 %endif
512 %if %{with wayland}
513            --enable-efl=no \
514 %else
515            --enable-efl=yes \
516 %endif
517 %if 0%{?enable_debug}
518            --enable-debug \
519 %endif
520            --enable-appfw=yes \
521            $configure_flags --libdir=%{_libdir}
522
523 # Build.
524 make %{?jobs:-j%jobs}
525
526 %endif
527
528
529 ##############################
530 # Installation
531 ##############################
532 %install
533 rm -rf %{buildroot}
534
535 pushd %{_builddir}/%{name}-%{version}/build/tizen
536 %make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
537
538
539 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
540 # !unified && (wearable || tv || ivi || mobile)
541 %if "%{?profile}" == "wearable" || "%{?profile}" == "tv" || "%{?profile}" == "ivi" || "%{?profile}" == "mobile"
542 rm -rf %{buildroot}%{_libdir}/libdali-adap*.so*
543 %endif
544
545 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
546 # wearable || tv || ivi || mobile || unified
547 %if "%{?profile}" != "common"
548 for FILE in libdali-*.so*; do mv "$FILE" "%{buildroot}%{_libdir}/$FILE"; done
549 %endif
550 popd
551
552 ##############################
553 # Upgrade order:
554 # 1 - Pre Install new package
555 # 2 - Install new package
556 # 3 - Post install new package
557 # 4 - Pre uninstall old package
558 # 5 - Remove files not overwritten by new package
559 # 6 - Post uninstall old package
560 ##############################
561
562 %pre
563 exit 0
564
565 ##############################
566 #  Post Install new package
567 ##############################
568 %post
569 /sbin/ldconfig
570 exit 0
571
572 ##############################
573 #  Pre Uninstall old package
574 ##############################
575 %preun
576 exit 0
577
578 ##############################
579 #  Post Uninstall old package
580 ##############################
581 %postun
582 /sbin/ldconfig
583 exit 0
584
585 %if %{with wayland}
586 %post dali-video-player-plugin
587 /sbin/ldconfig
588 exit 0
589 %endif
590
591 %if %{with wayland}
592 %postun dali-video-player-plugin
593 /sbin/ldconfig
594 exit 0
595 %endif
596
597
598 ##############################
599
600 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
601 # if mobile || "undefined"
602 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
603 %post profile_mobile
604 pushd %{_libdir}
605 for FILE in libdali-adap*.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
606 popd
607 /sbin/ldconfig
608 exit 0
609
610 %postun profile_mobile
611 /sbin/ldconfig
612 exit 0
613 %endif
614
615 ##############################
616
617 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
618 # if tv ||"undefined"
619 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
620 %post profile_tv
621 pushd %{_libdir}
622 for FILE in libdali-adap*.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
623 popd
624 /sbin/ldconfig
625 exit 0
626
627 %postun profile_tv
628 /sbin/ldconfig
629 exit 0
630 %endif
631
632 ##############################
633
634 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
635 # if wearable || "undefined"
636 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
637 %post profile_wearable
638 pushd %{_libdir}
639 for FILE in libdali-adap*.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
640 popd
641 /sbin/ldconfig
642 exit 0
643
644 %postun profile_wearable
645 /sbin/ldconfig
646 exit 0
647 %endif
648
649 ##############################
650
651 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
652 # if ivi ||"undefined"
653 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
654 %post profile_ivi
655 pushd %{_libdir}
656 for FILE in libdali-adap*.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
657 popd
658 /sbin/ldconfig
659 exit 0
660
661 %postun profile_ivi
662 /sbin/ldconfig
663 exit 0
664 %endif
665
666
667 ##############################
668 # Files in Binary Packages
669 ##############################
670
671 %files
672 %manifest dali-adaptor.manifest
673 %defattr(-,root,root,-)
674 %defattr(-,app,app,-)
675 %dir %{user_shader_cache_dir}
676 %{_bindir}/*
677 %license LICENSE
678
679 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
680 # if common ||"undefined"
681 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
682 %defattr(-,root,root,-)
683 %{_libdir}/libdali-adap*.so*
684 %exclude %{_libdir}/libdali-adap*.so*.mobile
685 %exclude %{_libdir}/libdali-adap*.so*.wearable
686 %exclude %{_libdir}/libdali-adap*.so*.tv
687 %exclude %{_libdir}/libdali-adap*.so*.ivi
688 %endif
689
690 %if %{with wayland}
691 %files dali-video-player-plugin
692 %manifest dali-adaptor.manifest
693 %defattr(-,root,root,-)
694 %{_libdir}/libdali-video-player-plugin.so*
695 %license LICENSE
696 %endif
697
698 %if 0%{?tizen_version_major} >= 3
699 %files dali-feedback-plugin
700 %manifest dali-adaptor.manifest
701 %defattr(-,root,root,-)
702 %{_libdir}/libdali-feedback-plugin.so*
703 %{dali_plugin_sound_files}/*
704 %endif
705
706 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
707 # if common ||"undefined"
708 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
709 %files profile_common
710 # default .so files are housed in the main pkg.
711 %endif
712
713 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
714 # if mobile || "undefined"
715 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
716 %files profile_mobile
717 %manifest dali-adaptor.manifest
718 %defattr(-,root,root,-)
719 %{_libdir}/libdali-adap*.so*.mobile
720 %endif
721
722 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
723 # if tv ||"undefined"
724 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
725 %files profile_tv
726 %manifest dali-adaptor.manifest
727 %defattr(-,root,root,-)
728 %{_libdir}/libdali-adap*.so*.tv
729 %endif
730
731 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
732 # if wearable || "undefined"
733 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
734 %files profile_wearable
735 %manifest dali-adaptor.manifest
736 %defattr(-,root,root,-)
737 %{_libdir}/libdali-adap*.so*.wearable
738 %endif
739
740 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
741 # if ivi ||"undefined"
742 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
743 %files profile_ivi
744 %manifest dali-adaptor.manifest
745 %defattr(-,root,root,-)
746 %{_libdir}/libdali-adap*.so*.ivi
747 %endif
748
749
750 %files devel
751 %defattr(-,root,root,-)
752 %{dev_include_path}/dali/dali.h
753 %{dev_include_path}/dali/public-api/*
754 %{dev_include_path}/dali/devel-api/*
755 %{dev_include_path}/dali/doc/*
756 %{_libdir}/pkgconfig/dali-adaptor.pc
757
758 %files integration-devel
759 %defattr(-,root,root,-)
760 %{dev_include_path}/dali/integration-api/adaptors/*
761 %{_libdir}/pkgconfig/dali-adaptor-integration.pc