Merge "Libraries & RPM renamed to provide DALi 2" into devel/master
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    1.9.10
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  fribidi-devel
65
66 BuildRequires:  pkgconfig(capi-system-info)
67 BuildRequires:  pkgconfig(capi-system-sensor)
68
69 BuildRequires:  pkgconfig(cairo)
70
71 BuildRequires:  pkgconfig(wayland-egl)
72 BuildRequires:  pkgconfig(wayland-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # We use ecore mainloop
77 %if 0%{?tizen_version_major} >= 5
78 BuildRequires:  pkgconfig(ecore-wl2)
79 BuildRequires:  pkgconfig(wayland-egl-tizen)
80 %else
81 BuildRequires:  pkgconfig(ecore-wayland)
82 %endif
83
84 # We need tbm_surface in tizen 3.0 wayland
85 BuildRequires:  pkgconfig(libtbm)
86
87 # for the adaptor
88 BuildRequires:  pkgconfig(appcore-ui)
89 BuildRequires:  pkgconfig(appcore-widget-base)
90 BuildRequires:  pkgconfig(bundle)
91 BuildRequires:  pkgconfig(capi-appfw-app-common)
92 BuildRequires:  pkgconfig(capi-appfw-app-control)
93 BuildRequires:  pkgconfig(ecore-imf)
94
95 BuildRequires:  pkgconfig(capi-system-system-settings)
96
97 # for feedback plugin
98 BuildRequires:  pkgconfig(mm-sound)
99 BuildRequires:  pkgconfig(feedback)
100
101 # for multiprofile
102 Requires:   %{name}-compat = %{version}-%{release}
103 Recommends: %{name}-profile_common = %{version}-%{release}
104
105 %description
106 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
107 platform abstraction and application shell
108
109 ###########################################
110 # Dali adapter for profiles
111 ###########################################
112
113 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
114 # if mobile || "undefined"
115 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
116 %package profile_mobile
117 Summary:        The DALi Tizen Adaptor for mobile
118 Provides:       %{name}-compat = %{version}-%{release}
119 Conflicts:      %{name}-profile_tv
120 Conflicts:      %{name}-profile_wearable
121 Conflicts:      %{name}-profile_ivi
122 Conflicts:      %{name}-profile_common
123 Requires:       %{name}
124 %description profile_mobile
125 The DALi Tizen Adaptor for mobile.
126 %endif
127
128 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
129 # if tv ||"undefined"
130 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
131 %package profile_tv
132 Summary:        The DALi Tizen Adaptor for tv
133 Provides:       %{name}-compat = %{version}-%{release}
134 Conflicts:      %{name}-profile_mobile
135 Conflicts:      %{name}-profile_wearable
136 Conflicts:      %{name}-profile_ivi
137 Conflicts:      %{name}-profile_common
138 Requires:       %{name}
139 %description profile_tv
140 The DALi Tizen Adaptor for tv.
141 %endif
142
143 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
144 # if wearable || "undefined"
145 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
146 %package profile_wearable
147 Summary:        The DALi Tizen Adaptor for wearable
148 Provides:       %{name}-compat = %{version}-%{release}
149 Conflicts:      %{name}-profile_mobile
150 Conflicts:      %{name}-profile_tv
151 Conflicts:      %{name}-profile_ivi
152 Conflicts:      %{name}-profile_common
153 Requires:       %{name}
154 %description profile_wearable
155 The DALi Tizen Adaptor for wearable.
156 %endif
157
158 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
159 # if ivi ||"undefined"
160 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
161 %package profile_ivi
162 Summary:        The DALi Tizen Adaptor for ivi
163 Provides:       %{name}-compat = %{version}-%{release}
164 Conflicts:      %{name}-profile_mobile
165 Conflicts:      %{name}-profile_wearable
166 Conflicts:      %{name}-profile_tv
167 Conflicts:      %{name}-profile_common
168 Requires:       %{name}
169 %description profile_ivi
170 The DALi Tizen Adaptor for ivi.
171 %endif
172
173 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
174 # if common ||"undefined"
175 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
176 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
177 %package profile_common
178 Summary:        The DALi Tizen Adaptor for common
179 Provides:       %{name}-compat = %{version}-%{release}
180 Conflicts:      %{name}-profile_mobile
181 Conflicts:      %{name}-profile_wearable
182 Conflicts:      %{name}-profile_tv
183 Conflicts:      %{name}-profile_ivi
184 Requires:       %{name}
185 %description profile_common
186 The DALi Tizen Adaptor for common.
187 %endif
188
189 ##############################
190 # devel
191 ##############################
192 %package devel
193 Summary:    Development components for the DALi Tizen Adaptor
194 Group:      Development/Building
195 Requires:   %{name} = %{version}-%{release}
196 Requires:   %{name}-integration-devel = %{version}-%{release}
197
198 %description devel
199 Development components for the DALi Tizen Adaptor - public headers and package configs
200
201 ##############################
202 # integration-devel
203 ##############################
204 %package integration-devel
205 Summary:    Integration development package for the Adaptor
206 Group:      Development/Building
207 Requires:   %{name} = %{version}-%{release}
208
209 %description integration-devel
210 Integration development package for the Adaptor - headers for integrating with an adaptor library.
211
212 ##############################
213 # Dali Feedback Plugin
214 ##############################
215 %package dali2-feedback-plugin
216 Summary:    Plugin to play haptic and audio feedback for Dali
217 Group:      System/Libraries
218 Requires:   %{name} = %{version}-%{release}
219 %description dali2-feedback-plugin
220 Feedback plugin to play haptic and audio feedback for Dali
221
222 ##############################
223 # Preparation
224 ##############################
225 %prep
226 %setup -q
227
228 #Use TZ_PATH when tizen version is 3.x or greater
229
230 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
231 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
232 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
233 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
234 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
235 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
236
237 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
238 %define dali_plugin_sound_files  /plugins/sounds/
239
240 ##############################
241 # Build
242 ##############################
243 %build
244 PREFIX+="/usr"
245 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
246 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
247
248 %ifarch %{arm}
249 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
250 %endif
251
252 CFLAGS+=" -DWAYLAND"
253 CXXFLAGS+=" -DWAYLAND"
254 cmake_flags=" -DENABLE_WAYLAND=ON"
255
256 # Use this conditional when Tizen version is 5.x or greater
257 %if 0%{?tizen_version_major} >= 5
258 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
259
260 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
261 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
262 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
263 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
264 %endif
265
266 %if 0%{?enable_debug}
267 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
268 %endif
269
270 %if 0%{?enable_trace}
271 cmake_flags+=" -DENABLE_TRACE=ON"
272 %endif
273
274 %if 0%{?enable_appfw}
275 cmake_flags+=" -DUSE_APPFW"
276 %endif
277
278 libtoolize --force
279 cd %{_builddir}/%{name}-%{version}/build/tizen
280
281 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
282 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
283 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
284 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
285 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
286 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
287 %if 0%{?tizen_platform_config_supported}
288 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
289 %endif
290
291 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
292 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
293 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
294 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
295 cmake_flags+=" -DENABLE_FEEDBACK=YES"
296 cmake_flags+=" -DENABLE_APPFW=YES"
297
298 # Set up the build via Cmake
299 #######################################################################
300 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
301 # if mobile || "undefined"
302 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
303
304 mkdir mobile
305 pushd mobile
306
307 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
308
309 # Build.
310 make %{?jobs:-j%jobs}
311 popd
312
313 %endif
314
315 #######################################################################
316 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
317 # if tv ||"undefined"
318 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
319
320 mkdir tv
321 pushd tv
322
323 cmake -DENABLE_PROFILE=TV $cmake_flags ..
324
325 # Build.
326 make %{?jobs:-j%jobs}
327 popd
328
329 %endif
330
331 #######################################################################
332 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
333 # if wearable || "undefined"
334 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
335
336 mkdir wearable
337 pushd wearable
338
339 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
340
341 # Build.
342 make %{?jobs:-j%jobs}
343 popd
344
345 %endif
346
347 #######################################################################
348 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
349 # if ivi ||"undefined"
350 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
351
352 mkdir ivi
353 pushd ivi
354
355 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
356
357 # Build.
358 make %{?jobs:-j%jobs}
359 popd
360
361 %endif
362
363 #######################################################################
364 # common
365 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
366 # if common ||"undefined"
367 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
368
369 mkdir common
370 pushd common
371
372 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
373
374 # Build.
375 make %{?jobs:-j%jobs}
376 popd
377
378 %endif
379
380 ##############################
381 # Installation
382 ##############################
383 %install
384 rm -rf %{buildroot}
385
386 pushd %{_builddir}/%{name}-%{version}/build/tizen
387
388 # if mobile || "undefined"
389 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
390 pushd mobile
391 %make_install
392 %if "%{?profile}" != "mobile"
393 pushd  %{buildroot}%{_libdir}
394 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
395 popd
396 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
397 %endif
398 popd
399 %endif
400
401 # if tv ||"undefined"
402 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
403 pushd tv
404 %make_install
405 %if "%{?profile}" != "tv"
406 pushd  %{buildroot}%{_libdir}
407 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
408 popd
409 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
410 %endif
411 popd
412 %endif
413
414 # if wearable || "undefined"
415 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
416 pushd wearable
417 %make_install
418 %if "%{?profile}" != "wearable"
419 pushd  %{buildroot}%{_libdir}
420 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
421 popd
422 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
423 %endif
424 popd
425 %endif
426
427 # if ivi ||"undefined"
428 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
429 pushd ivi
430 %make_install
431 %if "%{?profile}" != "ivi"
432 pushd  %{buildroot}%{_libdir}
433 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
434 popd
435 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
436 %endif
437 popd
438 %endif
439
440 # if common ||"undefined"
441 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
442 pushd common
443 %make_install
444 # No clean so we can gather symbol/size information for the common profile
445 popd
446 %endif
447
448 # Create a symbolic link in integration-api to preserve legacy repo build
449 pushd %{buildroot}%{_includedir}/dali/integration-api
450 ln -sf adaptor-framework adaptors
451 popd
452
453 ##############################
454 # Upgrade order:
455 # 1 - Pre Install new package
456 # 2 - Install new package
457 # 3 - Post install new package
458 # 4 - Pre uninstall old package
459 # 5 - Remove files not overwritten by new package
460 # 6 - Post uninstall old package
461 ##############################
462
463 ##############################
464 # Adaptor package Commands
465 %pre
466 exit 0
467
468 %post
469 pushd %{_libdir}
470 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
471 popd
472 /sbin/ldconfig
473 exit 0
474
475 %preun
476 exit 0
477
478 %postun
479 /sbin/ldconfig
480 exit 0
481
482 ##############################
483 # Mobile Profile Commands
484 # if mobile || "undefined"
485 # No need to create a symbolic link on install required if only building this profile
486 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
487 %post profile_mobile
488 %if "%{?profile}" != "mobile"
489 pushd %{_libdir}
490 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
491 popd
492 %endif
493 /sbin/ldconfig
494 exit 0
495
496 %postun profile_mobile
497 /sbin/ldconfig
498 exit 0
499 %endif
500
501 ##############################
502 # TV Profile Commands
503 # No need to create a symbolic link on install required if only building this profile
504 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
505 %post profile_tv
506 %if "%{?profile}" != "tv"
507 pushd %{_libdir}
508 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
509 popd
510 %endif
511 /sbin/ldconfig
512 exit 0
513
514 %postun profile_tv
515 /sbin/ldconfig
516 exit 0
517 %endif
518
519 ##############################
520 # Wearable Profile Commands
521 # No need to create a symbolic link on install required if only building this profile
522 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
523 %post profile_wearable
524 %if "%{?profile}" != "wearable"
525 pushd %{_libdir}
526 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
527 popd
528 %endif
529 /sbin/ldconfig
530 exit 0
531
532 %postun profile_wearable
533 /sbin/ldconfig
534 exit 0
535 %endif
536
537 ##############################
538 # IVI Profile Commands
539 # No need to create a symbolic link on install required if only building this profile
540 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
541 %post profile_ivi
542 %if "%{?profile}" != "ivi"
543 pushd %{_libdir}
544 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.0.0.0
545 popd
546 %endif
547 /sbin/ldconfig
548 exit 0
549
550 %postun profile_ivi
551 /sbin/ldconfig
552 exit 0
553 %endif
554
555 ##############################
556 # Common Profile Commands
557 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
558 %post profile_common
559 /sbin/ldconfig
560 exit 0
561
562 %postun profile_common
563 /sbin/ldconfig
564 exit 0
565 %endif
566
567 ##############################
568 # Files in Binary Packages
569 ##############################
570
571 %files
572 %manifest dali-adaptor.manifest
573 %defattr(-,root,root,-)
574 %dir %{user_shader_cache_dir}
575 %{_bindir}/*
576 %license LICENSE
577 %defattr(-,root,root,-)
578 %{_libdir}/libdali2-adaptor.so
579 %{_libdir}/libdali2-adaptor.so.2
580 %{_libdir}/libdali2-adaptor.so.2.0.0
581
582 #################################################
583
584 %files dali2-feedback-plugin
585 %manifest dali-adaptor.manifest
586 %defattr(-,root,root,-)
587 %{_libdir}/libdali2-feedback-plugin.so*
588 %{dali_plugin_sound_files}/*
589
590 #################################################
591
592 # if common ||"undefined"
593 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
594 %files profile_common
595 %manifest dali-adaptor.manifest
596 # default .so files are housed in the main pkg.
597 %endif
598
599 # if mobile || "undefined"
600 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
601 %files profile_mobile
602 %manifest dali-adaptor.manifest
603 %defattr(-,root,root,-)
604 %if "%{?profile}" != "mobile"
605 %{_libdir}/libdali2-adaptor.so.mobile
606 %endif
607 %endif
608
609 # if tv ||"undefined"
610 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
611 %files profile_tv
612 %manifest dali-adaptor.manifest
613 %defattr(-,root,root,-)
614 %if "%{?profile}" != "tv"
615 %{_libdir}/libdali2-adaptor.so.tv
616 %endif
617 %endif
618
619 # if wearable || "undefined"
620 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
621 %files profile_wearable
622 %manifest dali-adaptor.manifest
623 %defattr(-,root,root,-)
624 %if "%{?profile}" != "wearable"
625 %{_libdir}/libdali2-adaptor.so.wearable
626 %endif
627 %endif
628
629 # if ivi ||"undefined"
630 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
631 %files profile_ivi
632 %manifest dali-adaptor.manifest
633 %defattr(-,root,root,-)
634 %if "%{?profile}" != "ivi"
635 %{_libdir}/libdali2-adaptor.so.ivi
636 %endif
637 %endif
638
639 %files devel
640 %defattr(-,root,root,-)
641 %{_includedir}/dali/dali.h
642 %{_includedir}/dali/public-api/*
643 %{_includedir}/dali/devel-api/*
644 %{_includedir}/dali/doc/*
645 %{_libdir}/pkgconfig/dali2-adaptor.pc
646
647 %files integration-devel
648 %defattr(-,root,root,-)
649 %{_includedir}/dali/integration-api/adaptor-framework/*
650 %{_includedir}/dali/integration-api/adaptors
651 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc