DALi Version 2.1.15
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.1.15
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 %endif
40
41 BuildRequires:  pkgconfig(screen_connector_provider)
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  hyphen-devel
65 BuildRequires:  fribidi-devel
66
67 BuildRequires:  pkgconfig(capi-system-info)
68 BuildRequires:  pkgconfig(capi-system-sensor)
69
70 BuildRequires:  pkgconfig(cairo)
71
72 BuildRequires:  pkgconfig(wayland-egl)
73 BuildRequires:  pkgconfig(wayland-client)
74 BuildRequires:  pkgconfig(input-method-client)
75 BuildRequires:  wayland-devel
76 BuildRequires:  wayland-extension-client-devel
77
78 # WebP support only from Tizen 6 onwards
79 %if 0%{?tizen_version_major} >= 6
80 BuildRequires:  pkgconfig(libwebp)
81 BuildRequires:  pkgconfig(libwebpdecoder)
82 BuildRequires:  pkgconfig(libwebpdemux)
83 BuildRequires:  pkgconfig(libwebpmux)
84 %endif
85
86 # We use ecore mainloop
87 %if 0%{?tizen_version_major} >= 5
88 BuildRequires:  pkgconfig(ecore-wl2)
89 BuildRequires:  pkgconfig(wayland-egl-tizen)
90 %else
91 BuildRequires:  pkgconfig(ecore-wayland)
92 %endif
93
94 # We need tbm_surface in tizen 3.0 wayland
95 BuildRequires:  pkgconfig(libtbm)
96
97 # for the adaptor
98 BuildRequires:  pkgconfig(appcore-ui)
99 BuildRequires:  pkgconfig(appcore-widget-base)
100 BuildRequires:  pkgconfig(bundle)
101 BuildRequires:  pkgconfig(capi-appfw-app-common)
102 BuildRequires:  pkgconfig(capi-appfw-app-control)
103 BuildRequires:  pkgconfig(ecore-imf)
104
105 BuildRequires:  pkgconfig(capi-system-system-settings)
106
107 # for ATSPI (Accessibility) support
108 BuildRequires:  pkgconfig(eldbus)
109
110 # for feedback plugin
111 BuildRequires:  pkgconfig(mm-sound)
112 BuildRequires:  pkgconfig(feedback)
113 BuildRequires:  pkgconfig(component-based-core-base)
114
115
116 %if ( 0%{?tizen_version_major} == 6 && 0%{?tizen_version_minor} >= 5 ) || 0%{?tizen_version_major} >= 7
117 BuildRequires:  pkgconfig(thorvg)
118 %endif
119
120 # for multiprofile
121 Requires:   %{name}-compat = %{version}-%{release}
122 Recommends: %{name}-profile_common = %{version}-%{release}
123
124 %description
125 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
126 platform abstraction and application shell
127
128 ###########################################
129 # Dali adapter for profiles
130 ###########################################
131
132 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
133 # if mobile || "undefined"
134 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
135 %package profile_mobile
136 Summary:        The DALi Tizen Adaptor for mobile
137 Provides:       %{name}-compat = %{version}-%{release}
138 Conflicts:      %{name}-profile_tv
139 Conflicts:      %{name}-profile_wearable
140 Conflicts:      %{name}-profile_ivi
141 Conflicts:      %{name}-profile_common
142 Requires:       %{name}
143 %description profile_mobile
144 The DALi Tizen Adaptor for mobile.
145 %endif
146
147 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
148 # if tv ||"undefined"
149 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
150 %package profile_tv
151 Summary:        The DALi Tizen Adaptor for tv
152 Provides:       %{name}-compat = %{version}-%{release}
153 Conflicts:      %{name}-profile_mobile
154 Conflicts:      %{name}-profile_wearable
155 Conflicts:      %{name}-profile_ivi
156 Conflicts:      %{name}-profile_common
157 Requires:       %{name}
158 %description profile_tv
159 The DALi Tizen Adaptor for tv.
160 %endif
161
162 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
163 # if wearable || "undefined"
164 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
165 %package profile_wearable
166 Summary:        The DALi Tizen Adaptor for wearable
167 Provides:       %{name}-compat = %{version}-%{release}
168 Conflicts:      %{name}-profile_mobile
169 Conflicts:      %{name}-profile_tv
170 Conflicts:      %{name}-profile_ivi
171 Conflicts:      %{name}-profile_common
172 Requires:       %{name}
173 %description profile_wearable
174 The DALi Tizen Adaptor for wearable.
175 %endif
176
177 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
178 # if ivi ||"undefined"
179 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
180 %package profile_ivi
181 Summary:        The DALi Tizen Adaptor for ivi
182 Provides:       %{name}-compat = %{version}-%{release}
183 Conflicts:      %{name}-profile_mobile
184 Conflicts:      %{name}-profile_wearable
185 Conflicts:      %{name}-profile_tv
186 Conflicts:      %{name}-profile_common
187 Requires:       %{name}
188 %description profile_ivi
189 The DALi Tizen Adaptor for ivi.
190 %endif
191
192 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
193 # if common ||"undefined"
194 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
195 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
196 %package profile_common
197 Summary:        The DALi Tizen Adaptor for common
198 Provides:       %{name}-compat = %{version}-%{release}
199 Conflicts:      %{name}-profile_mobile
200 Conflicts:      %{name}-profile_wearable
201 Conflicts:      %{name}-profile_tv
202 Conflicts:      %{name}-profile_ivi
203 Requires:       %{name}
204 %description profile_common
205 The DALi Tizen Adaptor for common.
206 %endif
207
208 ##############################
209 # devel
210 ##############################
211 %package devel
212 Summary:    Development components for the DALi Tizen Adaptor
213 Group:      Development/Building
214 Requires:   %{name} = %{version}-%{release}
215 Requires:   %{name}-integration-devel = %{version}-%{release}
216
217 %description devel
218 Development components for the DALi Tizen Adaptor - public headers and package configs
219
220 ##############################
221 # integration-devel
222 ##############################
223 %package integration-devel
224 Summary:    Integration development package for the Adaptor
225 Group:      Development/Building
226 Requires:   %{name} = %{version}-%{release}
227
228 %description integration-devel
229 Integration development package for the Adaptor - headers for integrating with an adaptor library.
230
231 ##############################
232 # Dali Feedback Plugin
233 ##############################
234 %package dali2-feedback-plugin
235 Summary:    Plugin to play haptic and audio feedback for Dali
236 Group:      System/Libraries
237 Requires:   %{name} = %{version}-%{release}
238 %description dali2-feedback-plugin
239 Feedback plugin to play haptic and audio feedback for Dali
240
241 #Use TZ_PATH when tizen version is 3.x or greater
242 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
243 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
244 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
245 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
246 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
247 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
248
249 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
250 %define dali_plugin_sound_files  /plugins/sounds/
251
252 ##############################
253 # Preparation
254 ##############################
255 %prep
256 %setup -q
257
258
259 ##############################
260 # Build
261 ##############################
262 %build
263 PREFIX+="/usr"
264 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
265 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
266
267 %ifarch %{arm}
268 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
269 %endif
270
271 CFLAGS+=" -DWAYLAND"
272 CXXFLAGS+=" -DWAYLAND"
273 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON"
274
275 # Use this conditional when Tizen version is 5.x or greater
276 %if 0%{?tizen_version_major} >= 5
277 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
278
279 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
280 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
281 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
282 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
283 %endif
284
285 # Use this conditional when Tizen version is 7.x or greater
286 %if 0%{?tizen_version_major} >= 7
287 CXXFLAGS+=" -DOVER_TIZEN_VERSION_7"
288 %endif
289
290 %if 0%{?enable_debug}
291 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
292 %endif
293
294 %if 0%{?enable_trace}
295 cmake_flags+=" -DENABLE_TRACE=ON"
296 %endif
297
298 %if 0%{?enable_logging}
299 cmake_flags+=" -DENABLE_NETWORK_LOGGING=ON"
300 %endif
301
302 libtoolize --force
303 cd %{_builddir}/%{name}-%{version}/build/tizen
304
305 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
306 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
307 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
308 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
309 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
310 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
311 %if 0%{?tizen_platform_config_supported}
312 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
313 %endif
314
315 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
316 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
317 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
318 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
319 cmake_flags+=" -DENABLE_FEEDBACK=YES"
320 cmake_flags+=" -DENABLE_APPFW=YES"
321 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
322
323 # Set up the build via Cmake
324 #######################################################################
325 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
326 # if mobile || "undefined"
327 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
328
329 mkdir -p mobile
330 pushd mobile
331
332 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
333
334 # Build.
335 make %{?jobs:-j%jobs}
336 popd
337
338 %endif
339
340 #######################################################################
341 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
342 # if tv ||"undefined"
343 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
344
345 mkdir -p tv
346 pushd tv
347
348 cmake -DENABLE_PROFILE=TV $cmake_flags ..
349
350 # Build.
351 make %{?jobs:-j%jobs}
352 popd
353
354 %endif
355
356 #######################################################################
357 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
358 # if wearable || "undefined"
359 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
360
361 mkdir -p wearable
362 pushd wearable
363
364 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
365
366 # Build.
367 make %{?jobs:-j%jobs}
368 popd
369
370 %endif
371
372 #######################################################################
373 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
374 # if ivi ||"undefined"
375 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
376
377 mkdir -p ivi
378 pushd ivi
379
380 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
381
382 # Build.
383 make %{?jobs:-j%jobs}
384 popd
385
386 %endif
387
388 #######################################################################
389 # common
390 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
391 # if common ||"undefined"
392 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
393
394 mkdir -p common
395 pushd common
396
397 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
398
399 # Build.
400 make %{?jobs:-j%jobs}
401 popd
402
403 %endif
404
405 ##############################
406 # Installation
407 ##############################
408 %install
409 rm -rf %{buildroot}
410
411 pushd %{_builddir}/%{name}-%{version}/build/tizen
412
413 # if mobile || "undefined"
414 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
415 pushd mobile
416 %make_install
417 %if "%{?profile}" != "mobile"
418 pushd  %{buildroot}%{_libdir}
419 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
420 popd
421 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
422 %endif
423 popd
424 %endif
425
426 # if tv ||"undefined"
427 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
428 pushd tv
429 %make_install
430 %if "%{?profile}" != "tv"
431 pushd  %{buildroot}%{_libdir}
432 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
433 popd
434 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
435 %endif
436 popd
437 %endif
438
439 # if wearable || "undefined"
440 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
441 pushd wearable
442 %make_install
443 %if "%{?profile}" != "wearable"
444 pushd  %{buildroot}%{_libdir}
445 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
446 popd
447 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
448 %endif
449 popd
450 %endif
451
452 # if ivi ||"undefined"
453 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
454 pushd ivi
455 %make_install
456 %if "%{?profile}" != "ivi"
457 pushd  %{buildroot}%{_libdir}
458 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
459 popd
460 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
461 %endif
462 popd
463 %endif
464
465 # if common ||"undefined"
466 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
467 pushd common
468 %make_install
469 # No clean so we can gather symbol/size information for the common profile
470 popd
471 %endif
472
473 # Create a symbolic link in integration-api to preserve legacy repo build
474 pushd %{buildroot}%{_includedir}/dali/integration-api
475 ln -sf adaptor-framework adaptors
476 popd
477
478 ##############################
479 # Upgrade order:
480 # 1 - Pre Install new package
481 # 2 - Install new package
482 # 3 - Post install new package
483 # 4 - Pre uninstall old package
484 # 5 - Remove files not overwritten by new package
485 # 6 - Post uninstall old package
486 ##############################
487
488 ##############################
489 # Adaptor package Commands
490 %pre
491 exit 0
492
493 %post
494 pushd %{_libdir}
495 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
496 popd
497 /sbin/ldconfig
498 exit 0
499
500 %preun
501 exit 0
502
503 %postun
504 /sbin/ldconfig
505 exit 0
506
507 ##############################
508 # Mobile Profile Commands
509 # if mobile || "undefined"
510 # No need to create a symbolic link on install required if only building this profile
511 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
512 %post profile_mobile
513 %if "%{?profile}" != "mobile"
514 pushd %{_libdir}
515 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
516 popd
517 %endif
518 /sbin/ldconfig
519 exit 0
520
521 %postun profile_mobile
522 /sbin/ldconfig
523 exit 0
524 %endif
525
526 ##############################
527 # TV Profile Commands
528 # No need to create a symbolic link on install required if only building this profile
529 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
530 %post profile_tv
531 %if "%{?profile}" != "tv"
532 pushd %{_libdir}
533 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
534 popd
535 %endif
536 /sbin/ldconfig
537 exit 0
538
539 %postun profile_tv
540 /sbin/ldconfig
541 exit 0
542 %endif
543
544 ##############################
545 # Wearable Profile Commands
546 # No need to create a symbolic link on install required if only building this profile
547 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
548 %post profile_wearable
549 %if "%{?profile}" != "wearable"
550 pushd %{_libdir}
551 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
552 popd
553 %endif
554 /sbin/ldconfig
555 exit 0
556
557 %postun profile_wearable
558 /sbin/ldconfig
559 exit 0
560 %endif
561
562 ##############################
563 # IVI Profile Commands
564 # No need to create a symbolic link on install required if only building this profile
565 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
566 %post profile_ivi
567 %if "%{?profile}" != "ivi"
568 pushd %{_libdir}
569 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
570 popd
571 %endif
572 /sbin/ldconfig
573 exit 0
574
575 %postun profile_ivi
576 /sbin/ldconfig
577 exit 0
578 %endif
579
580 ##############################
581 # Common Profile Commands
582 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
583 %post profile_common
584 /sbin/ldconfig
585 exit 0
586
587 %postun profile_common
588 /sbin/ldconfig
589 exit 0
590 %endif
591
592 ##############################
593 # Files in Binary Packages
594 ##############################
595
596 %files
597 %manifest dali-adaptor.manifest
598 %defattr(-,root,root,-)
599 %dir %{user_shader_cache_dir}
600 %{_bindir}/*
601 %license LICENSE
602 %defattr(-,root,root,-)
603 %{_libdir}/libdali2-adaptor.so
604 %{_libdir}/libdali2-adaptor.so.2
605 %{_libdir}/libdali2-adaptor.so.2.0.0
606
607 #################################################
608
609 %files dali2-feedback-plugin
610 %manifest dali-adaptor.manifest
611 %defattr(-,root,root,-)
612 %{_libdir}/libdali2-feedback-plugin.so*
613 %{dali_plugin_sound_files}/*
614
615 #################################################
616
617 # if common ||"undefined"
618 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
619 %files profile_common
620 %manifest dali-adaptor.manifest
621 # default .so files are housed in the main pkg.
622 %endif
623
624 # if mobile || "undefined"
625 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
626 %files profile_mobile
627 %manifest dali-adaptor.manifest
628 %defattr(-,root,root,-)
629 %if "%{?profile}" != "mobile"
630 %{_libdir}/libdali2-adaptor.so.mobile
631 %endif
632 %endif
633
634 # if tv ||"undefined"
635 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
636 %files profile_tv
637 %manifest dali-adaptor.manifest
638 %defattr(-,root,root,-)
639 %if "%{?profile}" != "tv"
640 %{_libdir}/libdali2-adaptor.so.tv
641 %endif
642 %endif
643
644 # if wearable || "undefined"
645 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
646 %files profile_wearable
647 %manifest dali-adaptor.manifest
648 %defattr(-,root,root,-)
649 %if "%{?profile}" != "wearable"
650 %{_libdir}/libdali2-adaptor.so.wearable
651 %endif
652 %endif
653
654 # if ivi ||"undefined"
655 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
656 %files profile_ivi
657 %manifest dali-adaptor.manifest
658 %defattr(-,root,root,-)
659 %if "%{?profile}" != "ivi"
660 %{_libdir}/libdali2-adaptor.so.ivi
661 %endif
662 %endif
663
664 %files devel
665 %defattr(-,root,root,-)
666 %{_includedir}/dali/dali.h
667 %{_includedir}/dali/public-api/*
668 %{_includedir}/dali/devel-api/*
669 %{_includedir}/dali/doc/*
670 %{_libdir}/pkgconfig/dali2-adaptor.pc
671
672 %files integration-devel
673 %defattr(-,root,root,-)
674 %{_includedir}/dali/integration-api/adaptor-framework/*
675 %{_includedir}/dali/integration-api/adaptors
676 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc