[Tizen] Add DALi Autofill implementation
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
1 # NOTES
2 # This spec file is used to build DALi Adaptor for different Tizen Profiles
3 # Current profiles are:  Mobile, TV, Wearable, Common
4 #
5 # The profile variable is defined outside of the spec file in a build.conf file.
6 # It will contain the profile and whether or not to build with X11 or Wayland
7 #
8 # gbs will try to download the build.conf for the platform automatically from the repo location when
9 # performing a gbs build ( use gbs build -v to see it download location) E.g.
10 # http://download.tizen.org/snapshots/tizen/tv/tizen-tv/repos/arm-wayland/packages/repodata/xxxx-build.conf.gz
11
12 # Do not provide .so automatically for the extensions.
13 # This if statement is for backward compatibility with GBM/Obsolete build systems
14 %if "%{?profile}" != "wearable" && "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
15 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
16 %endif
17
18 Name:       dali2-adaptor
19 Summary:    The DALi Tizen Adaptor
20 Version:    2.0.4
21 Release:    1
22 Group:      System/Libraries
23 License:    Apache-2.0 and BSD-3-Clause and MIT
24 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
25 Source0:    %{name}-%{version}.tar.gz
26
27 Requires(post): /sbin/ldconfig
28 Requires(postun): /sbin/ldconfig
29 Requires:       giflib
30
31 %define tizen_platform_config_supported 1
32 BuildRequires:  pkgconfig(libtzplatform-config)
33
34 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
35 # if wearable || "undefined"
36 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
37 BuildRequires:  pkgconfig(capi-appfw-watch-application)
38 BuildRequires:  pkgconfig(appcore-watch)
39 BuildRequires:  pkgconfig(screen_connector_provider)
40 %endif
41
42 BuildRequires:  pkgconfig(gles20)
43 BuildRequires:  pkgconfig(glesv2)
44 BuildRequires:  pkgconfig(ttrace)
45
46 BuildRequires:  dali2-devel
47 BuildRequires:  dali2-integration-devel
48
49 BuildRequires:  pkgconfig
50 BuildRequires:  gawk
51 BuildRequires:  cmake
52 BuildRequires:  giflib-devel
53 BuildRequires:  pkgconfig(fontconfig)
54 BuildRequires:  libjpeg-turbo-devel
55 BuildRequires:  pkgconfig(vconf)
56 BuildRequires:  tts-devel
57 BuildRequires:  pkgconfig(dlog)
58 BuildRequires:  libdrm-devel
59 BuildRequires:  pkgconfig(libexif)
60 BuildRequires:  pkgconfig(libpng)
61 BuildRequires:  pkgconfig(egl)
62 BuildRequires:  libcurl-devel
63 BuildRequires:  pkgconfig(harfbuzz)
64 BuildRequires:  fribidi-devel
65
66 BuildRequires:  pkgconfig(capi-system-info)
67 BuildRequires:  pkgconfig(capi-system-sensor)
68
69 BuildRequires:  pkgconfig(cairo)
70
71 BuildRequires:  pkgconfig(wayland-egl)
72 BuildRequires:  pkgconfig(wayland-client)
73 BuildRequires:  wayland-devel
74 BuildRequires:  wayland-extension-client-devel
75
76 # WebP support only from Tizen 6 onwards
77 %if 0%{?tizen_version_major} >= 6
78 BuildRequires:  pkgconfig(libwebp)
79 BuildRequires:  pkgconfig(libwebpdecoder)
80 BuildRequires:  pkgconfig(libwebpdemux)
81 BuildRequires:  pkgconfig(libwebpmux)
82 %endif
83
84 # We use ecore mainloop
85 %if 0%{?tizen_version_major} >= 5
86 BuildRequires:  pkgconfig(ecore-wl2)
87 BuildRequires:  pkgconfig(wayland-egl-tizen)
88 %else
89 BuildRequires:  pkgconfig(ecore-wayland)
90 %endif
91
92 # We need tbm_surface in tizen 3.0 wayland
93 BuildRequires:  pkgconfig(libtbm)
94
95 # for the adaptor
96 BuildRequires:  pkgconfig(appcore-ui)
97 BuildRequires:  pkgconfig(appcore-widget-base)
98 BuildRequires:  pkgconfig(bundle)
99 BuildRequires:  pkgconfig(capi-appfw-app-common)
100 BuildRequires:  pkgconfig(capi-appfw-app-control)
101 BuildRequires:  pkgconfig(ecore-imf)
102
103 BuildRequires:  pkgconfig(capi-system-system-settings)
104
105 # for ATSPI (Accessibility) support
106 BuildRequires:  pkgconfig(eldbus)
107
108 # for autofill
109 %if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
110 BuildRequires:  pkgconfig(capi-ui-autofill)
111 %endif
112
113 # for feedback plugin
114 BuildRequires:  pkgconfig(mm-sound)
115 BuildRequires:  pkgconfig(feedback)
116 BuildRequires:  pkgconfig(component-based-core-base)
117
118 # for multiprofile
119 Requires:   %{name}-compat = %{version}-%{release}
120 Recommends: %{name}-profile_common = %{version}-%{release}
121
122 %description
123 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
124 platform abstraction and application shell
125
126 ###########################################
127 # Dali adapter for profiles
128 ###########################################
129
130 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
131 # if mobile || "undefined"
132 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
133 %package profile_mobile
134 Summary:        The DALi Tizen Adaptor for mobile
135 Provides:       %{name}-compat = %{version}-%{release}
136 Conflicts:      %{name}-profile_tv
137 Conflicts:      %{name}-profile_wearable
138 Conflicts:      %{name}-profile_ivi
139 Conflicts:      %{name}-profile_common
140 Requires:       %{name}
141 %description profile_mobile
142 The DALi Tizen Adaptor for mobile.
143 %endif
144
145 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
146 # if tv ||"undefined"
147 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
148 %package profile_tv
149 Summary:        The DALi Tizen Adaptor for tv
150 Provides:       %{name}-compat = %{version}-%{release}
151 Conflicts:      %{name}-profile_mobile
152 Conflicts:      %{name}-profile_wearable
153 Conflicts:      %{name}-profile_ivi
154 Conflicts:      %{name}-profile_common
155 Requires:       %{name}
156 %description profile_tv
157 The DALi Tizen Adaptor for tv.
158 %endif
159
160 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
161 # if wearable || "undefined"
162 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
163 %package profile_wearable
164 Summary:        The DALi Tizen Adaptor for wearable
165 Provides:       %{name}-compat = %{version}-%{release}
166 Conflicts:      %{name}-profile_mobile
167 Conflicts:      %{name}-profile_tv
168 Conflicts:      %{name}-profile_ivi
169 Conflicts:      %{name}-profile_common
170 Requires:       %{name}
171 %description profile_wearable
172 The DALi Tizen Adaptor for wearable.
173 %endif
174
175 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
176 # if ivi ||"undefined"
177 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
178 %package profile_ivi
179 Summary:        The DALi Tizen Adaptor for ivi
180 Provides:       %{name}-compat = %{version}-%{release}
181 Conflicts:      %{name}-profile_mobile
182 Conflicts:      %{name}-profile_wearable
183 Conflicts:      %{name}-profile_tv
184 Conflicts:      %{name}-profile_common
185 Requires:       %{name}
186 %description profile_ivi
187 The DALi Tizen Adaptor for ivi.
188 %endif
189
190 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
191 # if common ||"undefined"
192 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
193 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
194 %package profile_common
195 Summary:        The DALi Tizen Adaptor for common
196 Provides:       %{name}-compat = %{version}-%{release}
197 Conflicts:      %{name}-profile_mobile
198 Conflicts:      %{name}-profile_wearable
199 Conflicts:      %{name}-profile_tv
200 Conflicts:      %{name}-profile_ivi
201 Requires:       %{name}
202 %description profile_common
203 The DALi Tizen Adaptor for common.
204 %endif
205
206 ##############################
207 # devel
208 ##############################
209 %package devel
210 Summary:    Development components for the DALi Tizen Adaptor
211 Group:      Development/Building
212 Requires:   %{name} = %{version}-%{release}
213 Requires:   %{name}-integration-devel = %{version}-%{release}
214
215 %description devel
216 Development components for the DALi Tizen Adaptor - public headers and package configs
217
218 ##############################
219 # integration-devel
220 ##############################
221 %package integration-devel
222 Summary:    Integration development package for the Adaptor
223 Group:      Development/Building
224 Requires:   %{name} = %{version}-%{release}
225
226 %description integration-devel
227 Integration development package for the Adaptor - headers for integrating with an adaptor library.
228
229 ##############################
230 # Dali Feedback Plugin
231 ##############################
232 %package dali2-feedback-plugin
233 Summary:    Plugin to play haptic and audio feedback for Dali
234 Group:      System/Libraries
235 Requires:   %{name} = %{version}-%{release}
236 %description dali2-feedback-plugin
237 Feedback plugin to play haptic and audio feedback for Dali
238
239 ##############################
240 # Preparation
241 ##############################
242 %prep
243 %setup -q
244
245 #Use TZ_PATH when tizen version is 3.x or greater
246
247 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
248 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
249 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
250 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
251 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
252 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
253
254 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
255 %define dali_plugin_sound_files  /plugins/sounds/
256
257 ##############################
258 # Build
259 ##############################
260 %build
261 PREFIX+="/usr"
262 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
263 LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
264
265 %ifarch %{arm}
266 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
267 %endif
268
269 CFLAGS+=" -DWAYLAND"
270 CXXFLAGS+=" -DWAYLAND"
271 cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=OFF"
272
273 # Use this conditional when Tizen version is 5.x or greater
274 %if 0%{?tizen_version_major} >= 5
275 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
276
277 # Need Ecore-Wayland2 when Tizen version is 5.x or greater
278 CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
279 CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
280 cmake_flags+=" -DENABLE_ECORE_WAYLAND2=ON"
281 %endif
282
283 %if 0%{?enable_debug}
284 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
285 %endif
286
287 %if 0%{?enable_trace}
288 cmake_flags+=" -DENABLE_TRACE=ON"
289 %endif
290
291 libtoolize --force
292 cd %{_builddir}/%{name}-%{version}/build/tizen
293
294 DALI_DATA_RW_DIR="%{dali_data_rw_dir}" ; export DALI_DATA_RW_DIR
295 DALI_DATA_RO_DIR="%{dali_data_ro_dir}"  ; export DALI_DATA_RO_DIR
296 FONT_PRELOADED_PATH="%{font_preloaded_path}" ; export FONT_PRELOADED_PATH
297 FONT_DOWNLOADED_PATH="%{font_downloaded_path}" ; export FONT_DOWNLOADED_PATH
298 FONT_APPLICATION_PATH="%{font_application_path}"  ; export FONT_APPLICATION_PATH
299 FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION_FILE
300 %if 0%{?tizen_platform_config_supported}
301 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
302 %endif
303
304 cmake_flags+=" -DCMAKE_INSTALL_PREFIX=$PREFIX"
305 cmake_flags+=" -DCMAKE_INSTALL_LIBDIR=%{_libdir}"
306 cmake_flags+=" -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}"
307 cmake_flags+=" -DENABLE_TIZEN_MAJOR_VERSION=%{tizen_version_major}"
308 cmake_flags+=" -DENABLE_TIZEN_MINOR_VERSION=%{tizen_version_minor}"
309 cmake_flags+=" -DENABLE_FEEDBACK=YES"
310 cmake_flags+=" -DENABLE_APPFW=YES"
311 cmake_flags+=" -DCOMPONENT_APPLICATION_SUPPORT=YES"
312
313 # Set up the build via Cmake
314 #######################################################################
315 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
316 # if mobile || "undefined"
317 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
318
319 mkdir mobile
320 pushd mobile
321
322 cmake -DENABLE_PROFILE=MOBILE $cmake_flags ..
323
324 # Build.
325 make %{?jobs:-j%jobs}
326 popd
327
328 %endif
329
330 #######################################################################
331 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
332 # if tv ||"undefined"
333 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
334
335 mkdir tv
336 pushd tv
337
338 cmake -DENABLE_PROFILE=TV $cmake_flags ..
339
340 # Build.
341 make %{?jobs:-j%jobs}
342 popd
343
344 %endif
345
346 #######################################################################
347 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
348 # if wearable || "undefined"
349 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
350
351 mkdir wearable
352 pushd wearable
353
354 cmake -DENABLE_PROFILE=WEARABLE $cmake_flags ..
355
356 # Build.
357 make %{?jobs:-j%jobs}
358 popd
359
360 %endif
361
362 #######################################################################
363 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
364 # if ivi ||"undefined"
365 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
366
367 mkdir ivi
368 pushd ivi
369
370 cmake -DENABLE_PROFILE=IVI $cmake_flags ..
371
372 # Build.
373 make %{?jobs:-j%jobs}
374 popd
375
376 %endif
377
378 #######################################################################
379 # common
380 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
381 # if common ||"undefined"
382 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
383
384 mkdir common
385 pushd common
386
387 cmake -DENABLE_PROFILE=COMMON $cmake_flags ..
388
389 # Build.
390 make %{?jobs:-j%jobs}
391 popd
392
393 %endif
394
395 ##############################
396 # Installation
397 ##############################
398 %install
399 rm -rf %{buildroot}
400
401 pushd %{_builddir}/%{name}-%{version}/build/tizen
402
403 # if mobile || "undefined"
404 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
405 pushd mobile
406 %make_install
407 %if "%{?profile}" != "mobile"
408 pushd  %{buildroot}%{_libdir}
409 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
410 popd
411 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
412 %endif
413 popd
414 %endif
415
416 # if tv ||"undefined"
417 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
418 pushd tv
419 %make_install
420 %if "%{?profile}" != "tv"
421 pushd  %{buildroot}%{_libdir}
422 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
423 popd
424 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
425 %endif
426 popd
427 %endif
428
429 # if wearable || "undefined"
430 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
431 pushd wearable
432 %make_install
433 %if "%{?profile}" != "wearable"
434 pushd  %{buildroot}%{_libdir}
435 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
436 popd
437 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
438 %endif
439 popd
440 %endif
441
442 # if ivi ||"undefined"
443 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
444 pushd ivi
445 %make_install
446 %if "%{?profile}" != "ivi"
447 pushd  %{buildroot}%{_libdir}
448 cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
449 popd
450 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
451 %endif
452 popd
453 %endif
454
455 # if common ||"undefined"
456 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
457 pushd common
458 %make_install
459 # No clean so we can gather symbol/size information for the common profile
460 popd
461 %endif
462
463 # Create a symbolic link in integration-api to preserve legacy repo build
464 pushd %{buildroot}%{_includedir}/dali/integration-api
465 ln -sf adaptor-framework adaptors
466 popd
467
468 ##############################
469 # Upgrade order:
470 # 1 - Pre Install new package
471 # 2 - Install new package
472 # 3 - Post install new package
473 # 4 - Pre uninstall old package
474 # 5 - Remove files not overwritten by new package
475 # 6 - Post uninstall old package
476 ##############################
477
478 ##############################
479 # Adaptor package Commands
480 %pre
481 exit 0
482
483 %post
484 pushd %{_libdir}
485 for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
486 popd
487 /sbin/ldconfig
488 exit 0
489
490 %preun
491 exit 0
492
493 %postun
494 /sbin/ldconfig
495 exit 0
496
497 ##############################
498 # Mobile Profile Commands
499 # if mobile || "undefined"
500 # No need to create a symbolic link on install required if only building this profile
501 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
502 %post profile_mobile
503 %if "%{?profile}" != "mobile"
504 pushd %{_libdir}
505 ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
506 popd
507 %endif
508 /sbin/ldconfig
509 exit 0
510
511 %postun profile_mobile
512 /sbin/ldconfig
513 exit 0
514 %endif
515
516 ##############################
517 # TV Profile Commands
518 # No need to create a symbolic link on install required if only building this profile
519 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
520 %post profile_tv
521 %if "%{?profile}" != "tv"
522 pushd %{_libdir}
523 ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
524 popd
525 %endif
526 /sbin/ldconfig
527 exit 0
528
529 %postun profile_tv
530 /sbin/ldconfig
531 exit 0
532 %endif
533
534 ##############################
535 # Wearable Profile Commands
536 # No need to create a symbolic link on install required if only building this profile
537 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
538 %post profile_wearable
539 %if "%{?profile}" != "wearable"
540 pushd %{_libdir}
541 ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
542 popd
543 %endif
544 /sbin/ldconfig
545 exit 0
546
547 %postun profile_wearable
548 /sbin/ldconfig
549 exit 0
550 %endif
551
552 ##############################
553 # IVI Profile Commands
554 # No need to create a symbolic link on install required if only building this profile
555 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
556 %post profile_ivi
557 %if "%{?profile}" != "ivi"
558 pushd %{_libdir}
559 ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.2.0.0
560 popd
561 %endif
562 /sbin/ldconfig
563 exit 0
564
565 %postun profile_ivi
566 /sbin/ldconfig
567 exit 0
568 %endif
569
570 ##############################
571 # Common Profile Commands
572 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
573 %post profile_common
574 /sbin/ldconfig
575 exit 0
576
577 %postun profile_common
578 /sbin/ldconfig
579 exit 0
580 %endif
581
582 ##############################
583 # Files in Binary Packages
584 ##############################
585
586 %files
587 %manifest dali-adaptor.manifest
588 %defattr(-,root,root,-)
589 %dir %{user_shader_cache_dir}
590 %{_bindir}/*
591 %license LICENSE
592 %defattr(-,root,root,-)
593 %{_libdir}/libdali2-adaptor.so
594 %{_libdir}/libdali2-adaptor.so.2
595 %{_libdir}/libdali2-adaptor.so.2.0.0
596
597 #################################################
598
599 %files dali2-feedback-plugin
600 %manifest dali-adaptor.manifest
601 %defattr(-,root,root,-)
602 %{_libdir}/libdali2-feedback-plugin.so*
603 %{dali_plugin_sound_files}/*
604
605 #################################################
606
607 # if common ||"undefined"
608 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
609 %files profile_common
610 %manifest dali-adaptor.manifest
611 # default .so files are housed in the main pkg.
612 %endif
613
614 # if mobile || "undefined"
615 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
616 %files profile_mobile
617 %manifest dali-adaptor.manifest
618 %defattr(-,root,root,-)
619 %if "%{?profile}" != "mobile"
620 %{_libdir}/libdali2-adaptor.so.mobile
621 %endif
622 %endif
623
624 # if tv ||"undefined"
625 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
626 %files profile_tv
627 %manifest dali-adaptor.manifest
628 %defattr(-,root,root,-)
629 %if "%{?profile}" != "tv"
630 %{_libdir}/libdali2-adaptor.so.tv
631 %endif
632 %endif
633
634 # if wearable || "undefined"
635 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
636 %files profile_wearable
637 %manifest dali-adaptor.manifest
638 %defattr(-,root,root,-)
639 %if "%{?profile}" != "wearable"
640 %{_libdir}/libdali2-adaptor.so.wearable
641 %endif
642 %endif
643
644 # if ivi ||"undefined"
645 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
646 %files profile_ivi
647 %manifest dali-adaptor.manifest
648 %defattr(-,root,root,-)
649 %if "%{?profile}" != "ivi"
650 %{_libdir}/libdali2-adaptor.so.ivi
651 %endif
652 %endif
653
654 %files devel
655 %defattr(-,root,root,-)
656 %{_includedir}/dali/dali.h
657 %{_includedir}/dali/public-api/*
658 %{_includedir}/dali/devel-api/*
659 %{_includedir}/dali/doc/*
660 %{_libdir}/pkgconfig/dali2-adaptor.pc
661
662 %files integration-devel
663 %defattr(-,root,root,-)
664 %{_includedir}/dali/integration-api/adaptor-framework/*
665 %{_includedir}/dali/integration-api/adaptors
666 %{_libdir}/pkgconfig/dali2-adaptor-integration.pc