packaging: exclude on non X11 configuration
[platform/core/uifw/at-spi2-atk.git] / packaging / at-spi2-atk.spec
1 %bcond_with x
2
3 Name: at-spi2-atk
4 Version: 2.5.92
5 Release: 1
6 Summary: Assistive Technology Service Provider Interface - GTK+ module
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source0: http://download.gnome.org/sources/at-spi2-atk/2.5/%{name}-%{version}.tar.xz
11
12 Requires: at-spi2-core
13 BuildRequires: dbus-devel
14 BuildRequires: glib2-devel
15 BuildRequires: atk-devel
16 BuildRequires: at-spi2-core-devel
17 BuildRequires: gettext
18 %if ! %{with x}
19 ExclusiveArch:
20 %endif
21
22 BuildRoot: %{buildroot}
23
24 %description
25 AT-SPI is a general interface for applications to make use of the
26 accessibility toolkit. This version is based on dbus.
27
28 %package -n libatk-bridge-2_0-0
29 Summary: ATK/D-Bus bridging library
30 Group: System/Libraries
31
32 %description -n libatk-bridge-2_0-0
33 AT-SPI is a general interface for applications to make use of the
34 accessibility toolkit. This version is based on dbus.
35
36 The package contains a ATK/D-Bus bridge library.
37
38 %package devel
39 Summary: Assistive Technology Service Provider Interface - Developent files
40 Group: System/Libraries
41 Requires: libatk-bridge-2_0-0 = %{version}
42
43 %description devel
44 AT-SPI is a general interface for applications to make use of the
45 accessibility toolkit. This version is based on dbus.
46
47 %prep
48 %setup -q
49
50 %build
51 %configure
52 make %{?_smp_flags}
53
54 %install
55 rm -rf %{buildroot}
56 %make_install
57 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
58 find %{buildroot} -name '*.desktop' | xargs rm -f
59
60 %clean
61 rm -rf %{buildroot}
62
63 %post -n libatk-bridge-2_0-0 -p /sbin/ldconfig
64
65 %postun -n libatk-bridge-2_0-0 -p /sbin/ldconfig
66
67 %files -n libatk-bridge-2_0-0
68 %manifest packaging/%{name}.manifest
69 %defattr(-,root,root)
70 %{_libdir}/libatk-bridge-2.0.so.*
71 %{_datadir}/glib-2.0/schemas/org.a11y.atspi.gschema.xml
72 %{_libdir}/gtk-2.0/modules/libatk-bridge.so
73
74 %files devel
75 %manifest packaging/%{name}.manifest
76 %defattr(-,root,root)
77 %{_includedir}/at-spi2-atk/2.0/atk-bridge.h
78 %{_libdir}/libatk-bridge-2.0.so
79 %{_libdir}/pkgconfig/atk-bridge-2.0.pc
80
81 %changelog
82 * Mon Mar 25 2013 tomasz.duszynski@comarch.com
83 - Initial packaging of at-spi2-atk (2.5.92)
84