Update license in the spec file
[platform/core/uifw/anthy.git] / packaging / anthy.spec
index e1d6f6b..0b57dc3 100644 (file)
@@ -7,28 +7,37 @@ Version: 9100h
 Release: 1
 URL: http://www.sourceforge.jp/projects/anthy/
 Source0: %{name}-%{version}.tar.gz
+Source1001:    anthy.manifest
 #
 # URL: http://cannadic.oucrc.org
 # Source1: cannadic-0.93.tar.gz
-License: GPL
-Group: System Environment/Libraries
+License: LGPL-2.1+ and GPL-2.0+
+Group: Graphics & UI Framework/Input
 BuildRoot: %{_tmppath}/%{name}-root
 
 %description
+A Japanese character input system library.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 #tar zxf %{_sourcedir}/cannadic-0.93.tar.gz
 #ln -s ../cannadic-0.93/gcanna.t mkanthydic
 #ln -s ../cannadic-0.93/gcannaf.t mkanthydic
 
 %build
+[ ! -x autogen.sh ] || { rm -f configure ; %autogen ; }
+%reconfigure --disable-static --with-pic
+%__make %{?_smp_mflags}
+
 %configure
 
 make
 
 %install
 rm -rf ${RPM_BUILD_ROOT}
+mkdir -p %{buildroot}%{_datadir}/license
+cp COPYING %{buildroot}%{_datadir}/license/%{name}
 %makeinstall
 
 %clean
@@ -40,7 +49,9 @@ rm -rf ${RPM_BUILD_ROOT}
 %postun -p /sbin/ldconfig
 
 %files
+%manifest %{name}.manifest
 %defattr(-,root,root)
+%{_datadir}/license/%{name}
 %{_bindir}/*
 %{_sysconfdir}/*
 %{_datadir}/anthy