0b57dc3c104056c802e95db9163255fd47402826
[platform/core/uifw/anthy.git] / packaging / anthy.spec
1 %define __libtoolize :
2
3 #
4 Summary: A Japanese character input system library.(with dictionary)
5 Name: anthy
6 Version: 9100h
7 Release: 1
8 URL: http://www.sourceforge.jp/projects/anthy/
9 Source0: %{name}-%{version}.tar.gz
10 Source1001:     anthy.manifest
11 #
12 # URL: http://cannadic.oucrc.org
13 # Source1: cannadic-0.93.tar.gz
14 License: LGPL-2.1+ and GPL-2.0+
15 Group: Graphics & UI Framework/Input
16 BuildRoot: %{_tmppath}/%{name}-root
17
18 %description
19 A Japanese character input system library.
20
21 %prep
22 %setup -q
23 cp %{SOURCE1001} .
24 #tar zxf %{_sourcedir}/cannadic-0.93.tar.gz
25 #ln -s ../cannadic-0.93/gcanna.t mkanthydic
26 #ln -s ../cannadic-0.93/gcannaf.t mkanthydic
27
28 %build
29 [ ! -x autogen.sh ] || { rm -f configure ; %autogen ; }
30 %reconfigure --disable-static --with-pic
31 %__make %{?_smp_mflags}
32
33 %configure
34
35 make
36
37 %install
38 rm -rf ${RPM_BUILD_ROOT}
39 mkdir -p %{buildroot}%{_datadir}/license
40 cp COPYING %{buildroot}%{_datadir}/license/%{name}
41 %makeinstall
42
43 %clean
44 rm -rf ${RPM_BUILD_ROOT}
45
46 %post
47 /sbin/ldconfig
48
49 %postun -p /sbin/ldconfig
50
51 %files
52 %manifest %{name}.manifest
53 %defattr(-,root,root)
54 %{_datadir}/license/%{name}
55 %{_bindir}/*
56 %{_sysconfdir}/*
57 %{_datadir}/anthy
58 #%{_datadir}/emacs/site-lisp/*
59 %{_libdir}/pkgconfig/*
60 %{_libdir}/libanthy*
61 %{_includedir}/*
62 #%doc README doc
63
64 %changelog
65 * Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
66 - changed my mail address and URL of web page
67
68 * Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
69 - add %{_sysconfdir}/* at %files
70
71 * Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
72 - use _bindir and so on.
73
74 * Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
75 - Initial build.