Move .so file to devel package
[platform/core/uifw/anthy.git] / packaging / anthy.spec
1 %define __libtoolize :
2
3 #
4 Summary: A Japanese character input system library.(with dictionary)
5 Name: anthy
6 Version: 9100h
7 Release: 1
8 URL: http://www.sourceforge.jp/projects/anthy/
9 Source0: %{name}-%{version}.tar.gz
10 Source1001:     anthy.manifest
11 #
12 # URL: http://cannadic.oucrc.org
13 # Source1: cannadic-0.93.tar.gz
14 License: LGPL-2.1+ and GPL-2.0+
15 Group: Graphics & UI Framework/Input
16 BuildRoot: %{_tmppath}/%{name}-root
17
18 %description
19 A Japanese character input system library.
20
21 %package devel
22 Summary:        Include Files and Libraries mandatory for Development
23 Group:          System/Utilities
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 This package contains all necessary include files and libraries needed
28 to develop applications that require these.
29
30 %prep
31 %setup -q
32 cp %{SOURCE1001} .
33 #tar zxf %{_sourcedir}/cannadic-0.93.tar.gz
34 #ln -s ../cannadic-0.93/gcanna.t mkanthydic
35 #ln -s ../cannadic-0.93/gcannaf.t mkanthydic
36
37 %build
38 [ ! -x autogen.sh ] || { rm -f configure ; %autogen ; }
39 %reconfigure --disable-static --with-pic
40 %__make %{?_smp_mflags}
41
42 %configure --disable-zipcode
43
44 make
45
46 %install
47 rm -rf ${RPM_BUILD_ROOT}
48 %makeinstall
49 %{__rm} -f %{buildroot}%{_libdir}/*.la
50
51 %clean
52 rm -rf ${RPM_BUILD_ROOT}
53
54 %post
55 /sbin/ldconfig
56
57 %postun -p /sbin/ldconfig
58
59 %files
60 %manifest %{name}.manifest
61 %defattr(-,root,root)
62 %license COPYING
63 %{_bindir}/*
64 %{_sysconfdir}/*
65 %{_datadir}/anthy
66 #%{_datadir}/emacs/site-lisp/*
67 %{_libdir}/libanthy*.so.*
68 #%doc README doc
69
70 %files devel
71 %defattr(-,root,root)
72 %{_libdir}/pkgconfig/*
73 %{_includedir}/*
74 %{_libdir}/*.so
75
76 %changelog
77 * Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
78 - changed my mail address and URL of web page
79
80 * Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
81 - add %{_sysconfdir}/* at %files
82
83 * Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
84 - use _bindir and so on.
85
86 * Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
87 - Initial build.