Create devel package not to install header and .pc file in binary
[platform/core/uifw/anthy.git] / packaging / anthy.spec
1 %define __libtoolize :
2
3 #
4 Summary: A Japanese character input system library.(with dictionary)
5 Name: anthy
6 Version: 9100h
7 Release: 1
8 URL: http://www.sourceforge.jp/projects/anthy/
9 Source0: %{name}-%{version}.tar.gz
10 Source1001:     anthy.manifest
11 #
12 # URL: http://cannadic.oucrc.org
13 # Source1: cannadic-0.93.tar.gz
14 License: LGPL-2.1+ and GPL-2.0+
15 Group: Graphics & UI Framework/Input
16 BuildRoot: %{_tmppath}/%{name}-root
17
18 %description
19 A Japanese character input system library.
20
21 %package devel
22 Summary:        Include Files and Libraries mandatory for Development
23 Group:          System/Utilities
24 Requires:       %{name} = %{version}-%{release}
25
26 %description devel
27 This package contains all necessary include files and libraries needed
28 to develop applications that require these.
29
30 %prep
31 %setup -q
32 cp %{SOURCE1001} .
33 #tar zxf %{_sourcedir}/cannadic-0.93.tar.gz
34 #ln -s ../cannadic-0.93/gcanna.t mkanthydic
35 #ln -s ../cannadic-0.93/gcannaf.t mkanthydic
36
37 %build
38 [ ! -x autogen.sh ] || { rm -f configure ; %autogen ; }
39 %reconfigure --disable-static --with-pic
40 %__make %{?_smp_mflags}
41
42 %configure
43
44 make
45
46 %install
47 rm -rf ${RPM_BUILD_ROOT}
48 mkdir -p %{buildroot}%{_datadir}/license
49 cp COPYING %{buildroot}%{_datadir}/license/%{name}
50 %makeinstall
51
52 %clean
53 rm -rf ${RPM_BUILD_ROOT}
54
55 %post
56 /sbin/ldconfig
57
58 %postun -p /sbin/ldconfig
59
60 %files
61 %manifest %{name}.manifest
62 %defattr(-,root,root)
63 %{_datadir}/license/%{name}
64 %{_bindir}/*
65 %{_sysconfdir}/*
66 %{_datadir}/anthy
67 #%{_datadir}/emacs/site-lisp/*
68 %{_libdir}/libanthy*
69 #%doc README doc
70
71 %files devel
72 %defattr(-,root,root)
73 %{_libdir}/pkgconfig/*
74 %{_includedir}/*
75
76 %changelog
77 * Thu Jan  3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
78 - changed my mail address and URL of web page
79
80 * Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
81 - add %{_sysconfdir}/* at %files
82
83 * Wed Sep  9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
84 - use _bindir and so on.
85
86 * Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
87 - Initial build.