upload tizen1.0 source
[framework/telephony/tel-plugin-socket_communicator.git] / libclient / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12 CFLAGS ?= -Wall -g
13 CXXFLAGS ?=  -Wall -g
14 LDFLAGS ?=
15 PREFIX ?= /usr
16 DATADIR ?= /opt
17
18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19         CFLAGS += -O0
20         CXXFLAGS += -O0
21 else
22         CFLAGS += -O2
23         CXXFLAGS += -O2
24 endif
25
26 #CFLAGS += -fvisibility=hidden -fPIC
27 CFLAGS += -fvisibility=default -fPIC
28 LDFLAGS += -rdynamic -fPIC -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
29 #LDFLAGS += -Wl,--unresolved-symbols=ignore-in-shared-libs,--as-needed
30
31 CMAKE_TMP_DIR = $(CURDIR)/cmake_tmp
32
33 configure: configure-stamp
34 configure-stamp:
35         dh_testdir
36         # Add here commands to configure the package.
37         mkdir -p $(CMAKE_TMP_DIR);
38         cd $(CMAKE_TMP_DIR); CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" cmake .. -DCMAKE_INSTALL_PREFIX=$(PREFIX)
39
40         touch configure-stamp
41
42 build: build-stamp
43
44 build-stamp: configure-stamp
45         dh_testdir
46
47         # Add here commands to compile the package.
48         cd $(CMAKE_TMP_DIR) && $(MAKE) all
49
50         for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
51                 cat $$f > $${f%.in}; \
52                 sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
53                 sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
54         done
55
56         touch $@
57
58 clean:
59         dh_testdir
60         dh_testroot
61         rm -f build-stamp configure-stamp
62
63         # Add here commands to clean up after the build process.
64         rm -rf $(CMAKE_TMP_DIR)
65
66         for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
67                 rm -f $${f%.in}; \
68         done
69
70         dh_clean
71
72 install: build
73         dh_testdir
74         dh_testroot
75         dh_clean -k
76         dh_installdirs
77
78         # Add here commands to install the package into debian/wavplayer.
79         cd $(CMAKE_TMP_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
80
81
82 # Build architecture-independent files here.
83 binary-indep: build install
84 # We have nothing to do by default.
85
86 # Build architecture-dependent files here.
87 binary-arch: build install
88         dh_testdir
89         dh_testroot
90         dh_installchangelogs
91         dh_installdocs
92         dh_installexamples
93         dh_install --sourcedir=debian/tmp
94 #       dh_installmenu
95 #       dh_installdebconf
96 #       dh_installlogrotate
97 #       dh_installemacsen
98 #       dh_installpam
99 #       dh_installmime
100 #       dh_python
101 #       dh_installinit
102 #       dh_installcron
103 #       dh_installinfo
104         dh_installman
105         dh_link
106         dh_strip --dbg-package=libsocket-comm-client-0-dbg
107         dh_compress
108         dh_fixperms
109 #       dh_perl
110         dh_makeshlibs
111         dh_installdeb
112         dh_shlibdeps
113         dh_gencontrol
114         dh_md5sums
115         dh_builddeb
116
117 binary: binary-indep binary-arch
118 .PHONY: build clean binary-indep binary-arch binary install configure