Fix for 64 bit compatibility.
[framework/api/sim.git] / packaging / capi-telephony-sim.spec
1 #sbs-git:slp/api/sim capi-telephony-sim 0.1.0 338620cf30c11d71e7f17c6cad5968ac57d724d4
2 Name:       capi-telephony-sim
3 Summary:    Telephony SIM Framework
4 Version: 0.1.7
5 Release:    1
6 Group:      TO_BE/FILLED_IN
7 License:    TO BE FILLED IN
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  cmake
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(tapi)
12 BuildRequires:  pkgconfig(glib-2.0)
13 BuildRequires:  pkgconfig(capi-base-common)
14 Requires(post): /sbin/ldconfig  
15 Requires(postun): /sbin/ldconfig
16
17 %description
18
19
20 %package devel
21 Summary:  Telephony SIM Framework (Development)
22 Group:    TO_BE/FILLED_IN
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26
27
28
29 %prep
30 %setup -q
31
32
33 %build
34 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
35 %cmake . -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
36
37
38 make %{?jobs:-j%jobs}
39
40 %install
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %manifest capi-telephony-sim.manifest
50 %{_libdir}/libcapi-telephony-sim.so.*
51
52 %files devel
53 %{_includedir}/telephony/sim.h
54 %{_libdir}/pkgconfig/*.pc
55 %{_libdir}/libcapi-telephony-sim.so
56
57