modify a problem regarding build break
[external/systemd.git] / packaging / systemd.spec
1 #sbs-git:slp/pkgs/s/systemd systemd 37 8ba5df3f1f236e059a9bd77314ed3ca0b4ffcde7
2 Name:       systemd
3 Summary:    Systemd System and Service Manager
4 Version: 37
5 Release:    2
6 Group:      System/Base
7 License:    GPLv2
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires:  pkgconfig(dbus-1) >= 1.3.2
10 BuildRequires:  pkgconfig(gio-unix-2.0)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(libudev) >= 160
13 BuildRequires:  libcap-devel
14 BuildRequires:  libacl-devel
15 BuildRequires:  intltool
16 BuildRequires:  fdupes
17 BuildRequires:  gperf
18
19 %description
20 system and service manager systemd is a replacement for sysvinit.
21 It is dependency-based and able to read the LSB init script headers
22 in addition to parsing rcN.d links as hints.  .  It also provides
23 process supervision using cgroups and the ability to not only depend
24 on other init script being started, but also availability of a given
25 mount point or dbus service.
26
27 %package devel
28 Summary:   systemd development files
29 Requires:  %{name} = %{version}
30 Group:     Development/Libraries
31
32 %description devel
33 Headers and static libraries for systemd (Development)
34
35 %prep
36 %setup -q
37
38 %build
39
40 DH_OPTIONS='-Nlibpam-systemd -Nsystemd-gui'
41 export DH_OPTIONS
42
43 libtoolize -c --force
44 intltoolize -c -f
45 aclocal -I m4
46 autoconf -Wall
47 autoheader 
48 automake --copy --foreign --add-missing
49
50 ./configure --prefix=/usr --disable-static \
51            --disable-docs \
52            --with-rootdir=/ \
53            --with-rootlibdir=/lib \
54            --with-udevrulesdir=/lib/udev/rules.d \
55            --disable-gtk \
56            --disable-libcryptsetup \
57            --disable-audit \
58            --disable-pam \
59            --disable-tcpwrap \
60            --disable-selinux \
61            --with-distro=slp
62
63 make %{?jobs:-j%jobs}
64
65 %install
66 rm -rf %{buildroot}
67 %make_install
68
69 mkdir -p $RPM_BUILD_ROOT/usr/include
70 mkdir -p $RPM_BUILD_ROOT/usr/lib
71 cp src/sd-daemon.h $RPM_BUILD_ROOT/usr/include
72 #cp .libs/libsystemd-daemon.a $RPM_BUILD_ROOT/usr/lib
73
74 %remove_docs
75
76 %files
77 %defattr(-,root,root,-)
78 /bin/*
79 /etc/dbus-1/system.d/*
80 /lib/*
81 /lib/systemd/system-generators/systemd-getty-generator
82 /lib/systemd/system/*
83 /lib/systemd/system/*/*
84 /lib/udev/rules.d/*
85 /usr/bin/*
86 /usr/etc/*
87 /usr/etc/*/*
88 /usr/etc/*/*/*
89 /usr/lib/libsystemd-daemon.so
90 /usr/lib/libsystemd-login.so
91 /usr/lib/systemd/user/*
92 /usr/lib/tmpfiles.d/*
93 /usr/share/dbus-1/interfaces/*.xml
94 /usr/share/dbus-1/services/org.freedesktop.systemd1.service
95 /usr/share/dbus-1/system-services/*
96 /usr/share/polkit-1/actions/*
97 /usr/share/systemd/kbd-model-map
98
99 %files devel
100 /usr/include/*.h
101 /usr/include/*/*.h
102 /usr/lib/pkgconfig/*
103 /usr/share/pkgconfig/systemd.pc