Fixed hardcoding of lib path in .pc file
[external/libiri.git] / packaging / libiri.spec
1 Name:       libiri
2 Version:        1.1
3 Release:        1
4 License:        BSD
5 Summary:        An IRI parsing library
6 Url:            http://code.google.com/p/libiri/
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 BuildRequires:  autoconf
10 BuildRequires:  automake
11 BuildRequires:  libtool
12
13 %description
14 libiri is a simple toolkit for parsing Internationalized Resource Identifiers (IRIs).
15
16 For many intents and purposes, you can think of libiri as a “URL parser which supports Unicode”.
17
18 Specifically:
19
20 URLs are a subset of URIs
21 URIs are restricted to a portion of the ASCII character set
22 IRIs are a superset of URIs that are not restricted to ASCII characters
23 If something is a valid URL or URI, it's also a valid IRI.
24
25 %package devel
26 Summary:    An IRI parsing library - Development Files
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}
29
30 %description devel
31 libiri is a simple toolkit for parsing Internationalized Resource Identifiers (IRIs).
32
33 %prep
34 %setup -q
35
36 %build
37 sh ./autogen.sh
38 %configure
39 make %{?_smp_mflags}
40
41 %install
42 %make_install
43
44
45
46 %files
47 %manifest libiri.manifest
48 %{_libdir}/*.so
49
50
51 %files devel
52 %{_libdir}/pkgconfig/*.pc
53 %{_includedir}/*.h
54 /usr/bin/iri-config