upload tizen1.0 source
[external/libiri.git] / packaging / libiri.spec
1 Name:           libiri
2 Version:        1.1
3 Release:        1
4 License:        BSD
5 Summary:        An IRI parsing library
6 Url:            http://code.google.com/p/libiri/
7 Group:          Libraries
8 Source:         %{name}-%{version}.tar.gz
9 BuildRequires:  autoconf, automake, libtool
10
11 %description
12 libiri is a simple toolkit for parsing Internationalized Resource Identifiers (IRIs).
13
14 For many intents and purposes, you can think of libiri as a “URL parser which supports Unicode”.
15
16 Specifically:
17
18 URLs are a subset of URIs
19 URIs are restricted to a portion of the ASCII character set
20 IRIs are a superset of URIs that are not restricted to ASCII characters
21 If something is a valid URL or URI, it's also a valid IRI.
22
23 %prep
24 %setup -q
25
26 %build
27 sh ./autogen.sh
28 %configure
29 make %{?_smp_mflags}
30
31 %install
32 %make_install
33
34
35
36 %files
37 %{_libdir}/*.so
38
39
40 %package devel
41 Summary:    An IRI parsing library - Development Files
42 Group:      Development/Libraries
43 Requires:   %{name} = %{version}-%{release}
44
45 %description devel
46 libiri is a simple toolkit for parsing Internationalized Resource Identifiers (IRIs).
47
48 %files devel
49 %{_libdir}/pkgconfig/*.pc
50 %{_includedir}/*.h
51 /usr/bin/iri-config