3 Summary: System and Session Manager
6 Group: System/System Control
8 URL: http://www.freedesktop.org/wiki/Software/systemd
9 Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
10 Source1: pamconsole-tmp.conf
11 Source1001: systemd.manifest
12 Source1002: max_user_inotify.conf
13 Patch1: 0002-systemd-fsck-disable-l-until-linux.patch
14 Patch2: add-tmp.mount-as-tmpfs.patch
15 Patch3: tizen-login-location.patch
16 Patch4: tizen-service-file-workaround.patch
17 Patch5: journal-make-sure-to-refresh-window-position-and-poi.patch
18 Patch6: tizen-preserve-hostname.patch
19 Patch7: util-never-follow-symlinks-in-rm_rf_children.patch
20 Patch8: util-introduce-memdup.patch
21 Patch9: main-allow-system-wide-limits-for-services.patch
22 Patch10: enable-core-dumps-globally.patch
23 Patch11: SMACK-Add-configuration-options.-v3.patch
24 Patch12: reboot_syscall_param.patch
25 Patch13: default_oom_score.patch
26 Patch14: fix-syscall-NR_fanotify_mark-on-arm.patch
28 BuildRequires: pkgconfig(dbus-1) >= 1.4.0
29 BuildRequires: pkgconfig(dbus-glib-1)
30 BuildRequires: pkgconfig(gio-unix-2.0)
31 BuildRequires: pkgconfig(libudev) >= 174
32 BuildRequires: libcap-devel
34 BuildRequires: libxslt
35 BuildRequires: pam-devel
36 BuildRequires: intltool >= 0.40.0
37 BuildRequires: libacl-devel
39 BuildRequires: pkgconfig(libkmod)
40 Requires(post): %{_sbindir}/ldconfig
41 Requires(postun): %{_sbindir}/ldconfig
44 system and session manager for Linux, compatible with SysV and
45 LSB init scripts. systemd provides aggressive parallelization
46 capabilities, uses socket and D-Bus activation for starting
47 services, offers on-demand starting of daemons, keeps track of
48 processes using Linux cgroups, supports snapshotting and restoring
49 of the system state, maintains mount and automount points and
50 implements an elaborate transactional dependency-based service
51 control logic. It can work as a drop-in replacement for sysvinit.
53 # tools package dislabled because of pycairo package dependency
55 # Summary: Analyze systemd startup timing
56 # Group: Development/Tools
58 # Requires: python-xml
59 # Requires: %{name} = %{version}-%{release}
62 # This package installs the systemd-analyze tool, which allows one to
63 # inspect and graph service startup timing in table or graph format.
66 Summary: Development tools for systemd
67 Group: Development/Libraries
68 Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
69 Requires(post): %{_sbindir}/ldconfig
70 Requires(postun): %{_sbindir}/ldconfig
73 This package includes the libraries and header files you will need
74 to compile applications for systemd.
76 %package console-ttyS0
77 Summary: Systemd console ttyS0
78 Group: System/System Control
81 %description console-ttyS0
82 This package will setup a serial getty for ttyS0 is desired.
85 %package console-ttyS1
86 Summary: Systemd console ttyS1
87 Group: System/System Control
90 %description console-ttyS1
91 This package will setup a serial getty for ttyS1 is desired.
94 %package console-tty01
95 Summary: Systemd console tty01
96 Group: System/System Control
99 %description console-tty01
100 This package will setup a serial getty for tty01 is desired.
103 %package console-ttyO2
104 Summary: Systemd console ttyO2
105 Group: System/System Control
108 %description console-ttyO2
109 This package will setup a serial getty for ttyO2 is desired.
111 %package console-ttyMFD2
112 Summary: Systemd console ttyMFD2
113 Group: System/System Control
116 %description console-ttyMFD2
117 This package will setup a serial getty for ttyMFD2 is desired.
119 %package console-ttySAC2
120 Summary: Systemd console ttySAC2
121 Group: System/System Control
124 %description console-ttySAC2
125 This package will setup a serial getty for ttySAC2 is desired.
129 Summary: System and session manager man pages
130 Group: Development/Libraries
131 Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
134 This package includes the man pages for systemd.
138 # Summary: System and session manager man pages - SysV links
139 # Group: Development/Libraries
140 # Requires: %{name} = %{version}-%{release}
142 # %description sysv-docs
143 # This package provides the manual pages needed for systemd
144 # to replace sysvinit.
147 # Summary: System and session manager - SysV links
148 # Group: System/Startup Services
149 # Requires: %{name} = %{version}-%{release}
150 # Obsoletes: sysvinit < 3.0
151 # Provides: sysvinit = 3.0
155 # Systemd is a replacement for sysvinit. It is dependency-based and
156 # able to read the LSB init script headers in addition to parsing rcN.d
159 # It also provides process supervision using cgroups and the ability to
160 # not only depend on other init script being started, but also
161 # availability of a given mount point or dbus service.
163 # This package provides the links needed for systemd
164 # to replace sysvinit.
168 %setup -q -n %{name}-%{version}
187 %configure --disable-static \
189 --with-distro=meego \
196 --with-pamlibdir="/%{_libdir}/security" \
197 --with-udevrulesdir="%{_libdir}/udev/rules.d"
204 # Create SysV compatibility symlinks. systemctl/systemd are smart
205 # enough to detect in which way they are called.
206 # install -d %{buildroot}%{_sbindir}/
207 # ln -s ..%{_libdir}/systemd/systemd %{buildroot}%{_sbindir}/init
208 # ln -s ..%{_bindir}/systemctl %{buildroot}%{_sbindir}/halt
209 # ln -s ..%{_bindir}/systemctl %{buildroot}%{_sbindir}/poweroff
210 # ln -s ..%{_bindir}/systemctl %{buildroot}%{_sbindir}/reboot
211 # ln -s ..%{_bindir}/systemctl %{buildroot}%{_sbindir}/runlevel
212 # ln -s ..%{_bindir}/systemctl %{buildroot}%{_sbindir}/shutdown
213 # ln -s ..%{_bindir}/systemctl %{buildroot}%{_sbindir}/telinit
215 # /usr compat - delete when no longer needed
216 install -d %{buildroot}/bin/
217 ln -s ..%{_bindir}/systemctl %{buildroot}/bin/systemctl
219 mkdir %{buildroot}/run
221 # Make sure these directories are properly owned
222 mkdir -p %{buildroot}%{_libdir}/systemd/system/basic.target.wants
223 mkdir -p %{buildroot}%{_libdir}/systemd/system/dbus.target.wants
225 # enable readahead by default
226 ln -s ../systemd-readahead-collect.service %{buildroot}%{_libdir}/systemd/system/sysinit.target.wants/systemd-readahead-collect.service
227 ln -s ../systemd-readahead-replay.service %{buildroot}%{_libdir}/systemd/system/sysinit.target.wants/systemd-readahead-replay.service
229 # Don't ship documentation in the wrong place
230 rm %{buildroot}/%{_docdir}/systemd/*
232 mkdir -p %{buildroot}/etc/systemd/system/basic.target.wants
233 mkdir -p %{buildroot}/etc/systemd/system/getty.target.wants
234 mkdir -p %{buildroot}%{_libdir}/systemd/system/getty.target.wants
236 # Modify inotify max_user_instances
237 mkdir -p %{buildroot}/%{_libdir}/sysctl.d
238 cp %{SOURCE1002} %{buildroot}%{_libdir}/sysctl.d/
241 ln -s ../serial-getty@.service %{buildroot}%{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyMFD2.service
244 ln -s ../serial-getty@.service %{buildroot}%{_libdir}/systemd/system/getty.target.wants/serial-getty@ttySAC2.service
247 ln -s ../serial-getty@.service %{buildroot}%{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyS0.service
250 ln -s ../serial-getty@.service %{buildroot}%{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyS1.service
253 ln -s ../serial-getty@.service %{buildroot}%{_libdir}/systemd/system/getty.target.wants/serial-getty@tty01.service
256 ln -s ../serial-getty@.service %{buildroot}%{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyO2.service
260 ln -sf /proc/self/mounts /etc/mtab
262 /usr/bin/systemd-machine-id-setup >/dev/null 2>&1 || :
266 %postun -p %{_sbindir}/ldconfig
267 %post devel -p %{_sbindir}/ldconfig
268 %postun devel -p %{_sbindir}/ldconfig
272 %defattr(-,root,root,-)
273 %manifest systemd.manifest
276 # systemd-analyze is excluded for removing dependency with python-base
277 %exclude %{_bindir}/systemd-analyze
279 %config %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
280 %config %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
281 %config %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
282 %config %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
283 %config %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
284 %attr(0644,root,root) %{_libdir}/udev/rules.d/70-uaccess.rules
285 %attr(0644,root,root) %{_libdir}/udev/rules.d/71-seat.rules
286 %attr(0644,root,root) %{_libdir}/udev/rules.d/73-seat-late.rules
287 %config %{_sysconfdir}/systemd
288 %config %{_sysconfdir}/xdg/systemd/user
289 %config %{_sysconfdir}/bash_completion.d/systemd-bash-completion.sh
290 %{_prefix}/%{_lib}/tmpfiles.d/*
292 /%{_libdir}/security/pam_systemd.so
293 %{_libdir}/udev/rules.d/99-systemd.rules
294 %{_libdir}/libsystemd-daemon.so.0
295 %{_libdir}/libsystemd-daemon.so.0.0.1
296 %{_libdir}/libsystemd-login.so.0
297 %{_libdir}/libsystemd-login.so.0.2.0
298 %{_libdir}/libsystemd-id128.so.0
299 %{_libdir}/libsystemd-id128.so.0.0.2
300 %{_libdir}/libsystemd-journal.so.0
301 %{_libdir}/libsystemd-journal.so.0.0.2
302 %{_libdir}/sysctl.d/*
303 %{_datadir}/dbus-1/*/org.freedesktop.systemd1.*
304 %{_defaultdocdir}/systemd
305 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
306 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
307 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
308 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
309 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
310 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
311 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
312 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
313 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
314 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
315 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
316 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
317 %exclude %{_libdir}/systemd/system/getty.target.wants/serial-getty@tty01.service
318 %exclude %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyMFD2.service
319 %exclude %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttySAC2.service
320 %exclude %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyO2.service
321 %exclude %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyS0.service
322 %exclude %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyS1.service
323 %exclude %{_libdir}/systemd/system/sysinit.target.wants/systemd-vconsole-setup.service
324 %exclude %{_libdir}/systemd/user/default.target
326 %files console-ttySAC2
327 %defattr(-,root,root,-)
328 %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttySAC2.service
330 %files console-ttyMFD2
331 %defattr(-,root,root,-)
332 %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyMFD2.service
335 %defattr(-,root,root,-)
336 %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyS0.service
339 %defattr(-,root,root,-)
340 %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyS1.service
343 %defattr(-,root,root,-)
344 %{_libdir}/systemd/system/getty.target.wants/serial-getty@tty01.service
347 %defattr(-,root,root,-)
348 %{_libdir}/systemd/system/getty.target.wants/serial-getty@ttyO2.service
351 # tools package dislabled because of pycairo package dependency
353 # %defattr(-,root,root,-)
354 # %manifest systemd.manifest
355 # %{_bindir}/systemd-analyze
358 %defattr(-,root,root,-)
359 %manifest systemd.manifest
360 %{_datadir}/pkgconfig/systemd.pc
361 %{_includedir}/systemd/sd-daemon.h
362 %{_includedir}/systemd/sd-login.h
363 %{_includedir}/systemd/sd-id128.h
364 %{_includedir}/systemd/sd-journal.h
365 %{_includedir}/systemd/sd-messages.h
366 %{_libdir}/libsystemd-daemon.so
367 %{_libdir}/libsystemd-login.so
368 %{_libdir}/libsystemd-journal.so
369 %{_libdir}/libsystemd-id128.so
370 %{_libdir}/pkgconfig/libsystemd-daemon.pc
371 %{_libdir}/pkgconfig/libsystemd-login.pc
372 %{_libdir}/pkgconfig/libsystemd-id128.pc
373 %{_libdir}/pkgconfig/libsystemd-journal.pc
374 %{_datadir}/systemd/kbd-model-map
377 # %defattr(-,root,root,-)
381 # %{_sbindir}/poweroff
383 # %{_sbindir}/runlevel
384 # %{_sbindir}/shutdown
385 # %{_sbindir}/telinit