Tizen 2.1 base
[sdk/emulator/qemu.git] / gl / mesa / docs / MESA_pixmap_colormap.spec
1 Name
2
3     MESA_pixmap_colormap
4
5 Name Strings
6
7     GLX_MESA_pixmap_colormap
8
9 Contact
10
11     Brian Paul (brian.paul 'at' tungstengraphics.com)
12
13 Status
14
15     Shipping since Mesa 1.2.8 in May, 1996.
16
17 Version
18
19     Last Modified Date:  8 June 2000
20
21 Number
22
23     216
24
25 Dependencies
26
27     OpenGL 1.0 or later is required.
28     GLX 1.0 or later is required.
29
30 Overview
31
32     Since Mesa allows RGB rendering into drawables with PseudoColor,
33     StaticColor, GrayScale and StaticGray visuals, Mesa needs a colormap
34     in order to compute pixel values during rendering.
35
36     The colormap associated with a window can be queried with normal
37     Xlib functions but there is no colormap associated with pixmaps.
38
39     The glXCreateGLXPixmapMESA function is an alternative to glXCreateGLXPixmap
40     which allows specification of a colormap.
41
42 IP Status
43
44     Open-source; freely implementable.
45
46 Issues
47
48     None.
49
50 New Procedures and Functions
51
52     GLXPixmap glXCreateGLXPixmapMESA( Display *dpy, XVisualInfo *visual,
53                                       Pixmap pixmap, Colormap cmap );
54
55 New Tokens
56
57     None.
58
59 Additions to Chapter 3 of the GLX 1.3 Specification (Functions and Errors)
60
61     Add to section 3.4.2 Off Screen Rendering
62
63     The Mesa implementation of GLX allows RGB rendering into X windows and
64     pixmaps of any visual class, not just TrueColor or DirectColor.  In order
65     to compute pixel values from RGB values Mesa requires a colormap.
66
67     The function
68
69         GLXPixmap glXCreateGLXPixmapMESA( Display *dpy, XVisualInfo *visual,
70                                           Pixmap pixmap, Colormap cmap );
71
72     allows one to create a GLXPixmap with a specific colormap.  The image
73     rendered into the pixmap may then be copied to a window (which uses the
74     same colormap and visual) with the expected results.
75
76 GLX Protocol
77
78     None since this is a client-side extension.
79
80 Errors
81
82     None.
83
84 New State
85
86     None.
87
88 Revision History
89
90     8 June 2000 - initial specification