Add new package for ivi build
[scm/bb/tizen.git] / proto-meta-Tizen_generic / specfile-initial / libpinyin / packaging / libpinyin.spec
1 Name:           libpinyin
2 Version:        1.0.0
3 Release:        1
4 Summary:        Library to deal with pinyin
5 License:        GPL-2.0+
6 Group:          System/Libraries
7 URL:            https://github.com/libpinyin/libpinyin
8 Source0:        http://downloads.sourceforge.net/libpinyin/libpinyin/%{name}-%{version}.tar.gz
9 Source1001:     libpinyin.manifest
10
11 BuildRequires:  db4-devel, glib2-devel
12
13 %description
14 The libpinyin project aims to provide the algorithms core
15 for intelligent sentence-based Chinese pinyin input methods.
16
17
18 %package        devel
19 Summary:        Development files for %{name}
20 Requires:       %{name} = %{version}-%{release}
21
22 %description    devel
23 The %{name}-devel package contains libraries and header files for
24 developing applications that use %{name}.
25
26
27 %package        tools
28 Summary:        Tools for %{name}
29 Requires:       %{name} = %{version}-%{release}
30
31 %description tools
32 The %{name}-tools package contains tools.
33
34
35 %prep
36 %setup -q
37 cp %{SOURCE1001} .
38
39
40 %build
41 %configure --disable-static
42 make %{?_smp_mflags}
43
44 %install
45 make install DESTDIR=$RPM_BUILD_ROOT
46 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
47
48
49 %post -p /sbin/ldconfig
50
51 %postun -p /sbin/ldconfig
52
53
54 %files
55 %manifest %{name}.manifest
56 %doc AUTHORS COPYING README
57 %{_libdir}/*.so.*
58 %dir %{_libdir}/libpinyin
59 %{_libdir}/libpinyin/data
60
61 %files devel
62 %manifest %{name}.manifest
63 %doc
64 %dir %{_includedir}/libpinyin-1.0.0
65 %{_includedir}/libpinyin-1.0.0/*
66 %{_libdir}/*.so
67 %{_libdir}/pkgconfig/libpinyin.pc
68
69 %files tools
70 %manifest %{name}.manifest
71 %{_bindir}/gen_binary_files
72 %{_bindir}/import_interpolation
73 %{_bindir}/gen_unigram
74 %{_mandir}/man1/*.1.*