weston-extraconf.inc: avoid changing configure options
authorPatrick Ohly <patrick.ohly@intel.com>
Thu, 29 Jan 2015 14:46:08 +0000 (06:46 -0800)
committerPatrick Ohly <patrick.ohly@intel.com>
Thu, 29 Jan 2015 14:46:08 +0000 (06:46 -0800)
There is no need (anymore?) to change configure options
because we get the desired ones for IVI from the original
.spec file in the new .inc file.

Change-Id: Ib458dfaf5a7ebff3edb6bff4e646332a1b571bbd

meta-tizen-common-base/recipes-graphics/weston/weston-extraconf.inc

index d4ea6cb..b95560f 100644 (file)
@@ -6,30 +6,12 @@ RDEPENDS_${PN}_remove = "weston-startup"
 SRC_URI += "file://make-lcms-explicitly-configurable.patch"
 SRC_URI += "file://make-libwebp-explicitly-configurable.patch"
 
-EXTRA_OECONF += "   \
-                    --enable-wayland-compositor \
-                    --disable-vaapi-recorder \
-                    --enable-weston-launch \
-                    --enable-drm-compositor \
-                    --enable-sys-uid \
-                    --enable-egl \
-                    --enable-simple-egl-clients \
-                    --enable-fbdev-compositor \
-                    --disable-headless-compositor \
-                    --enable-setuid-install \
-                    --enable-demo-clients-install \
-                    --disable-lcms \
-                    --disable-webp \
-                    "
-
-EXTRA_OECONF += "   --disable-rdp-compositor "
-                    
-EXTRA_OECONF += "   --disable-dbus"
-
 do_configure_prepend() {
     sed -i 's/PKG_CHECK_MODULES(WAYLAND_SCANNER, wayland-scanner)//' configure.ac
 }
 
+# Disable unusable "useradd weston-launch" from .spec file.
+# Creating the user was moved to meta-tizen-ivi/recipes-image/config-tizen-profiles/config-tizen-ivi.bb.
 pkg_preinst_${PN}() {
 }