wayland-ivi-extension: fix build issues 03/27303/2
authorKévin THIERRY <kevin.thierry@open.eurogiciel.org>
Wed, 10 Sep 2014 12:10:26 +0000 (14:10 +0200)
committerKévin THIERRY <kevin.thierry@open.eurogiciel.org>
Wed, 10 Sep 2014 14:28:20 +0000 (16:28 +0200)
* Add build dependency to wayland-native since wayland-scanner is
  needed.
* Add missing build dependency to weston-ivi-shell.
* Move wayland-scanner call from the prep section to the configure
  section to be sure wayland-native is installed before wayland-scanner
  is called.

Change-Id: I9f2a76c104e66b0adfc9d10c25f027cbea6095d0
Signed-off-by: Kévin THIERRY <kevin.thierry@open.eurogiciel.org>
recipes-tizen/wayland-ivi-extension/wayland-ivi-extension-extraconf.inc

index 49c15c9..f53125f 100644 (file)
@@ -1,5 +1,7 @@
 inherit pkgconfig cmake
 
+DEPENDS += "wayland-native"
+DEPENDS += "weston-ivi-shell"
 
 RPROVIDES_genivi-shell += "wayland-ivi-extension"
 
@@ -21,11 +23,13 @@ do_prep() {
     chmod -Rf a+rX,u+w,g-w,o-w ${S}
     cp ${S}/packaging/genivi-shell.manifest .
 
-    ${STAGING_BINDIR_NATIVE}/wayland-scanner code < protocol/ivi-controller.xml > protocol/ivi-controller-protocol.c
-    
     sed -i "s@\${LIBS} \${WESTON_LIBDIR}/weston/ivi-shell.so@\${LIBS} ${PKG_CONFIG_SYSROOT_DIR}\${WESTON_LIBDIR}/weston/ivi-shell.so@g" ${S}/weston-ivi-shell/CMakeLists.txt 
 }
 
+cmake_do_configure_prepend() {
+    ${STAGING_BINDIR_NATIVE}/wayland-scanner code < protocol/ivi-controller.xml > protocol/ivi-controller-protocol.c
+}
+
 cmake_do_install_append() {
 
     rm -f ${D}${infodir}/dir