manifests: default Tizen manifest 44/30744/2
authorPatrick Ohly <patrick.ohly@intel.com>
Mon, 24 Nov 2014 20:20:15 +0000 (21:20 +0100)
committerRonan Le Martret <ronan@fridu.net>
Mon, 1 Dec 2014 13:36:45 +0000 (14:36 +0100)
All binary .rpms should be built with at least a stub .manifest file
assiging the "_" label to all packaged files. Explicitly adding that
to all Yocto recipes via .bbappend is cumbersome, so do it globally in
tizen.conf. It's still possible to override that default by prepending
a different .manifest[.in] file.

Change-Id: Ife3aa29c42c0e095f913c9b6effae78e5caa7e10
Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
meta-tizen-common-base/conf/distro/tizen-default.manifest [new file with mode: 0644]
meta-tizen-common-base/conf/distro/tizen.conf
meta-tizen-common-base/conf/layer.conf

diff --git a/meta-tizen-common-base/conf/distro/tizen-default.manifest b/meta-tizen-common-base/conf/distro/tizen-default.manifest
new file mode 100644 (file)
index 0000000..2a0cec5
--- /dev/null
@@ -0,0 +1,5 @@
+<manifest>
+  <request>
+    <domain name="_"/>
+  </request>
+</manifest>
index 9cc4217..d5071d5 100644 (file)
@@ -41,4 +41,25 @@ LICENSE_FLAGS_WHITELIST += "commercial"
 
 SYS_CTLR_PROVIDER = "murphy"
 
-SYSTEMD_DEFAULT_TARGET="graphical.target"
\ No newline at end of file
+SYSTEMD_DEFAULT_TARGET="graphical.target"
+
+
+# Fallback Smack .manifest file for packages which don't have any other
+# .manifest file settings. Override with either MANIFESTSFILES (if
+# .manifest part of the source) or other SRC_URI entries.
+#
+# In SRC_URI, any file ending in .manifest is considered a Tizen Smack
+# manifest file. The first one without a 'pkg' parameter is the
+# default for all packages. If a pkg parameter is given and non-empty,
+# its parameter is treated as a comma separated list of the names of
+# those packages for which this manifest file is used. The
+# file://tizen-default.manifest is set for all recipes automatically,
+# so most recipes don't need to be modified.
+#
+# A .manifest.in file may contain @<word>@ placeholders (@bindir@,
+# @TZ_USER_NAME@). Those get replaced before passing the file to rpm,
+# see metatizen.bbclass for details.
+#
+# The extra space at the end is a workaround for recipes which lack a
+# space in their own _append.
+SRC_URI_append = " file://${META_TIZEN_COMMON_BASE}/conf/distro/tizen-default.manifest "
index 8c48f76..846cf45 100644 (file)
@@ -1,6 +1,9 @@
 # We have a conf and classes directory, add to BBPATH
 BBPATH .= ":${LAYERDIR}"
 
+# Needed to find tizen-default.manifest.
+META_TIZEN_COMMON_BASE := "${LAYERDIR}"
+
 # We have a packages directory, add to BBFILES
 BBFILES := "${BBFILES} \
             ${LAYERDIR}/recipes-*/*/*.bb \