boost: Add Version 1.57 81/32781/2
authorSaul Wold <sgw@linux.intel.com>
Tue, 23 Dec 2014 15:52:57 +0000 (07:52 -0800)
committerronan(Eurogiciel) Le Martret <ronan.lemartret@open.eurogiciel.org>
Tue, 30 Dec 2014 14:02:27 +0000 (06:02 -0800)
Change-Id: I24529591f1a40a393c5caebcd53e1837299dc470
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta-tizen-adaptation/meta/recipes-support/boost/bjam-native_1.57.0.bb [new file with mode: 0644]
meta-tizen-adaptation/meta/recipes-support/boost/boost-1.57.0.inc [new file with mode: 0644]
meta-tizen-adaptation/meta/recipes-support/boost/boost.inc [new file with mode: 0644]
meta-tizen-adaptation/meta/recipes-support/boost/boost/arm-intrinsics.patch [new file with mode: 0644]
meta-tizen-adaptation/meta/recipes-support/boost/boost_1.57.0.bb [new file with mode: 0644]

diff --git a/meta-tizen-adaptation/meta/recipes-support/boost/bjam-native_1.57.0.bb b/meta-tizen-adaptation/meta/recipes-support/boost/bjam-native_1.57.0.bb
new file mode 100644 (file)
index 0000000..d85d1a9
--- /dev/null
@@ -0,0 +1,15 @@
+include boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+do_compile() {
+    ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+    install -d ${D}${bindir}/
+    install -c -m 755 bjam ${D}${bindir}/
+}
diff --git a/meta-tizen-adaptation/meta/recipes-support/boost/boost-1.57.0.inc b/meta-tizen-adaptation/meta/recipes-support/boost/boost-1.57.0.inc
new file mode 100644 (file)
index 0000000..809419d
--- /dev/null
@@ -0,0 +1,19 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+HOMEPAGE = "http://www.boost.org/"
+LICENSE = "BSL-1.0 & MIT & Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+BOOST_VER = "${@"_".join(d.getVar("PV",1).split("."))}"
+BOOST_MAJ = "${@"_".join(d.getVar("PV",1).split(".")[0:2])}"
+BOOST_P = "boost_${BOOST_VER}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
+
+SRC_URI[md5sum] = "1be49befbdd9a5ce9def2983ba3e7b76"
+SRC_URI[sha256sum] = "910c8c022a33ccec7f088bd65d4f14b466588dda94ba2124e78b8c57db264967"
+
+S = "${WORKDIR}/${BOOST_P}"
diff --git a/meta-tizen-adaptation/meta/recipes-support/boost/boost.inc b/meta-tizen-adaptation/meta/recipes-support/boost/boost.inc
new file mode 100644 (file)
index 0000000..d34ca7c
--- /dev/null
@@ -0,0 +1,181 @@
+SUMMARY = "Free peer-reviewed portable C++ source libraries"
+SECTION = "libs"
+DEPENDS = "bjam-native zlib bzip2"
+
+ARM_INSTRUCTION_SET = "arm"
+
+BOOST_LIBS = "\
+       date_time \
+       filesystem \
+       graph \
+       iostreams \
+       program_options \
+       regex \
+       serialization \
+       signals \
+       system \
+       test \
+       thread \
+       "
+
+# optional boost-python library
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[python] = ",,python"
+BOOST_LIBS += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}"
+inherit python-dir
+PYTHON_ROOT = "${STAGING_DIR_HOST}/${prefix}"
+
+# Make a package for each library, plus -dev
+PACKAGES = "${PN}-dbg ${BOOST_PACKAGES}"
+python __anonymous () {
+    packages = []
+    extras = []
+    for lib in d.getVar('BOOST_LIBS', True).split( ):
+            pkg = "boost-%s" % lib.replace("_", "-")
+            extras.append("--with-%s" % lib)
+            packages.append(pkg)
+            if not d.getVar("FILES_%s" % pkg, True):
+                    d.setVar("FILES_%s" % pkg, "${libdir}/libboost_%s*.so.*" % lib)
+    d.setVar("BOOST_PACKAGES", " ".join(packages))
+    d.setVar("BJAM_EXTRA", " ".join(extras))
+}
+
+# Override the contents of specific packages
+FILES_boost-serialization = "${libdir}/libboost_serialization*.so.* \
+       ${libdir}/libboost_wserialization*.so.*"
+FILES_boost-test = "${libdir}/libboost_prg_exec_monitor*.so.* \
+       ${libdir}/libboost_unit_test_framework*.so.*"
+
+# -dev last to pick up the remaining stuff
+PACKAGES += "${PN}-dev ${PN}-staticdev"
+FILES_${PN}-dev = "${includedir} ${libdir}/libboost_*.so"
+FILES_${PN}-staticdev = "${libdir}/libboost_*.a"
+
+# "boost" is a metapackage which pulls in all boost librabries
+PACKAGES += "${PN}"
+RRECOMMENDS_${PN} += "${BOOST_PACKAGES}"
+RRECOMMENDS_${PN}_class-native = ""
+ALLOW_EMPTY_${PN} = "1"
+
+# to avoid GNU_HASH QA errors added LDFLAGS to ARCH; a little bit dirty but at least it works
+TARGET_CC_ARCH += " ${LDFLAGS}" 
+
+# Oh yippee, a new build system, it's sooo cooool I could eat my own
+# foot.  inlining=on lets the compiler choose, I think.  At least this
+# stuff is documented...
+# NOTE: if you leave <debug-symbols>on then in a debug build the build sys
+# objcopy will be invoked, and that won't work.  Building debug apparently
+# requires hacking gcc-tools.jam
+#
+# Sometimes I wake up screaming.  Famous figures are gathered in the nightmare,
+# Steve Bourne, Larry Wall, the whole of the ANSI C committee.  They're just
+# standing there, waiting, but the truely terrifying thing is what they carry
+# in their hands.  At first sight each seems to bear the same thing, but it is
+# not so for the forms in their grasp are ever so slightly different one from
+# the other.  Each is twisted in some grotesque way from the other to make each
+# an unspeakable perversion impossible to perceive without the onset of madness.
+# True insanity awaits anyone who perceives all of these horrors together.
+#
+# Quotation marks, there might be an easier way to do this, but I can't find
+# it.  The problem is that the user.hpp configuration file must receive a
+# pre-processor macro defined as the appropriate string - complete with "'s
+# around it.  (<> is a possibility here but the danger to that is that the
+# failure case interprets the < and > as shell redirections, creating
+# random files in the source tree.)
+#
+#bjam: '-DBOOST_PLATFORM_CONFIG=\"config\"'
+#do_compile: '-sGCC=... '"'-DBOOST_PLATFORM_CONFIG=\"config\"'"
+SQD = '"'
+EQD = '\"'
+#boost.bb:   "...  '-sGCC=... '${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}config${EQD}'${SQD} ..."
+BJAM_CONF = "${SQD}'-DBOOST_PLATFORM_CONFIG=${EQD}boost/config/platform/${TARGET_OS}.hpp${EQD}'${SQD}"
+
+BJAM_TOOLS   = "-sTOOLS=gcc \
+               '-sGCC=${CC} '${BJAM_CONF} \
+               '-sGXX=${CXX} '${BJAM_CONF} \
+               '-sGCC_INCLUDE_DIRECTORY=${STAGING_INCDIR}' \
+               '-sGCC_STDLIB_DIRECTORY=${STAGING_LIBDIR}' \
+               '-sBUILD=release <optimization>space <threading>multi <inlining>on <debug-symbols>off' \
+               '-sPYTHON_VERSION=${PYTHON_BASEVERSION}' \
+               '-sPYTHON_ROOT=${PYTHON_ROOT}' \
+               '--layout=system' \
+               "
+
+# use PARALLEL_MAKE to speed up the build, but limit it by -j 64, greater paralelism causes bjam to segfault or to ignore -j
+# https://svn.boost.org/trac/boost/ticket/7634
+def get_boost_parallel_make(bb, d):
+    pm = d.getVar('PARALLEL_MAKE', True)
+    if pm:
+        # look for '-j' and throw other options (e.g. '-l') away
+        # because they might have different meaning in bjam
+        pm = pm.split()
+        while pm:
+            v = None
+            opt = pm.pop(0)
+            if opt == '-j':
+                v = pm.pop(0)
+            elif opt.startswith('-j'):
+                v = opt[2:].strip()
+            else:
+                v = None
+
+            if v:
+                v = min(64, int(v))
+                return '-j' + str(v)
+
+    return ""
+
+BOOST_PARALLEL_MAKE = "${@get_boost_parallel_make(bb, d)}"
+BJAM_OPTS    = '${BOOST_PARALLEL_MAKE} \
+               ${BJAM_TOOLS} \
+               -sBOOST_BUILD_USER_CONFIG=${S}/tools/build/example/user-config.jam \
+               --builddir=${S}/${TARGET_SYS} \
+               --disable-icu \
+               ${BJAM_EXTRA}'
+
+# Native compilation of bzip2 isn't working
+BJAM_OPTS_append_class-native = ' -sNO_BZIP2=1'
+
+do_boostconfig() {
+       cp -f boost/config/platform/linux.hpp boost/config/platform/linux-gnueabi.hpp
+
+       # D2194:Fixing the failure of "error: duplicate initialization of gcc with the following parameters" during compilation.
+       if ! grep -qe "^using gcc : 4.3.1" ${S}/tools/build/example/user-config.jam 
+       then
+               echo 'using gcc : 4.3.1 : ${CXX} : <cflags>"${CFLAGS}" <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;' >> ${S}/tools/build/example/user-config.jam
+       fi      
+
+       echo "using python : ${PYTHON_BASEVERSION} : : ${STAGING_INCDIR}/python${PYTHON_BASEVERSION} ;" >> ${S}/tools/build/example/user-config.jam
+
+       CC="${BUILD_CC}" CFLAGS="${BUILD_CFLAGS}" ./bootstrap.sh --with-bjam=bjam --with-toolset=gcc --with-python-root=${PYTHON_ROOT}
+       sed -i '/^using python/d' project-config.jam
+}
+
+addtask do_boostconfig after do_patch before do_configure
+
+do_compile() {
+       set -ex
+       bjam ${BJAM_OPTS} --prefix=${prefix} \
+               --exec-prefix=${exec_prefix} \
+               --libdir=${libdir} \
+               --includedir=${includedir}
+}
+
+do_install() {
+       set -ex
+       bjam ${BJAM_OPTS} \
+               --libdir=${D}${libdir} \
+               --includedir=${D}${includedir} \
+               install
+       for lib in ${BOOST_LIBS}; do
+               if [ -e ${D}${libdir}/libboost_${lib}.a ]; then
+                       ln -s libboost_${lib}.a ${D}${libdir}/libboost_${lib}-mt.a
+               fi
+               if [ -e ${D}${libdir}/libboost_${lib}.so ]; then
+                       ln -s libboost_${lib}.so ${D}${libdir}/libboost_${lib}-mt.so
+               fi
+       done
+
+}
+
+BBCLASSEXTEND = "native"
diff --git a/meta-tizen-adaptation/meta/recipes-support/boost/boost/arm-intrinsics.patch b/meta-tizen-adaptation/meta/recipes-support/boost/boost/arm-intrinsics.patch
new file mode 100644 (file)
index 0000000..fe85c69
--- /dev/null
@@ -0,0 +1,55 @@
+Upstream-Status: Backport
+
+8/17/2010 - rebased to 1.44 by Qing He <qing.he@intel.com>
+
+diff --git a/boost/smart_ptr/detail/atomic_count_sync.hpp b/boost/smart_ptr/detail/atomic_count_sync.hpp
+index b6359b5..78b1cc2 100644
+--- a/boost/smart_ptr/detail/atomic_count_sync.hpp
++++ b/boost/smart_ptr/detail/atomic_count_sync.hpp
+@@ -33,17 +33,46 @@ public:
+     long operator++()
+     {
++#ifdef __ARM_ARCH_7A__
++       int v1, tmp;
++       asm volatile ("1:                 \n\t"
++                     "ldrex   %0, %1     \n\t"
++                     "add     %0 ,%0, #1 \n\t"
++                     "strex   %2, %0, %1 \n\t"
++                     "cmp     %2, #0     \n\t"
++                     "bne     1b         \n\t"
++                     : "=&r" (v1), "+Q"(value_), "=&r"(tmp)
++                    );
++#else
+         return __sync_add_and_fetch( &value_, 1 );
++#endif
+     }
+     long operator--()
+     {
++#ifdef __ARM_ARCH_7A__
++       int v1, tmp;
++       asm volatile ("1:                 \n\t"
++                     "ldrex   %0, %1     \n\t"
++                     "sub     %0 ,%0, #1 \n\t"
++                     "strex   %2, %0, %1 \n\t"
++                     "cmp     %2, #0     \n\t"
++                     "bne     1b         \n\t"
++                     : "=&r" (v1), "+Q"(value_), "=&r"(tmp)
++                    );
++       return value_;
++#else
+         return __sync_add_and_fetch( &value_, -1 );
++#endif
+     }
+     operator long() const
+     {
++#if __ARM_ARCH_7A__
++        return value_;
++#else
+         return __sync_fetch_and_add( &value_, 0 );
++#endif
+     }
+ private:
diff --git a/meta-tizen-adaptation/meta/recipes-support/boost/boost_1.57.0.bb b/meta-tizen-adaptation/meta/recipes-support/boost/boost_1.57.0.bb
new file mode 100644 (file)
index 0000000..c09d5f4
--- /dev/null
@@ -0,0 +1,6 @@
+include boost-${PV}.inc
+include boost.inc
+
+SRC_URI += "\
+    file://arm-intrinsics.patch \
+"